Subject: [sfc] FW: New Version Notification for draft-penno-sfc-packet-03.txt

From: Dave Dolson <[email-masked]>
Date: Tue, 10 May 2016 15:26:53 +0000

This was submitted a couple of weeks ago.

Features:
Section 5.3.2 - a new optimized method of encoding reverse-path information in metadata that requires only 32 bits.

I'm interested to know which approaches people expect to use. 
(We expect to provide at least the approach of section 5.4.1 as a mode of operation.)

Section 7 - some fleshing out of the section on injecting metadata, defining several types of metadata:
   - Service-Path-Invariant Metadata
   - Service-Path-Default Metadata
   - Bidirectional Clonable Metadata
   - Unidirectional Clonable Metadata
   - Service-Function-Mastered Metadata
   - Metadata from Reclassification

I'd like to know if this taxonomy of metadata makes sense to people.

-Dave

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Friday, April 29, 2016 11:49 AM
To: Eric Wang; Reinaldo Penno; Chui-Tin Yen; Dave Dolson; Carlos Pignataro; Kent Leung
Subject: New Version Notification for draft-penno-sfc-packet-03.txt

A new version of I-D, draft-penno-sfc-packet-03.txt
has been successfully submitted by Reinaldo Penno and posted to the
IETF repository.

Name:		draft-penno-sfc-packet
Revision:	03
Title:		Packet Generation in Service Function Chains
Document date:	2016-04-29
Group:		Individual Submission
Pages:		26
URL:            https://www.ietf.org/internet-drafts/draft-penno-sfc-packet-03.txt
Status:         https://datatracker.ietf.org/doc/draft-penno-sfc-packet/
Htmlized:       https://tools.ietf.org/html/draft-penno-sfc-packet-03
Diff:           https://www.ietf.org/rfcdiff?url2=draft-penno-sfc-packet-03

Abstract:
   Service Functions (e.g., Firewall, NAT, Proxies and Intrusion
   Prevention Systems) generate packets in the reverse flow direction to
   the source of the current in-process packet/flow.  In this document
   we discuss and propose how to support this required functionality
   within the SFC framework.

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

---

From: "Haeffner, Walter, Vodafone DE" <[email-masked]>
Date: Wed, 11 May 2016 00:36:30 +0000

Section 7:
>From a user point of view the md classification sounds very technical and most definitions may not be obvious for people who simply deploy  an sfc. For a specific service these folks  expect to have a certain set of static metadata and a set of dynamic metadata. Static md may be related to a user, a service profile etc. That is, md you know in advance. Dynamic md may be related to user location, network conditions, user-selected value added service identifier etc. These are md which can even change on the fly.  Because of dynamic md a user-related service maps rather onto a sf-graph than a sf-chain.

 I can  e.g. think about dynamic md which enforce reclassification. Well, if I would use a md2-slot from nsh to signal reclassification, I could also understand "md from reclassification ". 

BR, Walter

-----Ursprüngliche Nachricht-----
Von: sfc [mailto:[email-masked]] Im Auftrag von Dave Dolson
Gesendet: Dienstag, 10. Mai 2016 17:27
An: [email-masked]
Betreff: [sfc] FW: New Version Notification for draft-penno-sfc-packet-03.txt

Features:

-Dave

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Friday, April 29, 2016 11:49 AM
To: Eric Wang; Reinaldo Penno; Chui-Tin Yen; Dave Dolson; Carlos Pignataro; Kent Leung
Subject: New Version Notification for draft-penno-sfc-packet-03.txt

Abstract:

The IETF Secretariat

_______________________________________________
sfc mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/sfc