Subject: [sfc] Robert Wilton's No Objection on draft-ietf-sfc-serviceid-header-12: (with COMMENT)

From: Robert Wilton via Datatracker <[email-masked]>
Date: Wed, 04 Nov 2020 04:23:52 -0800

Robert Wilton has entered the following ballot position for
draft-ietf-sfc-serviceid-header-12: No Objection

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-sfc-serviceid-header/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

Thank you for this document.

A few minor comments/questions:

3.  Subscriber Identification NSH Variable-Length Context Header

   This document adheres to the recommendations in [RFC8300] for
   handling the Context Headers at both ingress and egress SFC boundary
   nodes (i.e., to strip such Context Headers).  Revealing any personal
   and subscriber-related information to third parties is avoided by
   design to prevent privacy breaches in terms of user tracking.

This paragraph doesn't appear to be specific to "Subscriber Identification NSH
Variable-Length Context Header", yet appears under section 3.  Perhaps this
paragraph would be better at the end of the introduction, may be continuing on
from "This document assumes the NSH is used exclusively within a single
administrative domain."?

3.  Subscriber Identification NSH Variable-Length Context Header

       When multiple subscriber
       identifier Context Headers are present and an SF is instructed to
       strip the Subscriber Identifier Context Header, that SF MUST remove
       all Subscriber Identifier Context Headers.

Is a local policy allowed to remove a single subscriber identifier Context
Header?  This text implies that it must always be the case that if one is being
removed, they are always all removed.  Is that the intention?  E.g., I was
wondering whether the intent here is to explain that their might be multiple
context headers in a packet, and hence if a node is instructed to generically
remove the subscriber identifier then it better ensure that it removes all
subscriber identifier context headers and not just the first one that it finds.

A few nits:

"As such, means to allow" => "As such, methods to allow"
"out of the scope of this" => "outside the scope of this" or "out of scope for
this" "an additional internal structures" => "additional internal structures"
"decide unambiguously whether" => "specify whether"

---

From: <[email-masked]>
Date: Wed, 4 Nov 2020 12:41:17 +0000

Hi Rob, 

Thank you for the comments and suggestions. 

Integrated almost all of them: https://github.com/boucadair/draft-ietf-sfc-serviceid/commit/80313043c562a4656acb4b57708f2a7414413c6c 

I confirm that the intent is when a node is instructed to remove the subscriber header, it must strip all instances (as all of those point to the same subscriber). 

Cheers,
Med

> -----Message d'origine-----
> De : Robert Wilton via Datatracker [mailto:[email-masked]]
> Envoyé : mercredi 4 novembre 2020 13:24
> À : The IESG <[email-masked]>
> Cc : [email-masked]; [email-masked];
> [email-masked]; Greg Mirsky <[email-masked]>;
> [email-masked]
> Objet : Robert Wilton's No Objection on draft-ietf-sfc-serviceid-
> header-12: (with COMMENT)
> 
> When responding, please keep the subject line intact and reply to
> all email addresses included in the To and CC lines. (Feel free to
> cut this introductory paragraph, however.)
> 
> 
> This paragraph doesn't appear to be specific to "Subscriber
> Identification NSH Variable-Length Context Header", yet appears
> under section 3.  Perhaps this paragraph would be better at the end
> of the introduction, may be continuing on from "This document
> assumes the NSH is used exclusively within a single administrative
> domain."?
> 
> Is a local policy allowed to remove a single subscriber identifier
> Context Header?  This text implies that it must always be the case
> that if one is being removed, they are always all removed.  Is that
> the intention?  E.g., I was wondering whether the intent here is to
> explain that their might be multiple context headers in a packet,
> and hence if a node is instructed to generically remove the
> subscriber identifier then it better ensure that it removes all
> "out of the scope of this" => "outside the scope of this" or "out of
> scope for this" "an additional internal structures" => "additional
> internal structures"

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: "Rob Wilton (rwilton)" <[email-masked]>
Date: Wed, 4 Nov 2020 12:52:24 +0000

Hi Med,

> -----Original Message-----
> From: iesg <[email-masked]> On Behalf Of
> [email-masked]
> Sent: 04 November 2020 12:41
> To: Rob Wilton (rwilton) <[email-masked]>; The IESG <[email-masked]>
> Cc: [email-masked]; Greg Mirsky
> <[email-masked]>; [email-masked]; [email-masked]
> Subject: RE: Robert Wilton's No Objection on draft-ietf-sfc-serviceid-
> Integrated almost all of them: https://github.com/boucadair/draft-ietf-
> sfc-serviceid/commit/80313043c562a4656acb4b57708f2a7414413c6c
> 
> I confirm that the intent is when a node is instructed to remove the
> subscriber header, it must strip all instances (as all of those point to
> the same subscriber).
[RW] 

Okay, then please also take a look at this text in section 3:

   The classifier and NSH-aware SFs MAY inject or strip a Subscriber
   Identifier Context Header as a function of a local policy.

I interpreted this as a SF being allowed to remove just a single header.  You might want to consider tweaking this text to make it clear, or perhaps consider merging the other paragraph here.  But I'm happy to leave this to your discretion.

Regards,
Rob

> __________________________________________________________________________
> _______________________________________________
> 
> Ce message et ses pieces jointes peuvent contenir des informations
> confidentielles ou privilegiees et ne doivent donc
> pas etre diffuses, exploites ou copies sans autorisation. Si vous avez
> recu ce message par erreur, veuillez le signaler
> a l'expediteur et le detruire ainsi que les pieces jointes. Les messages
> electroniques etant susceptibles d'alteration,
> This message and its attachments may contain confidential or privileged
> information that may be protected by law;