Subject: [sfc] Éric Vyncke's No Objection on draft-ietf-sfc-serviceid-header-12: (with COMMENT)

From: Éric Vyncke via Datatracker <[email-masked]>
Date: Tue, 03 Nov 2020 23:06:49 -0800

Éric Vyncke has entered the following ballot position for
draft-ietf-sfc-serviceid-header-12: No Objection

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-sfc-serviceid-header/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

Thank you for the work put into this document.

Please find below a couple of non-blocking COMMENT points and I would
appreciate it if the authors answered to my points that were closed to be a
DISCUSS.

I hope that this helps to improve the document,

Regards,

-éric

-- Section 1 --
Please clarify the following text as NAT only applies to IPv4 and as there is
no private addresses in IPv6 "  Typically,
   because of the widespread use of private addressing in those
   networks, if SFs to be invoked are located after a NAT function, the
   identification based on the internal IP address is not possible once
   the NAT has been crossed. "

-- Section 3 --
While I am not familiar with NSH RFC 8300 and the concept of updating the NSH
context, the following text makes me wonder: "  The classifier and NSH-aware
SFs MAY inject or strip a Subscriber
   Identifier Context Header as a function of a local policy."

It appears to me that a SF would actually increase/decrease the size of NSH
which could lead to two issues: 1) the actual MTU is decreased on the path
*after* encapsulation 2) if ICMP is generated back to the source of the NSH
header, then will the source recognize the NSH packet inside the ICMP message
as it is different ?

---

From: <[email-masked]>
Date: Wed, 4 Nov 2020 07:42:37 +0000

Hi Eric,

Thank you for the review. 

Please see inline. 

Cheers,
Med

> -----Message d'origine-----
> De : Éric Vyncke via Datatracker [mailto:[email-masked]]
> Envoyé : mercredi 4 novembre 2020 08:07
> À : The IESG <[email-masked]>
> Cc : [email-masked]; [email-masked];
> [email-masked]; Greg Mirsky <[email-masked]>;
> [email-masked]
> Objet : Éric Vyncke's No Objection on draft-ietf-sfc-serviceid-
> header-12: (with COMMENT)
> 
> When responding, please keep the subject line intact and reply to
> all email addresses included in the To and CC lines. (Feel free to
> cut this introductory paragraph, however.)
> 
> 
> Please find below a couple of non-blocking COMMENT points and I
> would appreciate it if the authors answered to my points that were
> closed to be a DISCUSS.
> 
> Please clarify the following text as NAT only applies to IPv4 and as
> there is no private addresses in IPv6 "  Typically,

[Med] Changed to "IPv4". 

> 
> -- Section 3 --
> While I am not familiar with NSH RFC 8300 and the concept of
> updating the NSH context, the following text makes me wonder: "  The
> classifier and NSH-aware SFs MAY inject or strip a Subscriber
> It appears to me that a SF would actually increase/decrease the size
> of NSH which could lead to two issues: 1) the actual MTU is
> decreased on the path
> *after* encapsulation 2) 

[Med] Yes. This is discussed in Section 5 of 8300.

if ICMP is generated back to the source of
> the NSH header, then will the source recognize the NSH packet inside
> the ICMP message as it is different ?
> 

[Med] The transport encap will be used to identify the packet, but even if SFC information is needed, SFFs rely on the TTL + service path header for their lookup. Context headers are volatile and are not used for lookups (and thus identification).  

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: "Eric Vyncke (evyncke)" <[email-masked]>
Date: Wed, 4 Nov 2020 10:37:40 +0000

Bonjour Med,

Thank you for the "IPv4" fix and your reply about the insertion of NSH context on the fly (this still looks weird to me but if it respects RFC 8300 then I am fine)

-éric

-----Original Message-----
From: "[email-masked]" <[email-masked]>
Date: Wednesday, 4 November 2020 at 08:42
To: Eric Vyncke <[email-masked]>, The IESG <[email-masked]>
Cc: "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, Greg Mirsky <[email-masked]>
Subject: RE: Éric Vyncke's No Objection on draft-ietf-sfc-serviceid-header-12: (with COMMENT)

    Hi Eric,

    Please see inline. 

    Cheers,
    Med

    [Med] Changed to "IPv4".