Subject: [sfc] Erik Kline's No Objection on draft-ietf-sfc-nsh-integrity-06: (with COMMENT)

From: Erik Kline via Datatracker <[email-masked]>
Date: Mon, 12 Jul 2021 22:39:55 -0700

Erik Kline has entered the following ballot position for
draft-ietf-sfc-nsh-integrity-06: No Objection

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-sfc-nsh-integrity/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

[S7.{2,3}] [question]

* Is the timestamp a part of the input to the MAC/encrypted metadata
  generation?  If so, perhaps consider adding an explicit mention
  (perhaps I missed it).

  For that matter, I can't quite tell of some normalized version of the
  MAC#1/2 header overall is part of the input to the MAC/AAD generation
  or not.

---

From: <[email-masked]>
Date: Tue, 13 Jul 2021 06:42:41 +0000

Hi Erik, 

Thanks for the comments. 

The timestamp is not an input for encrypting data. However, it is part of the data covered by integrity. This is shown, for example, in Figures 6 and 7 and the "Message Authentication Code" description. 

Cheers,
Med

> -----Message d'origine-----
> De : Erik Kline via Datatracker [mailto:[email-masked]]
> Envoyé : mardi 13 juillet 2021 07:40
> À : The IESG <[email-masked]>
> Cc : [email-masked]; [email-masked];
> [email-masked]; [email-masked]; [email-masked]
> Objet : Erik Kline's No Objection on draft-ietf-sfc-nsh-integrity-
> 06: (with COMMENT)
> 
> When responding, please keep the subject line intact and reply to
> all email addresses included in the To and CC lines. (Feel free to
> cut this introductory paragraph, however.)
> 
> 

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.