Subject: [sfc] Warren Kumari's No Objection on draft-ietf-sfc-nsh-integrity-06: (with COMMENT)

From: Warren Kumari via Datatracker <[email-masked]>
Date: Wed, 14 Jul 2021 10:55:48 -0700

Warren Kumari has entered the following ballot position for
draft-ietf-sfc-nsh-integrity-06: No Objection

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-sfc-nsh-integrity/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

I support Roman and Eric's DISCUSS points.

I also found:
"Note that some transport encapsulations (e.g., IPsec) only provide hop-by-hop
security between two SFC data plane elements (e.g., two Service Function
Forwarders (SFFs), SFF to SF) and do not provide SF-to-SF security of NSH
metadata.  For example, if IPsec is used, SFFs or SFs within a Service Function
Path (SFP) that are not authorized to access the privacy-sensitive metadata
will have access to the metadata." to be incredibly hard to read/parse. I think
that my confusion comes in around the "that are not authorized to access the
privacy-sensitive metadata will have access to the metadata." test, and thing
that the last sentence should be rewritten to start with "Because IPsec does
not... it exposes privacy-sensitive metadata to..."

Also, thanks to Jürgen Schönwälder for the OpsDir review, and to the authors
for addressing the comments.

---

From: <[email-masked]>
Date: Thu, 15 Jul 2021 05:01:55 +0000

Hi Warren,

Thanks for the comment. 

Will see how to tweak that sentence. If we don't have a better alternative, we will leave it to the RFC editor. 

Cheers,
Med

> -----Message d'origine-----
> De : Warren Kumari via Datatracker [mailto:[email-masked]]
> Envoyé : mercredi 14 juillet 2021 19:56
> À : The IESG <[email-masked]>
> Cc : [email-masked]; [email-masked];
> [email-masked]; [email-masked]; [email-masked];
> [email-masked]
> Objet : Warren Kumari's No Objection on draft-ietf-sfc-nsh-
> integrity-06: (with COMMENT)
> 
> When responding, please keep the subject line intact and reply to
> all email addresses included in the To and CC lines. (Feel free to
> cut this introductory paragraph, however.)
> 
> 
> "Note that some transport encapsulations (e.g., IPsec) only provide
> hop-by-hop security between two SFC data plane elements (e.g., two
> Service Function Forwarders (SFFs), SFF to SF) and do not provide
> SF-to-SF security of NSH metadata.  For example, if IPsec is used,
> SFFs or SFs within a Service Function Path (SFP) that are not
> authorized to access the privacy-sensitive metadata will have access
> to the metadata." to be incredibly hard to read/parse. I think that
> my confusion comes in around the "that are not authorized to access
> the privacy-sensitive metadata will have access to the metadata."
> test, and thing that the last sentence should be rewritten to start
> with "Because IPsec does not... it exposes privacy-sensitive
> metadata to..."
> 
> Also, thanks to Jürgen Schönwälder for the OpsDir review, and to the
> authors for addressing the comments.
> 
> 

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.