Subject: [sidr] rpki-rtr: query for certain records & more detailed certification status

From: [email-masked]
Date: Wed, 23 Mar 2011 15:56:19 +0100

Hi,

I will start to work on a RTR C implementation soon and have 2 questions about the RTR draft:

The current draft provides a mechanism to fetch all or a bulk of validated prefix origin
records from the cache that have a serial number greater than X.

Is there any discussion to extend the protocol later with:

* a PDU to ask the cache for the validation list of a certain AS
  Number and/or Prefix? (instead of
  requesting _all_ data records from the cache)

* a mechanism to provide a more detailed certification status for a prefix origin?
  ie: valid/invalid/no signature available?
  (maybe in the reserved field in the Prefix PDUs?)

thanks for your help & best regards

Fabian

---

From: Randy Bush <[email-masked]>
Date: Wed, 23 Mar 2011 10:02:19 -0700

>   Number and/or Prefix? (instead of requesting _all_ data records from
>   the cache)
> 
> * a mechanism to provide a more detailed certification status for a
>   prefix origin?  ie: valid/invalid/no signature available?  (maybe in
>   the reserved field in the Prefix PDUs?)

no, there has not been.

randy