Subject: [sidr] Please re-charter SIDR

From: Christopher Morrow <[email-masked]>
Date: Mon, 7 Mar 2011 21:18:45 -0500

Howdy AD folk,
Please re-charter sidr with the new text included below. Some 103+
messages on-list boiled the original into what is now a more cogent
charter.

thanks!
-Chris
co-chair-weeble-wobble

------------------------------------ included text goes here
---------------------------------------------
Description of Working Group:

The purpose of the SIDR working group is to reduce vulnerabilities in
the inter-domain routing system. The two vulnerabilities that will be
addressed are:

 * Is an Autonomous System (AS) authorized to originate an IP prefix
 * Is the AS-Path represented in the route the same as the path through
    which the NLRI traveled

The SIDR working group will take practical deployability into consideration.

Building upon the already completed and implemented framework:

 * Resource Public Key Infrastructure (RPKI)
 * Distribution of RPKI data to routing devices and its use in
      operational networks
 * Document the use of certification objects within the secure
      routing architecture

This working group will specify security enhancements for inter-domain
routing protocols.

The SIDR working group is charged with the following goals and
milestones:
ID Date      Pub Date
Mar 2011   Jan 2012  An overview of the RPKI and BGP Protocol changes
required for origin and path validation
Mar 2011   Jun 2012  A document describing threats to the routing system
Mar 2011   Jun 2012  A requirements document that  addresses these threats
Mar2011    Jan 2012  Document the BGP protocol enhancements that meet
the security requirements
Nov 2010    Jul 2011   draft-ietf-sidr-origin-ops
Mar 2011   Jul 2012   Operational deployment guidance for network operators
Jun 2011    Dec 2011 System and architecture design choices made in
the protocol and RPKI
Mar 2010    Mar 2012   draft-ietf-sidr-cps-irs
Mar 2010    Mar 2012   draft-ietf-sidr-cps-isp
Nov 2010    Jan 2012   draft-ietf-sidr-pfx-validate
Jan 2010    Jun 2011    draft-ietf-sidr-publication
Nov 2010    Jun 2011   draft-ietf-sidr-repos-struct
Nov 2010    Jun 2011   draft-ietf-sidr-roa-format
Feb 2011    Jun 2011    draft-ietf-sidr-rpki-rtr
Nov 2010    Nov 2011   draft-ietf-sidr-ltamgmt
Dec 2010    Oct 2011   draft-rgaglian-sidr-algorithm-agility
May 2011    Dec 2011  draft-ietf-sidr-usecases
Jan 2011    Oct 2011   draft-ietf-sidr-ghostbusters
Jan 2010    Dec 2011   draft-ietf-sidr-keyroll
Jan 2010    May 2011  draft-ietf-sidr-arch
Jan 2010    May 2011  draft-ietf-sidr-cp
Jan 2010    May 2011  draft-ietf-sidr-res-certs
Jan 2010    Jun 2011  draft-ietf-sidr-roa-validation
Jan 2010    Jun 2011  draft-ietf-sidr-signed-object
Jan 2010    Jun 2011  draft-ietf-sidr-rpki-manifests
Jan 2010    Jul 2011  draft-ietf-sidr-rpki-algs
Jan 2010    Jul 2011  draft-ietf-sidr-rescerts-provisioning
Jan 2010    Aug 2011  draft-ietf-sidr-ta

------------------------------------ end included text
------------------------------------------------------

---

From: Christopher Morrow <[email-masked]>
Date: Mon, 7 Mar 2011 21:22:45 -0500

(note fix to Roque's doc - algorithm-agility)

On Mon, Mar 7, 2011 at 9:18 PM, Christopher Morrow
<[email-masked]> wrote:
> Dec 2010    Oct 2011   draft-ietf-sidr-algorithm-agility