Subject: Re: [Sidrops] draft-sidrops-rpkimaxlen

From: Christopher Morrow <[email-masked]>
Date: Thu, 23 Sep 2021 13:44:54 -0400

Howdy draft authors/readers-of-drafts:
  "This document seems to have petered out, and I think the end of the
thread here is: 'Meh, maybe we don't need this document?'"

Is this document not necessary anymore? or is the document ready for wglc ?
or ?

On Thu, Mar 11, 2021 at 10:15 AM Di Ma <[email-masked]> wrote:

> Interesting.
>
> AS0 ROA is yet another thing we can take into consideration.
>
> Di
>
> > 2021年3月11日 23:07，George Michaelson <[email-masked]> 写道：
> >
> > Is there a role for use of AS0 ROA, to "punch out" the elements
> > between /len and /maxlen, that are not "wanted" in routing?
> >
> > Is there a role for short-life AS0 ROA, to mark the "emergency use"
> > more specifics, So they can come live on the time for the AS0 to die
> > out or be repudiated, but not have to be announced until needed?
> >
> > (C/F Randy: George: stop inventing things we don't need) also (C/F
> > this may not actually be a new thought bubble)\
> >
> > -G
> >
> > On Thu, Mar 11, 2021 at 5:34 PM Di Ma <[email-masked]> wrote:
> >>
> >> Jakob,
> >>
> >>> 2021年3月10日 21:07，Jakob Heitz (jheitz) <jheitz=
> [email-masked]> 写道：
> >>>
> >>> I agree that a hijack is made easier when a ROA exists without a
> corresponding BGP advertisement.
> >>>
> >>> Implementing DDOS and RTBH as indicated in the draft is difficult
> without the ROAs for the required BGP announcements. As indicated in the
> draft, creating and distributing the ROAs required for RTBH and DDOS
> scrubbers is time consuming.
> >>>
> >>> Note that these ROAs are not required throughout the entire BGP space,
> the world.
> >>> These ROAs are only needed near the AS requiring these services, thus
> distributing them
> >>> around the entire world, just for some local RTBH implementation is
> disruptive to the
> >>> rest of the world.
> >>>
> >>> To help with these "limited distribution ROAs" that are required
> quickly, and in
> >>> a smaller space than the entire BGP space, I propose to invent a new
> BGP address
> >>> family to publish them. Using BGP to publish a ROA enables fast
> distribution
> >>> and allows to limit the distribution to only those ASes that need it.
> >>
> >> As I am maintaining RPSTIR the RP Software, I have been working on a
> feedback mechanism to enable RP to learn from BGP announcements to
> establish local/neighbor view. In the context of RPKI, I see those ASes
> sharing the same one RP are local.
> >>
> >> I think your proposed "limited distribution ROAs”  is going to help
> create local/neighbor view.
> >>
> >> Granted, we may have the ROA validation by RP not the router itself and
> should work on the interface between them.
> >>
> >>>
> >>> Anybody want to help me write a draft?
> >>
> >> Count me in if you think an RP implementor can help.
> >>
> >> Di
> >> _______________________________________________
> >> Sidrops mailing list
> >> [email-masked]
> >> https://www.ietf.org/mailman/listinfo/sidrops
> >
> > _______________________________________________
> > Sidrops mailing list
> > [email-masked]
> > https://www.ietf.org/mailman/listinfo/sidrops
>
> _______________________________________________
> Sidrops mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/sidrops
>

---

From: Ben Maddison <[email-masked]>
Date: Wed, 29 Sep 2021 12:35:48 +0200

Hi Chris,

> thread here is: 'Meh, maybe we don't need this document?'"
I still get asked the questions that this tries to answer on a
semi-regular basis. So, IMO it should still proceed.
The fact that it hasn't for ~6 months is mostly my fault.

> Is this document not necessary anymore? or is the document ready for wglc ?
I need to add some language to address the issue that Alexander raised
during the 110 meeting.
I'll try and ship something in the next couple of days.
After that, I think it will be ready for WGLC.

Cheers,

Ben

---

From: Christopher Morrow <[email-masked]>
Date: Wed, 29 Sep 2021 10:30:24 -0400

> semi-regular basis. So, IMO it should still proceed.

I also get asked this question set, so would like to see the document
progress :)

> The fact that it hasn't for ~6 months is mostly my fault.

s'ok things happen... we were/are just going through the document
list to find stuck things and attempting to poke with sharpened stakes[0]
to get them moving again.

> After that, I think it will be ready for WGLC.
sweet thanks!

-chris

0:
https://static.wikia.nocookie.net/buffy/images/5/51/Kendra_Mr_Pointy.png/revision/latest/scale-to-width-down/350?cb=20180712171700