Subject: Re: Filtering Infrastructure (was "Re: Who will write filtering scripts?")

From: John Mani <[email-masked]>
Date: Sun, 30 Mar 1997 19:16:08 -0800 (PST)

> Personally, I think any filtering should be done by
> the MTA, and I see little applicability in keying some filtering off of the
> opening of a mailbox.

	Ideally yes, but if the MTA does not implement/permit filtering or 
does not advertise the necessary hooks for the client to install filters, 
the client has to do the filtering on its own. And this is typically 
triggered off during the opening of the INBOX.
 	It would be nice if the filtering language does not assume that it
is always executed only by the MTA. Anyways I think MTA side filtering
capabalities are typically a subset of client-side filtering ....so shouldn't
be a problem ..

-john

---

From: "Jack De Winter" <[email-masked]>
Date: Mon, 31 Mar 1997 00:19:49 -0500

>capabalities are typically a subset of client-side filtering ....so shouldn't

My problems with such filtering are the trigger points and differing
cicumstances.  For the trigger points, what happens if you don't open
you mailbox a lot, and just keep it open?  For the circumstances, what
do you do to make a single script servicable to 2 different filtering
points? (Personally, I would mandate 2 distinct scripts myself)

regards,
Jack
-------------------------------------------------
Jack De Winter - Wildbear Consulting, Inc.
(519) 576-3873		http://www.wildbear.on.ca/

Author of SLMail for 95 & NT (http://www.seattlelab.com/)