Subject: Suggestions

From: Paul Vincent Craven <[email-masked]>
Date: 26 Jun 97 11:34:48 -0500

I'd like to see a "redirect" command added to the basic actions list.

Definition for exists needs to be spelled out in the grammer
e.g. exists = "exists" [WSP] "(" #(condition) [WSP] ")"

A way to pass a parameter to extension-actions
my_action( header("organization" ))

Some method where the extension action can reference the text of the message.
This would allow an extension action to file a message in a database for example.

I'd also like to see some discussion of rules on outgoing mail. We can do this
if rule processing is incorporated with the SMTP server. This would allow a
delayed mail feature. e.g.
if
  header("x-delay-until")
then
  delay_mail( header("x-delay-until"))
  toss // the original message

-------------
Paul Vincent Craven
[email-masked]
Software Engineer, CE Software
http://www.cesoft.com
http://www.raccoon.com/~pcraven

---

From: Tim Showalter <[email-masked]>
Date: Fri, 27 Jun 1997 15:41:59 -0400 (EDT)

> I'd like to see a "redirect" command added to the basic actions list.

What does redirect do?

> my_action( header("organization" ))

This is probably true.  The language design needs to be reworked to be more
sane. Just having an ad-hoc grammar will encourage a lot of bad extension
design.  This is probably a specific case of general argument passing.

> This would allow an extension action to file a message in a database for example.

I'm not sure what you're suggesting.  Are you looking for a way to deal with
the insides of a message?

>   toss // the original message

I think this is out of scope of what I'd intended.  I also belive delayed
mail is best done with a cron job.  Can you be more specific?

-- 
                                           Tim Showalter [email-masked]