Subject: notes on the managesieve protocol

From: Simon Josefsson <[email-masked]>
Date: 07 Mar 2001 22:30:58 +0100

I implemented the managesieve protocol (http://josefsson.org/sieve/)
and I joted down some notes while doing so.

/Simon

Notes on the managesieve protocol:

* add BYE <reason> to login message "OK"

* support anonymous sasl mode for syntax verification only

* Typo "SETACRIVE" line 588

* add semantic information in ebnf for response-listscripts: "ACTIVE
  string MUST NOT be present on more than one sieve-name).  Also add
  some text in the document with a MUST about this.

* client inactivity resulting in server autologouts should be
  discussed, maybe also a MUST on minimum time (30 minutes, like
  IMAP).

* just a thought: managesieve is not specific to sieve, perhaps it
  could be extended into allowing any language.  if the management
  protocol for mail splitting is language-independent we can replace
  sieve and keep the toolbase, when we discover that we want a turing
  complete language.

---

From: [email-masked]
Date: Fri, 30 Mar 2001 18:15:33 -0800 (PST)

Thanks for the input. Sorry for the delay replying to this.

>* add BYE <reason> to login message "OK"

Do you mean so the server can drop connections after failed logins such as:

BYE "Too many failed login attempts"
<connection closed>

I'd agree with this. Should the server be allowed to give this response to other commands? I see no reason why not.

>* support anonymous sasl mode for syntax verification only

I like this idea. It'll be in the next revision.

>  some text in the document with a MUST about this.

Agreed.

>  discussed, maybe also a MUST on minimum time (30 minutes, like

Agreed.

>  sieve and keep the toolbase, when we discover that we want a turing

This main goal of managesieve was to make something that was easy to implement so people could use sieve now. ACAP/LDAP provide more general solutions that, in the long run, TuringSieve scripts (or whatever) could be stored on.

From: [email-masked]
Date: Fri, 30 Mar 2001 18:15:33 -0800 (PST)
To: [email-masked], [email-masked]
Subject: Re: notes on the managesieve protocol
Sender: [email-masked]

Thanks for the input. Sorry for the delay replying to this.

>* add BYE <reason> to login message "OK"

Do you mean so the server can drop connections after failed logins such as:

BYE "Too many failed login attempts"
<connection closed>

I'd agree with this. Should the server be allowed to give this response to other commands? I see no reason why not.

>* support anonymous sasl mode for syntax verification only

I like this idea. It'll be in the next revision.

>  some text in the document with a MUST about this.

Agreed.

>  discussed, maybe also a MUST on minimum time (30 minutes, like

Agreed.

>  sieve and keep the toolbase, when we discover that we want a turing

This main goal of managesieve was to make something that was easy to implement so people could use sieve now. ACAP/LDAP provide more general solutions that, in the long run, TuringSieve scripts (or whatever) could be stored on.

Date: Sun, 25 Mar 2001 15:41:06 -0500
From: Ken Murchison <[email-masked]>
Organization: Oceana Matrix Ltd.
To: Kim Armann <[email-masked]>
CC: [email-masked]
Subject: Re: Vacation - unsupported feature ?
Sender: [email-masked]

Kim Armann wrote:
> 
> Hi,
> 
> I'm using cyrus-imapd-1.6.25 and I want to use vacation.
> installsieve works but in /var/log/messages I get
> 
> Mar 23 10:10:53 mars deliver[1736]: sieve parse error for kiar: line 1:
> unsupported feature

In order to use vacation, you MUST be running deliver in LMTP mode (-l
switch).  Otherwise, vacation is not supported by cmu-sieve and results
in the error above.

BTW, questions like these should be posted to
[email-masked], NOT to ietf-mta-filters.

> Here is my script :
> 
> require ["fileinto","vacation"];
> vacation "Out for now";
> 
> Btw. I cannot find a documentation about vacation
> (http://search.ietf.org/internet-drafts/draft-showalter-sieve-vacation-04.txt)
> dissapeared.

This is worthy of being on the list, just to nag the author ;-)

Ken
-- 
Kenneth Murchison     Oceana Matrix Ltd.
Software Engineer     21 Princeton Place
716-662-8973 x26      Orchard Park, NY 14127
--PGP Public Key--    http://www.oceana.com/~ken/ksm.pgp

Date: Fri, 23 Mar 2001 10:18:51 +0100
From: Kim Armann <[email-masked]>
To: [email-masked]
Subject: Vacation - unsupported feature ?
Sender: [email-masked]

Hi,

I'm using cyrus-imapd-1.6.25 and I want to use vacation.
installsieve works but in /var/log/messages I get

Mar 23 10:10:53 mars deliver[1736]: sieve parse error for kiar: line 1:
unsupported feature

Here is my script :

require ["fileinto","vacation"];
vacation "Out for now";

Btw. I cannot find a documentation about vacation
(http://search.ietf.org/internet-drafts/draft-showalter-sieve-vacation-04.txt)
dissapeared.

thanx kim

From: [email-masked]
To: <[email-masked]>
Subject: I CAN HELP !!!
Date: Fri, 16 Mar 2001 17:19:07 -0600
Reply-To: [email-masked]
Sender: [email-masked]

<HTML>
<BODY>

<FONT face=3D"MS Sans Serif">
<FONT size=3D2>
<FONT color=3D"#000000"> <HTML><BR>
   <HEAD><BR>
   <TITLE></TITLE><BR>
   </HEAD><BR>
   <BODY><BR>
   <TABLE BGCOLOR=3D"#ffffff" CELLPADDING=3D"0" CELLSPACING=3D"0" WIDTH=3D=
"250"><BR>
   <TR><BR>
   <TD><BR>
   <TABLE BGCOLOR=3D"#004080" CELLPADDING=3D"5" CELLSPACING=3D"0"><BR>
   <TR><BR>
   <TD><BR>
   <CENTER><BR><FONT COLOR=3D"#ffffff" FACE=3D"Arial" SIZE=3D"+1">Can't<BR=
   get email out to the masses without losing your ISP???<BR><BR><BR>
   Don't know how<BR>
   to get sales for your product???<BR><BR>Can't get traffic to your<BR>
   site???<BR><BR></FONT></CENTER></TD><BR>
   </TR><BR>
   <TR><BR>
   <TD BGCOLOR=3D"#008040"><BR><BR>
   <CENTER><FONT FACE=3D"Times New Roman"<BR>
   COLOR=3D"#ffffff"><B><FONT SIZE=3D"+2">Call<BR>
   1-888-242-5082<HTML><BR>
   <HEAD><BR>
   <TITLE></TITLE><BR>
   </HEAD><BR>
   <BODY><BR>
   <TABLE BGCOLOR=3D"#ffffff" CELLPADDING=3D"0" CELLSPACING=3D"0" WIDTH=3D=
"250"><BR>
   <TR><BR>
   <TD><BR>
   <TABLE BGCOLOR=3D"#004080" CELLPADDING=3D"5" CELLSPACING=3D"0"><BR>
   <TR><BR>
   <TD><BR>
   <CENTER><BR><FONT COLOR=3D"#ffffff" FACE=3D"Arial" SIZE=3D"+1">Can't<BR=
   get email out to the masses without losing your ISP???<BR><BR><BR>
   Don't know how<BR>
   to get sales for your product???<BR><BR>Can't get traffic to your<BR>
   site???<BR><BR></FONT></CENTER></TD><BR>
   </TR><BR>
   <TR><BR>
   <TD BGCOLOR=3D"#008040"><BR><BR>
   <CENTER><FONT FACE=3D"Times New Roman"<BR>
   COLOR=3D"#ffffff"><B><FONT SIZE=3D"+2">Call<BR>
   1-888-242-5082</FONT><BR><BR>I have plenty of fresh verified<BR>
   email names and can get you results.<BR>
   </B></FONT><BR><BR></CENTER></TD><BR>
   </TR><BR>
   <TR><BR>
   <TD BGCOLOR=3D"#ffffff"><BR><BR>
   <CENTER><BR>
   <TABLE BGCOLOR=3D"#000000" CELLPADDING=3D"3" CELLSPACING=3D"0"<BR>
   BORDER=3D"0"><BR>
   <TR><BR>
   <TD><BR>
   <TABLE BGCOLOR=3D"#ffffff" CELLPADDING=3D"3"<BR>
   CELLSPACING=3D"0" ><BR>
   <TR><BR>
   <TD><BR>
   <CENTER><FONT FACE=3D"Arial" COLOR=3D"#ff0000"<BR>
   SIZE=3D"+2">Price List</FONT><BR><FONT SIZE=3D"+1" FACE=3D"Arial"<BR>
   COLOR=3D"#008040">Discounts for larger<BR>
   orders</FONT></CENTER><BR>   <FONT<BR>
   FACE=3D"Times New Roman"><B>100<BR>
   Thousand - $200</B><BR>   <B>500 Thousand -<BR>
   $875</B><BR>   <B>1 Million -<BR>
   $1500</B></FONT><BR><BR></TD><BR>
   </TR><BR>
   </TABLE></TD><BR>
   </TR><BR>
   </TABLE></CENTER></TD><BR>
   </TR><BR>
   </TABLE><BR><BR>
   <CENTER><BR>
   <TABLE BGCOLOR=3D"#000000" CELLPADDING=3D"1" CELLSPACING=3D"0"><BR>
   <TR><BR>
   <TD><BR>
   <TABLE BGCOLOR=3D"#000000" CELLPADDING=3D"5" CELLSPACING=3D"0"><BR>
   <TR><BR>
   <TD><BR>
   <CENTER><FONT COLOR=3D"#ffffff" SIZE=3D"+2" FACE=3D"Arial">It<BR>
   is this easy!</FONT></CENTER></TD><BR>
   </TR><BR>
   <TR><BR>
   <TD BGCOLOR=3D"#ffffff"><FONT FACE=3D"Arial"<BR>
   COLOR=3D"#004080" SIZE=3D"+1">You simply furnish your message and I<BR>
   do the rest. I guarantee you<BR>
   100% delivery. It can even be done in <U><B>full color at no<BR>
   extra cost</B></U><BR>
   </FONT></TD><BR>
   </TR><BR>
   </TABLE></TD><BR>
   </TR><BR>
   </TABLE></CENTER> <BR><BR>
   <TABLE BGCOLOR=3D"#ff0000" CELLPADDING=3D"7" CELLSPACING=3D"0"><BR>
   <TR><BR>
   <TD><BR>
   <CENTER><FONT FACE=3D"Arial" SIZE=3D"+1"<BR>
   COLOR=3D"#ffffff">NOTICE</FONT></CENTER><BR><FONT FACE=3D"Times New<BR>
   Roman"><B>Under<BR>
   Bill s.1618 TITLE III passed by the 105th US Congress this letter<BR>
   cannot be<BR>
   considered spam as long as the sender includes contact information<BR>
   and a method<BR>
   of removal. To be removed, hit reply and type remove in the<BR>
   subject<BR>
   line.</B></FONT></TD><BR>
   </TR><BR>
   </TABLE> </TD><BR>
   </TR><BR>
   </TABLE> </BODY><BR>
   </HTML>/FONT><BR><BR>I have plenty of fresh verified<BR>
   email names and can get you results.<BR>
   </B></FONT><BR><BR></CENTER></TD><BR>
   </TR><BR>
   <TR><BR>
   <TD BGCOLOR=3D"#ffffff"><BR><BR>
   <CENTER><BR>
   <TABLE BGCOLOR=3D"#000000" CELLPADDING=3D"3" CELLSPACING=3D"0"<BR>
   BORDER=3D"0"><BR>
   <TR><BR>
   <TD><BR>
   <TABLE BGCOLOR=3D"#ffffff" CELLPADDING=3D"3"<BR>
   CELLSPACING=3D"0" ><BR>
   <TR><BR>
   <TD><BR>
   <CENTER><FONT FACE=3D"Arial" COLOR=3D"#ff0000"<BR>
   SIZE=3D"+2">Price List</FONT><BR><FONT SIZE=3D"+1" FACE=3D"Arial"<BR>
   COLOR=3D"#008040">Discounts for larger<BR>
   orders</FONT></CENTER><BR>   <FONT<BR>
   FACE=3D"Times New Roman"><B>100<BR>
   Thousand - $200</B><BR>   <B>500 Thousand -<BR>
   $875</B><BR>   <B>1 Million -<BR>
   $1500</B></FONT><BR><BR></TD><BR>
   </TR><BR>
   </TABLE></TD><BR>
   </TR><BR>
   </TABLE></CENTER></TD><BR>
   </TR><BR>
   </TABLE><BR><BR>
   <CENTER><BR>
   <TABLE BGCOLOR=3D"#000000" CELLPADDING=3D"1" CELLSPACING=3D"0"><BR>
   <TR><BR>
   <TD><BR>
   <TABLE BGCOLOR=3D"#000000" CELLPADDING=3D"5" CELLSPACING=3D"0"><BR>
   <TR><BR>
   <TD><BR>
   <CENTER><FONT COLOR=3D"#ffffff" SIZE=3D"+2" FACE=3D"Arial">It<BR>
   is this easy!</FONT></CENTER></TD><BR>
   </TR><BR>
   <TR><BR>
   <TD BGCOLOR=3D"#ffffff"><FONT FACE=3D"Arial"<BR>
   COLOR=3D"#004080" SIZE=3D"+1">You simply furnish your message and I<BR>
   do the rest. I guarantee you<BR>
   100% delivery. It can even be done in <U><B>full color at no<BR>
   extra cost</B></U><BR>
   </FONT></TD><BR>
   </TR><BR>
   </TABLE></TD><BR>
   </TR><BR>
   </TABLE></CENTER> <BR><BR>
   <TABLE BGCOLOR=3D"#ff0000" CELLPADDING=3D"7" CELLSPACING=3D"0"><BR>
   <TR><BR>
   <TD><BR>
   <CENTER><FONT FACE=3D"Arial" SIZE=3D"+1"<BR>
   COLOR=3D"#ffffff">NOTICE</FONT></CENTER><BR><FONT FACE=3D"Times New<BR>
   Roman"><B>Under<BR>
   Bill s.1618 TITLE III passed by the 105th US Congress this letter<BR>
   cannot be<BR>
   considered spam as long as the sender includes contact information<BR>
   and a method<BR>
   of removal. To be removed, hit reply and type remove in the<BR>
   subject<BR>
   line.</B></FONT></TD><BR>
   </TR><BR>
   </TABLE> </TD><BR>
   </TR><BR>
   </TABLE> </BODY><BR>
   </HTML><BR>
<BR>
</FONT></FONT><p><p><p><p><p><p><p><p><p><p>

<p><FONT face=3D"MS Sans Serif"><p><FONT size=3D2><p><FONT color=3D"#00000=
0"> <HTML><BR><p>   <HEAD><BR><p>   <TITLE></TITLE><BR><p><p><p><p><p><p><=
p><p><p></BODY></HTML>

From: Bill Fenner <[email-masked]>
To: [email-masked]
Subject: Modifying messages while filtering?
Date: Tue, 13 Mar 2001 16:25:29 -0800
Versions: dmail (solaris) 2.2g/makemail 2.9a
Sender: [email-masked]

Hi,

  I looked through the various sieve Internet-Drafts, and didn't
notice something that I really like my filters to be able to do:
remove a static string from a header.  The specific reason that
I use this is when mailing lists put their names in the Subject
header -- I know what list it is from the folder, so I'd rather use
that bit of screen real estate to see more characters of the subject.

  My current (homegrown) filtering system does this with a regexp,
but I find that I don't use anything more than simple string matching.
Is there any interest in such an extension for sieve?

Thanks,
  Bill

To: [email-masked]
Subject: notes on the managesieve protocol
From: Simon Josefsson <[email-masked]>
Date: 07 Mar 2001 22:30:58 +0100
Lines: 26
Sender: [email-masked]

/Simon