Subject: [Fwd: I-D ACTION:draft-hansen-sieve-loop-00.txt]

From: Tony Hansen <[email-masked]>
Date: Fri, 30 Jul 2004 01:29:36 -0400

This was supposed to be announced to the mta-filters list by the I-D 
editor, but wasn't.

	Tony Hansen
	[email-masked]

Subject: I-D ACTION:draft-hansen-sieve-loop-00.txt
From: [email-masked]
To: [email-masked]
Date: Fri, 16 Jul 2004 16:22:22 -0400
List-Id: i-d-announce.ietf.org

A New Internet-Draft is available from the on-line Internet-Drafts directories.

	Title		: Sieve Extension: Bodypart Loops
	Author(s)	: T. Hansen
	Filename	: draft-hansen-sieve-loop-00.txt
	Pages		: 5
	Date		: 2004-7-16
	
The current Sieve language has no looping mechanism, a way to look at
   individual parts, or any way to manipulate those individual parts.
   This document defines extensions for each of these needs.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-hansen-sieve-loop-00.txt

To remove yourself from the I-D Announcement list, send a message to 
[email-masked] with the word unsubscribe in the body of the message.  
You can also visit https://www1.ietf.org/mailman/listinfo/I-D-announce 
to change your subscription settings.

Internet-Drafts are also available by anonymous FTP. Login with the username
"anonymous" and a password of your e-mail address. After logging in,
type "cd internet-drafts" and then
	"get draft-hansen-sieve-loop-00.txt".

A list of Internet-Drafts directories can be found in
http://www.ietf.org/shadow.html 
or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

Internet-Drafts can also be obtained by e-mail.

Send a message to:
	[email-masked].
In the body type:
	"FILE /internet-drafts/draft-hansen-sieve-loop-00.txt".
	
NOTE:	The mail server at ietf.org can return the document in
	MIME-encoded form by using the "mpack" utility.  To use this
	feature, insert the command "ENCODING mime" before the "FILE"
	command.  To decode the response(s), you will need "munpack" or
	a MIME-compliant mail reader.  Different MIME-compliant mail readers
	exhibit different behavior, especially when dealing with
	"multipart" MIME messages (i.e. documents which have been split
	up into multiple messages), so check your local documentation on
	how to manipulate these messages.

Below is the data which will enable a MIME compliant mail reader
implementation to automatically retrieve the ASCII version of the
Internet-Draft.
_______________________________________________
I-D-Announce mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/i-d-announce

---

From: "Nigel Swinson" <[email-masked]>
Date: Fri, 30 Jul 2004 12:11:41 +0100

Hi Tony,

Just read your new I-Draft and it seems to be solving some of the same problems that the draft-daboo-sieve-mime-00.txt draft is trying to solve, so it seems like the two should probably be worked on together.  

The original draft is here:  http://www.ietf.org/internet-drafts/draft-daboo-sieve-mime-00.txt

But I made an alternative proposal in response that seemed to have a lot of support although was never written up into a new draft.  You can read my response here and follow the replies:  http://www.imc.org/ietf-mta-filters/mail-archive/msg02238.html

My proposal for a HEADER-PART tagged argument to the header does mostly the same job as your part test with :filename/:type/:subtype approach, and my :bodyparts optional argument does mostly the same job as your for.every.part loop test.  However the proposal does not include facilities for replace/delete/enclosing body parts.

I think my proposal allows significant extra message matching capabilities with less additional syntax, so I think it would be good if we could go with testing syntax more along the lines of what has already been proposed there.

Perhaps there's really two I-Drafts at play here, a written up version of my proposal for testing body parts, and then an additional one specifying the ability to replace/delete/enclose body parts which requires a "select" body part concept.  Maybe a foreach test, that is used instead of "if".  Then where you have:

   for.every.part {
       if anyof ( part :subtype :is "jpeg", part :filename :matches "*.jpg" {
           replace "Attachment removed by user filter";
       }
   }

We'd have this instead:

   foreach anyof :bodyparts (header :value :matches "Content-Type" "*/jpeg" ,
                                              header :parameter "filename" :matches "Content-Disposition" "*.jpg" ) {
       replace "Attachment removed by user filter";
   }

Cyrus, I expected you'd re-release the draft-daboo-sieve-mime-00.txt I-Draft encorporating all the feedback but don't see a version 01.txt.  Should I do this?

Nigel

---

From: Tony Hansen <[email-masked]>
Date: Fri, 30 Jul 2004 09:49:19 -0400

Nigel Swinson wrote:

> Hi Tony,
> 
> Just read your new I-Draft and it seems to be solving some of the 
> same problems that the draft-daboo-sieve-mime-00.txt draft is trying
> to solve, so it seems like the two should probably be worked on
> together.
 >
 > But I made an alternative proposal in response that seemed to have a
 > lot of support although was never written up into a new draft. You
 > can read my response here and follow the replies:
 > http://www.imc.org/ietf-mta-filters/mail-archive/msg02238.html

I agree - there is some overlap between our drafts, as well as with your 
ideas. I'll have to review the thread you pointed me to.

	Tony Hansen
	[email-masked]