Subject: Re: Draft minutes from Vancouver

From: Michael Haardt <[email-masked]>
Date: Wed, 23 Nov 2005 23:09:38 +0100

> 8) Do we want to allow suppression of identical notifications?
>
> Greg: the answer might depend on whether we need to provide 
> confidentiality. No consensus was reached, so the discussion should 
> continue of the mailing list.

Greg: Please elaborate.  What do you mean by "confidentiality" in this
context?

Are "identical notifications" multiple executed notify actions with
identical parameters in one script? Like:

notify :method "mailto:[email-masked]";
notify :method "mailto:[email-masked]";

If the method is required, and notify is a noop if none is given, then
why the tagged argument and not a positional argument? Just curious.

Michael

---

From: Alexey Melnikov <[email-masked]>
Date: Fri, 25 Nov 2005 13:57:25 +0000

>notify :method "mailto:[email-masked]";
Yes (when all parameters are the same after performing variable 
expansion, if variables are also used).

>If the method is required,
>
It is not.

>and notify is a noop if none is given, then
I was trying to keep backward compatibility with the deployed code.