Subject: [sieve] problem with sieve syntax

From: InterNetworX | Pascal Heverhagen <[email-masked]>
Date: Mon, 15 Feb 2016 13:28:09 +0100

Dear sirs,

I have trouble while setting up some sieve roules via roundcube plugin 
("managesieve"). When set up an autoresponder with 2 automatically-sent 
messages I won't receive any automatic e-mails anymore. When I remove 
one of these, it works fine again.

Heres my syntax:

# rule:[[email-masked]]
if allof (address :contains "to" "[email-masked]")
{
	vacation :days 1 :addresses "[email-masked]" :subject "Re: ${1}" text:
This is my automated mail number one
.
;
	vacation :addresses "[email-masked]" :subject "Re: ${1}" text:
This is my automated mail number two
.
;
}

Can you tell me whats the problem?

Many thanks,
Pascal

---

From: [email-masked]
Date: Mon, 15 Feb 2016 06:25:01 -0800 (PST)

> Can you tell me whats the problem?

It's not really the purpose of this list to provide assistance in debugging
sieve problems, but FWIW, I see two problems here:

(1) No require statement for the vacation extension:
 
    require "vacation";

(2) You're clearly trying to perform a variable substition, but there's
    no code to do that and no require statement for the variables extension
    either.

Now, both of these may be due to your not having provided the entire
script. If that's the case, and you have the necessary require commands
as well as some sort of preceeding :matches operation, then I don't
see any sieve problem here.

				Ned

---

From: Stephan Bosch <[email-masked]>
Date: Mon, 15 Feb 2016 21:40:50 +0100

Op 2/15/2016 om 1:28 PM schreef InterNetworX | Pascal Heverhagen:
> ("managesieve"). When set up an autoresponder with 2
> automatically-sent messages I won't receive any automatic e-mails
> anymore. When I remove one of these, it works fine again.
>
> Heres my syntax:
>

https://tools.ietf.org/html/rfc5230#section-4.7:

"Vacation can only be executed once per script.  A script MUST fail with an appropriate error if it attempts to execute two or more vacation actions."

Your software will probably log something about this problem. Ask the supplier for more information. I remember seeing this before and I think Roundcube developers know about this issue.

Regards,

Stephan.