Subject: [sieve] Sieve :index and string/hasflag tests

From: Ken Murchison <[email-masked]>
Date: Tue, 24 Jan 2017 10:34:27 -0500

All,

I just noticed that the :index extension has leaked into our grammar for 
the string and hasflag tests.  I can't think of any use case for this 
combination but wanted to check with the community before I rip it out.

-- 
Kenneth Murchison
Principal Systems Software Engineer
Carnegie Mellon University

---

From: [email-masked]
Date: Thu, 26 Jan 2017 12:29:50 -0800 (PST)

> combination but wanted to check with the community before I rip it out.

I can't think of a meaning either and our implementation doesn't allow
:index to be combined with string or hasflag (although since we implement
ihave it's an evaluation time check).

				Ned