Subject: Re: Static Configuration

From: "Benjamin J. Wilson,,," <[email-masked]>
Date: Fri, 30 Mar 2001 15:00:38 -0500

Kurt

I'll take a stab...but first of all I'll say that there
are not any procedures defined in the M3UA spec as to
how to handle DEREG REQ (i.e. what state the ASP must be
in to send it and what state it becomes after sending).

Since, I haven't read anywhere that a DEREG REQ can only
be sent for routing contexts that were created via a REG
REQ.  I would think that the ASP could send a DEREG REQ
for the routing context to each SG.  This would then move
the ASP to down state for that particular AS and cause the
routing context to be deleted (this is implementation dependant
however).

I guess depending on the SG implementation it could modify its
configuration but i would think the most likely upon restart
the routing key would be reloaded.

Just an idea.

Ben

Kurt Kite wrote:

> Hi,
> 
> I would like to get opionions on the following scenario.
> 
> The M3UA network consists of two SGs and one ASP. The SGs are
> both connected to the ASP. The SGs and the ASP are statically configured.
> The SGs and the ASP are both aware of the ASs and the routing keys for
> the ASs. The ASsare active. Traffic is flowing to the ASs.
> 
> Now lets say that the operator wants to remove an AS definition from
> the configuration data on the SG. Should this be allowed and, if yes,
> what is the correct procedure. I can think of the following answers (and
> undoubtably there are many more):
> 
> 1) Don't use static configuration data then you won't have this problem.
> 
>     The draft allows for static configuration, so this is not a good answer.
> 
> 2) Don't allow an AS definition on an SG to be removed if the AS is in
>     the inactive or down state.
> 
>     This should work because inactive or down would be the state of the
>      AS prior to sending an ASPIA/ASPAC. The shortcoming of this
>      solution is that the ASP must send ASPDN or ASPIA to get the AS
>     into the inactive or down state.
> 
> 3) Allow the AS defination to be removed. The SG simply removes the
>     AS definition from its configuration data.
> 
>     The problem with this solution is that the ASP is not aware that the
>     AS has been removed and it still thinks the AS is active. I cannot
>     see any mechanism in M3UA whereby an SG can indicate to an ASP
>     that it no longer wants to support sending traffic to an AS. Should
>     such a mechanism be added to M3UA? For example, the SG could
>     send a NOTIFY message to the ASP with a status indication that
>     the SG is no longer sending traffic for a routing context.
> 
> Thanks,
> Kurt
> 
> 
> 
> 
> ---
> You are currently subscribed to sigtran as: [email-masked]
> To unsubscribe send a blank email to [email-masked]

---
You are currently subscribed to sigtran as: [email-masked]
To unsubscribe send a blank email to [email-masked]

---

From: Joe Keller <[email-masked]>
Date: Fri, 30 Mar 2001 14:41:40 -0500

Kurt,

   I think Option 2 makes the most sense.  The only thing I disagree
with is the fact that the SG could do a management inhibit to bring
the AS to a down state.  Thoughts?

Joe

---