Subject: Re: [Tsvwg] RE: FW: I-D ACTION:draft-leung-sigtran-stream-sctp-00.txt

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Thu, 15 Mar 2001 19:02:07 -0600

Qiaobing,

In implementation, each stream consumes resources other than just it's
stream number.  64k is the range of the stream number, but a practical
limit may exist well below 64k on an implementation.

Recharacterizing the stream can recover or reuse resources associated
with the previous characterization of the stream.

Otherwise, why not just start with 64k streams inbound and 64k streams
outbound with each association?

On Thu, 15 Mar 2001, Qiaobing Xie wrote:

[snip]
> 
> Why not simply set up a pair of streams (one reliable and the other
> unreliable) for this particular session? You can have up to 64k streams
> for each association. 
>  
[snip]

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---
You are currently subscribed to sigtran as: [email-masked]
To unsubscribe send a blank email to [email-masked]

---

From: Qiaobing Xie <[email-masked]>
Date: Fri, 16 Mar 2001 12:11:40 -0600

Brian,

> limit may exist well below 64k on an implementation.

The resource for an idle stream is really small. I remember in the
earlier versions of the ref. implementation an idle stream consumes less
than 100 bytes of memory. When you choose an implementation, it's always
part of the system engineering to make sure you have the desired stream
capability.

> with the previous characterization of the stream.

This can be done if we allow dynamic adding and deleting of streams. I
think that is a better solution.

> outbound with each association?

That sounds like an irresponsible way of doing system engineering :-) 

---

---

From: "Randall R. Stewart" <[email-masked]>
Date: Mon, 26 Mar 2001 08:27:29 -0600

Qiaobing:

The current reference implementation uses 4 bytes for an
inbound stream and 4 bytes for an outbound stream. I am 
planning however to reduce this even further so that un-used
streams use NO bytes...

So the cost of un-used streams is '0' bytes of resources.

R

Qiaobing Xie wrote:
> _______________________________________________
> tsvwg mailing list
> [email-masked]
> http://www1.ietf.org/mailman/listinfo/tsvwg

-- 
Randall R. Stewart
[email-masked] or [email-masked]
815-342-5222 (cell) 815-477-2127 (work)

---