Subject: Re: [Tsvwg] Re: SCTP multi-homed fault-tolerance.

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Fri, 23 Mar 2001 13:13:31 -0600

Robert,

As you can see from the thread, I think it is an IP issue
rather than an SCTP issue.  That is because the routing and
reachability of the initial message is a Network issue not a
Transport issue.  Establishing the connection and maintaining
the established connection under congestion and other
anomalies is a Transport issue.

If there is a bunch of equipment which only accepts packets
for a Network address based on it's Link address, then I
suggest you don't use that equipment.  There are plenty which
maintain a good separation between Link and Network layers.

If you don't have a local router, you are attempting path
redundancy rather than interface redundancy.  In that case
SCTP does not give you the path redundancy that you are
expecting (because it does not track source-destination
characeristics, only destination characteristics).  You can
acheive little more that interface redundancy.

Yes there is a switchover time when an interface card fails
for the local (or remote) router to determine that the failed
interface is unreachable and reroute to the second interface.

During this time INITs will be lost.  So you try a couple of
times during this period.  So what?  It eventually recovers.

--Brian

On Fri, 23 Mar 2001, Fairlie-Cuninghame, Robert wrote:

> 
>    I agree RJ. I'm know many implementations that associate IP addresses
>    with particular physical interface. This should set a bound on what we
>    can expect from an multi-homed host. In fact, in my experience moving
>    addresses around interfaces is not as simple as you make it to be
>    Brian. You must inform the local routers that the address has moved.
>    You are also seem to be assuming that the addresses are on the same
>    subnet and/or use the same local router (in order for this operation
>    to be trivial). For rapid-recovery fault-tolerance this is typically
>    not the case. Moving an address onto an interface associated with a
>    different local router and subnet (you now have disjointed subnets) is
>    not impossible but it is far from trivial.
>    
>    So that being said, can we return to my original problem of
>    maintaining the multi-homedfault-tolerant properties while
>    establishing an association? <grin>
>    
>    Regards,
>    
>    Robert.
>    

-- 
Brian F. G. Bidulock    ¦ The reasonable man adapts himself to the ¦
[email-masked]    ¦ world; the unreasonable one persists in  ¦
http://www.openss7.org/ ¦ trying  to adapt the  world  to himself. ¦
                        ¦ Therefore  all  progress  depends on the ¦
                        ¦ unreasonable man. -- George Bernard Shaw ¦

---
You are currently subscribed to sigtran as: [email-masked]
To unsubscribe send a blank email to [email-masked]

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Fri, 23 Mar 2001 13:32:54 -0600

Robert,

As another note, in your circumstance you might want to relax
Section 8.4(1) to allow INITs to broadcast or multicast
addresses.  Then the sender could launch its INIT to a multi-
cast address including the IP list for the association and
only process the first INIT ack (as per INIT ACK rules).

Then stupid boxes which can only hear an address on one
interface can enjoy some tolerance at the expense of
security.

--Brian

---