Subject: Routing Table structure on ASP

From: "Srivats P." <[email-masked]>
Date: Sat, 3 Mar 2001 9:35:16 +0500

Hi,

The routing table structure on the SG has a list of routing keys and
the corresponding AS for each RK.

What does the routing table on an ASP look like ?

1. Same as SG ? ie. RKs and the associated AS ?

or 

2. PointCodes and the list of SGs via which the point code is
available ?

Regards,
Srivats P.
Mercury Corporation

---

From: [email-masked]
Date: Mon, 5 Mar 2001 08:46:38 +0200

> Hi Srivats,
> First off, I guess you are speaking about M3UA, but could you 
> clarify it?
> 
> My guess is this may be implementation specific - do you 
> feel that this should be something standardized in the 
> draft?
> 
> thanks
> John
>

---

From: "Srivats P." <[email-masked]>
Date: Mon, 5 Mar 2001 12:35:59 +0500

Thanks for your reply, John.

Please see comments inline ...

Regards,
Srivats

>First off, I guess you are speaking about M3UA, but could you 

[Srivats] Yes, I was speaking about M3UA. Sorry for not specifying
that in the orginal mail.

>feel that this should be something standardized in the 
[Srivats] The reason I posted this question is that my understanding of the
draft led me to believe that the M3UA Routing Table on the ASP
consisted of point codes and the list of SGs via which the point
code is accessible and NOT the RK-AS structure that is present
on the SG.

But the M3UA MIB Draft seems to indicate otherwise ...

From the draft -
"....
-- The Routing Table
-- *****************

-- The Routing table contains a list of routing keys which translate to
-- Application Servers or Signaling Gateways.

-- This table exists with any Proccess Type.

-- An Index Computation mechanism could be considered instead of current
-- multi-index mechanism.
m3uaRoutingTable OBJECT-TYPE
    SYNTAX      SEQUENCE OF M3uaRoutingEntry
    MAX-ACCESS  not-accessible
    STATUS      current
    DESCRIPTION
            "A table containing Routing-specific information."
    ::= { m3uaTables 5 }

m3uaRoutingEntry OBJECT-TYPE
    SYNTAX      M3uaRoutingEntry
    MAX-ACCESS  not-accessible
    STATUS      current
    DESCRIPTION
            "General common variables for a Routing Key."
    INDEX   { m3uaNA,
              m3uaNI,
              m3uaSI,
              m3uaOPC,
              m3uaDPC,
              m3uaSSN,
              m3uaCICmin,
              m3uaCICmax }

    ::= { m3uaRoutingTable 1 }
 
M3uaRoutingEntry ::= SEQUENCE {
	m3uaNA			Unsigned32,	
	m3uaNI			Unsigned32,
	m3uaSI			Unsigned32,
	m3uaOPC			Unsigned32,
	m3uaDPC			Unsigned32,
	m3uaSSN			Unsigned32,
	m3uaCICmin		Unsigned32,
	m3uaCICmax		Unsigned32,
	m3uaPeerAppId		Unsigned32,
        m3uaRoutingRowStatus	RowStatus
    }
..."

or is it that since DPC is a subset of the RK, the Routing Table on
the ASP contains RKs with only the DPC comprising the RK ?

Maybe the author(s) of the MIB draft could clariry ... Antonio ?

Regards,
Srivats