Subject: FW: M3UA: multiple PC and SGP

From: Ming Lin <[email-masked]>
Date: Sat, 17 Mar 2001 11:38:55 +0800

>Hi Greg,
>
>Now I can receive mails of the sigtran mail list,
>but I can't send mail to it, the mail server tells me
>the DNS is incorrect.
>So I send mail to you directly.
>
>1.
>I find M3UA doesn't support multiple OPC.
>It is possible that SG has multiple PC and 
>one ASP serves for two ASs,
>PCs of which  are different.
>
>The SSNM messages only have affect DPC parameter,
>but in the case mentioned above, affect OPC is needed.
>
>So, affect OPC should be added to SSNM message
>in order to support multi-PC.
>
>2.
>In the case that one ASP is connected to two SGPs , 
>one is active and one is backup,
>if the two SGPs want to switchover, now the only way is
>to disconnect active SGP from ASP, then when ASP receive
>communication down notify from sctp,  ASP switch traffic to backup SGP.
>Some traffic will lose after active SGP down or switchover, 
>before the notify from sctp, because sctp takes time to detect.
>
>If the backup SGP send an SGPM to ASP tell he that it is active now,
>the traffic will not lose.
>
>Pls correct me.
>Thanks&Regards
>Ming Lin
>
>

---
You are currently subscribed to sigtran as: [email-masked]
To unsubscribe send a blank email to [email-masked]

---

From: "Sidebottom, Greg [BCNR:7M01:EXCH]" <[email-masked]>
Date: Wed, 21 Mar 2001 02:39:12 -0500

Hi Ming,

Responses below ...

-----Original Message-----
From: Ming Lin [mailto:[email-masked]]
Sent: Friday, March 16, 2001 10:39 PM
To: [email-masked]
Subject: FW: M3UA: multiple PC and SGP
>in order to support multi-PC.
[Greg] I'm not sure what you mean by the M3UA "doesn't support multiple
OPC".  Are you suggesting a case where an SG has more than one PC in the SS7
network (in the SEP sense) AND handles SS7 traffic to two or more other PCs
(in the STP sense)?  If an SG has two PCs in the SS7 network then it is
really two SS7 nodes with separate linksets to the SS7 network (I'm not
talking about alias PCs here) and could really be considered as two SGs.
Please clarify so I can understand the issue.

>the traffic will not lose.

[Greg] You have a point here - in the current M3UA procedures there is no
SGP to ASP protocol like ASPAC/ASPIA to provide for an SGP switchover.  ASPs
really only know by the availability status of the SCTP association whether
a particular SGP is there (each SGP will have its own SCTP end-point) and
the protocol doesn't differentiate whether an ASP would view multiple SGPs
in an SG as primary/back-up or loadshared.

This was design intent as we wanted SGP support to be as simple as possible
in the protocol sense as i) many/most SGs will not be designed this way and
ii) for those SGs that are designed this way, this "switchover" would likely
be relatively rare (e.g., happen only upon complete failure of an SGP or a
management action).   In the management action case, a small protocol
addition could solve this (i.e. a new optional SGP active/inactive message
sent SGP-to-ASP) but I don't think this helps in the SGP failure case
because the SGP is not there to send the messages.  So there is a small gain
with the additional protocol but I am not sure it is worth it.

Cheers,
     Greg

---

---

From: Ming Lin <[email-masked]>
Date: Wed, 21 Mar 2001 20:46:53 +0800

Hi Greg,

1) As you said, what I means it is one SG has more than one PC in the SS7 network, 
and you can say it is two ss7 nodes, but it is one SG.
If one switch support more than 4096 circuits(CIC is 12 bits), multiple PC is used;
And if capacity of SCP/HLR is greater than what 16 links(SLS is 4 bits) can support,
multiple PC is used. 
It is realy mutiple ss7 node, but one switch or SCP/HLR.

2)Yes, the failure SGP is not there to send message, but the back-up SGP is there to send message.
The back-up SGP can take over the traffic as soon as the active SGP fails.

Pls correct me.
Thanks&Regards
Ming Lin
    -----Original Message-----
    发件人: Sidebottom, Greg [BCNR:7M01:EXCH] <[email-masked]>
    收件人: [email-masked] <[email-masked]>
    日期: 2001年3月21日 16:50
    主题: RE: M3UA: multiple PC and SGP

    Hi Ming, 

    Responses below ... 

    -----Original Message----- 
    From: Ming Lin [mailto:[email-masked]] 
    Sent: Friday, March 16, 2001 10:39 PM 
    To: [email-masked] 
    Subject: FW: M3UA: multiple PC and SGP 
    >in order to support multi-PC. 
    [Greg] I'm not sure what you mean by the M3UA "doesn't support multiple OPC".  Are you suggesting a case where an SG has more than one PC in the SS7 network (in the SEP sense) AND handles SS7 traffic to two or more other PCs (in the STP sense)?  If an SG has two PCs in the SS7 network then it is really two SS7 nodes with separate linksets to the SS7 network (I'm not talking about alias PCs here) and could really be considered as two SGs.  Please clarify so I can understand the issue.

    >the traffic will not lose. 

    [Greg] You have a point here - in the current M3UA procedures there is no SGP to ASP protocol like ASPAC/ASPIA to provide for an SGP switchover.  ASPs really only know by the availability status of the SCTP association whether a particular SGP is there (each SGP will have its own SCTP end-point) and the protocol doesn't differentiate whether an ASP would view multiple SGPs in an SG as primary/back-up or loadshared.

    This was design intent as we wanted SGP support to be as simple as possible in the protocol sense as i) many/most SGs will not be designed this way and ii) for those SGs that are designed this way, this "switchover" would likely be relatively rare (e.g., happen only upon complete failure of an SGP or a management action).   In the management action case, a small protocol addition could solve this (i.e. a new optional SGP active/inactive message sent SGP-to-ASP) but I don't think this helps in the SGP failure case because the SGP is not there to send the messages.  So there is a small gain with the additional protocol but I am not sure it is worth it.

    Cheers, 
         Greg 

    ---
    You are currently subscribed to sigtran as: [email-masked]
    To unsubscribe send a blank email to [email-masked] 

---

---

From: 조민수 <[email-masked]>
Date: Thu, 22 Mar 2001 11:04:11 +0900

RE: M3UA: multiple PC and SGP        Hi everyboby,

        I think one SG has to provide multiple OPC for the network scalability. It is not multiple SS7 nodes.
        In the case that SG operates as SEP and each IPSP has virtual point code respectively, 
        If one SG only support one OPC, one SG can connect just one IPSP. 
        It is not efficient. there is not need to seperate Gateway into SG and MGC(IPSP).
        At the decomposition archtecture, one SG should be able to associate with multiple IPSP.

        Best Regards,

        Minsu Cho
        Xener.com Inc,
        
  -----Original Message-----
  From: Ming Lin [mailto:[email-masked]]
  Sent: Wednesday, March 21, 2001 9:47 PM
  To: [email-masked]
  Subject: Re: M3UA: multiple PC and SGP

  Hi Greg,

   
  Pls correct me.
  Thanks&Regards
  Ming Lin
    -----Original Message-----
    ������: Sidebottom, Greg [BCNR:7M01:EXCH] <[email-masked]>
    �ռ���: [email-masked] <[email-masked]>
    ����: 2001��3��21�� 16:50
    ����: RE: M3UA: multiple PC and SGP

    Hi Ming, 

    Responses below ... 

    -----Original Message----- 
    From: Ming Lin [mailto:[email-masked]] 
    Sent: Friday, March 16, 2001 10:39 PM 
    To: [email-masked] 
    Subject: FW: M3UA: multiple PC and SGP 

    Cheers, 
         Greg 

    ---
    You are currently subscribed to sigtran as: [email-masked]
    To unsubscribe send a blank email to [email-masked] 
  ---
  You are currently subscribed to sigtran as: [email-masked]
  To unsubscribe send a blank email to [email-masked] 
b����.����\����&�v�,�kjv��(-��ڭ�b�螵�+�:.�˛���m��֛���zf���%y�޲(-����}H�*�z+��gz�(�K�

---

From: "Mc Grew, Michael A (Mike)" <[email-masked]>
Date: Thu, 22 Mar 2001 08:35:37 -0500

Greetings, all,
 
As someone who has SS7 MTP experience but has not been following this
discussion recently, I find this thread getting very confusing.
 
By definition, an MTP3 has a single point code because it is used between
adjacent signaling points for, among other things, the exchange of
signaling link information.
If an implementation has more than one of these MTP3s,  then I believe it
must be called "multiple SS7 nodes", even if the implementation wishes to
call it a single gateway for any reason. This agrees with Greg's "original"
comment.
 
There are ways to scale up the capacity of the gateway without adding point
codes.
And the implementation may be called one gateway or, if it has multiple
point codes, *may* be called "more than one gateway."
That's not a protocol issue, just an issue of naming the implementation.
 
So, in conclusion, it is necessary to distinguish protocol from
implementations, and not put dependencies on the protocol that are not
really there (e.g., for scalability).
 
Regards,
Mike McGrew
Lucent Technologies

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Wednesday, March 21, 2001 9:04 PM
To: [email-masked]
Subject: RE: M3UA: multiple PC and SGP

        Hi everyboby,
 
        I 

---

---

From: Ming Lin <[email-masked]>
Date: Mon, 26 Mar 2001 21:15:15 +0800

Hi all,

Multiple PCs is widespread in China for scaling up the capacity
of switch(limited by 12bit CIC),
or HLR or SCP(limited by 16 links between two PCs).
2Mbit/s link is alternative of Mutiple PCs solution for HLR and SCP.

MTP user(e.g. ISUP) and MTP both know the existing
of multiple PCs. When MTP inform MTP user of DPC status change,
it should also inform the affected OPC(one of the multiple PCs).

In the traditional SS7, multiple PCs is local and implementation issue,
but now since MTP user is not along with MTP, it is not local and
implementation issue, and it is protocol issue now.
The affected OPC should appear in SSNM messages along with DPC.

The same as SUA.

Pls correct me.
Thanks&Regards
Ming Lin
-----Original Message-----
랙숭훙: Mc Grew, Michael A (Mike) <[email-masked]>
澗숭훙: [email-masked]
<[email-masked]>
휑퍅: 2001쾨3墩22휑 21:54
寮痙: RE: M3UA: multiple PC and SGP

>To unsubscribe send a blank email to
[email-masked]

---

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Mon, 26 Mar 2001 08:01:55 -0600

Ming,

Because you are only using multiple point codes to scale up
links, why does M3UA need to know about them?  M3UA is not
concerned with links.

For example, I have point codes A, B, C and D used to scale
up links.  An MTP-User of the signalling point need only 
worry about the reachablity of network points for the
signalling point, not for each individual point code.  So,
it need only worry about DPC status, not OPC status, because
A, B, C, and D are the same signalling point.

SUA need only concern itself with different signalling points
(rather than signalling point that are all the same).  Have
your SG translate A, B, C, and D to, say, A when communicating
with the ASP.

Follow?

--brian

> it should also inform the affected OPC(one of the multiple PCs).

No.  DPC status change cannot be different for OPCs which are used
merely to scale links.  If DPC Z is unreachable from A, it is also
unreachable from B, C, and D.

-- 
Brian F. G. Bidulock    ¦ The reasonable man adapts himself to the ¦
[email-masked]    ¦ world; the unreasonable one persists in  ¦
http://www.openss7.org/ ¦ trying  to adapt the  world  to himself. ¦
                        ¦ Therefore  all  progress  depends on the ¦
                        ¦ unreasonable man. -- George Bernard Shaw ¦

---

---

From: Á¶¹Î¼ö <[email-masked]>
Date: Tue, 27 Mar 2001 11:29:41 +0900

Hello,

	I have a comment.

-----Original Message-----
From: Brian F. G. Bidulock [mailto:[email-masked]]
Sent: Monday, March 26, 2001 11:02 PM
To: [email-masked]
Cc: [email-masked]
Subject: Re: M3UA: multiple PC and SGP

Ming,

[Minsu>] 
In case that SG has multiple point codes(A, B, C, D), 
for example, OPC A  and OPC B have an each signaling route to DPC F respectively. 
If a DPC F status is changed to the unreachable status by MTP-pause indication received at OPC A,
MTP3 Routing Management only consider as DPC F related to the OPC A not B . 
So, MTP3-User at MGC can send ISUP message that OPC is B and DPC is F.
MTP3-User has to maintain the DPC state per OPC.

Follow?

--brian

---
You are currently subscribed to sigtran as: [email-masked]
To unsubscribe send a blank email to [email-masked]
ÿÿØ¢æ«yË«éí—+.nÇ+‰·¶‹"‚ÚÚ«ÿ²(-©ÿj·!Š÷ÿ‰ë_þŠàN‹§²æìr¸›zÇ§u¦åjy™¨¥¶‰^j÷ÿ²(-©ÿ×½õ#ùr®+ÿžŠízYÞ·
+’ÏÜ

---

From: Ming Lin <[email-masked]>
Date: Tue, 27 Mar 2001 18:57:31 +0800

Hi, all
Please see comments below.
-----Original Message-----
发件人: Brian F. G. Bidulock <[email-masked]>
收件人: [email-masked]
<[email-masked]>
抄送: [email-masked]
<[email-masked]>
日期: 2001年3月27日 11:37
主题: Re: M3UA: multiple PC and SGP

炼刮荐,

If PC A receives TFP from an STP Y with respect to PC F and PC
B, C, and D have parallel linksets to Y, then PC B, C, and D
will also receive TFP from STP Y with respect to DPC F.

[Ming]Have you consider that if the links of PC A to STP Y are failure,
and the links of other PC to STP Y are OK?

On Tue, 27 Mar 2001, 炼刮荐 wrote:
>
> In case that SG has multiple point codes(A, B, C, D), for
> example, OPC A  and OPC B have an each signaling route to DPC
> F respectively.  If a DPC F status is changed to the
> unreachable status by MTP-pause indication received at OPC A,
> MTP3 Routing Management only consider as DPC F related to the
> OPC A not B .  So, MTP3-User at MGC can send ISUP message that
> OPC is B and DPC is F.  MTP3-User has to maintain the DPC
> state per OPC.
>

--
Brian F. G. Bidulock    ?The reasonable man adapts himself to the ?
[email-masked]    ?world; the unreasonable one persists in  ?
http://www.openss7.org/ ?trying  to adapt the  world  to himself. ?
                        ?Therefore  all  progress  depends on the ?
                        ?unreasonable man. -- George Bernard Shaw ?

---

---

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Tue, 27 Mar 2001 06:45:37 -0600

Ming,

If the links from PC A to STP Y are failed but the links from PC B, C and
D to STP Y are ok, that neither changes the reachablity of a distant
point code, nor the reachability of STP Y.  PC A should use PC B, C or
D's routesets to Y and beyond.  In other words, linksets B-Y, C-Y, and D-Y
should be alternative linksets for A.  A should perform forced rerouting
to these linksets.  Anything else and you have 4 separate and completely
partitioned signalling points (they share no routesets and have no routes
between them) which should be treated as 4 SGs.

--Brian

---

---

From: Ming Lin <[email-masked]>
Date: Wed, 28 Mar 2001 14:53:52 +0800

Brian,

There are two cases of multiple PCs: rerouting mutually and isolated.

In rerouting mutually case, the SG and STP Y regard all of the multiple PCs
of SG
as STP, the both side(SG and STP Y) should reroute
when the links of one PCs to STP Y are failure.

In isolated case, teh SG and STP Y regard all of the multiple PCs of SG
as SP, no rerouting is done when the links of one PCs to STP Y are failure.
The loadsharing is done by MTP3 user.
Whatever you call this case, such as multiple(4) SGs, there are only one
MTP3
and one MTP3 user. So MTP3 user also need the affected PC(one of multiple
PCs),
when it is informed of DPC status.

In the case of rerouting, as you said, affected PC(one of multiple PCs) is
not
needed, it is because all of the multiple PCs are affected. So there are
still
affected PCs.

So, we need a optional parameter of affected PC in SSNM messages,
and if it is absent, it means all of the multiple PCs are affected.

Thanks&Regards
Ming Lin

-----Original Message-----
发件人: Brian F. G. Bidulock <[email-masked]>
收件人: [email-masked]
日期: 2001年3月27日 20:48

Ming,

--Brian

---

---

---

From: Ming Lin <[email-masked]>
Date: Mon, 30 Apr 2001 16:36:06 +0800

Brian,

But actually there is only one SG with multiple PCs.
And, M3UA should not restrict user to choose rerouting or not.

As I said before, the default affected PCs are all of the
multiple PCs, so affected PCs may not be in the SSNM messages.
But we should not let this default case cover all the cases,
so I still think we should carry affected PCs in SSNM messages,
and if it is not there,
it means all the multiple PCs are affected.

Thanks&Regards
Ming Lin
-----Original Message-----
发件人: Brian F. G. Bidulock <[email-masked]>
收件人: Ming Lin <[email-masked]>
日期: 2001年3月29日 2:00
主题: Re: M3UA: multiple PC and SGP

Ming,

If there is no rerouting you have multiple SG and ASP must
loadshare between multiple SG.  If there is rerouting, use
single PC.

--Brian

On Wed, 28 Mar 2001, Ming Lin wrote:

> In rerouting mutually case, the SG and STP Y regard all of the
> multiple PCs of SG as STP, the both side(SG and STP Y) should reroute
> In isolated case, teh SG and STP Y regard all of the multiple PCs of
> SG as SP, no rerouting is done when the links of one PCs to STP Y are
> failure.  The loadsharing is done by MTP3 user.  Whatever you call
> this case, such as multiple(4) SGs, there are only one MTP3 and one
> MTP3 user. So MTP3 user also need the affected PC(one of multiple
> PCs), when it is informed of DPC status.
>
> In the case of rerouting, as you said, affected PC(one of multiple
> PCs) is not needed, it is because all of the multiple PCs are
> affected. So there are still affected PCs.
>
> So, we need a optional parameter of affected PC in SSNM messages, and
> if it is absent, it means all of the multiple PCs are affected.
>
> Thanks&Regards
> Ming Lin
>

                        ?unreasonable man. -- George Bernard Shaw

---