Subject: Mgmt Blocking of ASP at SG

From: "Srivats P." <[email-masked]>
Date: Fri, 23 Mar 2001 14:13:13 +0500

Hi,

How should Management blocking be handled in an SG for
an active ASP which is currently actively processing traffic ?

The SG can stop sending traffic (DATA messages) to the ASP.
But what about the DATA messages received from the ASP ?
Should it discard the DATA message and send an ASPDN ACK
(Mgmt Blocking). Doesn't seem right ...

Or should the SG shutdown/abort the association serving the ASP ?
This too doesn't seem right ... as then the scenario of sending an
ASPDN ACK (mgmt blocking) in response to ASPM messages wd
become impossible.

I'm sure I'm missing something ... someone please tell me what !

Regards,
Srivats P.

---
You are currently subscribed to sigtran as: [email-masked]
To unsubscribe send a blank email to [email-masked]

---

From: [email-masked]
Date: Fri, 23 Mar 2001 15:04:22 +0530

Hi Srivats

The best option is that the SG sends an ASPDN-ACK to the
ASP, so that the ASP moves to ASP-DOWN state and then
the MGMT at SG will lock the ASP so that even on receiving an
ASP UP message from the ASP, ASP DN ACK will be
sent from the SG side, hence restricting ASP from
becoming INACTIVE.

Regards
Vipin

---

---

From: Alex Audu <[email-masked]>
Date: Fri, 23 Mar 2001 10:29:35 -0600 (CST)

Hi Srivats,

It is assumed that Management Blocking is explicitly initiated by some 
management entity (e.g. craftperson) with the full knowledge that traffic on
the ASP being blocked will be interrupted.  

With that in mind, the AS should direct further traffic messages to another
ASP (assuming there is one ACTIVE), and if not, the AS goes into a PENDING
state where it starts a timer and stores traffic messages arriving without an 
active ASP to  carry them. If before the pending state timer expires an ASP 
goes ACTIVE, then the messages are sent; if not, the messages are discarded. 
Again, this may be what the craft wants. I don't think there is any other way 
around this.

Regards,
Alex.
 
> You are currently subscribed to sigtran as: [email-masked]

---