Subject: RE: [Sigtran] Sigtran Plugtest SUA/M3UA/M2UA/IUA - Day 2

From: Tolga Asveren <[email-masked]>
Date: Thu, 7 Nov 2002 16:52:37 -0500

Brian,

> > [TOLGA] I think we agree that ASP does not decide for 
> congestion of SPMC.
> > But then what is the reason that ASP send SCON to SG as 
> described in RFC?
> 
> To potentially assist the SG in its decision.
[TOLGA] How?
> 
> > [TOLGA] How can SG make use of a SCON sent from ASP as a 
> response to an
> > incoming message? Based on that, I don't think SG can have 
> a combined
> > congestion view for the whole SPMC. 
> 
> The SG uses the information as advisory just as if it were
> sent on any other basis.
[TOLGA] How? I still think, the correct approach is that ASPs declare
congestion status changes to SG (and SG implements procedures to prevent
possible missequencing. Such mechanisms it needs anyhow also for other
scenarios). 
_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Thu, 7 Nov 2002 16:52:29 -0700

Tolga,

Tolga Asveren wrote:                                                               (Thu, 07 Nov 2002 16:52:37)
> Brian,
> 
> > > [TOLGA] I think we agree that ASP does not decide for congestion of SPMC.
> > > But then what is the reason that ASP send SCON to SG as described in RFC?
> > 

By providing the information to the SG that the ASP considers its
inocming signalling message handling functions to be congested.
This is what the ASP does when it sends SCON.

> > 
> > > [TOLGA] How can SG make use of a SCON sent from ASP as a response to an
> > > incoming message? Based on that, I don't think SG can have a combined

It makes no difference if the ASP sends SCON with each message during
congestion or not.  The SG can merely ignore the SCON messages which
do not change the last reported status if it chooses to do so.  If the
SG implementation requires more timely information, it can use each
SCON message if it so chooses.

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/