Subject: RE: [Sigtran] Sigtran Plugtest SUA/M3UA/M2UA/IUA - Day 2

From: Tolga Asveren <[email-masked]>
Date: Wed, 13 Nov 2002 10:12:12 -0500

Brian,

> -----Original Message-----
> From: Brian F. G. Bidulock [mailto:[email-masked]]
> Sent: Tuesday, November 12, 2002 6:55 PM
> To: Tolga Asveren
> Cc: [email-masked]'
> Subject: Re: [Sigtran] Sigtran Plugtest SUA/M3UA/M2UA/IUA - Day 2
> 
> 
> Tolga,
> 
> You cannot say SHOULD because the procedure is optional even in ANSI
> where it is applicable.
[TOLGA] I don't have too big problem if it is left MAY. The reason why I
prefer SHOULD is:
a) If possible, don't have MTP3 protocol related stuff in ASP-to-SGP, i.e.
terminate MTP3 at the SG. ASPs update their status on SG, and SG acts
according to relevant protocol (it won't be possible to make ASP/SGP
communciation 100% MTP3-protocol free, because we have congestion levels in
SCON, but still we can try as much as possible)
b) I believe for ANSI case, it might be quite usefull sending SCON, whenever
congestion happens, if ASP serves multiple AS and gets congested. 

But as I said, I don't have very strong preference for changing MAY to
SHOULD, I just try to make congestion indication from ASP to SGP similar to
other ASP-to-SGP procedures, without decreasing its functionality.

(I am waiting comments also for other items of the proposal)
> 
> --brian
> 
> Tolga Asveren wrote:                                          
>                      (Tue, 12 Nov 2002 09:39:14)
> > Brian,
> > 
> > My proposal:
> > 1)3.4.4
> > Current:
> > "The SCON message MAY also be sent from the M3UA layer of 
> an ASP to an M3UA
> > peer indicating that the M3UA layer or the ASP is congested."
> > Proposal:
> > "The SCON message SHOULD be sent from the M3UA layer of an 
> ASP to an M3UA
> > peer indicating that the congestion level of the M3UA layer 
> or of the ASP
> > has changed."
> > Why?: So, SCON will be sent, whenever ASP gets congested, 
> because of an
> > incoming message to ASP or for any other reason(for example 
> because of a
> > message destined for another AS, served by the same ASP). 
> IMO, it is also
> > better to change MAY to SHOULD, so we update the SG, and it 
> is up to it how
> > to behave.
> > 
> > 
> > 2)Replacing SCON from ASP to M3UA with a new ASPTM (I am 
> not very hopefull
> > but anyway)
> > Why?: Because Information about local SPMC is sent via ASPTM.
> > 
> > 3)IMO, there should be a section about congestion 
> indication mechanims
> > between ASP and SG, like we have sections "ASP Up Procedures" etc...
> > Why?: Because this is a procedure between ASP and SG, not 
> between ASP and
> > another SS7 endpoint. The relationship with other SS7 
> endpoints is between
> > SG and them. So, like other ASP/SG procedures are 
> explained, I also would
> > prefer a section for congestion procedure.
_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Wed, 13 Nov 2002 11:19:03 -0700

Tolga,

Tolga Asveren wrote:                                  (Wed, 13 Nov 2002 10:12:12)
> (I am waiting comments also for other items of the proposal)

You did not propose any other text changes.

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/