Subject: RE: [Sigtran] Sigtran Plugtest SUA/M3UA/M2UA/IUA - Day 2

From: Tolga Asveren <[email-masked]>
Date: Wed, 13 Nov 2002 13:27:01 -0500

Brian,

> -----Original Message-----
> From: Brian F. G. Bidulock [mailto:[email-masked]]
> Sent: Wednesday, November 13, 2002 1:19 PM
> To: Tolga Asveren
> Cc: [email-masked]'
> Subject: Re: [Sigtran] Sigtran Plugtest SUA/M3UA/M2UA/IUA - Day 2
> 
> 
> Tolga,
> 
> Tolga Asveren wrote:                                  (Wed, 
> 13 Nov 2002 10:12:12)
> > 
> > (I am waiting comments also for other items of the proposal)
> 
> You did not propose any other text changes.
[TOLGA] Yes I did:
My proposal:
1)3.4.4
Current:
"The SCON message MAY also be sent from the M3UA layer of an ASP to an M3UA
peer indicating that the M3UA layer or the ASP is congested."
Proposal:
"The SCON message SHOULD be sent from the M3UA layer of an ASP to an M3UA
peer indicating that the congestion level of the M3UA layer or of the ASP
has changed."
Why?: So, SCON will be sent, whenever ASP gets congested, because of an
incoming message to ASP or for any other reason(for example because of a
message destined for another AS, served by the same ASP). IMO, it is also
better to change MAY to SHOULD, so we update the SG, and it is up to it how
to behave.

[TOLGA] The poprosal was not just to change MAY to SHOULD, the sentence
itself is also modified.

2)Replacing SCON from ASP to M3UA with a new ASPTM (I am not very hopefull
but anyway)
Why?: Because Information about local SPMC is sent via ASPTM.

3)IMO, there should be a section about congestion indication mechanims
between ASP and SG, like we have sections "ASP Up Procedures" etc...
Why?: Because this is a procedure between ASP and SG, not between ASP and
another SS7 endpoint. The relationship with other SS7 endpoints is between
SG and them. So, like other ASP/SG procedures are explained, I also would
prefer a section for congestion procedure.
_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Wed, 13 Nov 2002 12:07:31 -0700

Tolga,

Tolga Asveren wrote:                                                               (Wed, 13 Nov 2002 13:27:01)
> [TOLGA] The poprosal was not just to change MAY to SHOULD, the sentence

So you did.  You need to still allow responsive SCON so that
approaches such as Kamesh's are still possible.  And the SHOULD
must be a MAY (because it is optional and not required for
interoperability).

Do you have any other text proposals?

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/