Subject: RE: [Sigtran] Sigtran Plugtest SUA/M3UA/M2UA/IUA - Day 2

From: Tolga Asveren <[email-masked]>
Date: Thu, 7 Nov 2002 18:57:42 -0500

Brian,

> -----Original Message-----
> From: Brian F. G. Bidulock [mailto:[email-masked]]
> Sent: Thursday, November 07, 2002 6:52 PM
> To: Tolga Asveren
> Cc: [email-masked]'
> Subject: Re: [Sigtran] Sigtran Plugtest SUA/M3UA/M2UA/IUA - Day 2
> 
> 
> Tolga,
> 
> Tolga Asveren wrote:                                          
>                      (Thu, 07 Nov 2002 16:52:37)
> > Brian,
> > 
> > > > [TOLGA] I think we agree that ASP does not decide for 
> congestion of SPMC.
> > > > But then what is the reason that ASP send SCON to SG as 
> described in RFC?
> > > 
> > > To potentially assist the SG in its decision.
> > [TOLGA] How?
> 
> By providing the information to the SG that the ASP considers its
> inocming signalling message handling functions to be congested.
> This is what the ASP does when it sends SCON.
[TOLGA] This does not contain enough information for SG to decide for the
combined SPMC congestion state, when there are multiple ASPs involved.
> 
> > > 
> > > > [TOLGA] How can SG make use of a SCON sent from ASP as 
> a response to an
> > > > incoming message? Based on that, I don't think SG can 
> have a combined
> > > > congestion view for the whole SPMC. 
> > > 
> > > The SG uses the information as advisory just as if it were
> > > sent on any other basis.
> > [TOLGA] How? I still think, the correct approach is that 
> ASPs declare
> > congestion status changes to SG (and SG implements 
> procedures to prevent
> > possible missequencing. Such mechanisms it needs anyhow 
> also for other
> > scenarios). 
> 
> It makes no difference if the ASP sends SCON with each message during
> congestion or not.  The SG can merely ignore the SCON messages which
> do not change the last reported status if it chooses to do so.  If the
> SG implementation requires more timely information, it can use each
> SCON message if it so chooses.
[TOLGA] What I am proposing is not that ASP sends SCON with each message but
that it informs about congestion changes whenever it occurs. Only this will
ensure that SG can decide for the combined SPMC view,when multiple ASPs are
serving the same AS.
 
_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Thu, 7 Nov 2002 20:56:56 -0700

Tolga,

Tolga Asveren wrote:                                                               (Thu, 07 Nov 2002 18:57:42)
> combined SPMC congestion state, when there are multiple ASPs involved.

But it can contribute to a decision.

> ensure that SG can decide for the combined SPMC view,when multiple ASPs are

Not true, the current situation is also sufficient.

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/