Subject: RE: [Sigtran] Routing Context is optional in ASPAC-M3UA?

From: "Wung, Joseph" <[email-masked]>
Date: Mon, 11 Nov 2002 09:04:48 -0500

Could it also mean that all AS's whether dynamically registered or
pre-configured on that SCTP are set to acive?

Joe

-----Original Message-----
From: Brian F. G. Bidulock [mailto:[email-masked]]
Sent: Monday, November 11, 2002 2:27 AM
To: Insun Kwon
Cc: [email-masked]
Subject: Re: [Sigtran] Routing Context is optional in ASPAC-M3UA?

Insun,

It is maybe easier to think of it this way: that the SCTP
association is processing traffic for only one AS.

--brian

Insun Kwon wrote:                                 (Mon, 11 Nov 2002
16:09:28)
> Hi, 
> 
> In 4.3.4.3  ASP Active Procedure, (RFC 3332)
> In the case where as ASP Active message does not contain a Routing Context
> parameter, the receiver must know, via configuration data, which
Application
> Server(s) the ASP is a member.
> 
> I think the case is SGP serves only one AS, or specific ASP is processing
> traffic for one AS.  Is it right?
> 
> please correct my fault.
> 
> /kils
> 
> _______________________________________________
> Sigtran mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/sigtran

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/
_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran
_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Wung, Joseph" <[email-masked]>
Date: Mon, 11 Nov 2002 17:19:23 -0500

Tolga,

Just thought to confirm.  An ASP-Active without a routing context covers
all the AS's that
have been dynamically registered as well as those that have been pre-
configured.
                ^^^^^^^^^^^^^^^^^^^^^^^^^^
It is not clear from the RFC whether the configured AS's inlcude
dynamically registered ones.

Joe

-----Original Message-----
From: Tolga Asveren [mailto:[email-masked]]
Sent: Monday, November 11, 2002 8:50 AM
To: [email-masked]'
Subject: RE: [Sigtran] Routing Context is optional in ASPAC-M3UA?

Insun,

This means that such an ASPAC will is a request from ASP, to activate
itself for all of the preconfigured AS. For example, if ASP is
preconfigured for AS1 and AS2, an ASPAC with no RC inside is equal to an
ASPAC with RC1 (RC for AS1) and RC2(RC for AS2) inside.

    Tolga

> From: Insun Kwon [mailto:[email-masked]]
> Sent: Monday, November 11, 2002 2:09 AM
> To: [email-masked]
> Subject: [Sigtran] Routing Context is optional in ASPAC-M3UA?
> 
> 
> Hi, 
> 
> In the case where as ASP Active message does not contain a 
> Routing Context parameter, the receiver must know, via 
> configuration data, which Application Server(s) the ASP is a member.
> 
> I think the case is SGP serves only one AS, or specific ASP 
> is processing traffic for one AS.
> Is it right?
> 
> please correct my fault.
> 
> /kils
>

---

From: Tolga Asveren <[email-masked]>
Date: Mon, 11 Nov 2002 17:44:33 -0500

Joe,

Although in the RFC it is said that "the receiver must know, via
configuration data", still I would think, ASPAC with no RC inside covers
also dynamically registered AS. If everybody thinks so, maybe this should be
clarified in IG.

     Tolga

> From: Wung, Joseph [mailto:[email-masked]]
> Sent: Monday, November 11, 2002 5:19 PM
> To: Tolga Asveren; [email-masked]'

---

From: Tolga Asveren <[email-masked]>
Date: Tue, 12 Nov 2002 07:55:30 -0500

Insun,

> Sent: Monday, November 11, 2002 8:11 PM
> To: [email-masked]
> Brian said that SCTP (i.e. ASP) association is processing 
> traffic for only one AS.
> of course, this case is example..
> but if there are "the receiver must know" case,  I must check 
> whether it is correct or not.
> In example, I check the ASP is only ASP of AS or not.
> 
> but according to Tolga,
> then there is no need to check if any case.
> If ASPAC no RC is received, I just update all ASP's state(for 
> RC1, RC2 in previous example) to ASP_ACTIVE.
> Is this right?
[TOLGA] Yes.
> 
> 
> -------------------------------
> ASP is for RC1, RC2, RC3.
> In case ASP which is for RC1, RC2 is ACTIVE,   ASPAC contains 
> RC1, RC2.
> In case ASP which is for all RC is ACTIVE, ASPAC contains no RC.
> 
> ASP is for only one AS.
> In case ASP is ACTIVE, ASPAC contains no RC.
> ------------------------------
> 
> 
> and I have a question. 
> "Although in the RFC it is said that "the receiver must know, 
> via configuration data", still I would think, ASPAC with no 
> RC inside covers also dynamically registered AS. If everybody 
> thinks so, maybe this should be clarified in IG."
> 
> What is "IG"?
> 
> 
> My English is not good. sorry. :)
> 
> /kils
> 
> ----- Original Message ----- 
> From: "Tolga Asveren" <[email-masked]>
> To: <[email-masked]>
> Sent: Monday, November 11, 2002 10:49 PM