Subject: RE: [Sigtran] Sigtran Plugtest SUA/M3UA/M2UA/IUA - Day 2

From: Tolga Asveren <[email-masked]>
Date: Thu, 14 Nov 2002 08:48:20 -0500

Brian,

> > BTW, IMO trying to support 
> backhaul/non-backhaul/singleSG/multipleSG cases
> > all with the same model gets more and more ugly. 
> 
> Yes, but without the deviations, multiple SG would not be supported.
> Consideration was given that installing M3UA at an STP pair could be
> not only a desirable thing, but a commonplace thing in 
> quasi-associated
> networks, and support was necessary.  I often said that 
> properly addressing
> the configuration would require an M3PA protocol of which SG-SG is 
> probably not so different, but the RFC had to be bitten off 
> at some point.
[TOLGA]I am also not advocating that multiple SG case shouldn't be
supported, it should be, just I prefer a clean and proper way of supporting
it. 

> 
> > [TOLGA] Because stream selection based on AS is not 
> mandatory, personally I
> > still wouldn't prefer relying on SCTP congestion.
> 
> Well, no, it is not an interoperability matter.  It is the SG 
> which selects
> the outgoing stream to the AS and the SG which wants to 
> monitor backlog on
> the stream.  If the SG wishes to monitor in this fashion, it 
> would need to
> select indepdent outgoing streams, but that is solely at the 
> control of the SG
> and need not be known to the ASP.
> 
> Also, the SG doesn't really need to address streams at all, 
> just have separate
> queues to SCTP for each AS, and monitor the depth of the 
> backlog on each
> queue.  This is possible entirely within M3UA at the SG 
> without any SCTP or
> ASP involvement.
[TOLGA] My comment that I would prefer not to rely on SCTP congestion was
from protocol point of view, otherwise as long as it does not require
special action on the peer, everybody is of course free to do whatever
she/he thinks as usefull.
But it is not clear to me how this will work. ASP-SCTP will not acknowledge
messages based on their stream value. And when somehow SCTP congestion
propogates to SGP-SCTP, it will be applicable for all traffic destined to
the congested ASP.

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Fri, 15 Nov 2002 00:59:16 -0700

Tolga,

Tolga Asveren wrote:                                                               (Thu, 14 Nov 2002 08:48:20)
> propogates to SGP-SCTP, it will be applicable for all traffic destined to

All that is necessary is to have a queue for each AS feeding the SCTP transmit
queue and adjust the SCTP transmit buffer size down to a reasonably small
amount (one that will still encourage bundling but will be responsive to
congestion (cwnd) and flow control (a_rwnd).  Monitoring the queue depth of
each AS queue feeding SCTP will give a good indication of congestion in the
message handling functions are the ASP.  No acknowlegements required.

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/