Subject: Re: [Sigtran] M2PA draft 7 question -- alignment conclusion

From: [email-masked]
Date: Thu, 13 Feb 2003 09:26:41 -0500

Hello Brian,

I should know better than put 'conclusion' in the title of
a SIGTRAN post.

>There is the requirement that M2PA send repeated PROVING-NORMAL or
>PROVING-EMERGENCY messages while running T3 for this to work.

So what do you recommend? Leave M2PA alignment as it is?
Make it match Q.703 with some noted exceptions? I don't
see mention in Q.703 of repeated SIN/SIE during T3. Perhaps
you could explain.

I now think that it is a bad idea to change M2PA such that
during OOS it responds to received LSA with LSO.
I think this introduces a failed alignment loop, which was the
original topic of this thread. M2PA should continue to receive
LSA during OOS and record the reception so that it can be acted
upon when MTP3 start is subsequently received.

Case where M2PA during OOS responds to received
LSA by sending LSO. Results in continuous failure
to align.

MTP3     |    M2PA     |    M2PA     |   MTP3
         |             |             |
         |(clear LSA)  |(clear LSA)  |
         | OOS/Estab   | OOS/Estab   |
         |             |             |
start -->+             |             |
         | INIT ALIGN  |             |
         |      LSA -->+             |
         | T2 Start    |             |
         |             +<-- LSO      |
         |             |             |
         +<-- OSI      |             |
         | T2 Stop     |             |
         |(clear LSA)  |             |
         | OOS/Estab   |             |
         |             |             |
         |             |             +<-- start
         |             | INIT ALIGN  |
         |             +<-- LSA      |
         |             | T2 Start    |
         |      LSO -->+             |
         |             |             |
         |             |     OSI --->+
         |             | T2 Stop     |
         |             |(clear LSA)  |
         |             | OOS/Estab   |
         |             |             |
start -->+             |             |
         /         <repeats>         /

----------
OLD TEXT 4.1.3
After the association is established, M2PA SHALL send a Link Status
Out of Service message to its peer.

NEW TEXT 4.1.3 (revision #2)
After the association is established, M2PA SHALL send a Link Status
Out of Service message to its peer and, prior to receiving a Start
Request from MTP3, MAY periodically send Link Status Out of
Service messages. During the Out of Service State M2PA SHOULD
discard all received messages except Link Status Out of Service and
Link Status Alignment and respond to each discarded message by sending
a Link Status Out of Service message.

Regards,

Jeff

                      "Brian F. G.                                                                                                
                      Bidulock"                To:      [email-masked]                                                 
                      <bidulock@openss         cc:      wayne n taylor <[email-masked]>, Tom George <[email-masked]>,   
                      7.org>                   [email-masked]                                                                   
                      Sent by:                 Subject: Re: [Sigtran] M2PA draft 7 question -- alignment conclusion               
                      sigtran-admin@ie                                                                                            
                      tf.org                                                                                                      

                      02/12/03 03:46                                                                                              
                      PM                                                                                                          
                      Please respond                                                                                              
                      to bidulock                                                                                                 

jeffrey.craig,

There is the requirement that M2PA send repeated PROVING-NORMAL or
PROVING-EMERGENCY messages while running T3 for this to work.

--brian

[email-masked] wrote:
(Wed, 12 Feb 2003 15:25:35)
>
> Hello Brian,
>
> This thread has gotten too long. Let's try and conclude it with
> a summary of the recommended changes to the M2PA draft.
> The intent is to match Q.703.
>
> Regards,
>
> Jeff
>
> ----------
> Figure 7 is updated to show a transition from INITIAL_ALIGNMENT
> to PROVING upon reception of either a Link Status Alignment or
> Link Status Proving Normal or Link Status Proving Emergency
> message. (Q.703 figure 4, figure 9 sheet 2)
>
>
> ----------
> OLD TEXT 4.1.3
> After the association is established, M2PA SHALL send a Link Status
> Out of Service message to its peer.
>
> NEW TEXT 4.1.3
> After the association is established, M2PA SHALL send a Link Status
> Out of Service message to its peer and, prior to receiving a Start
> Request from MTP3, MAY periodically send Link Status Out of
> Service messages. During the Out of Service State M2PA SHOULD
> respond to received messages other than Link Status Out of Service
> by sending Link Status Out of Service.
>
>
> ----------
> OLD TEXT 4.1.3
> M2PA stops timer T2 when it has received the Link Status Alignment
> message from its peer.
>
> NEW TEXT 4.1.3
> M2PA stops timer T2 when it has received a Link Status Alignment
> message or Link Status Proving Normal or Link Status Emergency
> message from its peer.
>
>
> ----------
> OLD TEXT 4.1.3
> Note: Between the time M2PA sends Link Status Alignment to its peer
> and receives Link Status Alignment from its peer, M2PA may receive
> Link Status Out of Service from its peer. This message is
> ignored. After receiving Link Status Alignment from the peer, receipt
> of a Link Status Out of Service message causes M2PA to send Out of
> Service to MTP3 and return to the Out of Service state.
>
> NEW TEXT 4.1.3
> Note: Between the time M2PA sends Link Status Alignment to its peer
> and receives either Link Status Alignment or Link Status Proving
> Normal or Link Status Proving Emergency from its peer, M2PA may
> receive Link Status Out of Service from its peer. This message is
> ignored. After receiving Link Status Alignment or Link Status
> Proving Normal or Link Status Proving Emergency from its peer,
> receipt of a Link Status Out of Service message causes M2PA to
> send Out of Service to MTP3 and return to the Out of Service state.
>
> ----------
> OLD TEXT 4.1.3
>
> When M2PA has both sent and received the Link Status Alignment
> message, it has completed alignment.  M2PA starts the aligned timer
> T3 and moves to the proving state.
>
> M2PA stops timer T3 when it receives a Proving Normal or Proving
> Emergency message and starts proving period timer T4.
>
> NEW TEXT 4.1.3
>
> When M2PA has sent Link Status Alignment and received either a Link
> Status Alignment or a Link Status Proving Normal or a Link Status
> Proving Emergency message, it has completed alignment. M2PA starts
> the aligned timer T3 and moves to the proving state. Note that
> timer T3 is started even if reception of a proving message caused
> the transition to the proving state.
>
> M2PA stops timer T3 when it receives a Link Status Proving Normal
> or Link Status Proving Emergency message and starts proving period
> timer T4.
>

--
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/
_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Thu, 13 Feb 2003 08:04:17 -0700

Jeffrey,

Q.703 ignores receipt of SIOS after sending SIO and while
running T2.  M2PA should as well ignore LSO after sending LSA
while running T2.  Then there is no problem.

--brian

[email-masked] wrote:                                             (Thu, 13 Feb 2003 09:26:41)