Subject: Re: [Sigtran] Repost - More M2PA 7 questions]

From: "TOLGA ASVEREN" <[email-masked]>
Date: Thu, 20 Feb 2003 16:56:36 +0200

Brian,

I just think because in M2PA it is the normal behavior -as far as I
understand- that received messages during remote processor outage are
acknowledged, I would think there is no need to stop T7, which is started
while sending a message, sent before LSPO.

    Tolga

TOLGA,

TOLGA ASVEREN wrote:
(Thu, 20 Feb 2003 13:32:13)
>
> Brian,
> --- "Brian F. G. Bidulock" <[email-masked]> wrote:
> > TOLGA,
> >
> > Normal Q.703 procedures should prevail.
> >
> > When SIPO is sent T7 is stopped (see
> > Figure 13/Q.703 sheet 2 of 7).
> >
> > When the link resumes from processor outage,
> > T7 is started if the retransmission buffer
> > contains unacknowledged messages (see
> > Figure 13/Q.703 sheet 5 of 7 under "Send MSU").
> >
> > When LSPO is sent, T7 must be stopped for all
> > messages.
> [TOLGA]Even for the case, where T7 is running for a message, which is
sent
> before LSPO? So, won't the peer which receives LSPO assume, any incoming
> MSU after LSP is in fact sent not during remote processor outage and
> acknowledge it?

So what? The peer to which LSPO is sent is welcome
to acknowledge messages.   It is just not required
to do so within T7 until after LSPR is sent.

Read the SDLs (RC/TXC).  This is the same for Q.703.

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Thu, 20 Feb 2003 14:44:43 -0700

TOLGA,

You need to stop T7 because the other side is not required
(and should not) acknowledge messages after its receives LSPO.
So, if you don not stop T7 your link will fail prematurely if
T7 is less than MTP3 timer T1.

Also, MTP3 needs to know that no messages are sent from the
moment that processor outage is reported to L3 for time-controlled
changeover procedures to be properly refererenced to the last
message sent.

On this thread we already established that T7 is to be stopped
when LSPO is sent, and User Data is no longer sent.  The question
was when to restart T7.  It is restarted after LSPR is sent for
any messages in the retranmission buffer at the time that LSPR
is sent.

--brian

TOLGA ASVEREN wrote:                                                                 (Thu, 20 Feb 2003 16:56:36)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/