Subject: Re: [Sigtran] Repost - More M2PA 7 questions]

From: "TOLGA ASVEREN" <[email-masked]>
Date: Thu, 20 Feb 2003 07:51:16 +0200

Tom,
> > 3) How should T7 be handled when remote processor
> outage abates?  Should
> > we immediately check for excessive ack delay, or
> reset T7 somehow?
>
> From our earlier discussion of T7 during Busy, I
> think the answer is
> that T7 is not running during PO. Any messages would
> be flushed, so T7
> would not start again until a new message was sent.
[TOLGA]Will this flushing occur always? IMO, only if the processor outage
continues for long term, which is decided by MTP3.
Will the 08 draft follow your interpretation of how messages should be
handled during PO or not, i.e. they should be considered as sent either
before or after processor outage? If yes, should T7 be stopped for any
message, which was sent before receiving LS(PO)?

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Wed, 19 Feb 2003 23:55:49 -0700

TOLGA,

Normal Q.703 procedures should prevail.

When SIPO is sent T7 is stopped (see
Figure 13/Q.703 sheet 2 of 7).

When the link resumes from processor outage,
T7 is started if the retransmission buffer
contains unacknowledged messages (see
Figure 13/Q.703 sheet 5 of 7 under "Send MSU").

When LSPO is sent, T7 must be stopped for all
messages.

When LSPR is sent, T7 must be started for any
messages still present in the retransmission buffer.

It's that simple.

Flush buffers is only performed after a Stop, in
which case no timers are running.

--brian

TOLGA ASVEREN wrote:                                                                 (Thu, 20 Feb 2003 07:51:16)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/