Subject: Re: [Sigtran] to handle handle misconfiguration in IUA

From: [email-masked]
Date: Thu, 27 Feb 2003 20:05:41 +0530

Hi Ken,
   The objective of this example to handle the misconfiguration, So ASP side
stack  has to update its configuration based on peer SG configuration
   which is not correct. It is responsibility of the system management entities
to make the ASP and SG configuration alike. Why to update database on
   misconfiguration of SG side.

   Please correct me if i am wrong.

   Regards
   Manish S
   www.hssworld.com

Ken Morneault <[email-masked]> on 02/27/2003 07:58:04 PM

To:   Manish Sharma/HSS@HSS, [email-masked]
cc:

Subject:  Re: [Sigtran] to handle handle misconfiguration in IUA

Manish,

Why are you proposing that the SG return Error (Interface Identifer)
for valid Interface Identifiers?

Ken

At 07:37 PM 2/27/2003 +0530, [email-masked] wrote:

>Hi,
>   There is an example shown in IG to handle misconfiguration
>
>   "This scenario shows the example IUA message flows for the
>   establishment of traffic between an SG and an ASP in which some
>   of the Interface Identifiers have been misconfigured on the
>   ASP side.  The SG in this case has Interface Identifers 1-5
>   configured for ASP1."
>
>                SG                               ASP1
>                 |                                |
>                 |                                |
>                 |<----ASP Active (IIDs 1-10)-----|
>                 |---ASP Active Ack (IIDs 1-5)--->|
>                 |-------Error (IIDs 6)---------->|
>                 |-------Error (IIDs 7)---------->|
>                 |-------Error (IIDs 8)---------->|
>                 |-------Error (IIDs 9)---------->|
>                 |-------Error (IIDs 10)--------->|
>
>
>    The other alternative which i am showing is correct or not , as this is
>implementation dependant
>
>                 SG                               ASP1
>                 |                                |
>                 |-------Error (IIDs 1)---------->|
>                 |-------Error (IIDs 2)---------->|
>                 |-------Error (IIDs 3)---------->|
>                 |-------Error (IIDs 4)---------->|
>                 |-------Error (IIDs 5)---------->|
>                 |-------Error (IIDs 6)---------->|
>                 |-------Error (IIDs 7)---------->|
>                 |-------Error (IIDs 8)---------->|
>                 |-------Error (IIDs 9)---------->|
>                 |-------Error (IIDs 10)--------->|
>
>
> Regards
> Manish Sharma
> www.hssworld.com
>
>
>
>
>
>
>
>
>
>_______________________________________________
>Sigtran mailing list
>[email-masked]
>https://www1.ietf.org/mailman/listinfo/sigtran

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: Ken Morneault <[email-masked]>
Date: Thu, 27 Feb 2003 13:43:15 -0500

Manish,

Who's to say which side has been configured incorrectly.  Could be
the SG or ASP side.  

The first message flow allows traffic to flow for IIDs 1-5 and provides
a means for an alarm (by way of the Error msg) to be generated
to notify the operator of the misconfiguration of IIDs 6-10. 

Ken