Subject: RE: [Sigtran] Re: M3UA Notify message

From: "Javier Pastor-Balbas (ECE)" <[email-masked]>
Date: Mon, 17 Feb 2003 16:02:02 +0100

Hi Brian, 

Why do you say that: "'n' has always meant the number required for engineered maximum load" when the RFC says:

   The failover model supports an "n+k" redundancy model, where "n" ASPs
   is the minimum number of redundant ASPs required to handle traffic
   ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
   and "k" ASPs are available to take over for a failed or unavailable
   ASP.

(??)

Cheers // Javier.

> -----Original Message-----
> From: Brian F. G. Bidulock [mailto:[email-masked]]
> Sent: Saturday, February 15, 2003 7:37 PM
> To: Tolga Asveren
> Cc: [email-masked]
> Subject: Re: [Sigtran] Re: M3UA Notify message
> 
> 
> Tolga,
> 
> I have explained on this thread already the stop, start and
> restart decisions.  Also, 'n' has always meant the number
> required for engineered maximum load, you have simply
> just mis-interpreted it.  Do not update the inactive to
> active transition: it is adequately described in the RFC.
> 
> Strike IG section 3.15 an let the RFC be as it stands.
> 
> --brian
> 
> Tolga Asveren wrote:                     (Sat, 15 Feb 2003 10:22:02)
> > Hi Everybody,
> > > ksrinivas,
> > > 
> > > IMO section 3.15 of the IG just needs to be deleted.
> > > 
> > > --brian
> > Just to briefly summarize my opinion about n+k debate:
> > a)If nobody sees a need for n as mandatory, let's make
> > necessary changes(i.e. return to the old state
> > machine)
> > 
> > b)IMO, if n is to be interpreted as the engineered
> > value (but no mandatory) and the decision is to be
> > made by SG when traffic can flow between ASP/SGP, it
> > should be stated somewhere that NTFY(AS ACTIVE) is to
> > be interpreted by ASP to start traffic, because ASPs
> > can't decide when SG is going to decide that there are
> > enough ACTIVE ASPs for an AS.
> > 
> > c)IMO, it is unacceptable to have the statement that
> > ASPs SHOULD wait for n ACTIVE ASPs to start traffic,
> > if n is to be interpreted as in b). Because in this
> > case, SG can decide to start traffic before n ASPs are
> > ACTIVE, but ASPs will wait for n ACTIVE ASPs, so they
> > won't send traffic.
> > 
> > d)I would think, the most clean way is still to update
> > the transition from INACTIVE to ACTIVE in the very
> > first version of AS state machine by saying that SG
> > decides based on traffic conditions and on the number
> > of ACTIVE ASPs when this transition happens.
> > 
> > e)I don't know, whether there might be cases, where it
> > makes sense that ACTIVE to PENDING transition is also
> > decided by SG based on number of ACTIVE ASPs and
> > traffic conditions(intead of the last ASP going
> > INACTIVE)
> > 
> >     Tolga
> > 
> > __________________________________________________
> > Do you Yahoo!?
> > Yahoo! Shopping - Send Flowers for Valentine's Day
> > http://shopping.yahoo.com
> > _______________________________________________
> > Sigtran mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/sigtran
> 
> -- 
> Brian F. G. Bidulock
> [email-masked]
> http://www.openss7.org/
> _______________________________________________
> Sigtran mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/sigtran
> 
_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Mon, 17 Feb 2003 13:28:16 -0700

Javier,

Same thing.

What did you think one would use to determine the "traffic" that "n" ASPs
are required to handle, other than their engineered maximum traffic
handling capability?

--brian

Javier Pastor-Balbas (ECE) wrote:                                                   (Mon, 17 Feb 2003 16:02:02)