Subject: RE: [Sigtran] Re: M3UA Notify message

From: "Javier Pastor-Balbas (ECE)" <[email-masked]>
Date: Wed, 26 Feb 2003 09:12:43 +0100

Hi Samuel, 

Reading again your proposed change #1. I would agree to change n as recommended in traffic mode while mandatory at start time, as I said before.
But it seems to me that you are routing inside a RK, which is not disallowed, but why don't you use separate RKs? I mean, the RK should be sufficient to base the routing decissions on the SG...

Cheers // Javier.

> -----Original Message-----
> From: Samuel Dur D. Jeyaseelan [mailto:[email-masked]]
> Sent: miércoles, 26 de febrero de 2003 7:05
> To: [email-masked]
> Subject: RE: [Sigtran] Re: M3UA Notify message
> 
> 
> 
> Javier,
> 
> 
>                SG                        +------+  AS1
>  normal SS7  +-----+             +-------|      |
> -----------> |     |------------/--------| ASP1 |      
>  traffic(T)  |     |           /         +------+        'n' ASPs
>              | SGP1|          /          +------+
>              |     |---------/-----------| ASP2 |
>              +-----+        /     +------|      |
>                *           /     /       +------+
>                *          /     /        +------+  
>                **************************| ASP3 |  spare 'k' ASP
>                         /     /          +------+
>                        /     /              *
>              +---- +  /     /               *
>              |     |-+     /                *
>              |     |      /                 *
>              |SGP2 |-----+                  *
>              |     |                        *
>              +-----+                        *
>                *                            *
>                *                            *
>                ******************************
>                
> 
> At SGP1 SLS-ASP table
> --------------------
> SLS             ASP
> ---             ---
> X               ASP1
> Y               ASP2
> -               ASP3 (spare ASP)
> 
> AT AS1 SLS-ASP table
> -------------------
> SLS             ASP        PRIMARY-RT         SECND-RT
> ---             ---        ----------         --------
> A               ASP1        SGP1               SGP2
> B               ASP2        SGP1               SGP2
> 
> 
> Initially AS1 state at SGP is AS-DOWN.
> 
> SGP requires 'n' ASPs to handle the normal SS7 Traffic 'T', 
> this can be
> called as 'best traffic'.AS1 state is changed to AS-ACTIVE 
> when 'n' ASPs
> have become active.
> 
> Suppose ASP1 is failed so 'n' becomes '1'.
> 
> Now the question.
> 
> 1) If AS1 state is changed from ACTIVE to PENDING(as per IG)
>    then no DATA messages will be sent to AS.
>    
>    IMO, we should keep the AS state as ACTIVE.
>    
>    According to q.704 section 3.8.2 we should reroute the 
>    traffic to ASP2 provided congestion has not occured.
> 
>    Just reroute the SLS(X,Y) to available ASP1 , i beleive this is
>    what we follow in legacy SS7 network.
>    
>    When ASP2 transmission buffer reaches congestion level then
>    we can send NTFY to spare 'k' ASP and change the AS1 state to
>    PENDING along with timer running.
>    
>  2)What will happen when the traffic reaches from 'T' to 'T+1'?
>  
>    At SG 'n' ASPs are not sufficient to handle this 'worst case'.
>    So SG is required to send NTFY to spare 'k' ASP.
>    But RFC and IG ignores to handle this case.We should enhance IG to
>    support this case.
>    
>  IG section 3.15 misguides and should be re-writen to handle 
> the above two 
>  points.
>  
> --Samuel
> 
>   Alcatel USA, Inc.                  Internet: 
> <userid>@ssd.usa.alcatel.com
>   1000 Coit Road, Plano, Texas 75075
>   ******* The opinions expressed are not those of Alcatel 
> USA, Inc. *******
> 
> 
> _______________________________________________
> Sigtran mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/sigtran
> 
_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Samuel Dur D. Jeyaseelan" <[email-masked]>
Date: Wed, 26 Feb 2003 02:51:57 -0600 (CST)

Javier,

In n+k laodsharing case 'n' APSs are sharing the traffic for the
particular RK.In REG message there is no parameter, based on which
load is shared.So i have used SLS statically for loadsharing on RK.

If i use RK1-ASP1 and RK2-ASP2 , Can this be called loadsharing?

--Samuel

  Alcatel USA, Inc.                  Internet: <userid>@ssd.usa.alcatel.com
  1000 Coit Road, Plano, Texas 75075
  ******* The opinions expressed are not those of Alcatel USA, Inc. *******