Subject: RE: [Sigtran] M3UA - ASP database equalization

From: "Zannin, Francois" <[email-masked]>
Date: Thu, 6 Feb 2003 11:46:28 +0100

See below,

> -----Original Message-----
> From: Brian F. G. Bidulock [mailto:[email-masked]] 
> Sent: Thursday, February 06, 2003 11:17 AM
> To: Zannin, Francois
> Cc: Samuel Dur D. Jeyaseelan; Nagar, Ashish; [email-masked]
> Subject: Re: [Sigtran] M3UA - ASP database equalization
> 
> 
> Zannin,,
> 
> Zannin, Francois wrote:                                       
>                      (Thu, 06 Feb 2003 11:02:54)
> > Bidulock,,
> > 
> > > -----Original Message-----
> > > From: Brian F. G. Bidulock [mailto:[email-masked]]
> > > Sent: Thursday, February 06, 2003 10:54 AM
> > > To: Zannin, Francois
> > > Cc: Samuel Dur D. Jeyaseelan; Nagar, Ashish; [email-masked]
> > > Subject: Re: [Sigtran] M3UA - ASP database equalization
> > > 
> > > 
> > > Zannin,,
> > > 
> > > Zannin, Francois wrote:                                       
> > >                      (Thu, 06 Feb 2003 10:44:08)
> > > > Bidulock,,
> > > > 
> > > > > -----Original Message-----
> > > > > From: Brian F. G. Bidulock [mailto:[email-masked]]
> > > > > Sent: Thursday, February 06, 2003 10:22 AM
> > > > > To: Zannin, Francois
> > > > > Cc: Samuel Dur D. Jeyaseelan; Nagar, Ashish; [email-masked]
> > > > > Subject: Re: [Sigtran] M3UA - ASP database equalization
> > > > > 
> > > > > 
> > > > > Zannin,,
> > > > > 
> > > > > Zannin, Francois wrote:                                       
> > > > >                      (Thu, 06 Feb 2003 09:58:46)
> > > > > > Bidulock,,
> > > > > > 
> > > > > > Does it make sense to have "a lot" of ASP UP connected to a 
> > > > > > SGP
> > > > > > and
> > > > > > not ready to do anything?
> > > > > 
> > > > > They could be active for different AS.
> > > > 
> > > > In that case, because SSNM are for ss7 SP and concern all
> > > SI (AS), it
> > > > is not useless to receive (and you will receive) these
> > > SSNM. Now, the
> > > > question is about the RC in these SSNM.
> > > 
> > > AS is not synonymous with SI.  AS can be for different 
> point codes.
> > 
> > You are right, but it doesn't change anything...
> > 
> > > 
> > > > 
> > > > > 
> > > > > > If an ASP is UP for a SGP, it certainly must be ready to
> > > > > activate an
> > > > > > AS and then concerned by the SSNM, and again, for an
> > > emergency AS
> > > > > > recovery (AS-Pending notification) the ASP must be
> > > ready to operate
> > > > > > after the Active-ACK.
> > > > > > 
> > > > > > Only the "ready to operate for an AS" ASP have a reason to
> > > > > be "UP" on
> > > > > > a SG.
> > > > > 
> > > > > Wrong.  Whenever an ASP goes ASP UP it becomes 
> ASP-INACTIVE for 
> > > > > all AS for which it is configured to operate.  
> Depending on SG 
> > > > > configuration, this could mean that the ASP is 
> ASP-INACTIVE for 
> > > > > all AS served by the SG, regarless of whether the ASP 
> will ever 
> > > > > go ASP-ACTIVE for all of the AS.
> > > > > There is no way for an ASP to tell the SG that it is ASP-DOWN 
> > > > > for some AS and ASP-INACTIVE for others.
> > > > > 
> > > > > Also, the purpose of the ASP-INACTIVE state is to 
> receive NTFY 
> > > > > messages for the AS.  In override mode, one ASP is active for 
> > > > > the AS and the others are inactive.  The inactive 
> ASPs have no 
> > > > > intention of going active unless the active ASP 
> fails, or unless 
> > > > > manual management action is taken.
> > > > > 
> > > > 
> > > > A ss7 state concern all SI (AS) for a NA, the ASP receive
> > > the SSNM for
> > > > the ACTIVE (or activable) AS. If no AS is "activable" 
> no reason to
> > > > send an ASP-UP...
> > > 
> > > Yes, the reason is to act as standby for one active AS.
> > 
> > So, on AS IS "activable"...
> 
> What's "activalble"?

"Activable" is an AS that is ready to be activated when it receive a
pending notification or a activate management command.
If NO AS is ready to work on an ASP, there is no need to send an ASP-UP
to the SG, and then no SSNM is received.

If at least one AS is ready to work (ASP_ACTIVE is coming soon) it make
sense to receive SSNM from the SG

> --brian
> -- 
> Brian F. G. Bidulock
> [email-masked]
> http://www.openss7.org/
_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Thu, 6 Feb 2003 04:14:53 -0700

Zannin,,

Zannin, Francois wrote:                                                            (Thu, 06 Feb 2003 11:46:28)
> sense to receive SSNM from the SG

Going ASP UP with the intentions of going ASP-ACTIVE for one AS
can make an ASP ASP-INACTIVE for all AS.  There is no need to send
SSNM to inactive ASPs.

--brian

---

From: "Samuel Dur D. Jeyaseelan" <[email-masked]>
Date: Thu, 6 Feb 2003 05:26:33 -0600 (CST)

Brian,

  Alcatel USA, Inc.                  Internet: <userid>@ssd.usa.alcatel.com
  1000 Coit Road, Plano, Texas 75075
  ******* The opinions expressed are not those of Alcatel USA, Inc. *******

> can make an ASP ASP-INACTIVE for all AS.  There is no need to send

In override mode primary ASP will be in ASCTIVE state and backup ASP
will be in ASP INACT state.If it is DOWN state then we can declare that
M3UA stack has poor efficency.

Why ASP2 is in INACT state? the reason is anytime ASP1 may become
INACT and ASP2 will take the load by sending ASPAC message.

If the databases in ASP1 and ASP2 are same , this case ASP2 can easily
continue the traffic without any time delay.
How databases in ASP1 and ASP2 are same?
the answer is ASP2 should have received all the destination nodes statuses
when it was in inact state.

--Samuel

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Thu, 6 Feb 2003 04:30:35 -0700

Samuel,

Samuel Dur D. Jeyaseelan wrote:                                                     (Thu, 06 Feb 2003 05:26:33)
> M3UA stack has poor efficency.

How so?  What poor efficiency?

> continue the traffic without any time delay.

The can continue traffic without any dely even if their databases
are different.  What delay do you think is required by the RFC to occur?

> How databases in ASP1 and ASP2 are same?

They don't have to be.

> when it was in inact state.

No, ASP2 should receive all the destination node statuses after it goes
active.

--brian

---

From: "Samuel Dur D. Jeyaseelan" <[email-masked]>
Date: Thu, 6 Feb 2003 06:09:52 -0600 (CST)

Brian,

> How so?  What poor efficiency?
I should have said 'null efficiency'

section 4.3.1 says
In DOWN state ASP can receive only Hearbeat,ASP DOWN ACK and Error
messages.
So when ASP2 is in down state it will discard NTFY message from SGP.
Override mode will collapse here.
A good stack will expect ASP2(backup) in INACT state.
 
> are different.  What delay do you think is required by the RFC to occur?

They can't continue without delay.Because newly comeup ASP does not know
the current status of SS7 destinations with respect to the current route.
He has to spend some time by sending all un-necessary messages to SG.

> > How databases in ASP1 and ASP2 are same?
No comment.
> No, ASP2 should receive all the destination node statuses after it goes
No comment.

--Samuel

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Thu, 6 Feb 2003 05:20:04 -0700

Samuel,

Samuel Dur D. Jeyaseelan wrote:                                                     (Thu, 06 Feb 2003 06:09:52)
> In DOWN state ASP can receive only Hearbeat,ASP DOWN ACK and Error

An ASP can receive any message in any state.  Section 4.3.1 says that an SG
should not send other than these messages.

> So when ASP2 is in down state it will discard NTFY message from SGP.

It should not receive any NTFY message from the SGP.

> Override mode will collapse here.

Explain.

> A good stack will expect ASP2(backup) in INACT state.

It is not required by the RFC.  A backup ASP can be in any state.
If it is in the ASP-DOWN state, it will not receive any NTFY messages,
but that does not stop an ASP from determining the state of its
brethren by other means.

Where is the 'null efficiency'?

> He has to spend some time by sending all un-necessary messages to SG.

The newly active ASP must wait for ASPAC Ack from the SG before it sends
any DATA messages.  If the ASP sends DAUD with ASPAC and receives
the DAUD response with ASPAC Ack there is no additional delay whatsoever.

Where did you think there would be a delay?

> > > How databases in ASP1 and ASP2 are same?

I take it you agree.

> > No, ASP2 should receive all the destination node statuses after it goes

I take it you agree.

--brian