Subject: RE: [Sigtran] M3UA - ASP database equalization

From: "Zannin, Francois" <[email-masked]>
Date: Thu, 6 Feb 2003 13:44:40 +0100

Bidolock,,

> -----Original Message-----
> From: Brian F. G. Bidulock [mailto:[email-masked]] 
> Sent: Thursday, February 06, 2003 1:35 PM
> To: Zannin, Francois
> Cc: Samuel Dur D. Jeyaseelan; Nagar, Ashish; [email-masked]
> Subject: Re: [Sigtran] M3UA - ASP database equalization
> 
> 
> Zannin,,
> 
> So you see that there are ASP that do not want to receive 
> SSNM for inactive AS.  This is one reason why the SG cannot 
> be required to send such useless SSNM to inactive ASPs.

If an ASP do not need to receive SSNM, it just do not send the ASP UP.
As soon as the ASP is ready to activate an AS, it sends the ASP UP, and
then it is notified by the SSNM.
SSNM reflect the state of a ss7 SP and is valid for all AS of the same
NA, so receiving a SSNM for one or several AS is the same thing.
If you receive a SSNM for one AS, it is valid for all AS of the same NA.
If you don't need to receive SSNM,,,,  don't send the ASP UP.

> 
> --brian
> 
> Zannin, Francois wrote:                                       
>                      (Thu, 06 Feb 2003 13:23:37)
> > Bidulock,,
> > 
> > See below,
> > 
> > > -----Original Message-----
> > > From: Brian F. G. Bidulock [mailto:[email-masked]]
> > > Sent: Thursday, February 06, 2003 12:15 PM
> > > To: Zannin, Francois
> > > Cc: Samuel Dur D. Jeyaseelan; Nagar, Ashish; [email-masked]
> > > Subject: Re: [Sigtran] M3UA - ASP database equalization
> > > 
> > > 
> > > Zannin,,
> > > 
> > > Zannin, Francois wrote:                                       
> > >                      (Thu, 06 Feb 2003 11:46:28)
> > > > > 
> > > > > What's "activalble"?
> > > > 
> > > > "Activable" is an AS that is ready to be activated when it
> > > receive a
> > > > pending notification or a activate management command. 
> If NO AS is
> > > > ready to work on an ASP, there is no need to send an ASP-UP 
> > > to the SG,
> > > > and then no SSNM is received.
> > > > 
> > > > If at least one AS is ready to work (ASP_ACTIVE is 
> coming soon) it
> > > > make sense to receive SSNM from the SG
> > > 
> > > Going ASP UP with the intentions of going ASP-ACTIVE for one
> > > AS can make an ASP ASP-INACTIVE for all AS.  There is no need 
> > > to send SSNM to inactive ASPs.
> > > 
> > 
> > You are right, ASP UP WILL make ASP-INACTIVE for all AS, 
> but because 
> > at least one AS on this ASP is concerned by the SSNM, the 
> ASP anyway 
> > will receive the SSNM, maybe the RC list can change but 
> these SSNM are 
> > valid for all AS (for a NA). Because one ASP is active for 
> one AS, the 
> > number SSNM received by the ASP do not change.
> > If NO AS is "ready to work", you just do not send ASP UP to 
> the SG. BUT
> > if you need to be ready for an AS recovery (pending 
> notification), you
> > send the ASP UP and then you are concerned by the SSNM for 
> an emergency
> > recovery.
> > 
> > > --brian
> > > 
> > > 
> > > --
> > > Brian F. G. Bidulock
> > > [email-masked]
> > > http://www.openss7.org/
> > > 
> 
> -- 
> Brian F. G. Bidulock
> [email-masked]
> http://www.openss7.org/
> 
_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Thu, 6 Feb 2003 06:00:59 -0700

Zannin,,

Zannin, Francois wrote:                                                            (Thu, 06 Feb 2003 13:44:40)
> then it is notified by the SSNM.

There are ASP that need to receive NTFY for an AS but do not need
to receive SSNM for the AS.  In ASP-INACTIVE state, the ASP receives
NTFY, but does not receive SSNM.  If the ASP wishes to receive SSNM,
it moves to the ASP-ACTIVE state.

> NA, so receiving a SSNM for one or several AS is the same thing.

Not true.  Two AS in the same NA (but different point codes, not
just different SI) can have different routing.  One AS can be given
DUNA because it is not permitted to access the destination (has no
route to the destination), the other given DAVA because it is
permitted to access the destination (has a route to the destination).
So, where multiple AS share the same association, RC is required in
the SSNM message to indicate for which AS the SSNM message pertains.
All RCs to which the message pertains must be listed in the SSNM.
None of these RCs may be inactive.

> If you receive a SSNM for one AS, it is valid for all AS of the same NA.

That is not true.  See above.

> If you don't need to receive SSNM,,,,  don't send the ASP UP.

On the contrary, of you need to receive SSNM, send ASP Active.

--brian