Subject: RE: [Sigtran] m3ua: ASP Active w/o RC

From: "Wung, Joseph" <[email-masked]>
Date: Wed, 26 Feb 2003 14:58:41 -0500

Brian,

The problem I have is that "via configuration data" in the rule.
My interpretation of "configuration data" in this case is that
it only refers to the routing keys that have been statically 
registered, and does NOT refer to those already dynamically 
registered.  Am I being wrong?

Joe

> -----Original Message-----
> From: Brian F. G. Bidulock [mailto:[email-masked]]
> Sent: Wednesday, February 26, 2003 2:49 PM
> To: Wung, Joseph
> Cc: [email-masked]'
> Subject: Re: [Sigtran] m3ua: ASP Active w/o RC
> 
> 
> Joeseph,
> 
> Wung, Joseph wrote:                                           
>                        (Wed, 26 Feb 2003 14:39:51)
> > In section 4.3.4.3 of M3UA, ASP Active Procedures
> > 
> > 	"In the case where an ASP Active message does 
> > 	not contain a Routing Context parameter, the receiver 
> > 	must know, via configuration data, which Application 
> > 	Server(s) the ASP is a member." 
> > 
> > Does this rule apply to the dynamically registered routing keys?
> 
> What has dynamically registered routing keys go to do with it?
> 
> I think it is pretty clear that if there is no RC in the ASPAC that
> the SG has to know somehow which AS the message corresonds to.
> 
> --brian
> 
> -- 
> Brian F. G. Bidulock
> [email-masked]
> http://www.openss7.org/
> 
_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Wed, 26 Feb 2003 18:04:46 -0700

Joseph,

Configuration of the SG is largely outside the scope of the RFC (but would
be within the scope of the M3UA-MIB).  Whether a key is statically or
dynamically registered allocated shouldn't matter.  The ASP is not going
to use the RC value in either case.

Was the ASP going to register a single RK and then activate it without
giving reference to the returned RC?  What would that gain?

--brian

Wung, Joseph wrote:                                                                  (Wed, 26 Feb 2003 14:58:41)