Subject: RE: [Sigtran] Re: M3UA Notify message

From: "TOLGA ASVEREN" <[email-masked]>
Date: Wed, 26 Feb 2003 09:18:23 +0200

Samuel,
--- "Samuel Dur D. Jeyaseelan" <[email-masked]> wrote:
>
> Javier,
>
>
>                SG                        +------+
> AS1
>  normal SS7  +-----+             +-------|      |
> -----------> |     |------------/--------| ASP1 |
>
>  traffic(T)  |     |           /         +------+
>     'n' ASPs
>              | SGP1|          /          +------+
>              |     |---------/-----------| ASP2 |
>              +-----+        /     +------|      |
>                *           /     /       +------+
>                *          /     /        +------+
>                **************************| ASP3 |
> spare 'k' ASP
>                         /     /          +------+
>                        /     /              *
>              +---- +  /     /               *
>              |     |-+     /                *
>              |     |      /                 *
>              |SGP2 |-----+                  *
>              |     |                        *
>              +-----+                        *
>                *                            *
>                *                            *
>                ******************************
>
>
> At SGP1 SLS-ASP table
> --------------------
> SLS             ASP
> ---             ---
> X               ASP1
> Y               ASP2
> -               ASP3 (spare ASP)
>
> AT AS1 SLS-ASP table
> -------------------
> SLS             ASP        PRIMARY-RT
> SECND-RT
> ---             ---        ----------
> --------
> A               ASP1        SGP1               SGP2
> B               ASP2        SGP1               SGP2
>
>
> Initially AS1 state at SGP is AS-DOWN.
>
> SGP requires 'n' ASPs to handle the normal SS7
> Traffic 'T', this can be
> called as 'best traffic'.AS1 state is changed to
> AS-ACTIVE when 'n' ASPs
> have become active.
>
> Suppose ASP1 is failed so 'n' becomes '1'.
>
> Now the question.
>
> 1) If AS1 state is changed from ACTIVE to PENDING(as
> per IG)
>    then no DATA messages will be sent to AS.
>
>    IMO, we should keep the AS state as ACTIVE.
>
>    According to q.704 section 3.8.2 we should
> reroute the
>    traffic to ASP2 provided congestion has not
> occured.
[TOLGA]IMO Q.704 can't be binding for this decision. The interface between
ASP/SGP (especially from SGP to ASP direction) is a MTP3/MTP3-User
interface, not a MTP3/MTP3 interface. But I agree that SG behaves like you
describe is a clever choice for most of the times. Still my opinion is to
leave the decision to SG. SGPs can inform ASPs about this decision with
NTFY. This logic can be applied also to other transitions, like the
transitions from ACTIVE to PENDING and from PENDING to ACTIVE. Does this
count as a solution ın your opinion?
>
>    Just reroute the SLS(X,Y) to available ASP1 , i
> beleive this is
>    what we follow in legacy SS7 network.
>
>    When ASP2 transmission buffer reaches congestion
> level then
>    we can send NTFY to spare 'k' ASP and change the
> AS1 state to
>    PENDING along with timer running.
>
>  2)What will happen when the traffic reaches from
> 'T' to 'T+1'?
>
>    At SG 'n' ASPs are not sufficient to handle this
> 'worst case'.
>    So SG is required to send NTFY to spare 'k' ASP.
>    But RFC and IG ignores to handle this case.We
> should enhance IG to
>    support this case.
>
>  IG section 3.15 misguides and should be re-writen
> to handle the above two
>  points.

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Wed, 26 Feb 2003 00:39:02 -0700

TOLGA,

TOLGA ASVEREN wrote:                                                                 (Wed, 26 Feb 2003 09:18:23)
> count as a solution ýn your opinion?

The RFC already provides for the above.  It is IG 3.15 that does not.
Striking IG 3.15 is the best start.

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/