Subject: [Sigtran] I: sctp

From: Troiano Marco <[email-masked]>
Date: Thu, 13 Feb 2003 17:53:54 +0100

> Hi all.
> My name is Marco Troiano and I am a Telecommunication Enginner. I am
> studying  SCTP and I would like to ask you some questions about RFC 2960:
> 
> *	what is the length of the following fields:
> *	"Host Name address" parameter for INIT chunk (see page 24)?
> *	"State Cookie" parameter for INIT ACK chunk (see page 32)?
> *	"Sender-specific Heartbeat info" parameter for HEARTBEAT chunk (see
> page 36)?
> *	 "Cookie" parameter for COOKIE chunk (see page 46)?
> *	what are the possible values for Heartbeat timers?
> *	how can i choose the periodicity for sending Heartbeat chunks?
> *	what is the worst case for the length of an SCTP control chunk?
> 
> Thanks in advance
> 
> Marco
> 
> 
> 
>

---

From: Michael Tuexen <[email-masked]>
Date: Thu, 13 Feb 2003 20:14:40 +0100

Hi Marco,
see my comments below.
Best regards
Michael
On Thursday, Feb 13, 2003, at 17:53 Europe/Berlin, Troiano Marco wrote:

> • 	what is the length of the following fields:
> • 	"Host Name address" parameter for INIT chunk (see page 24)?
Length of the parameter header (= 4) + length of the hostname.
This depends on the hostname.
> • 	"State Cookie" parameter for INIT ACK chunk (see page 32)?
Length of the parameter header (= 4) + length of the cookie information.
This depends on the cookie information.
> • 	"Sender-specific Heartbeat info" parameter for HEARTBEAT chunk (see 
> page 36)?
Length of the parameter header (= 4) + length of the heartbeat 
information.
This depends on the heartbeat information.
> • 	 "Cookie" parameter for COOKIE chunk (see page 46)?
Length of the chunk header (= 4) + length of the cookie information.
This depends on the cookie information.
> • 	what are the possible values for Heartbeat timers?
The time between the heartbeats is RTO + HBInterval.
RTO is betweeen RTO.Min and RTO.Max and HB.Interval >= 0.
Which values can be chosen and how to do it is implementation dependent.
> • 	how can i choose the periodicity for sending Heartbeat chunks?
This is implementation dependent, but normally you are able to
configure RTO.Min, RTO.Max, HB.Interval.
> • 	what is the worst case for the length of an SCTP control chunk?
Hmm,
64K - IPV4 Header Length (20 Bytes)
     - SCTP Common Header Length (12 Bytes)
So you can send a HEARTBEAT chunk of 65504 bytes length. Not that it is
useful, but of maximum length.
> Marco

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran