Subject: Re: [Sigtran] M2PA LPO during alignment/proving (was: M2PA version 7 changes)

From: Tom George <[email-masked]>
Date: Tue, 04 Feb 2003 17:15:19 -0600

Brian,

I like the 2nd version (below). I will update the draft accordingly.

And when you say
> The effect is the same.  The diagram is certainly not intended to be 100%
> complete, it is an overview.  The text should be consulted.

I agree whole heartedly. I am running out of blank spaces on the
diagram. 8-)

tomG.

"Brian F. G. Bidulock" wrote:
> 
> Tom,
> 
> The problem is the LSC doesn't really have a proving state (only IAC
> has proving state).  LSC always moves from INITIAL ALIGNMENT to either
> ALIGNED READY or ALIGNED NOT READY.  You might change the diagram as
> follows:
> 
>  From:
  [...]
>  To:
  [...]
>   |                       | MTP3 Start                 |
>   |                       |                            |
>   |                       |   +-------+                |
>   |                       |   |       | LPO/LPR        |
>   |                       V   V       |                |
>   |                 +-----------+     |                |
>   |                 |  INITIAL  |<----+                |
>   +<----------------| ALIGNMENT |--------------------->+
>   |      MTP3 Stop  +-----------+     SCTP Comm Error  |
>   |   OR T2 Expiry        |        OR SCTP Comm Lost   |
>   |   OR Receive LS OOS   |                            |
>   |                       | Receive                    |
>   |                       | LS Align                   |
>   |                       |                            |
>   |                       |   +-------+                |
>   |                       |   |       | LPO/LPR        |
>   |                       V   V       |                |
>   |                 +-----------+     |                |
>   |                 |  PROVING  |<----+                |
>   |<----------------|           |--------------------->+
>   |      MTP3 Stop  +-----------+     SCTP Comm Error  |
>   |   OR T3 Expiry        | |      OR SCTP Comm Lost   |
>   |   OR Receive LS OOS   | |                          |
>   |                       | +--------------------------|--------+
>   |                       |                            |   T4   |
>   |                       | T4 Expiry                  | Expiry |
>   |                       | Send LS Ready              | Send   |
>   |                       V                            | LS PO  V
>   |                 +-----------+        LPO/LPR       |  +-----------+
>   |                 |  ALIGNED  |<---------------------|->|  ALIGNED  |
>   +<----------------|   READY   |--------------------->+  | NOT READY |
>   |      MTP3 Stop  +-----------+     SCTP Comm Error     +-----------+
>   |   OR T1 Expiry        |        OR SCTP Comm Lost         |       |
>   |   OR Receive LS OOS   |                                  |   T1  |
>   |   OR Receive LS Align | Receive LS Ready      Receive    | Expiry|
>   |                       | OR Receive User Data    LS Ready | OR Rcv|
>   |                       |                       OR Receive |    LS |
>   |                       |                         LS PO    |  Align|
>   |                       |                                  |       |
>   |                       |                                  |       |
>   |                       V                                  V       |
>   |                 +-----------+        LPO/LPR       +-----------+ |
>   |                 |    IN     |<-------------------->| PROCESSOR | |
>   |                 |  SERVICE  |                      |   OUTAGE  | |
>   |                 +-----------+                      +-----------+ |
> 
> The effect is the same.  The diagram is certainly not intended to be 100%
> complete, it is an overview.  The text should be consulted.
> 
> --brian

-- 
* Tom George       PB7-24001 (near B-21)      [email-masked]  *
* 972-519-3168   Intranet:  http://www.ssd.usa.alcatel.com/~tgeorge/  *
* Alcatel;  3400 West Plano Pkwy,  MS PB7-SWPRO;  Plano, Texas 75075  *
* I actively disclaim speaking for Alcatel USA, Inc. I do not purport *
* to advertise or represent its position,  operations, or activities. *
_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: Tom George <[email-masked]>
Date: Tue, 11 Feb 2003 14:33:04 -0600

Here is my idea for the new OOS section that I will reference throughout
the document. I thought I would make it section 4.1.6 and move the old
4.1.6ff down.

==========================
4.1.6  Link Out of Service

When M2PA places a link in the OUT OF SERVICE state, 

   (1) M2PA SHALL send a Link Status Out of Service message to its
       peer.

   (2) M2PA SHALL send an Out of Service indication to its upper layer
       MTP3. M2PA MAY send additional Link Status Out of Service
       messages to its peer while it remains in the OUT OF SERVICE
       state.

   (3) M2PA SHOULD NOT terminate the SCTP association.

M2PA waits for an MTP3 Start command to begin the alignment procedure.
==========================

"Brian F. G. Bidulock" wrote:
> 
> Tom,
> 
> I like the little OOS section idea.
> 
> --brian
> 
> Tom George wrote:                                                                      (Wed, 29 Jan 2003 15:52:14)
> > Franz and others,
> >
> > Yes, in that case M2PA should send LS OOS to its peer.
> >
> > There are several places in the document where the link goes OOS. As it
> > stands now, I do not always state all of the actions to be taken because
> > they are more-or-less understood:
> >
> > - Send LS OOS to the peer.
> > - Notify MTP3 of Out of Service condition.
> > - Leave the SCTP association up. (a SHOULD)
> > - Wait for MTP3 to begin alignment.
> >
> > What is the best way to explain this? Repeat it throughout the document,
> > or have a little OOS section (similar to 4.2.3  Link deactivation), or
> > just leave it as is and count on the reader to understand it?
> >
> > tomG.
> >
> > Gaiser Franz wrote:
> > >
> > > Dear All,
> > >
> > > some remarks to the new draft version 07:
> > >
> >   [...]
> > > 4.) 4.2.1 Paragraph "If M2PA receives a User Data message with
> > > an FSN that is out of order, M2PA SHALL take the link out of service."
> > > Does "take the link out of service"  mean also that the peer side is
> > > informed via sending LS OOS message.
> >   [...]
> >
> > --
> > * Alcatel USA, Inc.; 1000 Coit Rd, MS PB7-SWPRO; Plano TX 75075-5813  *
> Brian F. G. Bidulock
> [email-masked]
> http://www.openss7.org/

---

From: Tom George <[email-masked]>
Date: Tue, 11 Feb 2003 17:32:15 -0600

Oops. Of course, the 2nd sentence in (2) should be moved to (1). 

tomG.