Subject: RE: [Sigtran] M3UA - ASP database equalization

From: "Zannin, Francois" <[email-masked]>
Date: Thu, 6 Feb 2003 11:02:54 +0100

Bidulock,,

> -----Original Message-----
> From: Brian F. G. Bidulock [mailto:[email-masked]] 
> Sent: Thursday, February 06, 2003 10:54 AM
> To: Zannin, Francois
> Cc: Samuel Dur D. Jeyaseelan; Nagar, Ashish; [email-masked]
> Subject: Re: [Sigtran] M3UA - ASP database equalization
> 
> 
> Zannin,,
> 
> Zannin, Francois wrote:                                       
>                      (Thu, 06 Feb 2003 10:44:08)
> > Bidulock,,
> > 
> > > -----Original Message-----
> > > From: Brian F. G. Bidulock [mailto:[email-masked]]
> > > Sent: Thursday, February 06, 2003 10:22 AM
> > > To: Zannin, Francois
> > > Cc: Samuel Dur D. Jeyaseelan; Nagar, Ashish; [email-masked]
> > > Subject: Re: [Sigtran] M3UA - ASP database equalization
> > > 
> > > 
> > > Zannin,,
> > > 
> > > Zannin, Francois wrote:                                       
> > >                      (Thu, 06 Feb 2003 09:58:46)
> > > > Bidulock,,
> > > > 
> > > > Does it make sense to have "a lot" of ASP UP connected to a SGP 
> > > > and
> > > > not ready to do anything?
> > > 
> > > They could be active for different AS.
> > 
> > In that case, because SSNM are for ss7 SP and concern all 
> SI (AS), it 
> > is not useless to receive (and you will receive) these 
> SSNM. Now, the 
> > question is about the RC in these SSNM.
> 
> AS is not synonymous with SI.  AS can be for different point codes.

You are right, but it doesn't change anything...

> 
> > 
> > > 
> > > > If an ASP is UP for a SGP, it certainly must be ready to
> > > activate an
> > > > AS and then concerned by the SSNM, and again, for an 
> emergency AS
> > > > recovery (AS-Pending notification) the ASP must be 
> ready to operate 
> > > > after the Active-ACK.
> > > > 
> > > > Only the "ready to operate for an AS" ASP have a reason to
> > > be "UP" on
> > > > a SG.
> > > 
> > > Wrong.  Whenever an ASP goes ASP UP it becomes ASP-INACTIVE
> > > for all AS for which it is configured to operate.  Depending 
> > > on SG configuration, this could mean that the ASP is 
> > > ASP-INACTIVE for all AS served by the SG, regarless of 
> > > whether the ASP will ever go ASP-ACTIVE for all of the AS.  
> > > There is no way for an ASP to tell the SG that it is ASP-DOWN 
> > > for some AS and ASP-INACTIVE for others.
> > > 
> > > Also, the purpose of the ASP-INACTIVE state is to receive
> > > NTFY messages for the AS.  In override mode, one ASP is 
> > > active for the AS and the others are inactive.  The inactive 
> > > ASPs have no intention of going active unless the active ASP 
> > > fails, or unless manual management action is taken.
> > > 
> > 
> > A ss7 state concern all SI (AS) for a NA, the ASP receive 
> the SSNM for 
> > the ACTIVE (or activable) AS. If no AS is "activable" no reason to 
> > send an ASP-UP...
> 
> Yes, the reason is to act as standby for one active AS.

So, on AS IS "activable"...

> 
> > 
> > This can be less efficent for SG that plays multiple network!
> 
> Actually it is very efficient for an SG to consider all ASPs
> as ASP-INACTIVE for all AS that it serves: particularly if, 
> as in the RFC, it is not required to send SSNM to inactive ASPs.
> 
> > 
> > > > I don't think that it is useful to connect "UP" a lot of
> > > ASP with no
> > > > reason!
> > > 
> > > See above.
> > > 
> > > > 
> > > > You are right, DUNA is not the same thing as MTP-PAUSE, but
> > > the sense
> > > > is the same, a user (AS) cannot use a ROUTE (or SG) if the
> > > remote SP
> > > > is inaccessible because of TFP, TCP and then MTP-PAUSE which is 
> > > > the
> > > > consolidation of all the routes for a destination.
> > > > 
> > > > The reason to wait for a DAUD for the ss7 state on an ASP
> > > is to have a
> > > > selective use of the ss7 network SP by an AS (then ASP). In
> > > that case,
> > > > the number of DAUD is limited to the minimum after the ACTIVE
> > > > procedure. But as soon as the ASP is active, there is no 
> > > filter in the
> > > > SG for ASP concerned by the SSNM for specific destinations.
> > > 
> > > MTP procedures require MTP-PAUSE to be sent to MTP users that
> > > are sending to inaccessible destinations.  An MTP conforming 
> > > SG will send DUNA in response to messages sent to an 
> > > inacessible destination.
> > > 
> > 
> > Do you mean that when a SG receive a TFP on the last route for a 
> > destination, it does not send the DUNA to all the ASP??? If 
> yes, that 
> > a NEW behavior for a SG?????
> 
> I did not say that.  I said: "An MTP conforming SG will send 
> DUNA in response to messages sent to an inacessible destination."
> 
> --brian
> 
> -- 
> Brian F. G. Bidulock
> [email-masked]
> http://www.openss7.org/
> 
_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Thu, 6 Feb 2003 03:17:23 -0700

Zannin,,

Zannin, Francois wrote:                                                            (Thu, 06 Feb 2003 11:02:54)
> So, on AS IS "activable"...

What's "activalble"?

--brian