Subject: RE: [Sigtran] M3UA - ASP database equalization

From: "Nagar, Ashish" <[email-masked]>
Date: Wed, 5 Feb 2003 22:38:43 -0800

You can generate DAUD procedure at any time, so whenever ASP changes state
from Inactive to Active Just generate DAUD.

Thanks & Regards
Ashish Nagar

-----Original Message-----
From: Samuel Dur D. Jeyaseelan [mailto:[email-masked]] 
Sent: Thursday, February 06, 2003 11:27 AM
To: [email-masked]
Subject: [Sigtran] M3UA - ASP database equalization

Hi all,

Currently RFC 3332 says that SG sends SSNM messages to all 'concerned
ASPs'(means only ACTIVE ASPs).

+----+           +---+           +-----+
|SEP | ----------|SG |-----------| ASP1|
+----+           +---+           +-----+
                   |             
                   |             +-----+
                   +-------------| ASP2|
                                 +-----+

(ASP1 is active and ASP2 is incative - override mode)

When SEP is getting restarted ,SG sends DUNA to ASP1.
But SEP status is not changed in ASP2.There are two ways to solve this
problem

1. ASP1 can equalize its database with ASP2
or
2.SG itself can send DUNA... to ASP2 (eventhough ASP2 is inactive)

IMO, SG can send SSNM messages to ASP (either ASP is in active or inact
state)

Any comments?

-----

section 5.4.2.1

...
      - Pass the MTP-TRANSFER request primitive to the MTP3 of the
        concerned Network Appearance.

It conveys the meaning that M3UA layer (at SGP) MTP-TRANSFER request is
sent to MTP3.

But there is no primitive availabe between M3UA and MTP3.

I think it should be corrected.

----
Presently ASP is unaware of SG's MTP3 restart, 
ASP receives only DUNA for all SS7 point codes which can be
reachable via that SG.But in case of peer to peer protocol
SG and AS point codes are different, So why dont we send
DUNA with SG's point code to ASP? So that just by getting
single DUNA(with SG's PC) ASP will not route any message via that SG.
This can avoid sending multiple DUNAs to ASP.

Any comments?

-----
section 1.4.1

...
   Where a particular AS can be reached via more than one SGP, the
   corresponding Routing Keys in the SGPs should be identical.  (Note:
   It is possible for the SGP Routing Key configuration data to be
   temporarily out-of-sync during configuration updates).
 
                              +--------+
                              |        |
                 +------------+  SG 1  +--------------+
     +-------+   |  SS7 links | "STP"  |  IP network  |     ----
     |  SEP  +---+            +--------+              +---/      \
     |   or  |                    |*                      | ASPs  |
     |  STP  +---+            +--------+              +---\      /
     +-------+   |            |        |              |     ----
                 +------------+  SG 2  +--------------+
                              | "STP"  |
                              +--------+
 
                    Figure 1  Example with mated SGs

Here SGP1 is in SG1 and SGP2 is in SG2. Basically mated SGs are located
geographically in different places.The ideas is when SG1 goes down in
CITY1(due to earthquake...) , all the traffice still can be handled by SG2
which is in CITY2.

SGP2 is mate for SGP1, On failure of SGP1, all the messages will be
routed from SGP1 to SGP2.

Does all these things mean to say that SGP1's mate 'should be' present in
SG2 and not in SG1 itself ?

Comments are welcome.

--Samuel

  Alcatel USA, Inc.                  Internet: <userid>@ssd.usa.alcatel.com
  1000 Coit Road, Plano, Texas 75075
  ******* The opinions expressed are not those of Alcatel USA, Inc. *******

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran
_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Samuel Dur D. Jeyaseelan" <[email-masked]>
Date: Thu, 6 Feb 2003 00:59:54 -0600 (CST)

Ashish,

My point is if SG is able to send DUNA to all inact and active ASPs,
we should not restrict it.

Sending DAUD is an alternative way ,If SG has direct way of sending
DUNA then Why do you need alternative way?

--Samuel