Subject: [Sigtran] M3UA: Error message + RKM timers...

From: "Sibi George" <[email-masked]>
Date: Thu, 24 Apr 2003 13:11:37 +0530

hi all,

1)  Is Error Message directed always from SGP to ASP ?

2) How long should ASP wait for register/dereg response ?

thanks
sibi

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Thu, 24 Apr 2003 02:25:27 -0600

Sibi,

Sibi George wrote:                                                                    (Thu, 24 Apr 2003 13:11:37)
>    1)  Is Error Message directed always from SGP to ASP ?

No.

>    2) How long should ASP wait for register/dereg response ?

For a provisionable amount of time.

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/
_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Sibi George" <[email-masked]>
Date: Thu, 24 Apr 2003 14:39:51 +0530

hi brian,
  Comments inline

Sibi,

Sibi George wrote:
(Thu, 24 Apr 2003 13:11:37)
>    1)  Is Error Message directed always from SGP to ASP ?

No.
[sibi] Can you give us an instance where ASP sends an error message to SGP??

For a provisionable amount of time.
 [sibi] RFC provides retransmission timer for ASP UP/ACTIVE/INACTIVE/DOWN
messages.
  But only during reg/dereg it doesnot . Is there any specific reason?? I am
not able to
comprehend why RKM messages are treated differently unlike other message
classes(ASP TM/SM)....

thanks
sibi

--brian

--
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Thu, 24 Apr 2003 12:28:39 -0600

Sibi,

Sibi George wrote:                                                                    (Thu, 24 Apr 2003 14:39:51)
> [sibi] Can you give us an instance where ASP sends an error message to SGP??

Section 7.3.2:

  When an implementation receives a message type which it does not
  support, it MUST respond with an Error (ERR) message ("Unsupported
  Message Type").

> comprehend why RKM messages are treated differently unlike other message

Because the REG REQ has a Local-RK-Identifier.

--brian