Subject: Re: [Sigtran] M2PA: Revised section 4.2

From: Tom George <[email-masked]>
Date: Tue, 01 Apr 2003 17:30:53 -0600

No, there is no reason to deviate from Q.703. This is an example of why
the M2PA draft needs to be free of MTP2 duplication, and only point out
differences with MTP2. 

tomG.

"Brian F. G. Bidulock" wrote:
> 
> All,
> 
> Is there are reason do deviate from Q.703 on the assignment
> of initial sequence numbers?
> 
> --brian
> 
> On Thu, 20 Mar 2003, S Magesh wrote:
> 
> > Tom
> >
> > Under section 4.2.1,
> >
> > The first User Data Message sent after link is placed in service
> > is given a FSN of 1.
> >
> > Once the FSN has reached the maximum value, the next FSN is 0.
> >
> > The above two statements are contradicting.
> >
> > Apart from the above statements, for BSN the initial value is 0.
> >
> > So for first user data message the FSN value should be 0 rather 1,
> > once the link is placed inservice.
> >
> > Regards
> >
> > Magesh
> >
> 
> --
> Brian F. G. Bidulock    ¦ The reasonable man adapts himself to the ¦
> [email-masked]    ¦ world; the unreasonable one persists in  ¦
> http://www.openss7.org/ ¦ trying  to adapt the  world  to himself. ¦
>                         ¦ Therefore  all  progress  depends on the ¦
>                         ¦ unreasonable man. -- George Bernard Shaw ¦
> _______________________________________________
> Sigtran mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/sigtran

-- 
* Tom George       PB7-24001 (near B-21)      [email-masked]  *
* 972-519-3168   Intranet:  http://www.ssd.usa.alcatel.com/~tgeorge/  *
* Alcatel;  3400 West Plano Pkwy,  MS PB7-SWPRO;  Plano, Texas 75075  *
* I actively disclaim speaking for Alcatel USA, Inc. I do not purport *
* to advertise or represent its position,  operations, or activities. *
_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Rohan" <[email-masked]>
Date: Thu, 3 Apr 2003 09:50:10 +0530

All,
      Yes there isnt any need to deviate from Q.703.
   But in my understanding the basic reason for assigning FSN as 1 for the
first MSU sent would be because the peer sends a BSN of 0 in its first MSU
(initially it has no MSU's to acknowledge). Keeping  in mind this if the
sender had sent a FSN of 0 on receipt of a MSU from peer with BSN as 0, the
sender would consider this as a  acknowledgment for the MSU sent with FSN 0.
  Kindly correct me if i am wrong.

Rohan

----- Original Message -----
From: "Tom George" <[email-masked]>
To: <[email-masked]>
Cc: "SIGTRAN e-mail list" <[email-masked]>
Sent: Wednesday, April 02, 2003 5:00 AM
Subject: Re: [Sigtran] M2PA: Revised section 4.2

tomG.

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Wed, 2 Apr 2003 21:46:38 -0700

Rohan,

Q.703 sets the BSN initially to all 1's.  There is no reason to deviate
from Q.703 in that regard either.

--brian