Subject: [Sigtran] [m3ua]-ldshar basing on dpc

From: "Samuel Dur D. Jeyaseelan" <[email-masked]>
Date: Fri, 11 Apr 2003 06:09:28 -0500 (CDT)

Hi,
  
      SG1(a-b-c)                   
  +------+         RK1           +-------+
  | SGP1 |-----------------------| ASP1  |AS1(x-y-z)
  |      |------------------+    |-------|  
  +------+         RK1      |    | ASP2  |
                            +----+-------+
  Here
  How does SGP1 perform 'loadshare on DPC'?
  
-----------

      SG1(a-b-c)                   
  +------+               RK1     +-------+
  | SGP1 |-----------------------| ASP1  |AS1(x-y-z)
  |      |----------+            |       |  
  +------+          |            +-------+
                    |    RK1     +-------+
                    +------------| ASP2  |AS2(l-m-n)
                                 |       |
                                 +-------+

  Does this diagram represent 'loadshare on DPC' ?

  I think this is a wrong diagram because SGP1 can not return two 
  different RCs for the same RK1.
 
  Please guide me.

--Samuel  

  Alcatel USA, Inc.                  Internet: <userid>@ssd.usa.alcatel.com
  1000 Coit Road, Plano, Texas 75075
  ******* The opinions expressed are not those of Alcatel USA, Inc. *******

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: [email-masked]
Date: Fri, 11 Apr 2003 19:29:58 +0530

Tolga ,
      Can you given an example of how loadsharing can be done from ASP to
SGP based on DPC.
Regards
Kamesh

"TOLGA ASVEREN" <[email-masked]>@ietf.org on 04/11/2003 06:57:05
PM

Sent by:    [email-masked]

To:    [email-masked]
cc:

Subject:    Re: [Sigtran] [m3ua]-ldshar basing on dpc

Samuel,

Tolga,

I could find only the following text in mib.
                  "This variable indicates the method to be used when the
                   load must be shared between several ACTIVE Signaling
                   Processes."

It says "ACTIVE Signaling Processes" . It does not say "ACTIVE SGP".
[TOLGA]Current version of MIB document does not ditinguish between SGP and
ASP and tries to handle both of them in the same way. I would think, that
is the reason why it says "ACTIVEW Signaling Processes" rather than "ACTIVE
SGPs".

--Samuel

On Fri, 11 Apr 2003, TOLGA ASVEREN wrote:

>
> Samuel,
>
>
> Tolga,
>
>  I got this doubt while i was reading mib-04, where it is talking about
> load sharing method basing on DPC.
>  What is this 'basing on DPC - load sharing' ?
> [TOLGA]Probably it is referring to loadsharing from ASP to SGP.
>
> --Samuel
>
> On Fri, 11 Apr 2003, TOLGA ASVEREN wrote:
>
> >
> > Samuel,
> >
> >
> > Hi,
> >
> >       SG1(a-b-c)
> >   +------+         RK1           +-------+
> > [TOLGA] I don't think it does. As far as I understand RK type is DPC in
> > your example. Loadsharing should be based on a construct, which is less
> > granular than the RK itself (for example SLS).
> >
> > -----------
> >
> >       SG1(a-b-c)
> >   +------+               RK1     +-------+
> > [TOLGA]No, it doesn't. And as you pointed out below, AS1 and AS2 should
> be
> > seen as different RKs on SGP1.
> >

---

From: "TOLGA ASVEREN" <[email-masked]>
Date: Mon, 14 Apr 2003 08:21:17 +0300

Samuel,

My explanation of that loadsharing based on DPC is probably meant for
ASP-to-SGP direction was just a "guess", what the author might have
thought.
Personally I would think, it might be a good idea to wait for the next
version of M3UA-MIB document based on comments in AS/SG concept thread and
continue with further cleaning afterwards.

    Tolga

Tolga,

 So,Whay do you say? Should we delete 'loadsharing on DPC'? or Should we
 keep as it is?
 I think it is good to strike it from m3ua-mib, keeping this will put
 readers under confusion.

--Samuel

On Sun, 13 Apr 2003, Tolga Asveren wrote:

> Samuel,
> >  IMO, in the existing SS7 network there is no
> > concept called 'loadsharing
> >  on DPC",Because almost all SS7 nodes will select
> > outgoing linkset based
> >  on DPC.Since we have the concept of 'primary
> > linkset' and
> >  'alternative linkset', i dont find any confusion
> > here which lnkset to be
> > used to send the msg out,obviously it should be
> > 'primary linkset'.
> >
> > But without 'loadsharing on SLS' , after selecting a
> > linkset there will
> > be a confusion to findout which link to be used to
> > send msg out , to solve
> > this problem SLS is being used.
> >
> > So loadsharing on DPC is of no use in mib-m3ua.
> [TOLGA]Although I don't think that loadsharing
> mechanims from ASP to SGP are the most important thing
> to discuss for the current version of M3UA-MIB
> document still my opinion:
> 1-ASP/SGP interface is MTP3/MTP3-UserPart interface,
> so it is MTP3 on SG, which selects the link/linkset
> for outgoing messages to SS7 network, not ASP.
> 2-If one wants to assist SG (maybe to prevent some
> internal routing as much as possible) by selecting the
> "correct SGP" for outgoing messages, then I would
> think loadsharing based on DPC makes sense, if
> different linksets are controlled by different SGPs.
> Selecting the SGP, which controls the primary linkset
> for a destination can be achieved by loadsharing based
> on DPC (just for clarification, what I mean is DPC of
> outgoing message). Any loadsahring among links
> belonging to this linkset is responsibility of MTP3.
>
>
>
> __________________________________________________
> Do you Yahoo!?
> Yahoo! Tax Center - File online, calculators, forms, and more
> http://tax.yahoo.com