Subject: [Sigtran] M2PA pre-v8

From: David Lehmann <[email-masked]>
Date: Mon, 21 Apr 2003 16:38:29 -0400

Hello,

Since M2PA I-D v8 will rely more heavily on the Q.703
document, why not keep the same message names as Q.703?

e.g.  In section 4.1.3, it states, "The Link Status
Alignment message replaces the SIO message of MTP2."
Why not call this message, "M2PA SIO"?

-- 

David Lehmann                          Ulticom, Inc.
AOL/Yahoo IM: davidULCM                1020 Briggs Road
1-856-787-2729                         Mt. Laurel, NJ 08054   USA

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: Tom George <[email-masked]>
Date: Tue, 22 Apr 2003 10:09:54 -0500

It is possible to do that. But the formats of the two messages are
somewhat different. So following the principle that different things
should have different names, I stuck with the M2PA names. 

I plan to release v8 in a day or two. I just have to put in the page
numbers, etc.

tomG.

-- 
* Tom George       PB7-24001 (near B-21)      [email-masked]  *
* 972-519-3168   Intranet:  http://www.ssd.usa.alcatel.com/~tgeorge/  *
* Alcatel;  3400 West Plano Pkwy,  MS PB7-SWPRO;  Plano, Texas 75075  *
* I actively disclaim speaking for Alcatel USA, Inc. I do not purport *
* to advertise or represent its position,  operations, or activities. *
_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: David Lehmann <[email-masked]>
Date: Tue, 22 Apr 2003 11:59:46 -0400

> should have different names, I stuck with the M2PA names. 

I see your point.  However, the messages have the same purpose,
which, IMHO, is more important than the format differences.
Besides, the format differences can be clearly shown in section 2
of the document.  So there should be no confusion in that regard.

I urge the authors to consider using the same names for messages with
the same purpose.  If there is some ambiguity, use the protocol as an
adjective (e.g. "MTP2 SIO" or "M2PA SIO").  However, I think
the context would provide enough clarification in most cases.

This spec is so reliant upon Q.703 that the use of different
message names makes the text confusing.

--

---

From: Tom George <[email-masked]>
Date: Tue, 22 Apr 2003 14:21:21 -0500

I would add that not only are there different formats, the list of
messages is different.

---

From: David Lehmann <[email-masked]>
Date: Tue, 22 Apr 2003 16:41:35 -0400

Let me clarify my position.
The M2PA messages, which have the same purpose/function
as the MTP2 messages, should have the same name as their
MTP2 counterparts.

e.g. In the I-D, it states in various places that
'The X message replaces the Y message of MTP2'.
IMHO, it should say, 'The M2PA Y message replaces
the Y message of MTP2'.

Personally, I think that the M2PA protocol was better
served by explicit and complete instructions in the I-D.
Since we need to have this I-D and Q.703 in hand to have
a complete understanding, they should use the same
terminology.

... just one person's opinion.

--