Subject: Re: [Sigtran] Re: M2PA draft "7b"

From: [email-masked]
Date: Mon, 14 Apr 2003 07:53:38 -0400

Hello Tom,

>Please give me a little more detail about your issues in 4.1.2 and
>4.1.3. Do you mean that instead of requiring LS Ready, it should say
>send LS Ready or LS PO as in MTP2?

Yes. Read the Q.703 SDLs and prior list postings on this subject.
The mentioned M2PA v7b sections add confusion rather than clarity.

Regards,

Jeff

                      Tom George                                                                                                  
                      <Tom.George@alca         To:      SIGTRAN e-mail list <[email-masked]>                                    
                      tel.com>                 cc:                                                                                
                      Sent by:                 Subject: [Sigtran] Re: M2PA draft "7b"                                             
                      sigtran-admin@ie                                                                                            
                      tf.org                                                                                                      

                      04/11/03 05:42                                                                                              
                      PM                                                                                                          

Jeff,

A lot of the conversations on the list were of the form:
"M2PA does X, but Q.703 does Y. M2PA should do Y, too."
IMHO that is the kind of thing that should not be in the draft.

Please give me a little more detail about your issues in 4.1.2 and
4.1.3. Do you mean that instead of requiring LS Ready, it should say
send LS Ready or LS PO as in MTP2?

I have not made any effort to make the draft versions
backward-compatible. My inclination would be to make the sequence
numbers like MTP2, unless there is reason not to.

tomG.

Jeff Craig asked off-list:
>
> Hello Tom,
>
> I am okay with this new direction for the M2PA draft, as long as the
> content of the many, many mailing list discussions is reflected in it.
> I have not reviewed the new draft thoroughly, but already I see an
> issue with the last paragraph of 4.1.2 and with 4.1.3 (either LSR or LSPO
> are sent at the end of proving, not both).
>
> In addition, on the issue of the initial FSN/BSN, I think this is one
> area M2PA should continue to be different than MTP2. I see no
> point in making all current M2PA implementations incompatible with
> the new draft by changing this simply to match Q.703. Whether the
> initial FSN is 1 or 0 does not matter from a protocol standpoint --  as
> long as both sides use the same starting point. So what if M2PA starts
> with FSN=1, unlike MTP2 which starts with 0. No problem, just mention
> the difference in the M2PA draft.
>
> Regards,
>
> Jeff
  [...]

--
* Tom George       PB7-24001 (near B-21)      [email-masked]  *
* 972-519-3168   Intranet:  http://www.ssd.usa.alcatel.com/~tgeorge/  *
* Alcatel;  3400 West Plano Pkwy,  MS PB7-SWPRO;  Plano, Texas 75075  *
* I actively disclaim speaking for Alcatel USA, Inc. I do not purport *
* to advertise or represent its position,  operations, or activities. *
_______________________________________________
Sigtran mailing list
[email-masked]
 https://www1.ietf.org/mailman/listinfo/sigtran

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: Tom George <[email-masked]>
Date: Mon, 14 Apr 2003 18:20:08 -0500

Jeff,

Here is the last paragraph in 4.1.3:
=====
The Link Status Ready message replaces the FISU of MTP2 that is sent
at the end of the proving period. The Link Status Ready message is
used to verify that both ends have completed proving. When M2PA starts
timer T1, it SHALL send a Link Status Ready message to its peer. M2PA
MAY send additional Link Status Ready messages while timer T1 is
running.
=====

I will think of a way to reword it by replacing "it SHALL send a Link
Status Ready message to its peer" with something that refers to MTP2. 

tomG.

  [...]