Subject: Re: [Sigtran] M2PA: T7 and dropping SCTP association after link failure

From: [email-masked]
Date: Thu, 24 Apr 2003 08:23:53 -0400

Hello Tolga,

I think it is a bad idea to drop the association due to M2PA protocol
events,
for reasons that have be previously stated in several SIGTRAN threads.

I also have no issues with the current M2PA text pertaining to timer T7.
This
topic has also been thoroughly discussed in prior threads.

Regards,

Jeff

                      "TOLGA ASVEREN"                                                                                             
                      <TOLGA.ASVEREN@o         To:      [email-masked]                                                          
                      2.com.tr>                cc:                                                                                
                      Sent by:                 Subject: [Sigtran] M2PA: T7 and dropping SCTP association after link failure       
                      sigtran-admin@ie                                                                                            
                      tf.org                                                                                                      

                      04/24/03 02:00                                                                                              
                      AM                                                                                                          

Hi Tom,

1) In M2PA 4.2.1
"Because propagation delays in IP networks are more variable than in
traditional SS7 networks, a single T7 timer (excessive delay of
acknowledgement) is inadequate. A T7 timer SHALL be started for each
message in the M2PA retransmit buffer."

I think this explanation might be confusing -or better said not complete-
for people, which did not follow the threads related with T7. IMO, it could
be better to mention about possibility of SCTP delaying acknowledgements
for a specific message. Furthermore, based on what it stands in RFC2960 6.1
"This document is specified as if there is a single retransmission timer
per destination transport address, but implementations MAY have a
retransmission timer for each DATA chunk." , I would think it could be
better to revise the above section of M2PA, reflecting that based on how
the underlying SCTP handles T3, how to use M2PA T7 might be different.

2) A few weeks ago there was a thread about why we don't want to drop
association when  link failure occures. Personally I still think dropping
SCTP association is a better choice, because IMO there is no real reason
-as far as I can see- to not drop it and if not dropped, messages arriving
in the old link context might trigger a new link failure(in this thread
there are also counterarguments expressed by Brian). What do the others
think?

     Tolga

_______________________________________________
Sigtran mailing list
[email-masked]
 https://www1.ietf.org/mailman/listinfo/sigtran

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Thu, 24 Apr 2003 12:37:28 -0600

jeffrey.craig,

I agree Jeff.  These things have been discussed, resolved and concensus
was reached.  IMO there is no need to change them now.

--brian

[email-masked] wrote:                                             (Thu, 24 Apr 2003 08:23:53)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: Tom George <[email-masked]>
Date: Tue, 29 Apr 2003 10:43:13 -0500

I agree as well. 

tomG.

-- 
* Tom George       PB7-24001 (near B-21)      [email-masked]  *
* 972-519-3168   Intranet:  http://www.ssd.usa.alcatel.com/~tgeorge/  *
* Alcatel;  3400 West Plano Pkwy,  MS PB7-SWPRO;  Plano, Texas 75075  *
* I actively disclaim speaking for Alcatel USA, Inc. I do not purport *
* to advertise or represent its position,  operations, or activities. *
_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran