Subject: [Sigtran] SUA latest draft

From: "Doss, James" <[email-masked]>
Date: Thu, 27 Mar 2003 10:00:28 -0800

Hi, 
Where can I find the latest release of SUA.
What is the status of the draft and the latest released version. Is it an
approved spec or just RFC.
regards
James
Verisign Inc

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Ong, Lyndon" <[email-masked]>
Date: Tue, 1 Apr 2003 15:34:01 -0800

Hi James,

The last release was v.14, which is still linked
to the Sigtran WG home page.  Since then it has been under
review at IESG, held up due to the general security
issue.  The security framework is being reviewed now
and if all is well, this should open the gate to getting
SUA approved and RFC.

Cheers,

Lyndon

-----Original Message-----
From: Doss, James [mailto:[email-masked]]
Sent: Thursday, March 27, 2003 10:00 AM
To: [email-masked]
Subject: [Sigtran] SUA latest draft

Hi,

---

From: "Mohan Parthasarathy" <[email-masked]>
Date: Tue, 1 Apr 2003 17:32:00 -0800

Ong,

As far as I can tell, this draft is not up to date with respect to
the discussions that happened sometime back. I am not sure whether
there was consensus or not. But we did discuss about the ability
to tell the SG from the AS side regarding some ASP being down or not.
Brian sent out some suggested text. I don't find this in the draft.
Am I missing something ?

-mohan

> From: Ong, Lyndon [mailto:[email-masked]] 
> Sent: Tuesday, April 01, 2003 3:34 PM
> To: 'Doss, James'; [email-masked]
> Subject: RE: [Sigtran] SUA latest draft
> 
> 
> Hi James,
> 
> review at IESG, held up due to the general security issue.  
> The security framework is being reviewed now and if all is 
> well, this should open the gate to getting SUA approved and RFC.
> 
> Cheers,
> 
> Lyndon
> 
> What is the status of the draft and the latest released 
> version. Is it an approved spec or just RFC. regards James 
> Verisign Inc
>

---

From: [email-masked]
Date: Wed, 2 Apr 2003 06:46:27 +0300

Hi Mohan,

It will be updated, I've just been waiting for the
security issues to be resolved before updating it. I could
look into producing an updated version next week.

John

> From: ext Mohan Parthasarathy [mailto:[email-masked]]
> Sent: 02 April, 2003 04:32
> To: Ong, Lyndon; Doss, James; [email-masked]

---

From: "Doss, James" <[email-masked]>
Date: Wed, 2 Apr 2003 06:15:13 -0800

Hi John,
Few weeks back I posted a question regarding the ASP and SGP in load sharing
mode.
The question is about how to send the response coming back from network to
the corresponsding applications. The SUA draft says transaction ID can be
used to route the message back to the same application.
I could not find a clear answer in the spec and moreover which transaction
ID is used.
Is it TCAP transaction ID or the IP packet correlation ID.
I am not sure how the SUA layer will know the Transaction Id without
decoding the TCAP-User part of the message.
Can you please explain me how this works.
Thanks
James Henrydoss
Software Engineer
Verisign Inc
Norcross, GA

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Tuesday, April 01, 2003 10:46 PM
To: [email-masked]; [email-masked]; [email-masked];
[email-masked]

Hi Mohan,

John

---

From: "Doss, James" <[email-masked]>
Date: Wed, 2 Apr 2003 06:22:11 -0800

Hi Lyndon,
Thanks for the info. We are in the process of finalizing to use SUA or M3UA
for our ss7 IP interface. But our application will be easy to build if we
can use SUA. Since M3UA is in draft version we are thinking of using M3UA.
Is SUA going to replace M3UA in the future for TCAP services.
Thanks
James

-----Original Message-----
From: Ong, Lyndon [mailto:[email-masked]]
Sent: Tuesday, April 01, 2003 6:34 PM
To: 'Doss, James'; [email-masked]
Subject: RE: [Sigtran] SUA latest draft

Hi James,

Cheers,

Lyndon

-----Original Message-----
From: Doss, James [mailto:[email-masked]]
Sent: Thursday, March 27, 2003 10:00 AM
To: [email-masked]
Subject: [Sigtran] SUA latest draft

Hi,

---

From: [email-masked]
Date: Wed, 2 Apr 2003 18:00:42 +0300

James,

> Is SUA going to replace M3UA in the future for TCAP services.

SUA or M3UA can be used for TCAP services - they are not really in
compitition.  I think the SIGTRAN WG's view is that there are a number
of UAs that can, ultimately, transport SS7 application protocols - 
and that there is no 'correct' one - it is based upon deployment
considerations, etc.

SUA has had IESG review, all it is waiting on is the SIGTRAN Security
document to be completed.  I will updated the draft and fix some editorial
concerns and a couple of points that were brought up.

John