Subject: [Sigtran] SCTP heartbeats for failure detection.

From: "Mohan Parthasarathy" <[email-masked]>
Date: Fri, 4 Apr 2003 11:39:26 -0800

Hello,

SCTP specification (RFC 2960) discusses about endpoint failure detection
(retransmissions) and path failure detection (heartbeats). Both involves
exponential backoffs when there is no response from the other side. This
essentially makes it longer to detect failures. I understand that you
don't want to detect false failures. Could somebody comment on how
folks use it when used to detect the failure in the ss7 network e.g
AS -SG path failure ?

thanks
mohan
_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: Andreas Jungmaier <[email-masked]>
Date: Mon, 7 Apr 2003 12:20:09 +0200

> folks use it when used to detect the failure in the ss7 network e.g

Mohan, all,

you might be interested in the results of a paper of my research
group, which deals with failovers and the effects of some SCTP
parameters on them. You can find it on our webpage located at
http://tdrwww.exp-math.uni-essen.de/inhalt/forschung/sctp_fb/sctp_links.html
(all on one line). The paper is named
"On the Use of SCTP in Failover-Scenarios"

While this does not cover all possible scenarios, naturally, it
should give implementors some helpful insights.

Hope that helps,

Andreas

- -- 
Dipl.-Ing. Andreas Jungmaier              
Computer Networking Technology Group     
University of Duisburg-Essen                       
http://www.exp-math.uni-essen.de/~ajung   
My PGP Key-ID: D3824AC0             

My PGP Key-Fingerprint: 228C 7C2C 3381 2DD4  9998 2812 5C0B 0B04  D382 4AC0