Subject: [Sigtran] M3UA: clarification on supported scenarios

From: De Luca Marco <[email-masked]>
Date: Fri, 04 Apr 2003 17:28:04 +0200

Hi all,

following last discussion on the SG-SG scenario, a clarification on my mind arose on the scenario supported by M3UA as defined in RFC 3332.
I would like to have a clarification on the following scenario:
Two ASP located in differnet IP Server (let's imagine two User Part utilizing SCCP services) communicating via a SG equipped with SCCP and M3UA
In this scenario we can have tow type of situation

ASP (PC x) ------- SG (PC y) ------- ASP (PC z)

1. SG executing GTT
2. SG executing M3UA relaying

which of two scenarios, if any, are supported by M3UA RFC?

In my understanding:
- scenario 1 is supported since SCCP acts as an M3UA User Part. In this case the DATA message coming form ASP PC x has DPC y requseting GTT service
- scenario 2 is not supported since the NIF in the SG does not support relaying. In this case the DATA message coming from an ASP PC x has DPC z so the NIF translates it in a MTP TRANSFER Request and passes it to MTP3.
To support this scenario is necessary any change in the RFC or is it an implementation dependent issue so could be a feature of commercial equipment?

please any clarification is appreciated
thanks
Marco

Telecom Italia Lab
Research & Operations

====================================================================
CONFIDENTIALITY NOTICE
This message and its attachments are addressed solely to the persons
above and may contain confidential information. If you have received
the message in error, be informed that any use of the content hereof
is prohibited. Please return it immediately to the sender and delete
the message. Should you have any questions, please contact us by
replying to [email-masked]. Thank you
====================================================================
_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Fri, 4 Apr 2003 15:10:10 -0700

De,

We agreed in the working group at M3UA LC that
the SG is permitted to perform SCCP relay or MTP
transfer.  Also that no change is required to the
RFC to permit this.

--brian

De Luca Marco wrote:                                                                    (Fri, 04 Apr 2003 17:28:04)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: "Samuel Dur D. Jeyaseelan" <[email-masked]>
Date: Sat, 5 Apr 2003 00:35:58 -0600 (CST)

Marco,

Scenario 1:
GTT may result in DPC+SSN or DPC alone.If it results in DPC alone then
M3UA can easily route the message to the corresponding DPC.But if GTT 
results in DPC+SSN, here M3UA has no idea about SSN, to solve this problem
we should have a static SSN configuration to route the message to the
correspondig subsystem like LNP,HLR...

Scenario 2:
Conventional MTP3 layer matches the received PC with self PC, if match is
found then the message is delivered to message discrimination function
else to message routing function- this case, message can be delivered to
NIF so that it will perform relay function.

My understanding is RFC need not be modified.

--Samuel 

  Alcatel USA, Inc.                  Internet: <userid>@ssd.usa.alcatel.com
  1000 Coit Road, Plano, Texas 75075
  ******* The opinions expressed are not those of Alcatel USA, Inc. *******