Subject: Re: [Sigtran] M3UA: clarification on supported scenarios

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Mon, 7 Apr 2003 09:32:00 -0600

Marco,

De Luca Marco wrote:                                                                    (Mon, 07 Apr 2003 09:56:37)
> It sounds good to me since GTT and MTP3 routing are SG (NIF) functionalities
> more than M3UA protocol capabilities. And more becuase that means less time
> to have it available.
> 
> BTW, I noted in a mail exchange (if I remember fine it was a Lyndon Ong
> ones) summing up WG activities a statement about WG general agreement on
> SG-SG draft edited by Tolga.  Going through it, 

> - first I read: 1.1 Scope: "M3UA does not have relaying capabilities between
> PCs". This seems to me agains what we said before

M3UA doesn't have relay capability (i.e, IPSPs do not have the transfer
function).  But that doesn't mean that MTP and SCCP can't relay.

> - then I noted that M3UA, as it is, does not support SGP-SGP communications.
> But in many cases level 3 routing could mean SG-SG communication

SGP-SGP communication protocol is out of scope.  That doesn't mean that M3UA
doesn't permit SGP-SGP communication.  Nor does it mean that SGs cannot
communicate with each other: it is just via SS7 or some other protocol rather
than M3UA.

> - there is a need of M3UA changes to support CO/CB procedure and that seems
> to me correct to assure pure MTP3-M3UA interworking

See draft-bidulock-sigtran-corid-01.txt for procedures equivalent to CO/CB for
M3UA.

> 
> Which are network scenario now supported from M3UA and other scenarios that
> imposes M3UA extensions?

The SG-SG draft proposes a mechanism for IPSPs to communicate with each other
and support the transfer function.  The CORID draft provides extensions to
M3UA to permit CO/CB.

--brian

> 
> any clarification is appreciated
> thanks
> Marco
> 
> Telecom Italia Lab
> Research & Operations

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/
_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: De Luca Marco <[email-masked]>
Date: Mon, 07 Apr 2003 09:56:37 +0200

It sounds good to me since GTT and MTP3 routing are SG (NIF) functionalities more than M3UA protocol capabilities. And more becuase that means less time to have it available.

BTW, I noted in a mail exchange (if I remember fine it was a Lyndon Ong ones) summing up WG activities a statement about WG general agreement on SG-SG draft edited by Tolga. 
Going through it, 
- first I read: 1.1 Scope: "M3UA does not have relaying capabilities between PCs". This seems to me agains what we said before
- then I noted that M3UA, as it is, does not support SGP-SGP communications. But in many cases level 3 routing could mean SG-SG communication
- there is a need of M3UA changes to support CO/CB procedure and that seems to me correct to assure pure MTP3-M3UA interworking

Which are network scenario now supported from M3UA and other scenarios that imposes M3UA extensions?

Telecom Italia Lab
Research & Operations

-----Original Message-----
From: Brian F. G. Bidulock [mailto:[email-masked]]
Sent: Saturday, April 05, 2003 12:10 AM
To: De Luca Marco
Cc: [email-masked]
Subject: Re: [Sigtran] M3UA: clarification on supported scenarios

De,

We agreed in the working group at M3UA LC that
the SG is permitted to perform SCCP relay or MTP
transfer.  Also that no change is required to the
RFC to permit this.

--brian

De Luca Marco wrote:                                                                    (Fri, 04 Apr 2003 17:28:04)
> Hi all,
> 
> following last discussion on the SG-SG scenario, a clarification on my mind arose on the scenario supported by M3UA as defined in RFC 3332.
> I would like to have a clarification on the following scenario:
> Two ASP located in differnet IP Server (let's imagine two User Part utilizing SCCP services) communicating via a SG equipped with SCCP and M3UA
> In this scenario we can have tow type of situation
> 
> ASP (PC x) ------- SG (PC y) ------- ASP (PC z)
> 
> 1. SG executing GTT
> 2. SG executing M3UA relaying
> 
> which of two scenarios, if any, are supported by M3UA RFC?
> 
> In my understanding:
> - scenario 1 is supported since SCCP acts as an M3UA User Part. In this case the DATA message coming form ASP PC x has DPC y requseting GTT service
> - scenario 2 is not supported since the NIF in the SG does not support relaying. In this case the DATA message coming from an ASP PC x has DPC z so the NIF translates it in a MTP TRANSFER Request and passes it to MTP3.
> To support this scenario is necessary any change in the RFC or is it an implementation dependent issue so could be a feature of commercial equipment?
> 
> please any clarification is appreciated
> thanks
> Marco
> 
> Telecom Italia Lab
> Research & Operations
> 
> 
>   
> 
> 
> ====================================================================
> CONFIDENTIALITY NOTICE
> This message and its attachments are addressed solely to the persons
> above and may contain confidential information. If you have received
> the message in error, be informed that any use of the content hereof
> is prohibited. Please return it immediately to the sender and delete
> the message. Should you have any questions, please contact us by
> replying to [email-masked]. Thank you
> ====================================================================

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

====================================================================
CONFIDENTIALITY NOTICE
This message and its attachments are addressed solely to the persons
above and may contain confidential information. If you have received
the message in error, be informed that any use of the content hereof
is prohibited. Please return it immediately to the sender and delete
the message. Should you have any questions, please contact us by
replying to [email-masked]. Thank you
====================================================================
_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: Tolga Asveren <[email-masked]>
Date: Mon, 7 Apr 2003 12:21:58 -0700 (PDT)

Marco, Brian,

Please see below for comments.

[..snip..]
> > to me correct to assure pure MTP3-M3UA
[TOLGA] IMO, there is no need -at least for now- for
such a procedure between SGs. I think one should
provide network redundancy by making use of
multihoming feature of SCTP for SG-SG communication,
and basically when the remote host is down, CO/CB like
procedures won't help. Changeover Mechanism Related
Messages as described in 4.4 of SG-SG draft are just
for the case explained in Figure7.
> procedures equivalent to CO/CB for
[TOLGA] IMO, the procedures defined in corid draft are
not equivalent to CO/CB procedures. corid procedures
try to address the case, where the remote peer is
down.
(Whether those procedures are necessary or not and if
yes when should be topic of another thread IMO, i.e. I
am not trying to say that they are useless) 

__________________________________________________
Do you Yahoo!?
Yahoo! Tax Center - File online, calculators, forms, and more
http://tax.yahoo.com
_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Mon, 7 Apr 2003 17:15:34 -0600

Tolga,

Tolga Asveren wrote:                                                                 (Mon, 07 Apr 2003 12:21:58)
> try to address the case, where the remote peer is

Actually, the draft explains otherwise in great detail.

--brian