Subject: [Sigtran] m3ua

From: manish rathi <[email-masked]>
Date: Tue, 28 Oct 2003 15:07:51 +0530

Hi,
I'd like to know
1)
asp id par. is used in asp up msg while not in asp down msg.
How SG know that asp down is for that particular ASP?

2)Why & when (tell the cases) management layer will call
m-asp-status.req ?

3) Is there any case where asp up/down msg is sent from signalling
gateway?

Thanks
Regards
Manish

--
Things work out best for those who make the best use of it.

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Mon, 3 Nov 2003 19:10:19 -0700

manish,

manish rathi wrote:                                                                 (Tue, 28 Oct 2003 15:07:51)
>    How SG know that asp down is for that particular ASP?

1 SCTP assoc <=> one ASP

the ASP sending the ASP down is the same as the one that sent ASP UP

>    2)Why   &   when   (tell   the   cases)  management  layer  will  call

The management interface is implementation specific.

>    3)  Is  there  any  case where asp up/down msg is sent from signalling

No.

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Samuel Dur D. Jeyaseelan" <[email-masked]>
Date: Mon, 3 Nov 2003 23:53:40 -0600 (CST)

Brian,

Sometimes back there was a concensus made that adjacent ASP(i think n+k
case) can send ASP-DOWN message with failed ASP-ID... finally it was
concluded that ASP-DOWN message will be modified to have ASP-ID, this
decision was taken when hearBeat is disabled between SGP to ASP or 
hearbeat mechanism is failed.

Did you remember?

--Samuel

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Mon, 3 Nov 2003 23:46:31 -0700

Samuel,

IIRC it was the NOTIFY("ASP Failure") message that was proposed
to indicate an adjacent ASP failure (not ASP-DOWN).

Regardless, my response was per the RFC.

--brian

Samuel Dur D. Jeyaseelan wrote:                                                     (Mon, 03 Nov 2003 23:53:40)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: "Samuel Dur D. Jeyaseelan" <[email-masked]>
Date: Tue, 4 Nov 2003 01:08:00 -0600 (CST)

Brian,

I am referring to Parthasarathi's issue, you too agreed to modify
ASP-DOWN message to have ASP-ID.

--Samuel

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Tue, 4 Nov 2003 02:01:39 -0700

Samuel,

Where was that in the RFC?

--brian

Samuel Dur D. Jeyaseelan wrote:                                                     (Tue, 04 Nov 2003 01:08:00)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: "Samuel Dur D. Jeyaseelan" <[email-masked]>
Date: Tue, 4 Nov 2003 08:03:02 -0600 (CST)

Brian,

RFC does not say but ASP is developed keeping reliability in mind.
There is nothing wrong to find an ASP failure with the help of an
another ASP.

Now current RFC says that an ASP failure is detected only by SG,
Why does ASP developer fully depend on SG to find ASP Failure?

It was an old topic but i could not find any proper answer for this qtn.

--Samuel

  Alcatel USA, Inc.                  Internet: <userid>@ssd.usa.alcatel.com
  1000 Coit Road, Plano, Texas 75075
  ******* The opinions expressed are not those of Alcatel USA, Inc. *******