Subject: [Sigtran] Understanding adaptation layers in sigtran

From: Mark Easterbrook <[email-masked]>
Date: Thu, 11 Mar 2004 17:06:39 +0000

I am having problems understanding how UAs fit into the sigtran stack.

An example gateway configuration:

(A)            (GW)           (B)
MAP . . . . . . . . . . . . . MAP
TCAP           IWF            TCAP
SCCP       SCCP |SUA.s        SUA.c
L3MTP      L3MTP|SCTP         SCTP
L2MTP      L2MTP|IP           IP
L1MTP      L1MTP|  |           |
   |           |    -------------
   ------------       IP network
    SS7 network

Here, the MAP application at A communicates with the MAP application at 
B because the SCCP is backhauled between the server SUA at the gateway
to the client SUA at B.
IWF=interworking function.
SUA.s=SUA as a server
SUA.c=SUA as a client
MAP=Mobile application part.
I understand this far...

I have a box that supports traditional ITU SS7 (64kbit/s) and SS7 over 
ATM (2Mbit/s). The next stage of development is to add SS7 over IP
so I get:

        MAP/GSM
        TCAP
        SCCP
        L3MTP
-------------------
AAL  | L2MTP | M2PA
ATM  | L1MTP | SCTP
2M/E1| 64kbs | IP
   |      |      |
   |      |      ----IP network
   |      |
   |      ----SS7 network
   |
   ----ATM network

Can my box with SS7 over IP support talk to B in the first diagram?
My guess is no, because in my box the IP is just providing an SS7 
signalling link over IP, but B does not have a MTP3 to deal with the
other end of the link.
If not, what do I need to do to make it talk? Do I need to provide
SUA as in:

             MAP/GSM
             TCAP
        -----------------
        SCCP   |      SUA
        L3MTP  |       .
-------------------   .
AAL1 | L2MTP | M2PA | .
ATM  | L1MTP |    SCTP
2M/E1| 64kbs |    IP
   |      |         |
   |      |         ----IP network
   |      |
   |      ----SS7 network
   |
   ----ATM network

This means TCAP has two SCCP modules to deal with, so needs to make
routing decisions, whereas at the moment it just lets L3MTP deal
with routing.

I have searched the net for the answer but cannot find anything that 
doesn't use the model as in my first diagram, i.e. SS7 only, IP only, 
and an interworking gateway. Neither can I find any books on the 
subject. I would be grateful if someone can point me to some suitable 
material.

(Although I talk about ITU SS7, which uses E1 bearers, support for
ANSI SS7 using T1 is implemented and undergoing testing, so any solution
needs to support both, however, I don't believe this is relevant).

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: Michael Tuexen <[email-masked]>
Date: Mon, 22 Mar 2004 23:48:57 +0100

Mark,

why don't you just use a GW which runs M2PA and may act as an SCCP
relay point? Why does it need to talk to (B)?

Best regards
Michael

On 11. Mar 2004, at 18:06 Uhr, Mark Easterbrook wrote:

> Here, the MAP application at A communicates with the MAP application 
> at B because the SCCP is backhauled between the server SUA at the 
> gateway
> to the client SUA at B.

---

From: "Tolga Asveren" <[email-masked]>
Date: Mon, 22 Mar 2004 18:04:36 -0500

Or you might consider using M3UA -for GW case ASP/SGP mode and for
peer-to-peer case IPSP mode-.

  Tolga

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On Behalf Of
> Michael Tuexen
> Sent: Monday, March 22, 2004 5:49 PM
> To: Mark Easterbrook
> Cc: [email-masked]'
> Subject: Re: [Sigtran] Understanding adaptation layers in sigtran
>
>
> Mark,
>

---

From: "Samuel Dur D. Jeyaseelan" <[email-masked]>
Date: Tue, 23 Mar 2004 00:01:39 -0600 (CST)

Mark,

             MAP/GSM
             TCAP
        -----------------
        SCCP   |      SUA
        L3MTP  |       .
-------------------   .
AAL1 | L2MTP |     | .
ATM  | L1MTP |    SCTP
2M/E1| 64kbs |    IP
   |      |         |
   |      |         ----IP network
   |      |
   |      ----SS7 network
   |
   ----ATM network

basically you want to have an SS7 element which supports
conventional SS7/64kbs signaling, SS7oATM and SS7oIP. 
I think your diagram above is correct (just i deleted M2PA).
TCAP having 2 SCCP modules is an implementation dependent.

--Samuel

  Alcatel USA, Inc.                  Internet: <userid>@ssd.usa.alcatel.com
  1000 Coit Road, Plano, Texas 75075
  ******* The opinions expressed are not those of Alcatel USA, Inc. *******

---

From: "Tolga Asveren" <[email-masked]>
Date: Tue, 23 Mar 2004 08:21:52 -0500

I wouldn't think the below figure represents a logical stack layering. For
SUA case SCCP is somewhere else (in SG) and you also have a local
SCCP -please note, as a SPC you have only one SCCP from other network
elements point of view-. I am not sure, whether and how this could work.

    Tolga

> Samuel Dur D. Jeyaseelan
> Sent: Tuesday, March 23, 2004 1:02 AM
> To: Mark Easterbrook
> Cc: [email-masked]