Subject: [Sigtran] SUA v16: Global Title address signal layout

From: "Barry Nagelberg" <[email-masked]>
Date: Wed, 3 Mar 2004 09:11:24 -0500

In section 3.10.2.3 (Global Title), the following diagram needs some more
explanation:

<snip>
   Global Title:

    Octets contain a number of address signals and possibly filler as
    shown:

      0                   1                   2                   3
      0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1
     +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
     |2 addr.|1 addr.|4 addr.|3 addr.|6 addr.|5 addr.|8 addr.|7 addr.|
     |  sig. | sig.  |  sig. | sig.  |  sig. | sig.  |  sig. | sig.  |
     +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
     |        .............          |filler |N addr.|   filler      |
     |                               |if req | sig.  |               |
     +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
<snip>

1. What does "............." represent?
2. There is probably some significance to the modulo 8 remainder of 'N'. I'm
guessing it is 1. Is this correct?
3. How would this picture look if the modulo 8 remainder of 'N' is 5?

Barry Nagelberg

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Wed, 3 Mar 2004 10:48:28 -0700

Barry,

Barry Nagelberg wrote:                                                               (Wed, 03 Mar 2004 09:11:24)
>     Octets contain a number of address signals and possibly filler as

Obviously: address signals 1 through 4.

> guessing it is 1. Is this correct?

No, the modulo 8 remainder is 5; but, it is the modulo 4 remainder (1) that is
significant.

> 3. How would this picture look if the modulo 8 remainder of 'N' is 5?

The modulo 8 remainder is 5 for the diagram.

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: "Barry Nagelberg" <[email-masked]>
Date: Wed, 3 Mar 2004 13:11:35 -0500

Brian,

Thanks. You say that "............." is "obviously" address signals 1
through 4, but I it's apparently not "obvious" even to you - I think you
mean 9 through 12.

This should definitely be explained in the SUA IG.

Barry Nagelberg

> -----Original Message-----
> From: Brian F. G. Bidulock [mailto:[email-masked]]
> Sent: Wednesday, March 03, 2004 12:48 PM
> To: Barry Nagelberg
> Cc: SIGTRAN Mailing List
> Subject: Re: [Sigtran] SUA v16: Global Title address signal layout
>
>
> Barry,
>
> Barry Nagelberg wrote:

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Wed, 3 Mar 2004 11:57:15 -0700

Barry,

No, I mean 1 through 4:

 XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX
 XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX

Simply read what is written above the `............'.

--brian

Barry Nagelberg wrote:                                                               (Wed, 03 Mar 2004 13:11:35)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: "Barry Nagelberg" <[email-masked]>
Date: Wed, 3 Mar 2004 14:10:53 -0500

Brian,

Thanks. Please draw for us, without any ".........", the contents of all 8
bytes below, for the following cases:

a. 9 address signals
b. 13 address signals

Barry Nagelberg

> From: [email-masked] [mailto:[email-masked]]On Behalf Of
> Brian F. G. Bidulock

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Wed, 3 Mar 2004 12:20:57 -0700

Barry,

If you are having such problem with this, perhaps you should take
a look at the Ethereal SUA decoder.

--brian

Barry Nagelberg wrote:                            (Wed, 03 Mar 2004 14:10:53)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/