Subject: [Sigtran] SUAv16: Question regarding Address Indicator

From: [email-masked]
Date: Thu, 25 Mar 2004 09:03:10 -0000

In Section 3.10.2.2 the coding for the Address Indicator is defined for 'Bit 1', 'Bit 2' and 'Bit 3'. However in the diagram at the start of 3.10.2, the Address Indicator bits are numbered 16 to 31. 
I am assuming that:
  Bit 1 = Bit 31
  Bit 2 = Bit 30
  Bit 3 = Bit 29

Is this correct?

Thanks,
Joyce

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Thu, 25 Mar 2004 03:20:44 -0700

joyce_archibald,

Yes, that is correct.  Bits within a field in the document are numbered from 
least significant bit (bit 1) to most significant bit (bit n).  I don't know
whether that is totally in fitting with IETF practice or not, but the same
approach was taken with other UA documents as well.

--brian

[email-masked] wrote:                                         (Thu, 25 Mar 2004 09:03:10)
> In Section 3.10.2.2 the coding for the Address Indicator is defined for 'Bit
> 1', 'Bit 2' and 'Bit 3'. However in the diagram at the start of 3.10.2, the
> Address Indicator bits are numbered 16 to 31. 
> I am assuming that:
>   Bit 1 = Bit 31
>   Bit 2 = Bit 30
>   Bit 3 = Bit 29
> 
> Is this correct?
> 
> Thanks,
> Joyce
> 

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/