Subject: [Sigtran] M3UA-v02 Last Call Comment: ASP Id in ASPUP ACK

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Fri, 7 May 2004 18:18:16 -0600

There is no reason to forbid an SGP from returning an ASP Id.  The offending
passage is as follows:

|3.5.2 ASP Up Acknowledgement (ASP Up Ack)
|
|   ...
|
|   The optional ASP Identifier parameter is specifically useful for IPSP
|   communication. In that case the IPSP answering the ASP Up message MAY
|   include its own ASP Identifier value. For AS-SG communication this
|   parameter MUST NOT be used.

Strike the last sentence.

--brian

-- 
Brian F. G. Bidulock    ¦ The reasonable man adapts himself to the ¦
[email-masked]    ¦ world; the unreasonable one persists in  ¦
http://www.openss7.org/ ¦ trying  to adapt the  world  to himself. ¦
                        ¦ Therefore  all  progress  depends on the ¦
                        ¦ unreasonable man. -- George Bernard Shaw ¦

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Tolga Asveren" <[email-masked]>
Date: Mon, 10 May 2004 08:41:20 -0400

Brian,

Do you see any real use of that, considering that there is no procedure
defined in the protocol to use AspID in ASPUP-ACK message? Or do we want to
allow each parameter in every message?

   Tolga

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On Behalf Of
> Brian F. G. Bidulock
> Sent: Friday, May 07, 2004 8:18 PM
> To: [email-masked]
> Subject: [Sigtran] M3UA-v02 Last Call Comment: ASP Id in ASPUP ACK
>
>

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Mon, 10 May 2004 08:51:43 -0600

Tolga,

The SG could return the understood ASP Id (also if it came from
configuration).  Also, here is value in simply changing the message type and
returning the message rather than reformatting.  Explicitly forbidding it
doesn't seem right.

--brian

Tolga Asveren wrote:                                                                 (Mon, 10 May 2004 08:41:20)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/