Subject: [Sigtran] M2UA - State Indication Message

From: Vijaya Venkatachalam <[email-masked]>
Date: Wed, 25 May 2005 09:04:46 -0400

Brian,

Similar to this is the case with State Indication message.
When would the SGP report EVENT_LPO_ENTER and
EVENT_LPO_EXIT to the ASP. Since ASP is on the
MGC side, shouldn't it be ASP that sends EVENT_LPO_ENTER
and EXIT to the SGP, instead of being the other way round.

Thanks,
Vijaya

Brian F. G. Bidulock wrote:

>Franz,
>
>There are three states in MTP2:
>
>1. no receive congestion
>2. receive congestion but still accepting (and acknowledging) MSUs
>3. receive congestion and discarding MSUs.
>
>You will see 1, 2 and 3 on Figure 14/Q.703 (sheet 6 of 7) as the
>signals "Congestion discard", "Congestion Accept", and
>"No congestion".  These signals "mark congestion discard", "mark
>congestion accept" or "cance congestion discard and congestion
>accept" providing three states.
>
>Congestion discard and congestion accept flags are checked on
>Figure 14/Q.703 (sheet 5 of 7).
>
>In both situations of convestion, SIB is sent.  However, these
>two separate states (discard and accept) are not invisible to
>the peer.  In the former (discard) messages are not
>acknowledged; in the latter they are.
>
>Hope that clears it up for you.
>
>--brian
>
>Gaiser Franz wrote:                                                                 (Wed, 13 Apr 2005 09:52:57)
>  
>
>>   Hi all,
>>
>>
>>
>>   I  have  question  regarding  the  State  Request  Message  defined in
>>   RFC3331,  3.3.1.5.  The  following values of the State are defined but
>>   there is no description how to use these values in the whole document.
>>   As  I  understand these States are used to indicate receive congestion
>>   at  the  MGC to the SG. Comparing with MTP2 which uses the Busy Method
>>   in this situation, there I have only two messages.
>>
>>
>>
>>   STATUS_CONG_CLEAR       0x8    Congestion cleared
>>   STATUS_CONG_ACCEPT     0x9    Congestion accept
>>   STATUS_CONG_DISCARD    0xA    Congestion discard
>>
>>   Thanks. Best regards, Franz
>>    
>>
>
>  
>
>>_______________________________________________
>>Sigtran mailing list
>>[email-masked]
>>https://www1.ietf.org/mailman/listinfo/sigtran
>>    
>>
>
>
>  
>
_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Wed, 25 May 2005 15:21:06 -0600

Vijaya,

Normally in SS7, processor outage (or, isolation between MTP3 and an
instance of MTP2 (signalling link)) is detected internally using an
implementation dependent function.  However, because M2UA exports the
MTP2/MTP3 interface from one host to another using M2UA, the detection
of isolation between MTP3 and an instance of MTP2 can occur on either
side of the M3UA connection (SGP or ASP).  On the ASP side, detection of
isolation is indicated internally to MTP3, as before, and no M2UA
protocol elements are necessary.  Detection of isolation on the SGP
side, however, must somehow signal MTP (at the ASP) that isoation has
occured.  Thus the two indications: EVENT_LPO_ENTER and EVENT_LPO_EXIT.

--brian

Vijaya Venkatachalam wrote:                       (Wed, 25 May 2005 09:04:46)
> [1][email-masked]
> [2]https://www1.ietf.org/mailman/listinfo/sigtran
> 
> References
> 
>    1. mailto:[email-masked]
>    2. https://www1.ietf.org/mailman/listinfo/sigtran

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/