Subject: Re: [Sigtran] IPSP State in SUA IPSP DE Model

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Thu, 28 Apr 2005 22:39:06 -0600

Jarek,

M3UA definitely moved to SE.  See the bis document.

--brian

Jarek Mazur wrote:                                                                    (Fri, 29 Apr 2005 14:26:02)
> 
>    Hi Brian,
> 
>    Hopefully the same goes for M3UA.
> 
>    Actually  I had similar question in my mind related to IPSP-DE, during
>    up/activation (that I never got around to actually send).
> 
>    What  if IPSP-A sent ASP Up/Active, received ASP Up/Active Ack but did
>    not received ASP Up/Active from the peer.
>    Should it after some time interval try to re-send ASP Up/Active again?
> 
>    Are there any plans to resolve this?
>    Considering  above,  is it OK for a M3UA implementation not to support
>    IPSP-DE model and "force" peers to use IPSP-SE?
>    Your view would be much appreciated.
> 
>    Cheers,
>    Jarek
> 
>    -----Original Message-----
>    From: [email-masked] [[1]mailto:[email-masked]] On
>    Behalf Of Brian F. G. Bidulock
>    Sent: Friday, 29 April 2005 1:53 PM
>    To: Jay N Bhuyan
>    Cc: [email-masked]
>    Subject: Re: [Sigtran] IPSP State in SUA IPSP DE Model
> 
>    Jay,
> 
>    It  was a problem with the DE model that it could become hung half way
>    like  this.   I  think  the  text  is  quite clear that it takes all 4
>    messages  to  do the job.  2 messages is just half way.  How much half
>    way  is  not  of  much  moment.  This is one of the reasons why the SE
>    model is to be used over the DE model.
> 
>    --brian
> 
>    Jay N Bhuyan wrote:                                  (Thu, 28 Apr 2005
>    18:43:51)
>    > Hi,
>    >
>    >  I  have  a question on SUA IPSP DE model. As per Section 3.4.4.1 in
>    RFC
>    >  3868,   four  messages  must  be exchanged between peer IPSPs for a
>    state
>    > change.
>    >
>    > Consider the following scenario:
>    >
>    > Both IPSP A and IPSP B are using IPSP DE model and are in the
>    > ASP-ACTIVE state. IPSP A sent an ASP Inactive message to IPSP B and
>    >  received  an  ASP  Inactive  Ack  message. However, IPSP A  did not
>    receive
>    > any ASP Inactive message from IPSP B.
>    >
>    > My question is:
>    > What is the status of IPSP A in IPSB B, and similarly what is the
>    > status of IPSP B in IPSP A?
>    >
>    > IPSP A                                                  IPSP B
>    >
>    >     [Both the IPSPs are in the ASP-ACTIVE state (IPSP DE Model)]
>    >
>    >    +-------------------------------ASP Inactive----------------->
>    >    <--------------------ASP Inactive Ack------------------------+
>    >
>    >
>    >
>    > 3.4.4.1.  IPSP Considerations
>    >
>    >     An  IPSP may be considered in the ASP-INACTIVE state by a remote
>    IPSP
>    >     after  an  ASP  Inactive  or  ASP  Inactive Ack message has been
>    received
>    >    from it.
>    >
>    >    Alternatively, when using IPSP DE model, an interchange of ASP
>    >    Inactive messages from each end MUST be performed.  Four messages
>    are
>    >    needed for completion.
>    >
>    >
>    > Thanks,
>    > Jay
>    >
>    >
>    >
>    >
>    > _______________________________________________
>    > Sigtran mailing list
>    > [email-masked] [2]https://www1.ietf.org/mailman/listinfo/sigtran
> 
>    --
>    Brian F. G. Bidulock
>    [email-masked]
>    [3]http://www.openss7.org/
> 
>    _______________________________________________
>    Sigtran mailing list
>    [email-masked]
>    [4]https://www1.ietf.org/mailman/listinfo/sigtran
> 
> References
> 
>    1. mailto:[email-masked]
>    2. https://www1.ietf.org/mailman/listinfo/sigtran
>    3. http://www.openss7.org/
>    4. https://www1.ietf.org/mailman/listinfo/sigtran

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Jarek Mazur" <[email-masked]>
Date: Fri, 29 Apr 2005 14:26:02 +1000

Hi Brian,

Actually I had similar question in my mind related to IPSP-DE, during
up/activation (that I never got around to actually send).
What if IPSP-A sent ASP Up/Active, received ASP Up/Active Ack but did not
received ASP Up/Active from the peer.
Should it after some time interval try to re-send ASP Up/Active again?

Are there any plans to resolve this?
Considering above, is it OK for a M3UA implementation not to support IPSP-DE
model and "force" peers to use IPSP-SE?
Your view would be much appreciated.

Cheers,
Jarek 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf
Of Brian F. G. Bidulock
Sent: Friday, 29 April 2005 1:53 PM
To: Jay N Bhuyan
Cc: [email-masked]
Subject: Re: [Sigtran] IPSP State in SUA IPSP DE Model

Jay,

It was a problem with the DE model that it could become hung half way like
this.  I think the text is quite clear that it takes all 4 messages to do
the job.  2 messages is just half way.  How much half way is not of much
moment.  This is one of the reasons why the SE model is to be used over the
DE model.

--brian

> Hi,
> 
> I have a question on SUA IPSP DE model. As per Section 3.4.4.1 in RFC 
> 3868,  four messages must be exchanged between peer IPSPs for a state 
> change.
> 
> received an ASP Inactive Ack message. However, IPSP A  did not receive 
>    An IPSP may be considered in the ASP-INACTIVE state by a remote IPSP
>    after an ASP Inactive or ASP Inactive Ack message has been received
>    from it.
> 
>    Inactive messages from each end MUST be performed.  Four messages are
>    needed for completion.
> 
> 
> Thanks,
> Jay
> 
> 
> 
> 
> [email-masked] https://www1.ietf.org/mailman/listinfo/sigtran

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/