Subject: [Sigtran] LinkSet-RouteSet in M3UA

From: "Ambika Tripathy" <[email-masked]>
Date: Thu, 4 Jan 2007 16:01:33 +0530

Hi All,

I have a doubt regarding the LinkSet and RouteSet concept in M3UA. Can any
body help me for the same by providing more information in it.

As per my knowledge there is no concept of LinkSet and RouteSet in M3UA. The
LinkSet and Route set comes in MTP2 and MTP3 links.
How can one relate LinkSet and RouteSet in M3UA?

-- 
Br,
Ambika Prasad Tripathy
Nethawk Networks
Cell: +91-94375 47730
_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Kuldeep Janjua" <[email-masked]>
Date: Thu, 4 Jan 2007 16:12:38 +0530

Hi Ambika,

Link-Set and Rout-Set are the terms associated with MTP3.

In M3UA there is only Routing-Key which is generally used for traffic range
between MTP3 and its user lying in the IP domain.

Regards,
Kuldeep

On 1/4/07, Ambika Tripathy <[email-masked]> wrote:
> As per my knowledge there is no concept of LinkSet and RouteSet in M3UA.
> The LinkSet and Route set comes in MTP2 and MTP3 links.

---

From: "Haresign Lincoln" <[email-masked]>
Date: Thu, 4 Jan 2007 08:44:21 -0500

I believe there are similar concepts in M3UA when viewed from the ASP
towards the SS7 network.
 
For example, you can have multiple associations from an ASP connecting
to an SG if the SG consists of multiple SGPs.  Therefore, this set of
associations could be considered an "association set".
 
Also, an ASP can connect to multiple SGs.  In order to route a message
to a PC in the SS7 network, the ASP would need to choose which set of
routes (which SG to route through) in order to properly route the
message.  Hence the "route set".
 
Regards,
Lincoln

________________________________

From: Kuldeep Janjua [mailto:[email-masked]] 
Sent: Thursday, January 04, 2007 5:43 AM
To: Ambika Tripathy; [email-masked]
Subject: Re: [Sigtran] LinkSet-RouteSet in M3UA

Hi Ambika,

In M3UA there is only Routing-Key which is generally used for traffic
range between MTP3 and its user lying in the IP domain.

Regards,
Kuldeep

	Hi All,
	I have a doubt regarding the LinkSet and RouteSet concept in
M3UA. Can any body help me for the same by providing more information in
it.
	 
	As per my knowledge there is no concept of LinkSet and RouteSet
in M3UA. The LinkSet and Route set comes in MTP2 and MTP3 links.
	How can one relate LinkSet and RouteSet in M3UA?
	 
	-- 
	Br,
	Ambika Prasad Tripathy
	Nethawk Networks
	Cell: +91-94375 47730

---

From: "Ambika Tripathy" <[email-masked]>
Date: Thu, 4 Jan 2007 19:20:42 +0530

There is a one to one mapping of ASP to Association and the traffic modes of
M3UA come into picture when below scenario comes.

Then what is the utility of this?

Br,
Ambika

On 1/4/07, Haresign Lincoln <[email-masked]> wrote:
> For example, you can have multiple associations from an ASP connecting to
> an SG if the SG consists of multiple SGPs.  Therefore, this set of
> Also, an ASP can connect to multiple SGs.  In order to route a message to
> a PC in the SS7 network, the ASP would need to choose which set of routes
> (which SG to route through) in order to properly route the message.  Hence
> the "route set".
>
> Regards,
> Lincoln
>
>  ------------------------------
> *From:* Kuldeep Janjua [mailto:[email-masked]]
> *Sent:* Thursday, January 04, 2007 5:43 AM
> *To:* Ambika Tripathy; [email-masked]
> *Subject:* Re: [Sigtran] LinkSet-RouteSet in M3UA
>
>
>  Hi Ambika,
>
> >  I have a doubt regarding the LinkSet and RouteSet concept in M3UA. Can
> > any body help me for the same by providing more information in it.
> >

---

From: "Ambika Tripathy" <[email-masked]>
Date: Thu, 4 Jan 2007 19:31:59 +0530

Then it is the concept of load sharing/broadcasting when one ASP connects to
multiple SGP.

But is there any way to send data of one ASP through multiuple Association
to the peer SGP in oneASP-one SGP coonection then we can term it association
sets.

The above way can be a better approach..

Br,
Ambika

On 1/4/07, Haresign Lincoln <[email-masked]> wrote:
>
>  THere is a one to one mapping when the SGP is determing which ASP to send
> to.
>
> When the ASP is routing the message to the SS7 network, it can route
> through multiple associtations and possibly multiple SGs (association sets).
>
> Regards,
> Lincoln
>
> *From:* Ambika Tripathy [mailto:[email-masked]]
> *Sent:* Thursday, January 04, 2007 8:51 AM
> *To:* Haresign Lincoln
> *Cc:* Kuldeep Janjua; [email-masked]
>  There is a one to one mapping of ASP to Association and the traffic modes
> of M3UA come into picture when below scenario comes.
>
> > to a PC in the SS7 network, the ASP would need to choose which set of routes
> > On 1/4/07, Ambika Tripathy <[email-masked] > wrote:
> > >
> > >
> > > Hi All,
> > >  I have a doubt regarding the LinkSet and RouteSet concept in M3UA.
> > > Can any body help me for the same by providing more information in it.
> > >
> > > As per my knowledge there is no concept of LinkSet and RouteSet in
> > > M3UA. The LinkSet and Route set comes in MTP2 and MTP3 links.

---

From: "Haresign Lincoln" <[email-masked]>
Date: Thu, 4 Jan 2007 08:53:38 -0500

THere is a one to one mapping when the SGP is determing which ASP to
send to.
 
When the ASP is routing the message to the SS7 network, it can route
through multiple associtations and possibly multiple SGs (association
sets).
 
Regards,
Lincoln

From: Ambika Tripathy [mailto:[email-masked]] 
Sent: Thursday, January 04, 2007 8:51 AM
To: Haresign Lincoln
Cc: Kuldeep Janjua; [email-masked]
Subject: Re: [Sigtran] LinkSet-RouteSet in M3UA

There is a one to one mapping of ASP to Association and the traffic
modes of M3UA come into picture when below scenario comes.

Br,
Ambika

	I believe there are similar concepts in M3UA when viewed from
the ASP towards the SS7 network.
	 
	For example, you can have multiple associations from an ASP
connecting to an SG if the SG consists of multiple SGPs.  Therefore,
this set of associations could be considered an "association set". 
	 
	Also, an ASP can connect to multiple SGs.  In order to route a
message to a PC in the SS7 network, the ASP would need to choose which
set of routes (which SG to route through) in order to properly route the
message.  Hence the "route set". 
	 
	Regards,
	Lincoln

	
	Hi Ambika,

	In M3UA there is only Routing-Key which is generally used for
traffic range between MTP3 and its user lying in the IP domain.
	
	Regards,
	Kuldeep

		Hi All,
		I have a doubt regarding the LinkSet and RouteSet
concept in M3UA. Can any body help me for the same by providing more
information in it.
		 
		As per my knowledge there is no concept of LinkSet and
RouteSet in M3UA. The LinkSet and Route set comes in MTP2 and MTP3
links.
		How can one relate LinkSet and RouteSet in M3UA?
		 
		-- 
		Br,
		Ambika Prasad Tripathy
		Nethawk Networks
		Cell: +91-94375 47730

---

From: "Ashish Soregaonkar" <[email-masked]>
Date: Thu, 4 Jan 2007 19:33:48 +0530

I see the below relations.

1. A route-set to a set of ASPs in an AS. With each ASP connecting to the
same SG(with or without multiple SGPs) we have multiple routes to the same
peer.

2. SCTP associations with multiple streams relating to a link-set. All links
have the same adjacent node.

-Ashish

---

From: "Haresign Lincoln" <[email-masked]>
Date: Thu, 4 Jan 2007 09:04:45 -0500

Ambika,

If you have a single ASP and a single SGP, why would you want to have
multiple associations?

Regards,
Lincoln 

From: Ambika Tripathy [mailto:[email-masked]] 
Sent: Thursday, January 04, 2007 9:02 AM
To: Haresign Lincoln
Cc: Kuldeep Janjua; [email-masked]
Subject: Re: [Sigtran] LinkSet-RouteSet in M3UA

Then it is the concept of load sharing/broadcasting when one ASP
connects to multiple SGP.
 
But is there any way to send data of one ASP through multiuple
Association to the peer SGP in oneASP-one SGP coonection then we can
term it association sets. 

Br,
Ambika

	THere is a one to one mapping when the SGP is determing which
ASP to send to.
	 
	When the ASP is routing the message to the SS7 network, it can
route through multiple associtations and possibly multiple SGs
(association sets).
	 
	Regards,
	Lincoln

	

		There is a one to one mapping of ASP to Association and
the traffic modes of M3UA come into picture when below scenario comes.

	Br,
	Ambika

	On 1/4/07, Haresign Lincoln <[email-masked] >
wrote: 

		I believe there are similar concepts in M3UA when viewed
from the ASP towards the SS7 network.
		 
		For example, you can have multiple associations from an
ASP connecting to an SG if the SG consists of multiple SGPs.  Therefore,
this set of associations could be considered an "association set". 
		 
		Also, an ASP can connect to multiple SGs.  In order to
route a message to a PC in the SS7 network, the ASP would need to choose
which set of routes (which SG to route through) in order to properly
route the message.  Hence the "route set". 
		 
		Regards,
		Lincoln

				Hi Ambika,
		
		Link-Set and Rout-Set are the terms associated with
MTP3.
		
		In M3UA there is only Routing-Key which is generally
used for traffic range between MTP3 and its user lying in the IP domain.
		
		Regards,
		Kuldeep

		On 1/4/07, Ambika Tripathy <[email-masked]
<mailto:[email-masked]> > wrote: 

			Hi All,
			I have a doubt regarding the LinkSet and
RouteSet concept in M3UA. Can any body help me for the same by providing
more information in it.
			 
			As per my knowledge there is no concept of
LinkSet and RouteSet in M3UA. The LinkSet and Route set comes in MTP2
and MTP3 links.
			How can one relate LinkSet and RouteSet in M3UA?
			 
			-- 
			Br,
			Ambika Prasad Tripathy
			Nethawk Networks
			Cell: +91-94375 47730 

			

	-- 
	Br,
	Ambika Prasad Tripathy
	Nethawk Networks
	Cell: +91-94375 47730 

-- 
Br,
Ambika Prasad Tripathy
Nethawk Networks
Cell: +91-94375 47730

---

From: "Haresign Lincoln" <[email-masked]>
Date: Thu, 4 Jan 2007 09:09:31 -0500

I think the concept of "association set" and "route set" only exist from
the ASP looking towards the SS7 network through the SG and not from the
SG towards the AS.

A single ASP may have multiple routes to get to a particular DPC.  This
may be because there are multiple SGPs within the adjacent SG (therefore
multiple associations to choose from), or this may be because there are
multiple SGs connected to the ASP.  Or both conditions may exist.

Regards,
Lincoln

From: Ashish Soregaonkar [mailto:[email-masked]] 
Sent: Thursday, January 04, 2007 9:04 AM
To: sigtran
Subject: Re: [Sigtran] LinkSet-RouteSet in M3UA

1. A route-set to a set of ASPs in an AS. With each ASP connecting to
the same SG(with or without multiple SGPs) we have multiple routes to
the same peer.

2. SCTP associations with multiple streams relating to a link-set. All
links have the same adjacent node. 

-Ashish

	There is a one to one mapping of ASP to Association and the
traffic modes of M3UA come into picture when below scenario comes.

	Br,
		Ambika

			On 1/4/07, Haresign Lincoln
<[email-masked] > wrote: 

		 
		 
		Regards,
		Lincoln

				Hi Ambika,

		
		Regards,
		Kuldeep

			Hi All,

			-- 
			Br,
			Ambika Prasad Tripathy
			Nethawk Networks
			Cell: +91-94375 47730 

			

	-- 
	Br,
	Ambika Prasad Tripathy
	Nethawk Networks
	Cell: +91-94375 47730

---

From: "Ashish Soregaonkar" <[email-masked]>
Date: Thu, 4 Jan 2007 19:50:55 +0530

With the relations that I mentioned I dont see a change of view looking from
either side.

Personally I do not think M3UA was defined to make it as relatable as
possible to MTP3 concepts. Drawing parallels is probably useful only for
understanding M3UA functionality. We cant generalize this for other UAs.

-Ashish