Subject: [Sigtran] Resolution::Cannot Support Unique Routing

From: "Ambika Tripathy" <[email-masked]>
Date: Wed, 10 Jan 2007 14:35:17 +0530

Hi,

        I have one doubt regarding the Registration Response Error-Cannot
Support Unique Routing as per rfc 3332.

Say an ASP1 registers RK1(OPC=*,DPC=x, SI = SCCP) with SGP1 then SS7
traffic  is flowing between SGP1 and ASP1.
Now same ASP1 further registers RK2(OPC=*,DPC=x,SI=ISUP) with same SGP1, but
ASP1 receives the  Error - "Cannot Support Unique Routing" in the REG RESP
message.
The intention of RK2 is to support only ISUP ss7 traffic with DPC=x.

1.        Let me know whether it is a valid scenario or not?

2.        If Yes then how can we resolve this problem in M3UA?

-- 
Br,
Ambika Prasad Tripathy
Nethawk Networks
Cell: +91-94375 47730
_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Wed, 10 Jan 2007 11:02:55 -0700

Ambika,

I does not sound like SGP1 is behaving correctly to me.  Which error
it should use depends on why the implementation cannot support both
routing keys (but uniqueness is not it, as the RKs are disjoint as
defined).

--brian

Ambika Tripathy wrote:                        (Wed, 10 Jan 2007 14:35:17)
> 
>    Hi,
> 
> 
> 
>              I   have  one  doubt  regarding  the  Registration  Response
>    Error-Cannot Support Unique Routing as per rfc 3332.
> 
> 
> 
>    Now  same  ASP1  further  registers RK2(OPC=*,DPC=x,SI=ISUP) with same
>    SGP1,  but  ASP1 receives the  Error - "Cannot Support Unique Routing"
>    in the REG RESP message.
> 

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/