Subject: [Sigtran] testing Sigtran protocols

From: "Troiano Marco" <[email-masked]>
Date: Mon, 29 Jan 2007 10:37:44 +0100

Hi all,

my name is Marco Troiano. I am a TLC engineer who wants to test the
following Sigtran protocols:

SCTP, M3UA, M2PA, SUA

In the past I used the following documents (from ETSI site) as a basis
for testing SCTP and M3UA:

1.	ETSI TS 102 369 V1.1.1 (2004-11) Methods for Testing and
Specification (MTS); Stream Control Transmission Protocol (SCTP); Test
Suite Structure and Test Purposes (TSS&TP);
2.	ETSI TS 102 381 V1.1.1 (2004-12) Technical Specification Methods
for Testing and Specification (MTS); SS7 Message Transfer Part 3 - User
Adaptation Layer; (IETF RFC 3332); Test Suite Structure and Test
Purposes (TSS&TP)

Can you suggest me new versions that makes docs 1 and 2 (SCTP, M3UA)
obsolete? 

Can you help me for the other protocols (M2PA and SUA)? 

Thanks in advance

Marco Troiano

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: Michael Tuexen <[email-masked]>
Date: Mon, 29 Jan 2007 12:17:38 +0100

Hi Troiano,

see my comments below.

Best regards
Michael

On Jan 29, 2007, at 10:37 AM, Troiano Marco wrote:

> In the past I used the following documents (from ETSI site) as a  
> basis for testing SCTP and M3UA:
>
>
>
> ETSI TS 102 369 V1.1.1 (2004-11) Methods for Testing and  
> Specification (MTS); Stream Control Transmission Protocol (SCTP);  
> Test Suite Structure and Test Purposes (TSS&TP);
> ETSI TS 102 381 V1.1.1 (2004-12) Technical Specification Methods  
> for Testing and Specification (MTS); SS7 Message Transfer Part 3 -  
> User Adaptation Layer; (IETF RFC 3332); Test Suite Structure and  
> Test Purposes (TSS&TP)
>
>
> Can you suggest me new versions that makes docs 1 and 2 (SCTP,  
> M3UA) obsolete?
As you said: these document are from ETSI. The SIGTRAN WG has not  
made any
effort to publish conformance test specification.

Please note that you can get pen source implementations of the above  
conformance
test suite from
http://sctp.fh-muenster.de

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Mon, 29 Jan 2007 15:51:49 -0700

Troiano,

  For M2PA, draft-bidulock-sigtran-m2pa-test-07.txt, but it has expired so get it here:

  http://www.openss7.org/internet-drafts/draft-bidulock-sigtran-m2pa-test-07.txt

  An -08 version with a couple of corrections will be submitted to the rfc editor soon.

  For SUA, you can find some test specifications that various organizations
  have submitted here:

  http://www.openss7.org/sigtran03.html

  TS 102 380 and TS 102 381 are not that out of date as they are based on
  TS 102 141 and TS 102 142.  TS 102 142 has many IG changes and sits between
  RFC 3332 and RFC 4666.

--brian

Troiano Marco wrote:                                                               (Mon, 29 Jan 2007 10:37:44)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/