Subject: [Sigtran] SUA::Address Parameter in CLDT

From: "Ambika Tripathy" <[email-masked]>
Date: Fri, 18 May 2007 12:10:02 +0530

Hi Folks,

     Can one SUA end point encode the RI in Source Address Paramter for
routing on SSN+PC and RI in Destination Address parameter for Route on
Global Title?

-- 
Br,
Ambika Prasad Tripathy
Nethawk Networks
Cell: +91-94375 47730
_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Fri, 18 May 2007 00:57:55 -0600

Ambika,

You could, but real SS7 networks do not perform translation in
the reverse direction and then only route on point code.  Also,
translation is not performed on any message except the initial
message of a transaction or connection.

--brian

Ambika Tripathy wrote:                           (Fri, 18 May 2007 12:10:02)
> 
>    Hi Folks,
> 
> 
> 
>          Can  one  SUA end point encode the RI in Source Address Paramter
>    for  routing  on  SSN+PC  and  RI in Destination Address parameter for
>    Route on Global Title?
>    --
>    Br,
>    Ambika Prasad Tripathy
>    Nethawk Networks
>    Cell: +91-94375 47730

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: "Stewart Patch" <[email-masked]>
Date: Fri, 18 May 2007 13:54:19 -0400

Brian, that is true for North American networks, but less so for
networks using ITU-T MTP, with its smaller point code space. In
internetwork use nodes may use global title addresses containing E.164
addresses to refer to one another. Such an address would appear as
source address in a transaction begin and then be translated in the
reverse direction when sending back the response.

Stewart Patch
Network Signalling Advisor

-----Original Message-----
From: Brian F. G. Bidulock [mailto:[email-masked]] 
Sent: Friday, May 18, 2007 2:58 AM
To: Ambika Tripathy
Cc: sigtran
Subject: [Sigtran] Re: SUA::Address Parameter in CLDT

Ambika,

--brian

Ambika Tripathy wrote:                           (Fri, 18 May 2007
12:10:02)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Fri, 18 May 2007 14:06:01 -0600

Hi Stu,

Not for connection-oriented.  Also, for connectionless there is never
a need to perform translation in the reverse direction as you describe,
regardless of the size of the point code numbering space, since the
BEGIN always contains either the originating point code in the calling
party address field or in the MTP routing label and this, coupled with
the originating SSN, is always sufficient for routing the response.

--brian

Stewart Patch wrote:                            (Fri, 18 May 2007 13:54:19)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/