Subject: RE: [Sigtran] Error - Routing Key not Currently Provisioned

From: "Salil Agrawal" <[email-masked]>
Date: Mon, 7 May 2007 14:13:54 +0530

Hi Abhishek, 

I agree with Brian, all the SS7 routes should be statically configured
at SS7 network and there is no way of dynamic learning in the SS7
network and that is the reason why you need to explicitly provision all
routing keys. 

Thanks,
Salil

-----Original Message-----
From: Brian F. G. Bidulock [mailto:[email-masked]] 
Sent: Monday, May 07, 2007 1:26 PM
To: Abhishek Jain
Cc: sigtran
Subject: Re: [Sigtran] Error - Routing Key not Currently Provisioned

Abhishek,

For SS7 MTP there is no discovery protocol for routes: all routes are
explicitly provisioned.  On top of that, some might be provisioned for
use by an ASP and some might not.

--brian

Abhishek Jain wrote:                           (Mon, 07 May 2007
12:23:55)
> 
>    Hi,
> 
> 
>    From the excerpt in RFC 4666
> 
>     
> 
>    If  an  SGP  determines that a received Routing Key does not
currently
>    exist,  and  the  SGP supports dynamic configuration but requires
that
>    the  Routing  Key  first  be  manually provisioned at the SGP, the
SGP
>    returns  a  Registration  Response  message  to  the ASP,
containing a
>    Registration Result "Error - Routing Key not Currently
Provisioned".
> 
>     
> 
>    Can  anyone  give  clarification  what is the rationale behind
keeping
>    routing  keys manually provisioned. Does this statement means that
all
>    Routing  Keys  have  to  be  statically  configured  on  SGP  and
any
>    registration  request  for  new  routing key will be rejected, in
this
>    scenario  mentioned  or  is  this  statement  applicable  for
selected
>    routing  keys  which  always  have to manually provisioned rather
than
>    dynamically.
>    Thanks
>    Abhishek

> _______________________________________________
> Sigtran mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/sigtran

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Mon, 7 May 2007 05:08:17 -0600

cinar.eren,

What is dynamic is the assignment of an RC value to a Routing Key.  With
dynamic registration, the ASP only needs to know the Routing Key and not
the RC value.  The Routing Key is expressed in terms native to the MTP
User, whereas, the RC value is just an index assigned by the SGP.
Therefore, dynamic registration relieves the application (or ASP) from
provisioning RC values (nothing to do with MTP3) at the ASP to
correspdond to routing keys (expressed in MTP routing label parameters).
It may have advantage in some implementations of the ASP, not in others.
Note that ETSI UMTS/3GPP forbids dynamic registration.

--brian

[email-masked] wrote:                     (Mon, 07 May 2007 11:58:10)
> Hi experts,
> 
> then can u summarize shortly what we should understand if an SGP
> supports dynamic configuration?
> what is done dynamically/automatically(as i understand)?
> 
> thanks in advance.
> BR..
> cinar
>  
> 
> From: ext Salil Agrawal [mailto:[email-masked]] 
> Sent: 07 May 2007 11:44
> To: [email-masked]; Abhishek Jain
> Cc: sigtran
> Subject: RE: [Sigtran] Error - Routing Key not Currently Provisioned
> 
> Hi Abhishek, 
> 

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/