Subject: [Sigtran] TUP\IUP over M3UA.

From: Igor Fedotov <[email-masked]>
Date: Mon, 25 Jun 2007 17:09:47 +0400

Can anyone explain how SS7 TUP messages are transported over M3UA?
The problem is in the mapping TUP Routing Label to M3UA message. Am I right that 
OPC\DPC from it are mapped to Origination Point Code and Destination Point Code fields 
of Protocol Data parameter of M3UA Data message? But where should I put CIC?
Is it mapped to some fields of Protocol Data parameter or is it encoded right 
before the TUP message?
If the second case is correct - how CIC padding to integral number of octets 
( as it is 12 bit long ) is performed?
Thanks in advance.

-- 
Best regards,
 Igor                          mailto:[email-masked]

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Mon, 25 Jun 2007 07:48:13 -0600

Igor,

First, can you point to somewhere in the world where TUP is still used?

Next, can you indicate who in that part of the world will be running TUP
over M3UA?

Then, move the 4 bits of the CIC that normally overlap into the SLS
field of the SS7 routing label into the SLS field in the Protocol Data
parameter of M3UA and leave the other 8 bits of the CIC in the User
Protocol Data field of M3UA, just as is done in SS7 between the routing
label and the SIF.

--brian

Igor Fedotov wrote:                               (Mon, 25 Jun 2007 17:09:47)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: "Haresign Lincoln" <[email-masked]>
Date: Mon, 25 Jun 2007 10:00:32 -0400

TUP is still being used in France.

Regards,
Lincoln 

-----Original Message-----
From: Brian F. G. Bidulock [mailto:[email-masked]] 
Sent: Monday, June 25, 2007 9:48 AM
To: Igor Fedotov
Cc: [email-masked]
Subject: Re: [Sigtran] TUP\IUP over M3UA.

Igor,

--brian

Igor Fedotov wrote:                               (Mon, 25 Jun 2007
17:09:47)
> The problem is in the mapping TUP Routing Label to M3UA message. Am I 
> right that OPC\DPC from it are mapped to Origination Point Code and 
> Destination Point Code fields of Protocol Data parameter of M3UA Data
message? But where should I put CIC?
> Is it mapped to some fields of Protocol Data parameter or is it 
> encoded right before the TUP message?
> If the second case is correct - how CIC padding to integral number of 
> octets ( as it is 12 bit long ) is performed?
> Thanks in advance.
> 
> --
> Best regards,

--
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: Igor Fedotov <[email-masked]>
Date: Mon, 25 Jun 2007 18:07:54 +0400

Brian,

Thank you very much for the answer.

BFGB> Igor,

BFGB> First, can you point to somewhere in the world where TUP is still used?

BFGB> Next, can you indicate who in that part of the world will be running TUP
BFGB> over M3UA?
Initially I have got this question about UK IUP (ND1006:2005/02). But
as it's similar to TUP in Routing Label structure I mentioned TUP in
the question ( it's more well-known I think ).
And IUP is used in the UK :)

BFGB> Then, move the 4 bits of the CIC that normally overlap into the SLS
BFGB> field of the SS7 routing label into the SLS field in the Protocol Data
BFGB> parameter of M3UA and leave the other 8 bits of the CIC in the User
BFGB> Protocol Data field of M3UA, just as is done in SS7 between the routing
BFGB> label and the SIF.

BFGB> --brian

BFGB> Igor Fedotov wrote:                               (Mon, 25 Jun 2007 17:09:47)

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Mon, 25 Jun 2007 08:20:57 -0600

Igor,

Igor Fedotov wrote:                            (Mon, 25 Jun 2007 18:07:54)
> And IUP is used in the UK :)

I understood that BT now requires ISUPv2 (with BT variations of course).

Regardless of whether IUP was used at one time in the UK, what makes you
think that someone will run it over M3UA?

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Mon, 25 Jun 2007 08:22:50 -0600

Lincoln,

Haresign Lincoln wrote:                        (Mon, 25 Jun 2007 10:00:32)
> TUP is still being used in France.

Could you provide a web link to Colt or France Telecom's plans to
run it over M3UA? ;)

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: "Haresign Lincoln" <[email-masked]>
Date: Mon, 25 Jun 2007 10:34:49 -0400

Brian,

Sorry, I don't have any insights on whether they plan on moving French
TUP over M3UA.  I imagine if they are upgrading their switches to
SIGTRAN, I would hope they are also upgrading to ISUP.  I had heard that
BT had switched from IUP to ISUP also.  So I'm surprised they are
looking for IUP over M3UA.

Also, I know that China is still using TUP and CMCC is going through
major interop testing for SIGTRAN right now.  At the moment, it's for
GSM over M3UA.   

Regards,
Lincoln

-----Original Message-----
From: Brian F. G. Bidulock [mailto:[email-masked]] 
Sent: Monday, June 25, 2007 10:23 AM
To: Haresign Lincoln
Cc: [email-masked]
Subject: Re: [Sigtran] TUP\IUP over M3UA.

Lincoln,

Haresign Lincoln wrote:                        (Mon, 25 Jun 2007
10:00:32)
> TUP is still being used in France.

Could you provide a web link to Colt or France Telecom's plans to run it
over M3UA? ;)

--brian

--
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: [email-masked]
Date: Tue, 26 Jun 2007 09:52:05 +0800

Brian，
I have a question, thanks.
the tup code: 
   |cic| opc| dpc|
so I think all the bits of cic should be put into the User Protocol Data 
field of M3UA and at the same time, 4 bits
of the CIC that normally overlap into the SLS field of the SS7 routing 
label into the SLS field in the Protocol Data 
parameter of M3UA? 

"Brian F. G. Bidulock" <[email-masked]>

2007-06-25 21:48

        收件人：        Igor Fedotov <[email-masked]>
        抄送：  [email-masked]
        主题：  Re: [Sigtran] TUP\IUP over M3UA.

Igor,

--brian

> The problem is in the mapping TUP Routing Label to M3UA message. Am I 
right that 
> If the second case is correct - how CIC padding to integral number of 
octets 

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Mon, 25 Jun 2007 22:42:05 -0600

fan.dongming,

[email-masked] wrote:                      (Tue, 26 Jun 2007 09:52:05)
>    Brian£¬
>    so  I  think  all the bits of cic should be put into the User Protocol
>    Data field of M3UA and at the same time, 4 bits

That would be wrong. See RFC 4666 3.3.1:

   ...

   User Protocol Data: variable-length octet string

   The User Protocol Data field contains an octet string of MTP-User
   information from the original SS7 message, starting with the first
   octet of the original SS7 message following the Routing Label
   [7][8][26].

   ...

The SLS field that CIC shares is part of the routing label.  The first
octet past the SLS (following the Routing Label) is the first octet of
the User Protocol Data.

Please don't bring this up again: it is a waste of time.

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: Igor Fedotov <[email-masked]>
Date: Tue, 26 Jun 2007 13:04:48 +0400

Brian,

BFGB> I understood that BT now requires ISUPv2 (with BT variations of course).

BFGB> Regardless of whether IUP was used at one time in the UK, what makes you
BFGB> think that someone will run it over M3UA?

Our UK customer asked whether we support IUP over M3UA.
But it seems that they are uncertain about this thing.
Thank you very much for your comment.