Subject: [Sigtran] SCTP heartbeat timeout

From: "David Laight" <[email-masked]>
Date: Mon, 10 Dec 2007 16:09:18 -0000

SCTP uses a heartbeat message to detect failure of the peer system.

When we test this with the SCTP code in linux 2.6 it takes 15-16
minutes to report a failure on an idle connection.

Is this the expected timeout, it seems a little long!

I would have expected the code to try more aggressively to get
a response once the original 30 second timer expires.

	David

Registered Address Lakeside, Bramley Road, Mount Farm, Milton Keynes, MK1 1PT, UK
Registration No: 1397386 (Wales)  
P Please consider the environment and don't print this e-mail unless you really need to

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: Michael Tuexen <[email-masked]>
Date: Mon, 10 Dec 2007 17:54:54 +0100

Hi David,

it is within the spec to retransmit HB after RTO + HB.Interval
where RTO is doubled but within RTO.min and RTO.max.

What is the maximum number of retransmissions you use until
the assoc dies?

Best regards
Michael

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Mon, 10 Dec 2007 10:16:31 -0700

David,

That is almost normal behaviour when parameters are set to the
recommended values of RFC 4460.  (It should take about 10 minutes.)

You could try reducing the heartbeat interval and RTO.Max to reduce
the overall time or use an application timer.

--brian

David Laight wrote:                                         (Mon, 10 Dec 2007 16:09:18)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/