Subject: [Sigtran] M2PA Processor Outage state ?

From: Sheshendra Rathi <[email-masked]>
Date: Wed, 5 Dec 2007 02:01:46 -0800 (PST)

Hi

When an  M2PA is in Processor Outage state and 
The SCPT ABORT or Shut Down is received 
is it right to Send an XCOO on the other link.

i.e. in a Processot outage state can we do an Change over if the SCTP abort
or shutdown is received.

Thanks,
Sheshendra Rathi
-- 
View this message in context: http://www.nabble.com/M2PA-Processor-Outage-state---tf4948563.html#a14168478
Sent from the IETF - Sigtran mailing list archive at Nabble.com.

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Wed, 5 Dec 2007 08:14:12 -0700

Sheshendra,

Yes.  Abort is certainly link failure at Level 3.

--brian

Sheshendra Rathi wrote:                                (Wed, 05 Dec 2007 02:01:46)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: Sheshendra Rathi <[email-masked]>
Date: Wed, 5 Dec 2007 23:32:55 -0800 (PST)

Dose it mean that I should be handling the link failures during Processor
Outage,
As RFC does not say any thing on link failures during Processor outage.

--Rathi

Brian F. G. Bidulock wrote:
>> View this message in context:
>> http://www.nabble.com/M2PA-Processor-Outage-state---tf4948563.html#a14168478

-- 
View this message in context: http://www.nabble.com/M2PA-Processor-Outage-state---tf4948563.html#a14187640
Sent from the IETF - Sigtran mailing list archive at Nabble.com.

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Thu, 6 Dec 2007 02:29:06 -0700

Sheshendra,

Q.703 permits link failure during remote processor outage.
Q.703 does not permite link failure during local processor
outage (because if L2 can deliver link failure to L3 there is no
local processor outage at L2).

Also:

|4.  Procedures
|
|   Because M2PA provides MTP3 with an interface and functionality like
|   MTP2, its internal functioning is similar to that of MTP2.
|
|   Except as modified in this document, M2PA SHOULD follow the
|   requirements of the applicable MTP2 specification.  These may include
|   [Q.703] or [T1.111].  The same standard MUST be followed on both ends
|   of the M2PA link.
|
|   In particular, the corresponding applicable timer value defaults and
|   ranges specified for the applicable MTP2 standard should be used for
|   the M2PA timers.
|
|   When referring to MTP2 terminology in this document, the terminology
|   of [Q.703] is used.  This does not imply that the requirements of
|   [Q.703] are to be followed.

--brian

Sheshendra Rathi wrote:                          (Wed, 05 Dec 2007 23:32:55)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/