Subject: [Sigtran] Can SGP send ASPDN or ASPUP messages?

From: Shmelev Kirill <[email-masked]>
Date: Thu, 17 Jan 2008 00:25:28 -0800 (PST)

Hi, experts!

Can SGP (or server in broader meaning) ever send ASPDN message? Sometimes it
is more preferrable than closing SCTP association, since the connection will
not be closed until ASPDN_ACK is received
-- 
View this message in context: http://www.nabble.com/Can-SGP-send-ASPDN-or-ASPUP-messages--tp14914300p14914300.html
Sent from the IETF - Sigtran mailing list archive at Nabble.com.

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: Christopher Benson <[email-masked]>
Date: Mon, 28 Jan 2008 13:29:56 -0800 (PST)

Hi Shmelev,

A procedure that has been used in M3UA is that the SGP 
will send an ASP-Inactive-Ack without receiving an ASP
Inactive message first. I believe this has the same
eventual result that you desire.

ASP Inactive and ASP Down messages *FROM* an SGP, are not 
recognized message types in that direction, and so cannot 
and should not be used.

With thanks, from Chris Benson.

On Thu, 17 Jan 2008, Shmelev Kirill wrote:

>>  Date: Thu, 17 Jan 2008 00:25:28 -0800 (PST)
>>  From: Shmelev Kirill <[email-masked]>
>>  To: [email-masked]
>>  Subject: [Sigtran] Can SGP send ASPDN or ASPUP messages?
>>  
>>  
>>  Hi, experts!
>>

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Mon, 28 Jan 2008 18:12:34 -0700

Christopher,

The SGP may also send unsolicited ASP Down Ack,
which is quicker than many ASP Inactive Acks.

--brian

Christopher Benson wrote:              (Mon, 28 Jan 2008 13:29:56)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/