Subject: Re: [Sigtran] Interface Identifier in ASPTM message in M2UA

From: Rajesh Makhija <[email-masked]>
Date: Mon, 29 Aug 2011 16:52:32 +0530

Hi Aditi

Thanks for your inputs.

With reference to your last mail:

"As per the structure of ASPAC defined under the section 3.3.2.7, the Interface Identifier (Tag 0x1), the value can be a set of "Interface Identifiers". The length can be other than 8."

However from one of the earlier discussion threads on Sigtran forum....:

www.ietf.org/mail-archive/web/sigtran/current/msg08554.html<http://www.ietf.org/mail-archive/web/sigtran/current/msg08554.html>

It appears that if multiple interface identifiers are to be sent they must be sent in the following manner....snippet from earlier discussions follows:

"If you want to list two Integer Interface Identifiers it is:

            Tag (0x1), Length (8)
            Integer interface id 1
            Tag (0x1), Length (8)
            Integer interface id 2

Therefore, from the earlier discussion thread, it appears that the length field can only be 8.  This is slightly different from what you mentioned. If possible, I would request Brian to throw more light on this matter.

It would be great if we can reach a consensus on this matter on this forum (.i.e. length can only be 8 or not more than 8 is also possible when tag is (0x1), as this can possibly lead to interoperability issues.

Thank you in advance for your views on this matter.

Thanks and Regards

Rajesh

===============================================================================
Please refer to http://www.aricent.com/legal/email_disclaimer.html
for important disclosures regarding this electronic communication.
===============================================================================

---

From: Rajesh Makhija <[email-masked]>
Date: Mon, 29 Aug 2011 16:59:05 +0530

Hi Aditi

Thanks for your inputs.

            Tag (0x1), Length (8)
            Integer interface id 1
            Tag (0x1), Length (8)
            Integer interface id 2

Thanks and Regards

Rajesh