Subject: [Sigtran] [SIGTRAN:M3UA] Query regarding the behavior of network appearance in the DAUD message

From: "Shetty, Vishma (NSN - IN/Bangalore)" <[email-masked]>
Date: Fri, 9 Sep 2011 19:57:14 +0800

Hi,

We have a SIGTRAN setup with ITU, ANSI and Chinese variants with network appearance values configured as 1, 2, and 3 respectively as the DUT.

Now, if I send an ITU-DAUD message with network appearance value as 3 from the peer to the DUT. There is no error message sent from the DUT to the peer. Should there be no error message sent to the peer saying “Invalid Network Appearance” ? 

According to RFC 4666, we see that Invalid Network Appearance error message is sent for the below scenario:

The "Invalid Network Appearance" error is sent by an SGP if an ASP sends a message with an invalid (unconfigured) Network Appearance value. For this error, the invalid (unconfigured) Network Appearance MUST be included in the Network Appearance parameter.

So, does that mean “invalid (configured)” means the NA that’s not configured for any variant on the DUT? 

Could you please comment on this behavior.

Thanks & Regards, 
Vishma R Shetty

---

From: "Nemana, Satya" <[email-masked]>
Date: Fri, 9 Sep 2011 09:13:12 -0400

Hi Vishma

NA is optional in DAUD.

Are there multiple ASPs on the peer AS sharing a single SCTP assoc?

Is your same ASP connecting to Multiple SGP (which in turn are in
multiple networks, itu, ansi and china?)

If it is not connecting to multiple SGPs, then you do not need the NA at
all.

So, in your case the SGP is ignoring the NA parameter in the DAUD.

Guess the AS is registered statically, else this problem would not have
risen in case on dynamic reg.

What problem is this DAUD causing in the network?

Regards,

Satya

________________________________

From: [email-masked] [mailto:[email-masked]] On
Behalf Of Shetty, Vishma (NSN - IN/Bangalore)
Sent: 09 September 2011 12:57
To: [email-masked]
Subject: [Sigtran] [SIGTRAN:M3UA] Query regarding the behavior of
networkappearance in the DAUD message

Hi,

We have a SIGTRAN setup with ITU, ANSI and Chinese variants with network
appearance values configured as 1, 2, and 3 respectively as the DUT.

Now, if I send an ITU-DAUD message with network appearance value as 3
from the peer to the DUT. There is no error message sent from the DUT to
the peer. Should there be no error message sent to the peer saying
"Invalid Network Appearance" ? 

According to RFC 4666, we see that Invalid Network Appearance error
message is sent for the below scenario:

The "Invalid Network Appearance" error is sent by an SGP if an ASP sends
a message with an invalid (unconfigured) Network Appearance value. For
this error, the invalid (unconfigured) Network Appearance MUST be
included in the Network Appearance parameter.

So, does that mean "invalid (configured)" means the NA that's not
configured for any variant on the DUT? 

 

Thanks & Regards, 
Vishma R Shetty

---

From: "Shetty, Vishma (NSN - IN/Bangalore)" <[email-masked]>
Date: Sat, 10 Sep 2011 00:14:25 +0800

Hi,

Thank you for the response.

Yes. Correct. NA is optional. But we were checking the different scenarios with all the parameters in the message.

There are multiple ASPs with different SCTP assocs for all the variants..  The same SGPs are connected to the ASPs of different variants.

Here, when the message from the ASP with the different NA is sent to the SGP, we can see the error message in the logs as “Unable to find any AS serving with nw appr 3”. 

But I wanted to know if this behavior is correct or should there be an appropriate message sent to the ASP regarding the same.

Thanks & Regards, 
Vishma R Shetty 

From: ext Nemana, Satya [mailto:[email-masked]] 
Sent: Friday, September 09, 2011 6:43 PM
To: Shetty, Vishma (NSN - IN/Bangalore); [email-masked]
Subject: RE: [Sigtran] [SIGTRAN:M3UA] Query regarding the behavior of networkappearance in the DAUD message

Hi Vishma

NA is optional in DAUD.

Is your same ASP connecting to Multiple SGP (which in turn are in multiple networks, itu, ansi and china?)

If it is not connecting to multiple SGPs, then you do not need the NA at all.

Guess the AS is registered statically, else this problem would not have risen in case on dynamic reg.

Regards,

Satya

From: [email-masked] [mailto:[email-masked]] On Behalf Of Shetty, Vishma (NSN - IN/Bangalore)
Sent: 09 September 2011 12:57
To: [email-masked]
Subject: [Sigtran] [SIGTRAN:M3UA] Query regarding the behavior of networkappearance in the DAUD message

Hi,

 

Thanks & Regards, 
Vishma R Shetty