Subject: [Sigtran] M3UA: SCON: congestion condition never abates

From: urte plesske <[email-masked]>
Date: Tue, 23 Oct 2012 16:58:27 +0200

Hello, I'm faced with a problem based on the following architecture:

AS connected to two SGs
   AS
  /  \
 /    \
SG1---SG2
SCCP: SGs are making GTTs to route to the ss7 network.
MTP configurations on AS:
There are two routesets defined on AS, one to SG1 (containing direct route and route over SG2) and to SG2 (containing direct route and route over SG1)
 
SCON message was received by AS from SG2 with affected PC SG1.
On AS the route set (PC SG1) was inhibited. No traffic was sent to SG1 by AS any more. 
 
Usually the AS would start sending periodic DAUDs messages as a result of the congestion, but because SG1 was got to know as adjacent node, no DAUDs with affected Point Code = Point Code SG1 were sent by any ASP.
No SCON messages were sent by SG2 to AS because no DATA and DAUD messages were received to react.
The congestion condition never abates.
 
Could you please help me with the following questions:
How to solve this situation (timer on AS?)? 
Is it correct not to audit adjacent nodes?
Can (should) SG2 send a SCON message even there are no DATA and DAUD messages to react?  
Where can I find (rfc) the information, that SCON is like TFC and not TFR?
 
Thanks a lot!
 
regards, urte

---

From: "Nemana, Satya" <[email-masked]>
Date: Tue, 23 Oct 2012 15:13:24 +0000

Hi Urte

Even if AS does not send DAUD(for SG1 PC) to SG2, SG2 should send an SCON(Level-0) when the congestion clears.
In your case, you don't explain if the AS clears(for SG1) when SG2 sends SCON(Level-0) for SG1 PC.
The DAUD from AS is not as important as the SCON(Level-0) that should be sent by SG2 for clearing congestion towards SG1.
The congestion in your case is not abating because SG2 is never clearing congestion for PC:SG1.
This sounds normal scenario as per protocol.

Regards,
Satya

From: [email-masked] [mailto:[email-masked]] On Behalf Of urte plesske
Sent: 23 October 2012 15:58
To: [email-masked]
Subject: [Sigtran] M3UA: SCON: congestion condition never abates

AS connected to two SGs
   AS
  /  \
 /    \
SG1---SG2

Thanks a lot!

regards, urte

---

From: "David Laight" <[email-masked]>
Date: Tue, 23 Oct 2012 16:21:38 +0100

I presume this is (supposed to be) M3UA?

M3UA is an abstraction of the interface between MTP3 and its userparts (typically SCCP and ISUP).

This means that the ‘AS’ box isn’t running MTP3, so your descriptions about routing are incorrect.

The M3UA SCON indication is telling the userpart that MTP3 received a TFC for the route.

This could be used by the userpart to reduce its traffic.

There is no network message that indicates that congestion has ceased.

IIRC M3UA also doesn’t contain any such message.

The ‘congestion level’ will be 1, 2 or 3 in ansi networks, and always 0 in ITU networks.

                David

AS connected to two SGs
   AS
  /  \
 /    \
SG1---SG2

 
 
Thanks a lot!
 
regards, urte

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Tue, 23 Oct 2012 15:23:12 -0600

urte,

Please see comments inline...

urte plesske wrote:                                         (Tue, 23 Oct 2012 16:58:27)
>    There are two routesets defined on AS, one to SG1 (containing direct
>    route and route over SG2) and to SG2 (containing direct route and route
>    over SG1)
> 

This, to begin with, is somewhat peculiar.  The circumstances
under which SG2 would send SCON to the AS concerning SG1's point
code would be:

 - traffic on the association from AS to SG2 is overloading;

 - SG2's SMH function is overloading (in which case it should
   have first attempted a DRST in ANSI-based networks);

 - the C-links between SG2 and SG1 are congested.

Which begs the question, why is the AS sending messages with DPC
of SG1 to SG2?  Is not the direct route between AS and SG1
available and unrestricted?  Perhaps you have already received a
DRST from SG1 concerning its own point-code? (which would not be
correct).

So, that's number 1 problem: Why are you sending M3UA-User
messages from the AS to SG1 via the indirect route through SG2
when there exists a direct route to SG1?

>    Usually the AS would start sending periodic DAUDs messages as a result
>    of the congestion, but because SG1 was got to know as adjacent node, no
>    DAUDs with affected Point Code = Point Code SG1 were sent by any ASP.

No, that is incorrect.  You should audit even though the
destination is adjacent.  Following on on my first issue,
you should be auditing SG1 already because there is something
the matter with the direct route for you to have been sending
messages on the indirect route.  The direct route must be
restricted or unavailable, or the AS is doing the wrong thing.

>    How to solve this situation (timer on AS?)?

Send periodic DAUD while point codes are marked congested.
The period should be 1.4 to 2.0 seconds.

>    Is it correct not to audit adjacent nodes?

No it is not.  Adjacent nodes need not be audited for
availability, but they do need to be audited for restriction and
congestion.

>    Can (should) SG2 send a SCON message even there are no DATA and DAUD

No, is does not have to.  SG2 only need send SCON to the AS
under the same conditions as an STP would send TFC to an
adjacent signalling point.

>    Where can I find (rfc) the information, that SCON is like TFC and not

In the sections describing SCON and DRST.  SCON is equivalent
to TFC, DRST is equivalent to TFR.

--brian

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Tue, 23 Oct 2012 15:28:31 -0600

Satya,

No, in the multiple STP as SG configuration there is no basis
under which the SG can send SCON(0) unless the SG sends 
signalling route set congestion test messages on behalf of all
its subtending nodes.  Therefore, the AS in this configuration
should periodically audit.

--brian

Nemana, Satya wrote:                                     (Tue, 23 Oct 2012 15:13:24)
>    Hi Urte
> 
> 
>    Even if AS does not send DAUD(for SG1 PC) to SG2, SG2 should send an
>    SCON(Level-0) when the congestion clears.
> 
>    The DAUD from AS is not as important as the SCON(Level-0) that should
>    be sent by SG2 for clearing congestion towards SG1.
> 

> _______________________________________________
> Sigtran mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/sigtran

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Tue, 23 Oct 2012 15:31:19 -0600

urte,

I should point out that there is an alternative to auditting congestion.
That is to simply resume sending traffic after a short period (1.4-2.0
seconds).  If the network is still congested, you should get a SCON message
rather immediately.  Otherise, traffic can just continue.

--brian

Brian F. G. Bidulock wrote:                                 (Tue, 23 Oct 2012 15:23:12)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Tue, 23 Oct 2012 16:19:57 -0600

David,

SCON(0) is a valid message indicating "No congestion" for networks
the implement multiple congestion levels.  SCON messages for
international method do not include a congestion level parameter.

In international networks, congestion abatement is signalled in
response to DAUD with a DAVA not preceded by a SCON.

There is an implementation note undef RFC4666/3.4.4 that indicates
that an M3UA may maintain a timer to control congestion notification
vality that will be useful in cases where the peer node fails to
indicate congestion abatement.

There is also a note undef RFC4666/4.5.3 ASP Auditing that states
that periodic DAUD should not be initiated in response to SCON(0)
(i.e. multiple congestion level network signalling congestion
abatement).

--brian

David Laight wrote:                                        (Tue, 23 Oct 2012 16:21:38)
>    This means that the `AS' box isn't running MTP3, so your descriptions
>    about routing are incorrect.
> 
> 
>    IIRC M3UA also doesn't contain any such message.
> 
>    The `congestion level' will be 1, 2 or 3 in ansi networks, and always 0
>    in ITU networks.
> 
> 
>                    David
> 

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Tue, 23 Oct 2012 16:23:37 -0600

Satya,

An SG is not always able to notify congestion abatement in the
multiple SG as STP configuration.  In this configuration the
AS is responsible for maintaining the state of routes, route lists
and routesets toward the SS7 network via each SG/STP.

What you way really only applys to the normal case where the
SG "owns" the AS point code (i.e. the SG is an SEP and not an
STP in an STP pair).

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/