Subject: [Sigtran] Simultaneous support single exchange and double exchange in M3UA

From: Kevin Peterson <[email-masked]>
Date: Sun, 18 Aug 2013 06:20:54 +0000

Hi, 

Can one implementation support single exchange and double exchange models of IPSP at the same time ? Or does it have to be configured and only one of the models can be active at a time ? Is there any M3UA procedure which can help in dynamic negotiation of SE/DE models.

Thanks,
Kevin Peterson

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Sun, 18 Aug 2013 06:33:10 -0600

Kevin,

SE support is mandatory.  DE support is optional.  Therefore, when an
implementation supports DE it must also support SE.

Some implementations might only support one model at a time for a
given AS/ASP, but that is a (minor) limitiation of that implementation.

There is no need for negotiation: all implementations supporting IPSP
MUST support SE: so just use that.

Nevertheless, when an IPSP sends an ASP-UP message and receives an
ASP-UP message in response, or sends an ASP-ACTIVE message and receives
an ASP-ACTIVE message in response, it can determine that the peer
is using DE mode and proceed accordingly.

It can also determine DE mode from REGREQ messages in a similar manner
when registration is used.

--brian

Kevin Peterson wrote:                     (Sun, 18 Aug 2013 06:20:54)
> Hi, 
> 
> Can one implementation support single exchange and double exchange
> models of IPSP at the same time ? Or does it have to be configured and
> only one of the models can be active at a time ? Is there any M3UA
> procedure which can help in dynamic negotiation of SE/DE models.
> 

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/