Subject: [Sigtran] Query regarding SLC

From: Ajay Garg <[email-masked]>
Date: Fri, 28 Mar 2014 17:19:23 +0530

Hi all.

Does SLC select a "SCTP-link" within a "SCTP-linkset", or a "stream" within
a "SCTP-link", or both?

Will be grateful for clarifications.

Thanks and Regards,
Ajay

---

From: Ajay Garg <[email-masked]>
Date: Fri, 28 Mar 2014 17:22:22 +0530

Pardon me.. I meant "SLS".

On Fri, Mar 28, 2014 at 5:19 PM, Ajay Garg <[email-masked]> wrote:

> Hi all.
>
> Does SLC select a "SCTP-link" within a "SCTP-linkset", or a "stream"
> within a "SCTP-link", or both?
>
>

-- 
Regards,
Ajay

---

From: David Laight <[email-masked]>
Date: Fri, 28 Mar 2014 12:01:40 +0000

Messages sent by a userpart with the same sls must take the same route
through the network so that they arrive at the destination in the same order
as they were sent.

                David

From: Sigtran [mailto:[email-masked]] On Behalf Of Ajay Garg
Sent: 28 March 2014 11:52
To: [email-masked]
Subject: Re: [Sigtran] Query regarding SLC

On Fri, Mar 28, 2014 at 5:19 PM, Ajay Garg <[email-masked]<mailto:[email-masked]>> wrote:
Hi all.
Does SLC select a "SCTP-link" within a "SCTP-linkset", or a "stream" within a "SCTP-link", or both?

Thanks and Regards,
Ajay

--
Regards,
Ajay

---

From: Ajay Garg <[email-masked]>
Date: Fri, 28 Mar 2014 17:42:04 +0530

Thanks David for the reply.

But I am still unclear about following points ::
===============================

1)
Is there a one-to-one mapping between a SLS and a SCTP-link? Or a
one-to-many mapping between a SLS and SCTP-links?

2)
Assuming there is a one-to-one mapping, still there might be chances of
sequencing-failures, *IF* different "streams" are selected within the same
SCTP-link?

Thanks and Regards,
Ajay

On Fri, Mar 28, 2014 at 5:31 PM, David Laight <[email-masked]>wrote:

> *From:* Sigtran [mailto:[email-masked]] *On Behalf Of *Ajay Garg
> *Sent:* 28 March 2014 11:52
> *To:* [email-masked]
> *Subject:* Re: [Sigtran] Query regarding SLC
>
>
>
> Registered Address Lakeside, Bramley Road, Mount Farm, Milton Keynes, MK1
> 1PT, UK
> Registration No: 1397386 (Wales)
>
> P *Please consider the environment and don't print this e-mail unless you
> really need to*
>
>

-- 
Regards,
Ajay

---

From: David Laight <[email-masked]>
Date: Fri, 28 Mar 2014 13:14:50 +0000

Read what I wrote ...
The route through the network has to depend on the sls.
So the ‘stream’ on an sctp link has to depend on the sls.

Unless you know by some other means that the ordering of the traffic doesn’t matter.
Which can be arranged to be true for locally generated TCAP traffic that that doesn’t
request ‘sequential delivery’ from SCCP, and has not been fragmented.

                David

From: Ajay Garg [mailto:[email-masked]]
Sent: 28 March 2014 12:12
To: David Laight
Cc: [email-masked]
Subject: Re: [Sigtran] Query regarding SLC

1)
Is there a one-to-one mapping between a SLS and a SCTP-link? Or a one-to-many mapping between a SLS and SCTP-links?

2)
Assuming there is a one-to-one mapping, still there might be chances of sequencing-failures, IF different "streams" are selected within the same SCTP-link?

Thanks and Regards,
Ajay

On Fri, Mar 28, 2014 at 5:31 PM, David Laight <[email-masked]<mailto:[email-masked]>> wrote:
Messages sent by a userpart with the same sls must take the same route
through the network so that they arrive at the destination in the same order
as they were sent.

                David

From: Sigtran [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Ajay Garg
Sent: 28 March 2014 11:52
To: [email-masked]<mailto:[email-masked]>
Subject: Re: [Sigtran] Query regarding SLC

Thanks and Regards,
Ajay

--
Regards,
Ajay

Registered Address Lakeside, Bramley Road, Mount Farm, Milton Keynes, MK1 1PT, UK
Registration No: 1397386 (Wales)

P Please consider the environment and don't print this e-mail unless you really need to

--
Regards,
Ajay