Subject: [Sigtran] Query for "Routing Context"

From: Ajay Garg <[email-masked]>
Date: Sun, 16 Mar 2014 21:11:47 +0530

Hi all.

I have exactly the same query as asked already at
http://www.ietf.org/mail-archive/web/sigtran/current/msg08662.html.

In particular, where is the mapping/indexing for Routing-Key <->
Routing-Context kept? At the AS?  At the SG?  Both?
A Hello-worldish state-machine diagram will be highly appreciated !! :)

Thanks and Regards,
Ajay

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Sun, 16 Mar 2014 15:26:48 -0600

Ajay,

Please see comments below...

Ajay Garg wrote:                                 (Sun, 16 Mar 2014 21:11:47)
>    [1]http://www.ietf.org/mail-archive/web/sigtran/current/msg08662.html.

The answer to exactly that same query is already at
http://www.ietf.org/mail-archive/web/sigtran/current/msg08664.html

>    Routing-Context kept? At the AS?  At the SG?  Both?

At the SG.  An ASP can discover a mapping using the dynamic registration
procedure.  If an ASP is statically configured it will need to be
statically configured.

>    A Hello-worldish state-machine diagram will be highly appreciated !! :)

  Table State        Action
  -----------        ------
  Empty ---------------+
                       |
                       v
                You fill it out
                       |
  Full <---------------+

  ;)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Sun, 16 Mar 2014 22:11:46 -0600

Ajay,

You might want to take a look at a couple of MIBS for M3UA
that I wrote years ago.  These are not standardized
(unfortunately, the WG did not finalize an M3UA MIB before
shutting down); however, if you are used to reading SNMP mibs
they might be of some use to you in understanding the
provisioning challenges of the protocol.  You can view them
here:

  http://www.openss7.org/docs/OPENSS7-M3UA-TC.mib
  http://www.openss7.org/docs/OPENSS7-M3UA-ASP-MIB.mib
  http://www.openss7.org/docs/OPENSS7-M3UA-SGP-MIB.mib

They are named a little funny: the ASP-MIB handles
provisining of ASP information at an SG; the SGP-MIB,
SGP and SG information at an ASP.  You will find the
RC table in the m3uaAspRcTable element in the ASP-MIB.

Hope that helps...

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: Ajay Garg <[email-masked]>
Date: Mon, 17 Mar 2014 11:24:00 +0530

Thanks Brian !!

One query ::
=========

As per 5.1.1.1 <https://tools.ietf.org/html/rfc4666#section-5.1.1.1>.
"Single ASP in an Application Server ("1+0" Sparing), No Registration", the
Routing-Context is initially sent from the ASP to SGP. Let's say, the ASP
fills in "RC_ASP".

In this case, is "RC_ASP" ANY integer, which the ASP and SGP then use? Or
"RC_ASP" needs to be "defined" in some way at the ASP (before being sent to
the SGP in the "ASP Active" message)?

Thanks and Regards,
Ajay

---

From: Ajay Garg <[email-masked]>
Date: Mon, 17 Mar 2014 11:30:25 +0530

Brian.

Oops.. just saw your other mail.. guess
http://www.openss7.org/docs/OPENSS7-M3UA-ASP-MIB.mib is what I need !!
Sorry for the noise :-\

Sorry, Thanks and Regards,
Ajay

On Mon, Mar 17, 2014 at 11:24 AM, Ajay Garg <[email-masked]> wrote:

> "Single ASP in an Application Server ("1+0" Sparing), No Registration",
> the Routing-Context is initially sent from the ASP to SGP. Let's say, the
> ASP fills in "RC_ASP".
>
> On Mon, Mar 17, 2014 at 2:56 AM, Brian F. G. Bidulock <
> [email-masked]> wrote:
>
>> Ajay,
>>
>> >    [1]

-- 
Regards,
Ajay