Subject: RE: [Simple] We need a clear description of Presence

From: "Boyer, David G (Dave)" <[email-masked]>
Date: Tue, 19 Mar 2002 09:32:26 -0500

> -----Original Message-----
> From: Jonathan Rosenberg [mailto:[email-masked]]
> Sent: Tuesday, March 19, 2002 12:14 AM
> To: Paul Kyzivat
> Cc: Li Hua Tang; [email-masked]
> Subject: Re: [Simple] We need a clear description of Presence
> 
> 
> 
> 
> Paul Kyzivat wrote:
> > 
> 
> > If you receive a voice call, and want to indicate unavailability for
> > voice,
> > but continued availability to chat, you might reregister:
> > 
> >         REGISTER ...
> >         ...
> >         Contact: sip:your@device;media="message/*"
> > 
> > They you would update this again at completion of your call when
> > you are again willing to receive voice.
> > 
> > Given a suitable linkage between the registrar and presence server,
> > then these changes ought to be reported as presence changes.

Presence changes should also be reportable by non-communicative devices -
video motion detection/face recognition, blue-tooth node registration,
etc.  Desiring presence information about someone does not necessarily imply
the desire to communicate with that person.
...
> 
> Using caller prefs for the UA to explicitly set presence is bad, since
> it depends on the UA knowing the policy of the presence server in its
> construction of the presence doc. By being explicit, i..e, "set my
> presence to available", that problem is avoided.

Shouldn't availability be expressible on a per user basis, not just
globally?
> 
> That said, I think much work is needed to build upon PIDF and 
> add status
> values and other parameters needed for a more expressive 
> system. At the
> very least, we need some statuses for IM. I would really like to see
> such a work item picked up by SIMPLE.
> 
> Thanks,
> Jonathan R.
> 
> 
> -- 
> Jonathan D. Rosenberg, Ph.D.            72 Eagle Rock Avenue
> Chief Scientist                         First Floor
> dynamicsoft                             East Hanover, NJ 07936
> [email-masked]                 FAX: (973) 952-5050
> http://www.jdrosen.net                  PH:  (973) 952-5000
> http://www.dynamicsoft.com
> _______________________________________________
> simple mailing list
> [email-masked]
> http://mailman.dynamicsoft.com/mailman/listinfo/simple
> 
_______________________________________________
simple mailing list
[email-masked]
http://mailman.dynamicsoft.com/mailman/listinfo/simple

---

From: Paul Kyzivat <[email-masked]>
Date: Tue, 19 Mar 2002 11:36:40 -0500

comments below.

	Paul

> the desire to communicate with that person.

I don't understand your point. Devices must be communicative in some way
to report presence. Are you saying that some devices that don't do sip
may want to update presence?

I am not suggesting that registration must be the *only* way of doing so.

But I am suggesting that a *subset* of the presence information is in
1:1 correspondence to registration information, and that *one way*
for that information to get into the presence document is via the registrar.

I realize this is controversial, but I believe that it is *best* for
the presence server to get that portion of the presence document content
from the registrar. This is analogous to expecting a proxy server and
registrar to communicate via an unspecified location service.

> Shouldn't availability be expressible on a per user basis, not just

Again I don't understand your point. ("Not just globally?" ???)
                                           ****
_______________________________________________
simple mailing list
[email-masked]
http://mailman.dynamicsoft.com/mailman/listinfo/simple

---

From: Jonathan Rosenberg <[email-masked]>
Date: Tue, 19 Mar 2002 21:44:09 -0500

Paul Kyzivat wrote:

> registrar to communicate via an unspecified location service.

I don't want to ever dictate policy on how a PA composes a presence
document. Its that simple. All we can do is provide ways for a user to
explicitly indicate what they want. How the PA collects that information
and generates a composite presence document MUST be permitted to be
entirely a matter of local policy.

-Jonathan R.

---

From: "Ben Campbell" <[email-masked]>
Date: Wed, 20 Mar 2002 09:18:02 -0600

> From: [email-masked]
> [mailto:[email-masked]]On Behalf Of Paul Kyzivat
> Sent: Tuesday, March 19, 2002 10:37 AM
> To: Boyer, David G (Dave)
> Cc: Jonathan Rosenberg; Li Hua Tang; [email-masked]

That is a perfectly acceptable and useful presence service to build with
SIMPLE. But SIMPLE must not mandate that particular service. I can envision
SIMPLE related services with no registrar involved at all.