Subject: [Simple] I-D ACTION:draft-ietf-simple-winfo-format-01.txt

From: [email-masked]
Date: Fri, 08 Mar 2002 07:00:24 -0500

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the SIP for Instant Messaging and Presence Leveraging Extensions Working Group of the IETF.

	Title		: An XML Based Format for Watcher Information
	Author(s)	: J. Rosenberg
	Filename	: draft-ietf-simple-winfo-format-01.txt
	Pages		: 10
	Date		: 07-Mar-02
	
Watchers are defined as entities that request (i.e., subscribe to)
information about a resource. There is fairly complex state
associated with these subscriptions. The union of the state for all
subscriptions to a particular resource is called the watcher
information for that resource.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-ietf-simple-winfo-format-01.txt

To remove yourself from the IETF Announcement list, send a message to 
ietf-announce-request with the word unsubscribe in the body of the message.

Internet-Drafts are also available by anonymous FTP. Login with the username
"anonymous" and a password of your e-mail address. After logging in,
type "cd internet-drafts" and then
	"get draft-ietf-simple-winfo-format-01.txt".

A list of Internet-Drafts directories can be found in
http://www.ietf.org/shadow.html 
or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

Internet-Drafts can also be obtained by e-mail.

Send a message to:
	[email-masked].
In the body type:
	"FILE /internet-drafts/draft-ietf-simple-winfo-format-01.txt".
	
NOTE:	The mail server at ietf.org can return the document in
	MIME-encoded form by using the "mpack" utility.  To use this
	feature, insert the command "ENCODING mime" before the "FILE"
	command.  To decode the response(s), you will need "munpack" or
	a MIME-compliant mail reader.  Different MIME-compliant mail readers
	exhibit different behavior, especially when dealing with
	"multipart" MIME messages (i.e. documents which have been split
	up into multiple messages), so check your local documentation on
	how to manipulate these messages.

Below is the data which will enable a MIME compliant mail reader
implementation to automatically retrieve the ASCII version of the
Internet-Draft.

---

From: Paul Kyzivat <[email-masked]>
Date: Fri, 08 Mar 2002 11:49:51 -0500

I have a question about:

        duration: The amount of time, in seconds, that the subscription
             was in the previous state before transitioning to the state
             described in the status parameter.

I can see how this can be useful when receiving a notification containing only changes. But it is less useful when doing a fetch, or when receiving the initial notification
following a subscription. In those cases there is no way to know how long the subscription has been in the current state.

One solution would be to provide two values. But I think it is sufficient to provide only the duration in the current state. This is clearly the value needed when you have
no prior information about the subscription. If you have a prior value, then the total time in the prior state, if desired, can be computed using the prior duration value,
the time the last notification was sent, and the time the current notification was sent.

	Paul
_______________________________________________
simple mailing list
[email-masked]
http://mailman.dynamicsoft.com/mailman/listinfo/simple

---

From: Jonathan Rosenberg <[email-masked]>
Date: Wed, 20 Mar 2002 00:34:37 -0500

Paul Kyzivat wrote:
> I can see how this can be useful when receiving a notification
> containing only changes. But it is less useful when doing a fetch, or
> when receiving the initial notification
> following a subscription. 

Agreed.

> In those cases there is no way to know how
> long the subscription has been in the current state.

Good point.

> 
> One solution would be to provide two values. But I think it is
> sufficient to provide only the duration in the current state. This is
> clearly the value needed when you have
> no prior information about the subscription. If you have a prior value,
> then the total time in the prior state, if desired, can be computed
> using the prior duration value,

Seems reasonable. Of course, now the opposite problem occurs.
Notifications sent on state changes will always have a duration of zero,
providing meaningless information. So, either the fetch and
subscribe-triggered notifies have useless durations, or the
event-triggered notifications have useless durations....

-Jonathan R.

-- 
Jonathan D. Rosenberg, Ph.D.            72 Eagle Rock Avenue
Chief Scientist                         First Floor
dynamicsoft                             East Hanover, NJ 07936
[email-masked]                 FAX: (973) 952-5050
http://www.jdrosen.net                  PH:  (973) 952-5000
http://www.dynamicsoft.com
_______________________________________________
simple mailing list
[email-masked]
http://mailman.dynamicsoft.com/mailman/listinfo/simple