Subject: RE: [Simple] We need a clear description of Presence

From: "Boyer, David G (Dave)" <[email-masked]>
Date: Tue, 19 Mar 2002 11:44:40 -0500

> -----Original Message-----
> From: Paul Kyzivat [mailto:[email-masked]]
> Sent: Tuesday, March 19, 2002 11:37 AM
> To: Boyer, David G (Dave)
> Cc: Jonathan Rosenberg; Li Hua Tang; [email-masked]
> Subject: Re: [Simple] We need a clear description of Presence
> 
> 
> comments below.
> 
> 	Paul
> 
> "Boyer, David G (Dave)" wrote:
> > 
> > > -----Original Message-----
> > > From: Jonathan Rosenberg [mailto:[email-masked]]
> > > Sent: Tuesday, March 19, 2002 12:14 AM
> > > To: Paul Kyzivat
> > > Cc: Li Hua Tang; [email-masked]
> > > Subject: Re: [Simple] We need a clear description of Presence
> > >
> > >
> > >
> > >
> > > Paul Kyzivat wrote:
> > > >
> > >
> > > > If you receive a voice call, and want to indicate 
> unavailability for
> > > > voice,
> > > > but continued availability to chat, you might reregister:
> > > >
> > > >         REGISTER ...
> > > >         ...
> > > >         Contact: sip:your@device;media="message/*"
> > > >
> > > > They you would update this again at completion of your call when
> > > > you are again willing to receive voice.
> > > >
> > > > Given a suitable linkage between the registrar and 
> presence server,
> > > > then these changes ought to be reported as presence changes.
> > 
> > Presence changes should also be reportable by 
> non-communicative devices -
> > video motion detection/face recognition, blue-tooth node 
> registration,
> > etc.  Desiring presence information about someone does not 
> necessarily imply
> > the desire to communicate with that person.
> 
> I don't understand your point. Devices must be communicative 
> in some way
> to report presence. Are you saying that some devices that don't do sip
> may want to update presence?

Definitly - biometric devices are not capable of communications
but can indicate very accurate presence information, surveillance
cameras can be used to uniquely identify individuals, etc.  This
presence information should also be recorded in a Presence server.
Perhaps this is out side the scope of SIP, but it is not outside
the scope of a presence service.
> 
> I am not suggesting that registration must be the *only* way 
> of doing so.
> 
> But I am suggesting that a *subset* of the presence information is in
> 1:1 correspondence to registration information, and that *one way*
> for that information to get into the presence document is via 
> the registrar.
> 
> I realize this is controversial, but I believe that it is *best* for
> the presence server to get that portion of the presence 
> document content
> from the registrar. This is analogous to expecting a proxy server and
> registrar to communicate via an unspecified location service.

This is fine for SIP devices.  Perhaps the answer is that the other
devices need to communicate to the Presence server via a different means,
although it seems that using the SIP registration method would make sense
for these non-standard devices.
> 
> > > Using caller prefs for the UA to explicitly set presence 
> is bad, since
> > > it depends on the UA knowing the policy of the presence 
> server in its
> > > construction of the presence doc. By being explicit, i..e, "set my
> > > presence to available", that problem is avoided.
> > 
> > Shouldn't availability be expressible on a per user basis, not just
> > globally?
> 
> Again I don't understand your point. ("Not just globally?" ???)
>                                            ****
The way Johnathan worded setting availability above sounded to me that 
availability is something you toggle on and off.  Availability can be
more complex than that.  I am available to Johnathan through IM only,
I am available to Paul via cell-phone and IM, etc.  Perhaps I misunderstood
Johnathans comment.

Dave
_______________________________________________
simple mailing list
[email-masked]
http://mailman.dynamicsoft.com/mailman/listinfo/simple

---

From: Jonathan Rosenberg <[email-masked]>
Date: Tue, 19 Mar 2002 21:42:21 -0500

"Boyer, David G (Dave)" wrote:

> the scope of a presence service.

It is within the scope of a SIP based presence system to report presence
that includes that kind of information. It is fundamental to the model
we have been advocating that a presence document is a composition of
data sources from potentially disparate devices. In this case, it is
very unlikely that the presence data arrives to the server via SIP, but
it doesn't have to in order to be distributed by a SIP based presence
server. 

> I am available to Paul via cell-phone and IM, etc.  Perhaps I

I wasn't saying it was global. I was merely saying that a user should be
allowed to explicitly ask the server to set particular aspects of a
presence document, and the way it does this is by publishing such a
document to the server. Whether the presence server uses the values it
provides is a matter of local policy, but at least the server knows the
intent of the user.

-Jonathan R.

-- 
Jonathan D. Rosenberg, Ph.D.            72 Eagle Rock Avenue
Chief Scientist                         First Floor
dynamicsoft                             East Hanover, NJ 07936
[email-masked]                 FAX: (973) 952-5050
http://www.jdrosen.net                  PH:  (973) 952-5000
http://www.dynamicsoft.com
_______________________________________________
simple mailing list
[email-masked]
http://mailman.dynamicsoft.com/mailman/listinfo/simple