Subject: [Simple] Questions on draft-ietf-simple-filter-format-05

From: Goix Walter <[email-masked]>
Date: Mon, 14 Nov 2005 19:13:38 +0100

Hi,

I have a couple of questions regarding the handling on <exclude> filters in an Event Server:

- when only an <exclude> filter is present (no <include>), does the server need to provide the *whole* document but the excluded part, or is it implicit? In other words, do the server need an <include> filter as well to consider the whole document or part of it before to apply the <exclude> filter?

- when the <exclude> filter asks for removing a mandatory element, which is nesting elements from another namespaces, what would be the result of the exclusion process: is it the full content of the mandatory element, or only an 'empty' (or minimally valid) element. Below is an example:

1. <foo> is a mandatory element within <root> with an <any> only, i.e. it does not have any attribute nor mandate any sub-element
2. document in the server is:
<root>
<foo>
<o:bar>something</o:bar>
</foo>
</root>

3. filter contains
<exclude>
//root/foo
</exclude>

4. Result of filtering process is
(a)
<root>
<foo></foo>
</root>

or (b)
<root>
<foo>
<o:bar>something</o:bar>
</foo>
</root>   
?

Thanks for the clarification
Walter

Gruppo Telecom Italia - Direzione e coordinamento di Telecom Italia S.p.A.

====================================================================
CONFIDENTIALITY NOTICE
This message and its attachments are addressed solely to the persons
above and may contain confidential information. If you have received
the message in error, be informed that any use of the content hereof
is prohibited. Please return it immediately to the sender and delete
the message. Should you have any questions, please send an e_mail to
[email-masked]. Thank you
====================================================================

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: Hisham Khartabil <[email-masked]>
Date: Wed, 16 Nov 2005 08:50:20 +0100

On Nov 14, 2005, at 7:13 PM, Goix Walter wrote:

> - when only an <exclude> filter is present (no <include>), does the 
> server need to provide the *whole* document but the excluded part, or 
> is it implicit? In other words, do the server need an <include> filter 
> as well to consider the whole document or part of it before to apply 
> the <exclude> filter?

The draft states

"   The <exclude> element is used to define exceptions to the set of XML
    elements and/or attributes selected by the <include> elements."

So having an <exclude> without an <include> seems to be semantically 
wrong.

>
> - when the <exclude> filter asks for removing a mandatory element, 
> which is nesting elements from another namespaces, what would be the 
> result of the exclusion process: is it the full content of the 
> mandatory element, or only an 'empty' (or minimally valid) element. 
> Below is an example:
>
> 1. <foo> is a mandatory element within <root> with an <any> only, i.e. 
> it does not have any attribute nor mandate any sub-element

(b) is the choice.

 From the draft

"if
    the step in applying the <exclude> element value to an XML document
    results in an invalid document according to the schema, that step
    MUST be reveresed resulting in the elements and/or attributes being
    re-introduced into the resulting XML document, with their previous
    values, in order to make it valid."

Thanks,
Hisham