Subject: RE: [Simple] Issue 6: Consolidation

From: "Burger, Eric" <[email-masked]>
Date: Tue, 8 Nov 2005 07:24:44 -0500

This would be an important decision.  Everything becomes so easy if we
don't have consolidation.

Can we punt it?  My vote is "yes."  Hisham's vote is "yes."  Anyone else
for "yes" or "no"?

-----Original Message-----
From: Hisham Khartabil [mailto:[email-masked]] 
Sent: Monday, November 07, 2005 3:59 PM
To: Burger, Eric
Cc: [email-masked]
Subject: Re: [Simple] Issue 6: Consolidation

Actually, some parts of the draft talks about consolidation of 
responses and other parts of the draft say that consolidation was 
removed from the draft. I don't like the consolidation concept, mainly 
because it creates state in the B2BUA that is not really necessary.

I think having individual MDNs delivered to the IM sender is enough.

Hisham

On Nov 7, 2005, at 4:24 PM, Burger, Eric wrote:

> The IMDN draft says that whether a B2BUA consolidates responses is a
> local to the B2BUA matter.
>
> Should this be negotiable (via a Requires: CPIM header)?
>
> _______________________________________________
> Simple mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/simple
>

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: Ben Campbell <[email-masked]>
Date: Tue, 8 Nov 2005 10:55:01 -0800

Does consolidation need to be standardized? If we don't say anything  
about consolidation, do we prevent a list-exploder from consolidating  
as a matter of local policy?

---

From: Hisham Khartabil <[email-masked]>
Date: Tue, 8 Nov 2005 20:21:43 +0100

You would need to standardise the XML schema that carries the collected 
MDNs.

Also, not subject to standardisation, you need the relay (exploder) to 
keep state for x units of time.

Hisham

---

From: Ben Campbell <[email-masked]>
Date: Tue, 8 Nov 2005 15:36:18 -0800

I think that, given all that has been said, I agree that  
consolidation should go.

Thanks!

Ben.

On Nov 8, 2005, at 11:21 AM, Hisham Khartabil wrote:

> You would need to standardise the XML schema that carries the  
> collected MDNs.
>
> Also, not subject to standardisation, you need the relay (exploder)  
> to keep state for x units of time.
>
> Hisham
>> Does consolidation need to be standardized? If we don't say  
>> anything about consolidation, do we prevent a list-exploder from  
>> consolidating as a matter of local policy?
>>