Subject: [Simple] Issue 2: Sender keeps state

From: "Burger, Eric" <[email-masked]>
Date: Mon, 7 Nov 2005 10:24:50 -0500

In MDN, the message itself keeps state.  In the e-mail world, there is
no requirement for the UAC to keep the state of messages sent.  When the
UAS sends a MDN, it includes the message itself so the user can figure
out what the report is about.

This has turned into a major SPAM hole.  Folks send out SPAM
masquerading as a MDN.

I'd like to close this hole, which is what the draft does.  However, it
imposes the burden of the UAC keeping state of messages it sends.  My
logic is that this is a tiny price to pay to close the SPAM hole.

OK with everyone?

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: Hisham Khartabil <[email-masked]>
Date: Mon, 7 Nov 2005 19:57:02 +0100

I don't agree that state is needed at the client. SPAM will be solved 
elsewhere. And a UAS does not need to put the actual IM in the MDN. 
Often enough, the URI of the recipient of the IM is, imo, enough for 
the human user to know what this MDN is for. Having said that, we 
should not stop implementations from keeping state if they want to.

Also, think of having an inbox and and sent box (just like email or sms 
in your mobile phone). In those cases, the client is, soft of, keeping 
state until the user deletes items from the sent box. Matching of MDNs 
and IMs in this case can be done using message-id-

Hisham

---

From: Xiao Wang <[email-masked]>
Date: Tue, 08 Nov 2005 09:54:49 +0800

Burger,

But how long does the UAC keep state of messages it sends?
Because we don't know the UAS what time to send IMDN back, 
maybe an hour, a day, a month, or it dose not send back at all.
And before UAS send it back, UAC may restart some times.
So I think if have another way to resolve this issue, 
for example, the summary of message?

Xiao

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf
Of
> Burger, Eric
> Sent: Monday, November 07, 2005 11:25 PM
> To: [email-masked]
> Subject: [Simple] Issue 2: Sender keeps state
>

---

From: Xiao Wang <[email-masked]>
Date: Tue, 08 Nov 2005 10:26:18 +0800

This is a way. But if user delete items from sent box ,
receiving MDNs  don't have matching any IMs.
Now, inbox and sent box in the mobile phone are not big enough,
So they are often cleaned up.

Xiao

Of
> Hisham Khartabil
> Sent: Tuesday, November 08, 2005 2:57 AM
> To: Burger, Eric
> Cc: [email-masked]
> Subject: Re: [Simple] Issue 2: Sender keeps state
>