Subject: [Simple] xcap-list-usage schema doubt

From: Anurag Chakravarti <[email-masked]>
Date: Fri, 11 Nov 2005 04:45:30 -0500

Hi,
In draft-ietf-simple-xcap-list-usage-05 the schema for resource list
documents contains the following element.

<xs:complexType name="listType">
     <xs:sequence>
      <xs:element name="display-name" type="display-nameType"
minOccurs="0"/>
      <xs:sequence minOccurs="0" maxOccurs="unbounded">
       <xs:choice>
        <xs:element name="list">
         <xs:complexType>
          <xs:complexContent>
           <xs:extension base="listType"/>
          </xs:complexContent>
         </xs:complexType>
        </xs:element>
.....
.....

Is extending from the base type itself permitted. In the above, element
"list" extends from the complexType "listType". 

If we want recursive lists then 
<xs:element name="list" type="listType"/>
should suffice.

Particularly my parser throws error "Unique Particle Attribution" in the
former case. Maybe it is a bug with the parser (jaxp implementation)

Could some please comment on the choice for the former type.
-Anurag

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: [email-masked]
Date: Fri, 11 Nov 2005 16:00:29 +0200

Hi !

Good catch, yes this schema violates the infamous Unique Particle
Attribution (UPA) constraint (well yet another example that we should
switch using RELAX NG ;-)). It is not about recursion it is about
overlapping wildcards. So the first definition should be removed. Also
there are some processContents="lax" definitions that seem to be
missing, 48hours ?

btw. feel free to use a w3c schema validation web form tool at
<http://validate.openlaboratory.net/> which is based on xerces c++
(checks also UPA violations). This tool is also linked from
tools.ietf.org website.
br,
Jari

-----Original Message-----
From: [email-masked] on behalf of ext Anurag Chakravarti
Sent: Fri 11/11/2005 11:45 AM
To: [email-masked]
Subject: [Simple] xcap-list-usage schema doubt
 
Hi,