Subject: RE: [Simple] Multiple Media in MSRP SEND Request

From: [email-masked]
Date: Thu, 15 Dec 2005 09:15:11 +0530

How other side know abt that all of the three send request belongs to
the same message? Will use continuation flag (+) in the end line solve
this problem?

Regards,
Amit Kumar Goel
Infineon Technology,
11th Floor, Discoverer Building,
Whitefield,ITPL,
Bangalore-560066
Ph: +91(080)41392721
Mobile:9448948977

-----Original Message-----
From: Cullen Jennings [mailto:[email-masked]] 
Sent: Thursday, December 15, 2005 6:07 AM
To: Paul H Kyzivat; Goel Amitkumar (IFIN CSW WS)
Cc: [email-masked]
Subject: Re: [Simple] Multiple Media in MSRP SEND Request

Yes, what Paul said. Imagine you wanted to sent a GIF image of yourself,
a vcard with your contact information, and the message "Hello" all at
the same time. You could send these with three SEND requests all at the
same time.

On 12/14/05 6:08 AM, "Paul Kyzivat" <[email-masked]> wrote:

> The only constraint over what you put in the messages is the set of 
> content types that are negotiated in the offer/answer. If you 
> negotiate the use of mutiple mime types that represent different media

> then you are free to use one type in one SEND and a different type in 
> another SEND. And if you negotiate the use of multipart then you can 
> include multiple types in the same SEND.
> 
> Paul
> 
> [email-masked] wrote:
>> Hi All,
>>  
>> I am going through the draft-ietf-simple-message-sessions-11.txt and 
>> other related documents. I have one doubt. Is it possible to send 
>> multiple media in a same message? Suppose I am exchanging text 
>> messages to my friend  by using MSRP session. At some point of time I

>> also want to send some Audio along with the text message. Is this 
>> scenario possible in MSRP session messaging? If yes, how will user 
>> create the SEND request?
>>  
>> Regards,
>> Amit Kumar Goel
>> Infineon Technology,
>> 11th Floor, Discoverer Building,
>> Whitefield,ITPL,
>> Bangalore-560066
>> Ph: +91(080)41392721
>> Mobile:9448948977
>>  
>> 
>> 
>> ---------------------------------------------------------------------
>> ---
>> 
>> _______________________________________________
>> Simple mailing list
>> [email-masked] https://www1.ietf.org/mailman/listinfo/simple
> 
> _______________________________________________
> Simple mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/simple

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: Paul Kyzivat <[email-masked]>
Date: Thu, 15 Dec 2005 00:03:39 -0500

The way Cullen described they won't be one message - they will be three.

If you want them in one message, put them in a multipart/mixed and then 
into one SEND.

	Paul