Subject: [Simple] Multiple Media in MSRP SEND Request

From: [email-masked]
Date: Wed, 14 Dec 2005 16:22:53 +0530

Hi All,
 
I am going through the draft-ietf-simple-message-sessions-11.txt and
other related documents. I have one doubt. Is it possible to send
multiple media in a same message? Suppose I am exchanging text messages
to my friend  by using MSRP session. At some point of time I also want
to send some Audio along with the text message. 
Is this scenario possible in MSRP session messaging? If yes, how will
user create the SEND request?
 
Regards,
Amit Kumar Goel
Infineon Technology,
11th Floor, Discoverer Building,
Whitefield,ITPL,
Bangalore-560066
Ph: +91(080)41392721
Mobile:9448948977
 
_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: Vinod Joseph <[email-masked]>
Date: Wed, 14 Dec 2005 18:20:21 +0530

SIP provides the opportunity for multiple media types in a single session or
in related sessions to stay together, if that is what is desired.

On 12/14/05, [email-masked] <[email-masked]>
wrote:
>
> Hi All,
>
> I am going through the draft-ietf-simple-message-sessions-11.txt and other
> related documents. I have one doubt. Is it possible to send multiple media
> in a same message? Suppose I am exchanging text messages to my friend
> by using MSRP session. At some point of time I also want to send some
> Audio along with the text message.
> Is this scenario possible in MSRP session messaging? If yes, how will user
> create the SEND request?
>
> Regards,
> Amit Kumar Goel
> Infineon Technology,

--
Vinod Cherian Joseph
SISO

---

From: Paul Kyzivat <[email-masked]>
Date: Wed, 14 Dec 2005 09:08:16 -0500

The only constraint over what you put in the messages is the set of 
content types that are negotiated in the offer/answer. If you negotiate 
the use of mutiple mime types that represent different media then you 
are free to use one type in one SEND and a different type in another 
SEND. And if you negotiate the use of multipart then you can include 
multiple types in the same SEND.

	Paul

[email-masked] wrote:
> ------------------------------------------------------------------------
>

---

From: Cullen Jennings <[email-masked]>
Date: Wed, 14 Dec 2005 16:37:15 -0800

Yes, what Paul said. Imagine you wanted to sent a GIF image of yourself, a
vcard with your contact information, and the message "Hello" all at the same
time. You could send these with three SEND requests all at the same time.