Subject: RE: [Simple] IMDN Issue #1: Security of IMDN

From: "Burger, Eric" <[email-masked]>
Date: Mon, 12 Dec 2005 18:50:31 -0500

How about:

1. If UAS has a certificate, MUST sign IMDN.

2. If message was encrypted, MUST encrypt IMDN.  Doesn't encrypting
cover signing?  If not, to encrypt, need cert, so see rule 1.
 
-----Original Message-----
From: Cullen Jennings [mailto:[email-masked]] 
Sent: Monday, December 12, 2005 1:09 PM
To: Burger, Eric; [email-masked]
Subject: Re: [Simple] IMDN Issue #1: Security of IMDN

On 12/5/05 10:31 AM, "Burger, Eric" <[email-masked]> wrote:

> Proposal is that if the body of the message was encrypted or signed,
the
> IMDN MUST be encrypted or signed, otherwise it MAY be plain text.
> 
> Any dissent?

If the IMDN was only signed, but the original message was encrypted,
would
the IMDN reveal anything that was not in the unencrypted portion of the
message?

This proposal does seem a little weird - what happens if you can't sign
the
IMDN?

Perhaps we might want something like the following 3 rules

Always sign the IMDN if you have a cert.

If the message was singed and encrypted, MUST encrypt repose.

If the message was encrypted, MUST sign IMDN.

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: Cullen Jennings <[email-masked]>
Date: Wed, 14 Dec 2005 16:41:34 -0800

> 1. If UAS has a certificate, MUST sign IMDN.
that sounds good.

> cover signing?  If not, to encrypt, need cert, so see rule 1.
You can encrypt without signing. To encrypt a message from A to B, A needs
to have B's cert but A does not have to have a cert. However, I think that I
agree with your proposal here if message was encrypted, MUST encrypt IMDN
and if you can't encrypt the IMDN then MUST NOT send it.