Subject: [Simple] DISTSEND request method in MSRP

From: "Jussi K. Virtanen" <[email-masked]>
Date: Tue, 20 Dec 2005 09:10:51 +0200

Hi,

I have some issues related to the DISTSEND request method,
specified in the conference extension [3] to MSRP:

   1) The base protocol [1] requires that the body of a
      non-SEND request shall not be larger than 2048
      octets.

   2) Per the relay extension [2], a relay should, by
      default, treat requests with unknown request methods
      similarly as a REPORT request: the request should
      not be divided into smaller chunks and should not
      generate responses.

   3) As is already mentioned, the conference extension
      [3] introduces a new request method, DISTSEND, for
      private messages. According to the specification,
      the semantics of the request method are similar to
      SEND with the exception of the Distribution header
      field and the notion of privacy.

Clearly, (3) is in conflict with (1) as the body of a
SEND request can be arbitrary large and with (2) as a relay
that does not implement the DISTSEND request method is
naturally unable to obey, for example, the Failure-Report
header field in a such a request.

Finally, I believe that the capability negotiation related
to private messaging in conferences should be done in the
session establishment phase, not during a session.

   [1] draft-ietf-simple-message-sessions-12
   [2] draft-ietf-simple-msrp-relays-05
   [3] draft-niemi-simple-chat-03

BR,

-- Jussi K. Virtanen

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: [email-masked]
Date: Tue, 20 Dec 2005 14:03:32 +0200

Hi,

I have volunteered to maintain the SIMPLE WG supplementary web site at http://www.softarmor.com/simple. 

One of the most useful sections there is the status info on all SIMPLE related drafts: http://www.softarmor.com/wgdb/index.php?wg=SIMPLE. 

I have updated that page last week, based on e.g. info from auhors of individual I-Ds and IETF 64 minutes and subsequent list discussions. Take a look at the info, and let me know if you have something to update or add. I intend to do major updates at least always sometime after the IETF meeting, and try also otherwise to keep the status up-to-date.

Also, please send me any suggestions on how to improve the supplementary site.

Regards,
	Markus

---

From: Aki Niemi <[email-masked]>
Date: Thu, 29 Dec 2005 10:59:11 +0200

Hi,

Sorry for the delay. Inline.

> header field in a such a request.

Apparently, the size limit was increased to 10 kbytes, but the problem 
still remains.

If indeed relays aren't allowed to re-chunk non-SEND requests, then it 
means that any messaging necessarily needs to always use the SEND method 
and we need to change the chat specification to reflect that.

> session establishment phase, not during a session.

Agreed.

Cheers,
Aki