Subject: RE: [Simple] Filtering: the purpose of the 'ns-binding' element

From: "Thomson, Martin" <[email-masked]>
Date: Wed, 15 Mar 2006 15:06:24 -0600

I think that it is not only redundant, but dangerous.  It is possible to have contradictory values in there and in the xmlns:... attributes.  I can't think of a good reason to include such an element in this context.

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: Wednesday, 15 March 2006 9:25 PM
> To: [email-masked]
> Subject: [Simple] Filtering: the purpose of the 'ns-binding' element
> 
> Hi,
> 
> each filter-set document may contain the 'ns-binding' element.
> Considering that the XML document itself has the means of defining
> namespace abbreviations (xmlns attributes), I do not completely
> understand the purpose of this element.
> 
> Could anyone explain the importance of the 'ns-binding' element? Isn't
> it redundant? Why it doesn't suffice to extract namespace abbreviations
> from the xmlns attributes?
> 
> Thanks, in advance.
> 
> Regards,
> 
> Michal Burda
> 
> _______________________________________________
> Simple mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/simple

------------------------------------------------------------------------------------------------
This message is for the designated recipient only and may
contain privileged, proprietary, or otherwise private information.  
If you have received it in error, please notify the sender
immediately and delete the original.  Any unauthorized use of
this email is prohibited.
------------------------------------------------------------------------------------------------
[mf2]

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: Jari Urpalainen <[email-masked]>
Date: Fri, 17 Mar 2006 12:08:46 +0200

> > from the xmlns attributes?
The subscriber is not typically aware nor need to be aware about the
used prefixes of published presence information. These prefixes are thus
used for XPath evaluations during filtering, i.e. expanding the names
within 'xpath' attribute values of <include> and <exclude> elements. One
could argue that it were simpler just to use in-scope namespaces of
those elements of filter document (just like in xml-patch-ops) but it is
only a matter of taste. As such they are certainly needed. Using
published presence document context here is not right. Still one option
is to use "namespace-uri()" and "local-name()" functions but it leads to
ugly looking and long rules. Default namespace is handled similarly to
XPath 1.0, i.e. a selector "foo" locates a unqualified <foo> element.

br,
Jari