Subject: RE: [Simple] Filtering: triggering functionality - filters for one-time use?

From: <[email-masked]>
Date: Fri, 10 Mar 2006 15:56:26 +0100

So it is intended that filter with trigger <changed to="open"> is
one-time trigger which will result in only one notification and no more?

This makes it impossible to be notified about change to certain state
only; you must always define that you want to be notified about change
from the state, or you will receive one notification only.

Silvestr

> -----Original Message-----
> From: Hisham Khartabil [mailto:[email-masked]]
> Sent: Friday, March 10, 2006 1:53 PM
> To: Peknik Silvestr
> Cc: [email-masked]
> Subject: Re: [Simple] Filtering: triggering functionality - filters
for
> one-time use?
> 
> 
> On Mar 10, 2006, at 12:50 PM, <[email-masked]> wrote:
> 
> > Hi, I just want to make sure that I understand it correctly.
> >
> > Because triggers are being evaluated according to last notification
> > sent
> > to the watcher, then triggers like <changed from="closed" to="open">
> > will result in only one notification, because the trigger cannot be
> > fired again. If there is only <changed to="open"> trigger, then it
will
> > be fired every time when the element changes to "open", even if the
> > change compared to the previously sent document is not a change
really
> > ("open" to "open").
> >
> > Correct?
> 
> No, not correct. Change from open to open is not a change. <changed
> to="open"> means change from anything other than open to open.
> 
> You can, however, have 2 triggers as follows:
> 
> <changed from="open">
> <changed to="open">
> 
> Hisham
> 
> >
> > Thank you,
> >
> > Silvestr Peknik
> > Software Specialist
> > TietoEnator
> >
> > _______________________________________________
> > Simple mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/simple
> >

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: Hisham Khartabil <[email-masked]>
Date: Fri, 10 Mar 2006 15:58:59 +0100

You can have <changed> without the "from" and "to" attributes. Is that 
what you are looking for?

Hisham