Subject: [Simple] What is the difference between SIP PUBLISH and SIP SUBSRIBE

From: "Abhijit A. Mahajani" <[email-masked]>
Date: Fri, 17 Mar 2006 16:26:23 +0530

Hi
What is the difference between the following SIP Methods:
PUBLISH and SUBSCRIBE?
Is it mandatory to implement PUBLISH in presence implementation? 
Thanks and REgards.
Abhijit
_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: Gustavo García Bernardo <[email-masked]>
Date: Fri, 17 Mar 2006 12:06:28 +0100

PUBLISH method is for publishing your presence information  “I’m online”

SUBSCRIBE method is for subscribing to the presence of other  “I want to
receive the presence of xxx”

If you have a centralized presence server (working as presence agent) you
need to implement PUBLISH if you want that your SIP UA could change his
presence state using SIP.

If you implement presence in a P2P way (as Windows Messenger do for
example), you doesn’t need to implement PUBLISH.  But I think this P2P
solution has limited features (at least as implemented in WM). 

Regards

  _____  

De: Abhijit A. Mahajani [mailto:[email-masked]] 
Enviado el: viernes, 17 de marzo de 2006 11:56
Para: [email-masked]
Asunto: [Simple] What is the difference between SIP PUBLISH and SIP SUBSRIBE

Hi

PUBLISH and SUBSCRIBE?

Thanks and REgards.

Abhijit

---

From: "Abhijit A. Mahajani" <[email-masked]>
Date: Fri, 17 Mar 2006 16:42:41 +0530

Hi Sudhir,
Thanks. I perfectly agree.
But if i have not implemented PUBLISH, still i SUBSCRIBE for some body, then will i get any NOTIFICATION?
in simple words: I am implementing Instant messaging and presence in my SIP stack. Do I need to implemetn PUBLISH? is it mandatory?

Regards.
Abhijit
  ----- Original Message ----- 
  From: Sudhir 
  To: Abhijit A. Mahajani 
  Sent: Friday, March 17, 2006 4:35 PM
  Subject: Re: [Simple] What is the difference between SIP PUBLISH and SIP SUBSRIBE

  Hi Abhijit,

  The PUBLISH is used to publish ur presence status to the server. when any user send SUBSCRIBE to know abt u ... the server send the status to user which u send in the PUBLISH.

  i hope i'm clear. if not get badck to me
  \regards
  sudhir

  On 3/17/06, Abhijit A. Mahajani <[email-masked]> wrote: 
    Hi
    What is the difference between the following SIP Methods:
    PUBLISH and SUBSCRIBE?
    Is it mandatory to implement PUBLISH in presence implementation? 
    Thanks and REgards.
    Abhijit

---

From: Aki Niemi <[email-masked]>
Date: Fri, 17 Mar 2006 14:32:48 +0200

You only need PUBLISH, if there's a presence server that accepts
publications. That server is probably the same entity that accepts
subscriptions and sends notifications, too.

I'd say you need to support PUBLISH.

Cheers,
Aki

ext Abhijit A. Mahajani wrote:
> in simple words: I am implementing Instant messaging and presence in my
> SIP stack. Do I need to implemetn PUBLISH? is it mandatory?
>  
> Regards.
> Abhijit
> 
>     *From:* Sudhir <mailto:[email-masked]>
>     *To:* Abhijit A. Mahajani <mailto:[email-masked]>
>     *Sent:* Friday, March 17, 2006 4:35 PM
>     *Subject:* Re: [Simple] What is the difference between SIP PUBLISH
>     and SIP SUBSRIBE
> 
>     Hi Abhijit,
>      
>     The PUBLISH is used to publish ur presence status to the server.
>     when any user send SUBSCRIBE to know abt u ... the server send the
>     status to user which u send in the PUBLISH.
>      
>     On 3/17/06, *Abhijit A. Mahajani* <[email-masked]
>     <mailto:[email-masked]>> wrote:
> 
>         Hi
>         [email-masked] <mailto:[email-masked]>
> ------------------------------------------------------------------------
>

---

From: Fatih "Eyüp" NAR <[email-masked]>
Date: Fri, 17 Mar 2006 04:56:01 -0800 (PST)

Hi;
I am trying to identify; 

"what Proxy Shall do in case received session included
Originator's Preference
(ex:Request-Disposition=No-Fork) inside and Proxy also
has Terminator's CPL Rules (ex:it says Fork to call to
Home-Office-Mobile at the same time) ? 

I couln't see any explanation (i.e. RFC) about that
till now anywhere , can you help me on this please?

regards
  fatih e. nar

__________________________________________________
Do You Yahoo!?
Tired of spam?  Yahoo! Mail has the best spam protection around 
http://mail.yahoo.com

---

From: Ben Campbell <[email-masked]>
Date: Fri, 17 Mar 2006 08:23:17 -0600

To be clear, there is no specification that says you "MUST" implement  
PUBLISH to do presence. It really comes down to an architectural  
decision. If you want presentities to be able to push their presence  
information to a central presence server, you need PUBLISH. If you  
want to build a server or client that interoperates with other  
servers and/or clients, then PUBLISH is certainly a good idea.

But PUBLISH is not explicitly needed to make SUBSCRIBE work. You can  
have a device that consumes presence, but does not publish it--in  
which case that device would not need to implement PUBLISH.

On Mar 17, 2006, at 5:12 AM, Abhijit A. Mahajani wrote:

> in simple words: I am implementing Instant messaging and presence  
> in my SIP stack. Do I need to implemetn PUBLISH? is it mandatory?
>
> Regards.
> Abhijit