Subject: [Simple] MSRP chat and IMDN

From: "Jussi K. Virtanen" <[email-masked]>
Date: Mon, 20 Mar 2006 09:53:45 +0200

Hi,

In draft-niemi-simple-chat-04, a new status code, 427, is
specified for use in a situation in which the MSRP switch
is unable to forward a message to some of the intended
participants.

I think it would be more appropriate to use, for example,
IMDN (draft-burger-simple-imdn-03) for this purpose because
the forwarding mechanism in the MSRP switch is based on CPIM
instead of MSRP.

IMDN is anyway needed if a participant wishes to request
delivery notification. Delivery status in MSRP cannot be
used because each participant has its own MSRP session with
the MSRP switch.

Best Regards,

--
Jussi K. Virtanen

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: Miguel Garcia <[email-masked]>
Date: Mon, 20 Mar 2006 10:34:09 +0200

Hi Jussi:

I agree that at some point in time we need to synchronize MSRP chat with 
IMDN, and it is not our intention to specify a mechanism if we can reuse 
IMDN.

BUT: draft-burger-simple-imdn-03 does not provide a mechanism to inform 
whether a message has been delivered or not, instead, the draft relies 
on the protocol (MSRP). Instead, draft-khartabil-simple-im-receipts-00 
provides a mechanism for delivery receipt. So, depending on what the 
final IMDN mechanism is able to provide, we will need or not to extend MSRP.

BR,

      Miguel

-- 
Miguel A. Garcia           tel:+358-50-4804586
sip:[email-masked]
Nokia Research Center      Helsinki, Finland

---

From: "Jussi K. Virtanen" <[email-masked]>
Date: Mon, 20 Mar 2006 11:50:00 +0200

Hi Miguel,

On 2006-03-20, Miguel Garcia <[email-masked]> wrote:
> I agree that at some point in time we need to synchronize
> MSRP chat with IMDN, and it is not our intention to specify
> a mechanism if we can reuse IMDN.

> BUT: draft-burger-simple-imdn-03 does not provide a mechanism
> to inform whether a message has been delivered or not, instead,
> the draft relies on the protocol (MSRP). Instead,
> draft-khartabil-simple-im-receipts-00 provides a mechanism for
> delivery receipt. So, depending on what the final IMDN mechanism
> is able to provide, we will need or not to extend MSRP.

Couldn't the "first-recipient" mechanism of IMDN, described in
Section 9.3.1 of draft-burger-simple-imdn-03, be extended from
B2BUAs to MSRP switches as well? An excerpt from the section:

   o  If the B2BUA forwards the message, it SHOULD return an
      "processed" IMDN, mindful of the privacy considerations
      enumerated in Section 4.
   o  If there was an error processing the message, the B2BUA
      SHOULD return an "error" IMDN, mindful of the privacy
      considerations enumerated in Section 4.

I believe an "error" IMDN could be a substitute for a 427
response.

draft-khartabil-simple-im-receipts-00 explicitly prohibits
requests of delivery receipts for messages that are transferred
on top of MSRP (Section 7.1.1.). I see that as a problem because
the delivery status in MSRP is bound to an MSRP session but
one CPIM message can traverse on its way over multiple MSRP
sessions, as it does in MSRP chat (draft-niemi-simple-chat-04).

BR,

--
Jussi K. Virtanen

---

From: Miguel Garcia <[email-masked]>
Date: Mon, 20 Mar 2006 12:50:52 +0200

Hi Jussi:

Well, the case we are considering is not a full error, because some of 
the URIs are reachable, others aren't. I guess the mechanism could be 
extended to indicate "partial delivery", and include a list of URIs for 
which delivery failed. Certainly, we need a bit more of discussion on 
this, but first we (SIMPLE) need to take a determination of which path 
to follow (Eric's or Hisham's draft).

BR,

       Miguel