Subject: [Simple] draft-garcia-simple-poke-00

From: Henning Schulzrinne <[email-masked]>
Date: Wed, 5 Nov 2008 13:37:17 -0500

This seems like a reasonable feature, but I'm a bit worried about the  
complexity. Does this correspond to the feature set found in  
commercial systems? I'm reluctant to replicate MIDI or GIF animations  
for this simple purpose. Sender control of the fireworks unleashed on  
the poor recipient also seems to raise the risk of abuse.

Henning
_______________________________________________
Simple mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/simple

---

From: Gustavo Garcia Bernardo <[email-masked]>
Date: Fri, 07 Nov 2008 12:33:45 +0100

Thank you for your feedback,

The extra funcionality is intended to transmit the sender preferences for the poke rendering in the receiver side, and this is something not present in current comercial systems.

We considered that it could be useful, and we selected the list of poke rendering options based on mobile devices' features (we made a survey of their APIs).  We are not completelly sure about this functionality either, and we can remove it from the document and leave it open for future or propietary extensions.

BR,
G.
________________________________________
From: [email-masked] [[email-masked]] On Behalf Of Henning Schulzrinne [[email-masked]]
Sent: Wednesday, November 05, 2008 7:37 PM
To: [email-masked]
Subject: [Simple] draft-garcia-simple-poke-00

Henning

---

From: Henning Schulzrinne <[email-masked]>
Date: Fri, 7 Nov 2008 14:51:02 -0500

Given the current problems that our specs get selectively implemented,  
if at all, my suggestion would be to keep it very simple first. If the  
basic concept gets traction, adding functionality later seems simple.

Henning

On Nov 7, 2008, at 6:33 AM, Gustavo Garcia Bernardo wrote:

> The extra funcionality is intended to transmit the sender  
> preferences for the poke rendering in the receiver side, and this is  
> something not present in current comercial systems.
>
> We considered that it could be useful, and we selected the list of  
> poke rendering options based on mobile devices' features (we made a  
> survey of their APIs).  We are not completelly sure about this  
> functionality either, and we can remove it from the document and  
> leave it open for future or propietary extensions.
>
> BR,
> G.
> From: [email-masked] [[email-masked]] On Behalf Of  
> Henning Schulzrinne [[email-masked]]

---

From: Peter Saint-Andre <[email-masked]>
Date: Wed, 12 Nov 2008 14:54:12 -0700

+1 to keeping it simple. That will also make it easier to ensure
interworking with existing XMPP systems, which use XEP-0224:

http://xmpp.org/extensions/xep-0224.html

That spec is currently in Last Call at the XSF, and feedback is welcome.

Peter

Henning Schulzrinne wrote:
>> The extra funcionality is intended to transmit the sender preferences
>> for the poke rendering in the receiver side, and this is something not
>> present in current comercial systems.
>>
>> functionality either, and we can remove it from the document and leave
>> it open for future or propietary extensions.
>>
>> BR,
>> G.

---

From: Jonathan Rosenberg <[email-masked]>
Date: Tue, 18 Nov 2008 12:03:18 -0500

I agree as well. I think this is way too complicated. Being able to set 
vibration frequencies from the sender? Wow thats complicated.

Indeed, my suggestion is that we literally just reuse the XEP-0224 
schema, which defines a single element, <attention/>. Thats it.

I also want to make sure that there are folks who actually want to 
implement this.

Finally, just for future reference, the term 'vibrator' in U.S. english 
at least - has a common meaning that is probably not - appropriate - for 
this document. Take a look at wikipedia if you don't know what I mean.

-Jonathan R.

-- 
Jonathan D. Rosenberg, Ph.D.                   111 Wood Avenue South
Cisco Fellow                                   Iselin, NJ 08830
Cisco, Voice Technology Group
[email-masked]
http://www.jdrosen.net                         PHONE: (408) 902-3084
http://www.cisco.com
_______________________________________________
Simple mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/simple