Subject: [sip-clf] WG Last Call: draft-ietf-sipclf-format-03

From: Peter Musgrave <[email-masked]>
Date: Wed, 7 Dec 2011 09:41:25 -0500

Hi all, 

I would like to start a WG last call on the recent (hopefully final) update to the sip-clf format doc. 

Please provide your comments by Friday Dec. 16th - including just a simple "looks good".

I would really like to get this WG wrapped up in time for Xmas!

Regards, 

Peter Musgrave

---

From: Peter Musgrave <[email-masked]>
Date: Wed, 7 Dec 2011 10:03:01 -0500

Hi Gonzalo, 

Great job on the final version. I have two comments, one picky; one more substantive:

4.2
For the timestamp and fractional seconds the order is most significant character first I assume? Is it worth stating this explicitly?

4.3
The optional fields have a 2 byte hex length indicator. It is stated earlier that hex is to be specified in ASCII characters. This limits the size of an optional value to 255 bytes - which I suspect was not the intent.
Does this field need to made large enough to hold 4096 byte lengths?

Thanks

Peter

---

From: Gonzalo Salgueiro <[email-masked]>
Date: Wed, 7 Dec 2011 13:10:08 -0500

Peter - 

Thanks for the review. A few comments inline...

> For the timestamp and fractional seconds the order is most significant character first I assume? Is it worth stating this explicitly?
Once we specified that Unix Epoch time is used that this would be understood, but I think a bit of text stating that this explicitly could be helpful. I will add this in the next version.
> Does this field need to made large enough to hold 4096 byte lengths?
Thanks for spotting this. It was an oversight on my part and this will definitely be addressed in the next version with updated field length of 4 bytes.

Regards,

Gonzalo

---

From: Gonzalo Salgueiro <[email-masked]>
Date: Wed, 7 Dec 2011 14:35:31 -0500

Folks - 

To help expedite this I have addressed the two issues Peter raised in his review.  
The new version (-04) is in the IETF archives [1], and the diffs against -03 are at [2].

Specifically, these changes are:

(a) Added text to indicate Timestamp is most significant octet first
(b) Updated Optional Field Length to be 4 bytes to allow for fields of up to 4096 bytes.

[1] http://tools.ietf.org/html/draft-ietf-sipclf-format-04
[2] http://tools.ietf.org/rfcdiff?url2=draft-ietf-sipclf-format-04.txt

Thanks,

- Gonzalo

On Dec 7, 2011, at 9:41 AM, Peter Musgrave wrote:

> _______________________________________________
> sip-clf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/sip-clf
>