Subject: [sip-ops] SIP Resource availability Event package

From: "Parthasarathi R (partr)" <[email-masked]>
Date: Mon, 30 Aug 2010 22:21:04 +0530

Resource availability information from SIP devices improves the manageability of SIP devices by providing a framework for multiple applications like Resource utilization monitoring, overload handling in SIP based media servers. 

This draft was discussed in IETF-78 SoC WG and considered as outside the scope of SOC as it focus on SIP overload based on non-critical resources like DS0, DSP. By looking at the mediactrl WG charter and working documents, I doubt that this draft will falls under current media-ctrl work. As this draft helps in SIP based devices manageability, I looked for SIP manageability related WG but Sip-ops mailing alias only exists and there is no WG associated with it. So, I'm putting this document in dispatch WG for further proceedings. 

Abstract is as follows:

"Collecting Resource availability information in Session Initiation Protocol (SIP) devices in real time helps in better manageability of resources in the SIP network. Resource availability monitoring in SIP devices helps administrator to take informed decision and corrective measures to tackle under or over resource utilization in the network. Resource availability information can also be used for SIP overload control in SIP based Media servers by passing resource demand vector between devices. This document defines resource availability XML document and the mechanisms that can be used to exchange the document between SIP entities."

The draft is available at http://datatracker.ietf.org/doc/draft-partha-dispatch-resource-availability/ <http://datatracker.ietf.org/doc/draft-partha-dispatch-resource-availability/> . Could you please provide your valuable comments.

Thanks

Partha

________________________________

From: IETF I-D Submission Tool [mailto:[email-masked]]
Sent: Mon 8/30/2010 7:50 PM
To: Parthasarathi R (partr)
Cc: Sheshadri Shalya (svshesha)
Subject: New Version Notification for draft-partha-dispatch-resource-availability-00 

A new version of I-D, draft-partha-dispatch-resource-availability-00.txt has been successfully submitted by Parthasarathi R and posted to the IETF repository.

Filename:        draft-partha-dispatch-resource-availability
Revision:        00
Title:           Session Initiation Protocol (SIP) Resource availability Event package
Creation_date:   2010-08-30
WG ID:           Independent Submission
Number_of_pages: 17

Abstract:
Collecting Resource availability information in Session Initiation
Protocol (SIP) devices in real time helps in better managebility of
resources in the SIP network.  Resource availability monitoring in
SIP devices helps administrator to take informed decision and
corrective measures to tackle under or over resource utilization in
the network.  Resource availability information can also be used for
SIP overload control in SIP based Media servers by passing resource
demand vector between devices.  This document defines resource
availability XML document and the mechanisms that can be used to
exchange the document between SIP entities.

The IETF Secretariat.

---

From: Michael Miller <[email-masked]>
Date: Tue, 31 Aug 2010 17:35:05 -0400

This draft looks pretty good. Should there be language that saids management servers are alerted of critical conditions or is that outside of this draft?

Michael L. Miller
Sent from my Mobile Device

On Aug 30, 2010, at 12:51 PM, "Parthasarathi R (partr)" <[email-masked]> wrote:

> The draft is available at http://datatracker.ietf.org/doc/draft-partha-dispatch-resource-availability/. Could you please provide your valuable comments.
> 
> Thanks
> 
> Partha
> 
> 
> _______________________________________________
> dispatch mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dispatch

---

From: "Parthasarathi R (partr)" <[email-masked]>
Date: Wed, 1 Sep 2010 09:05:22 +0530

Michael,
 
Thanks for the comment. In the draft, Almost-out-of-resource element for the particular resource has to be used whenever the resource is reaching the critical condition (threshold) and it is explained in sec 5.4.1. Almost-out-of-resource indication provides the alert to the administrator about overuse of the specific resource in a particular device. I'll add the text in the resource availability indication mechanism for providing more clarity.
 
Thanks
Partha

From: Michael Miller [mailto:[email-masked]]
Sent: Wed 9/1/2010 3:05 AM
To: Parthasarathi R (partr)
Cc: <[email-masked]>; [email-masked]; [email-masked]; [email-masked]
Subject: Re: [dispatch] SIP Resource availability Event package

Michael L. Miller

	

	Abstract is as follows:

	Thanks

	Partha

	

	
	Abstract:

	The IETF Secretariat.