Subject: [sip-overload] Comments on draft-shen-soc-load-control-event-package-00.txt

From: <[email-masked]>
Date: Fri, 4 Jun 2010 12:20:08 +0200

About this I-D, I would like to come back to a discussion we already had in November 2009. This draft defines both a SIP Event and a MIME type with an associated XML schema. The I-D does not preclude other schemas to be used together with the SIP event but it mandates supporting at least the default schema it defines. 

As the schema defined in this I-D is simple and easy to use, it really meets the criteria for a good default schema. However, more sophisticated schemas may be used in specific environments and when all entities in a particular environment (e.g. a network or a federation of networks) support an alternative schema there is no need for supporting this default schema in addition to it. This applies for example to Next Generation Networks (NGN) that are compliant with ETSI specifications. In those networks overload control information is structured according to an ETSI-specific schema (ETSI ES 283 034)but the SIP procedures for carrying overload control information are identical to those defined in the I-D.

The SIP Event defined in the current version of the draft-shen is not suitable for use in those networks as it mandates support of the XML schema defined in Clause 7 of this Internet-Draft. Unless a modification of draft-shen is made on that point, another SIP Event Package will have to be defined to carry load control documents structured according to the ETSI schema. The schema will be the only difference between the two packages. 

According to RFC5727, IANA registration policy for event packages is "RFC required", which means that we could end-up with two RFCs (one of them would likely be Informational)defining two almost identical SIP Event Packages, the only difference being the associated schema.

Does this make sense? I'm not sure... If not, is there a more pragmatic and efficient way to accomodate all requirements?

Bruno

-----Message d'origine-----
De : [email-masked] [mailto:[email-masked]] De la part de [email-masked]
Envoyé : jeudi 3 juin 2010 14:15
À : [email-masked]
Objet : I-D Action:draft-shen-soc-load-control-event-package-00.txt 

A New Internet-Draft is available from the on-line Internet-Drafts directories.

	Title           : A Session Initiation Protocol (SIP) Load Control Event Package
	Author(s)       : C. Shen, et al.
	Filename        : draft-shen-soc-load-control-event-package-00.txt
	Pages           : 27
	Date            : 2010-06-03

This document defines a load control event package for the Session Initiation Protocol (SIP).  It allows SIP servers to distribute user load control information to other SIP servers in the network.  The load control can throttle calls based on their source or destination domain, telephone number prefix or for a specific user.  The mechanism helps to prevent signaling overload and complements feedback-based SIP overload control efforts.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-shen-soc-load-control-event-package-00.txt

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

Below is the data which will enable a MIME compliant mail reader implementation to automatically retrieve the ASCII version of the Internet-Draft.

---

From: Victor Pascual Avila <[email-masked]>
Date: Fri, 4 Jun 2010 13:10:24 +0200

Hi Bruno,

if the WG finally decided to go through the event package path...

On Fri, Jun 4, 2010 at 12:20 PM,  <[email-masked]> wrote:
> As the schema defined in this I-D is simple and easy to use, it really meets the criteria for a good default schema. However, more sophisticated schemas may be used in specific environments and when all entities in a particular environment (e.g. a network or a federation of networks) support an alternative schema there is no need for supporting this default schema in addition to it.

I agree

Cheers,
-Victor

---

From: <[email-masked]>
Date: Fri, 4 Jun 2010 13:15:41 +0200

Yes of course, I was indeed assuming that the WG would provide several outputs including at least one based on an Event Package, which I think is a sounded solution with some merits. 

> De : Victor Pascual Avila [mailto:[email-masked]] 
> Envoyé : vendredi 4 juin 2010 13:10
> À : CHATRAS Bruno RD-CORE-ISS
> Cc : [email-masked]
> Objet : Re: [sip-overload] Comments on 
> draft-shen-soc-load-control-event-package-00.txt
> 
> Hi Bruno,
> 
> On Fri, Jun 4, 2010 at 12:20 PM,  
> <[email-masked]> wrote:
> > As the schema defined in this I-D is simple and easy to 
> use, it really meets the criteria for a good default schema. 
> However, more sophisticated schemas may be used in specific 
> environments and when all entities in a particular 
> environment (e.g. a network or a federation of networks) 
> support an alternative schema there is no need for supporting 
> this default schema in addition to it.
> 
> I agree
> 
> Cheers,
> -Victor
>