Subject: Re: [sip-overload] Enhancement to Load Control Event Package to support partial updates to control restriction parameters and validity

From: "SHEN, CHARLES" <[email-masked]>
Date: Mon, 7 Nov 2011 20:07:12 +0000

Hi all: I am in the process of producing an updated version of the "Load Control Event Package" document. I would like to seek the group's opinion on the following proposal from Phil earlier.

Thanks

Charles

From: [email-masked] [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Tuesday, August 23, 2011 11:46 AM
To: [email-masked]
Subject: [sip-overload] Enhancement to Load Control Event Package to support partial updates to control restriction parameters and validity

Folks,

I have proposed to the authors of draft-ietf-soc-load-control-event-package-01 that Notifications of partial updates to control restriction parameters and validity (only) should be supported. Currently the spec explicitly states that they are not, in 5.7.(Notifier Generation of NOTIFY Requests):

...This event package does not support notifications that contain deltas to previous information or partial information.

This proposal is fine with Charles Shen, so we agreed to open it up for general views. My reasoning follows.

It would be common practice for updates to specific load control events to be made frequently by changing the control restriction parameter information only (e.g. rate, percent), but not other rule elements, such as call-identity. This will typically be because the utilisation of a resource subject to overload depends upon dynamic unknowns such as holding time and the relative distribution of offered load over subscribing SIP entities. The updates could originate manually or be determined automatically. The latter is referred to already in 4.2.(Filter Computation):

...it may be preferable to employ a dynamic load computation algorithm which adapts to current network status, rather than using a purely static mechanism.  The filter content computation algorithm is out of scope of this document.

[Note: A rate-based control would generally need a lower frequency of updates even when adaptive than say a loss-based method because of the dependence of the proportional method upon offered rates].

Another factor usually not known precisely or computed automatically is the duration of the load control event. Therefore it would also be common for the validity to change frequently.

Not allowing partial updates could be a significant limitation to performance when realised, since it makes such updates unnecessarily verbose. It would be a small enhancement to allow deltas which change the rate, win, or percent values of the action element, and the validity. They can be associated to the complete rule through the rule id.

Regards,

Phil Williams

---

From: <[email-masked]>
Date: Tue, 8 Nov 2011 09:35:24 +0100

I tend to agree that some rule elements will have to be updated more frequently than others. However, I'm not sure that partial updates will bring a significant gain as in practice rule descriptions will not that verbose...  Having said that, I'm not against adding this feature to the draft... 

BC

De : [email-masked] [mailto:[email-masked]] De la part de SHEN, CHARLES
Envoyé : lundi 7 novembre 2011 21:07
À : [email-masked]
Objet : Re: [sip-overload] Enhancement to Load Control Event Package to support partial updates to control restriction parameters and validity

Thanks

Charles

Folks,

Regards,

Phil Williams