Subject: [sip-overload] rate-control and event-package drafts and normative references

From: "Vijay K. Gurbani" <[email-masked]>
Date: Tue, 17 Dec 2013 07:59:40 -0600

Charles, Eric: The Gen-ART review of draft-ietf-soc-overload-control
triggered me to check the references of your drafts, especially whether
the reference to draft-ietf-soc-overload-control is normative or
informative in your drafts.

It appears that both the drafts list draft-ietf-soc-overload-control as
an informative reference.

I believe that this should be changed to a normative reference.

The distinction between normative and informative reference is
captured in http://www.rfc-editor.org/policy.html#policy.refs
 From this reading, it appears reasonable that someone wanting to
implement either rate-control or event-package will need to
read overload-control first.

You can ask the chairs for guidance as well, and assuming that you
do make the change, you can easily do so before IETF last call or
during Auth-48.

Thanks,

- vijay
-- 
Vijay K. Gurbani, Bell Laboratories, Alcatel-Lucent
1960 Lucent Lane, Rm. 9C-533, Naperville, Illinois 60563 (USA)
Email: vkg@{bell-labs.com,acm.org} / [email-masked]
Web: http://ect.bell-labs.com/who/vkg/  | Calendar: http://goo.gl/x3Ogq

---

From: Charles Shen <[email-masked]>
Date: Tue, 17 Dec 2013 23:31:14 +0800

Hi Vijay, I will update it in the next version. Thanks!

Charles

---

From: "Vijay K. Gurbani" <[email-masked]>
Date: Tue, 17 Dec 2013 09:39:05 -0600

> Hi Vijay, I will update it in the next version. Thanks!

Charles: I was looking at event-package draft and I think that perhaps
it is not necessary for you to upgrade the reference to normative.

event-package essentially fleshes out a rfc6665 event package; as
such it does not ask the actors to use overload control parameters
defined in the overload-control draft.

So it looks like an informative references from your document suffices.

The rate-control document will most definitely need to move the
reference to normative since it uses the overload control parameters
defined in the overload-control draft.

Cheers,

- vijay

---

From: Charles Shen <[email-masked]>
Date: Tue, 17 Dec 2013 23:42:03 +0800

I actually agree :)

---

From: "DRAGE, Keith (Keith)" <[email-masked]>
Date: Tue, 17 Dec 2013 23:54:56 +0000

I was about to respond saying pretty much what you have said below.

So treat this as a +1.

Keith 

> -----Original Message-----
> From: sip-overload [mailto:[email-masked]] On 
> Behalf Of Vijay K. Gurbani
> Sent: 17 December 2013 15:39
> To: Charles Shen
> Cc: [email-masked]
> Subject: Re: [sip-overload] rate-control and event-package 
> drafts and normative references
> 
> Charles: I was looking at event-package draft and I think 
> that perhaps it is not necessary for you to upgrade the 
> reference to normative.
> 
> event-package essentially fleshes out a rfc6665 event 
> package; as such it does not ask the actors to use overload 
> control parameters defined in the overload-control draft.
> 
> The rate-control document will most definitely need to move 
> the reference to normative since it uses the overload control 
> parameters defined in the overload-control draft.
> 
> Cheers,
> 
> - vijay
> --
> Vijay K. Gurbani, Bell Laboratories, Alcatel-Lucent 1960 
> Lucent Lane, Rm. 9C-533, Naperville, Illinois 60563 (USA)
> Web: http://ect.bell-labs.com/who/vkg/  | Calendar: 
> http://goo.gl/x3Ogq _______________________________________________
> sip-overload mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/sip-overload
>

---

From: Charles Shen <[email-masked]>
Date: Wed, 18 Dec 2013 08:27:27 +0800

Hi Keith, Just want to make sure your +1 is for "leaving it as
informative", is that correct or not?

I feel the most direct interaction between this draft and the
overload-control one is when you specify the numbers in the actions, such
as a rate. However, since it does not use the oc-parameter as Vijay
mentioned, and the computation of those numbers is also out of scope of
this document, It seems ok to leave it as informative.

Thanks

Charles

---

From: "DRAGE, Keith (Keith)" <[email-masked]>
Date: Wed, 18 Dec 2013 00:30:50 +0000

Yes, +1 to Vijay and leave as informative.

Keith

________________________________
From: [email-masked] [mailto:[email-masked]] On Behalf Of Charles Shen
Sent: 18 December 2013 00:27
To: DRAGE, Keith (Keith)
Cc: Gurbani, Vijay K (Vijay); [email-masked]
Subject: Re: [sip-overload] rate-control and event-package drafts and normative references

Hi Keith, Just want to make sure your +1 is for "leaving it as informative", is that correct or not?

I feel the most direct interaction between this draft and the overload-control one is when you specify the numbers in the actions, such as a rate. However, since it does not use the oc-parameter as Vijay mentioned, and the computation of those numbers is also out of scope of this document, It seems ok to leave it as informative.

Thanks

Charles

On Wed, Dec 18, 2013 at 7:54 AM, DRAGE, Keith (Keith) <[email-masked]<mailto:[email-masked]>> wrote:
I was about to respond saying pretty much what you have said below.

So treat this as a +1.

Keith

> From: sip-overload [mailto:[email-masked]<mailto:[email-masked]>] On
> Cc: [email-masked]<mailto:[email-masked]>
> Email: vkg@{bell-labs.com<http://bell-labs.com>,acm.org<http://acm.org>} / [email-masked]<mailto:[email-masked]>
> [email-masked]<mailto:[email-masked]>

---

From: Charles Shen <[email-masked]>
Date: Wed, 18 Dec 2013 11:03:05 +0800

Great.

On Wed, Dec 18, 2013 at 8:30 AM, DRAGE, Keith (Keith) <
[email-masked]> wrote:

>  ------------------------------
> *From:* [email-masked] [mailto:[email-masked]] *On
> Behalf Of *Charles Shen
> *Sent:* 18 December 2013 00:27
> *To:* DRAGE, Keith (Keith)
> *Cc:* Gurbani, Vijay K (Vijay); [email-masked]
>
> *Subject:* Re: [sip-overload] rate-control and event-package drafts and
> normative references
>