Subject: [SIP] a question on 183

From: "Pathangi N Janardhanan" <[email-masked]>
Date: Sun, 17 Sep 2000 07:40:31 +0530

Hi,

  The caller sends his capabilities in the SDP description in 
INVITE. Is early media meant for one way communication
towards the caller for call progress anouncements. In that 
case why do we need the SDP in the 183, since the caller
has already expressed the capability in INVITE? 

Thanks
Jana

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: Jonathan Rosenberg <[email-masked]>
Date: Mon, 18 Sep 2000 00:12:30 -0400

The SDP is needed largely to confirm that this is going to happen, and also
to provide address/ports for RTCP for feedback. If the early media is
unidirectional, the SDP in the 183 would also indicate that using the
sendonly attribute.

-Jonathan R.

---
Jonathan D. Rosenberg                       72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.cs.columbia.edu/~jdrosen         PHONE: (973) 952-5000
http://www.dynamicsoft.com

> -----Original Message-----
> From: Pathangi N Janardhanan [mailto:[email-masked]]
> Sent: Saturday, September 16, 2000 10:11 PM
> To: [email-masked]
> Subject: [SIP] a question on 183
> 
> 
> Hi,
>