Subject: RE: [SIP] SIP, SDP, and TCP-based media transport

From: "Fairlie-Cuninghame, Robert" <[email-masked]>
Date: Thu, 7 Sep 2000 23:23:33 -0700

Hi David,

> The direction parameter goes on the a= line, not the m= line. 
>  The "fmt" 
> identifier is a qualification of the protocol above TCP.  For 
> want of a 
> better example, "t38" would be a valid entry in that position 
> on the m= line.

Oh sorry, my mistake.

> I've finally had some time to work through some of the 
> scenarios, and I 
> think the solution is to abandon the "highest port wins" 
> heuristic and 
> replace it with the following:
.... 
> 
> I think that gets rid of the race condition, works through an 
> ALG where 
> port numbers might change, yet still allows one of the 
> connections to be 
> shut down when circumstances permit.  Worst case is each 
> connection becomes 
> unidirectional.
> 
> Comments?  Anyone see a hole I missed?
> 
Sounds good - I can't see any problems. So I guess this also means that once
you have received data on a TCP connection you may not close it.

> >someone made to point that the stated algorithm doesn't work 
> is both sides
> >are behind ALGs. Can anyone confirm?
> 
> I'm having trouble parsing this sentence to begin with, never mind 
> recalling the original issue. :-)  Could you rephrase?

Hahaha, my stimulus based keystroke protocol must have been having some
problems. :) I was saying that someone pointed out a problem in the "highest
port wins" algorithm when both endpoints are behind an ALG.

> I agree with most, but not all of this.  Certainly if you 
> "want to be able 
> to traverse a NAT/NAPT", then you likely would only need a single TCP 
> connection but are forced to attempt two in order to 
> determine who has the 
> unimpeded path.

Yup, that's fine now that we've got a workable tcp connection closing
algorithm.
 
Well that's about it then (other comments pending) - we've finally got a
draft TCP profile for SDP.

Cheers,

Robert.

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: David Yon <[email-masked]>
Date: Fri, 08 Sep 2000 11:15:55 -0400

>you have received data on a TCP connection you may not close it.

Correct.  Ditto if you've sent data on a TCP connection.  Once you've sent 
*and* received data, and they happen to occur both on the same TCP 
connection, it's safe to close the other one.

>draft TCP profile for SDP.

Ok, I've updated the online copy to reflect the most recent discussion, any 
and all comments welcome:

ftp://ftp.dialout.net/drafts/draft-ietf-sip-sdp-tcpmedia-00.txt

So, if there are no additional comments, how do I go about getting this 
into the queue?  Jonathan...?  Henning...?  Comment?

David Yon
Chief Technical Officer
Dialout.Net, Inc.
[email-masked]