Subject: RE: [SIP] Re-direct of Media During Ringing

From: "Tom-PT Taylor" <[email-masked]>
Date: Wed, 27 Sep 2000 13:51:34 -0400

Are you saying that instead of a re-INVITE in such cases, one should issue a
new initial INVITE to open up a new session?

> -----Original Message-----
> From: Doug Harbert [mailto:[email-masked]]
> Sent: Wednesday, September 27, 2000 12:50 PM
> To: Simon Barber
> Cc: Jonathan Rosenberg; Taylor, Tom-PT [NORSE:B901:EXCH]; 'sip'
> Subject: Re: [SIP] Re-direct of Media During Ringing
> 
[PTT] snip
> 
> The applications you describe here sound like sessions. In 
> fact, any time one
> party delivers media to another party, there is a session and 
> there should be
> explicit agreement between parties to form this session. 
> Perhaps what is needed
> 
> here is a way for your sip phone to automatically answer 
> calls from your alarm
> clock, or for your pager to automatically answer calls and 
> perform the page.
> These devices could modify their behaviors depending upon the 
> application
> requested for the session, low level alarm, high level alarm, page.
> 
> The recipient of the call or his/her agents (phones, 
> pagers,...) must have the
> authority to decide whether or not to accept the session, and 
> receive media.
> 
> Doug Harbert
> 
> 
> 
>

---

From: Doug Harbert <[email-masked]>
Date: Thu, 28 Sep 2000 15:31:27 -0600

Tom-PT Taylor wrote:

>
>
> Are you saying that instead of a re-INVITE in such cases, one should
> issue a new initial INVITE to open up a new session?
>

Tom:
    Yes, rather than issuing a re-INVITE before the final response (200)
has been received, it seems to me that we should
CANCEL the initial INVITE, and issue a new INVITE to start a new
session. However, once the session has been established,
re-INVITE is a perfectly appropriate way to change session parameters.

Doug Harbert.