Subject: [SIP] Re-direct of Media During Ringing

From: "Tom-PT Taylor" <[email-masked]>
Date: Mon, 25 Sep 2000 15:01:53 -0500

The consensus expressed in Pittsburgh was that additional transactions could
be opened before the final response to the initial INVITE has come back.
Section 4.2.1 forbids the issuance of re-INVITEs under these circumstances.
I have a case (blind call transfer) where I don't want to interrupt the
alerting being provided to the called subscriber, but I do need to change
the media path.  Do we really need the restriction on re-INVITE?

Tom Taylor

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: "Tom-PT Taylor" <[email-masked]>
Date: Wed, 27 Sep 2000 13:37:00 -0400

Here's the bare requirement:

A calls B, passing SDP to set up a media path.

Occasionally while B is alerting user B (after it has passed a 180 Ringing
interim response), A recognizes a need to change the media path.  After the
final response from the initial INVITE has come back, the procedure for
doing this is obvious: send a re-INVITE with new SDP.  However, the way
RFC2543bis currently reads, this can't be done while alerting is still in
progress.

The race condition in the alerting case is obvious.  However, waiting until
user B answers means that user B's initial greeting is potentially lost
while the new path is set up.  I'm inclined to think the extra complexity of
implementing a re-INVITE nested within the original INVITE transaction is
worth the improvement in service to the subscriber, but I haven't actually
reviewed or written any SIP code.  What do implementors think?

> -----Original Message-----
> From: Jonathan Rosenberg [mailto:[email-masked]]
> Sent: Tuesday, September 26, 2000 11:10 PM
> To: Taylor, Tom-PT [NORSE:B901:EXCH]; 'sip'
> Subject: RE: [SIP] Re-direct of Media During Ringing
> 
> 
> I don't follow the scenario. Can you elaborate?
> 
> -Jonathan R.
> 
> ---
> Jonathan D. Rosenberg                       72 Eagle Rock Ave.
> Chief Scientist                             First Floor
> dynamicsoft                                 East Hanover, NJ 07936
> [email-masked]                     FAX:   (973) 952-5050
> http://www.cs.columbia.edu/~jdrosen         PHONE: (973) 952-5000
> http://www.dynamicsoft.com
> 
> > -----Original Message-----
> > From: Tom-PT Taylor [mailto:[email-masked]]
> > Sent: Monday, September 25, 2000 4:02 PM
> > To: sip
> > Subject: [SIP] Re-direct of Media During Ringing
> > 
> >