Subject: [SIP] draft-ietf-sip-mib-01: Why no response counters per method?

From: "Brett Tate" <[email-masked]>
Date: Tue, 19 Sep 2000 19:28:00 -0400

Draft-ietf-sip-mib-01 (July 2000) does not define
a common object for obtaining response 
counters based upon a SIP Method.

I was wondering which of the following was true:
1) I'm not reading the draft correctly.
2) It was deemed "not important enough" and
    excluded as part of a counter reduction process. 
3) It was over looked, and may need to be added.

I assume that number 2 is the answer, but I just
wanted to make sure.

Thanks in advance for the response.

---

From: Kevin Lingle <[email-masked]>
Date: Wed, 20 Sep 2000 11:08:44 -0400

Brett,

If I understand the counters you speak of, I think it 
may have been number 3 with a tendancy toward number 2 ;)

So you are speaking of having counters that reflect
only response messages sent/received by the device
on a per method basis?

I think in the area of response messages we were naturally
more focused on the status code related statistics.  And in 
the area of per method stats we simply focused on general 
in/out counters.

The responses you speak of will be lumped into the
per method stats of sipMethodStatsTable.  I'm not sure
I see a need for providing anything more than that.

Kevin
> Brett Tate wrote:

-- 
=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=
 Kevin R. Lingle       919.392.2029
 checkout: http://wwwin-eng.cisco.com/Eng/IOS/SNMP_WWW/mib-police.html
 Sometimes I think I understand everything, then I regain consciousness.
=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: "Brett Tate" <[email-masked]>
Date: Wed, 20 Sep 2000 14:57:59 -0400

> I see a need for providing anything more than that.

The main benefit is to enable a correlation of 
method count to a success or failure count.  
For example, it might be nice to know that 
every time a BYE was sent a Request Failure 
was received.

I assume that it would be nice to know that
every time an INVITE was sent, a Request
Failure was received.  

I assume that it would also be nice to 
know how often a REFER was rejected 
because of a Request Failure.  

A similar counter was added for REGISTER.  
I just thought it might be nice to define these
at a global level to avoid having to individually
add success and failure counters for each
new method which might want it.

Just a thought...

-Brett