Subject: [SIP] syntax clarifications in the bis-draft-02

From: [email-masked]
Date: Tue, 19 Sep 2000 11:39:15 +0530

hi..

A  doubt in the ABNF of the bis-draft-02 dated Sept 04, 2000

Alert-Info = "Alert-Info" ":" # ( " < " URI " > " *( ";" generic-param ))
Call-Info = "Call-Info" ":" # ( " < " URI " > " *( ";" info-param) )
Error-Info = "Error-Info" ":" # ( " < " URI " > " *( ";"generic-param ))

all these indicate that the header can just be
     alert-info:
with blank header body...shouldn't they all be 1# ???

also sections H and I of the bis draft have the same title "changes to
01"...

regards,
Ashok

Ashok Roy @Hughes Software Systems

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: Henning Schulzrinne <[email-masked]>
Date: Tue, 19 Sep 2000 08:40:17 -0400

> with blank header body...shouldn't they all be 1# ???

Generally, empty headers are ok. I don't see a reason to prohibit them.
Encourages robustness...

> also sections H and I of the bis draft have the same title "changes to

Fixed.

-- 
Henning Schulzrinne   http://www.cs.columbia.edu/~hgs