Subject: [SIP] Modify media during a call

From: Francois-Xavier Guitton <[email-masked]>
Date: Tue, 19 Sep 2000 10:29:46 +0200

All,

Just a quick question: Is it possible to modify a media codec type during a call thanks to a second INVITE ? ( I can not find in the spec RFC 2543 where that case is described)

e.g.: A INVITE B with media m=audio 49170 RTP/AVP 0 , and the call is successfully established.

May A re-INVITE B in replacing the media line by m=audio 49170 RTP/AVP 2 (to replace PCMU by G721) ?

Fx./.

--
Francois-Xavier Guitton (SWD/ULC)
mailto:[email-masked]
Tel: +33 (0)1 69 63 47 52
Fax: +33 (0)1 69 63 17 89

---

From: "Pathangi N Janardhanan" <[email-masked]>
Date: Wed, 20 Sep 2000 06:43:32 +0530

Hi,

All,
Just a quick question: Is it possible to modify a media codec type during a call thanks
 to a second INVITE ? ( I can not find in the spec RFC 2543 where that case is described)
Please see section B.5
e.g.: A INVITE B with media m=audio 49170 RTP/AVP 0 , and the call is successfully established.
May A re-INVITE B in replacing the media line by m=audio 49170 RTP/AVP 2 (to replace PCMU by G721) ?

I guess the re-invite should look like:
m=audio 0 RTP/AVP 0
m=audio 49170 RTP/AVP 2

 The first line for deleting the original media stream selected
and the second line for adding the new one.

Jana