Subject: RE: [SIP] Attempt at summarizing current SIP drafts (SIP Mobility )

From: "Roy, Radhika R, ALCOO" <[email-masked]>
Date: Wed, 27 Sep 2000 14:33:46 -0400

Hi, Mike:

I guess that SIP, as you rightly pointed out, is dealing with the signaling
mechanism in the application layer. So, SIP does not need to deal with L3
media path.

SIP does deal with addresses of the source and destination(s). 

In mobile environment, the point of attachment (i.e., addresses) changes: 1.
Between the sessions (discrete mobility) and 2. During the session
(continuous mobility).

The problem that is being addressed is: What is the impact in SIP layer due
to these two kinds of mobility.

I guess that for discrete mobility, SIP has probably addressed most of the
problems (others may also provide comments on this).

For continuous mobility, there may need (or may not??) some works in the SIP
layer, if any (others may also provide comments).

However, SIP can only address the mobility related problems in the
application layer. This alone may not be enough to solve all problems
because some L3 and L2 problems may also need to be addressed at the same
time to have the complete solution.

In any solution, SIP mobility needs to be limited only to the application
layer (not L3, L2, etc.).

Best regards,
Radhika R. Roy
AT&T

-----Original Message-----
From: Michael Thomas [mailto:[email-masked]]
Sent: Wednesday, September 27, 2000 12:32 PM
To: Lewis Karl-QA3387
Cc: 'Henning Schulzrinne'; [email-masked]
Subject: RE: [SIP] Attempt at summarizing current SIP drafts

While I'm more than willing to believe that there
are mobility issues that SIP needs to deal with,
this paper seems to be positing SIP as the means
of initiating data sessions altogether. To my
mind, that's a rather bellheaded way of thinking
about how you do what amounts to L3 admission
control. In fact, the IETF already has an L3
admission control mechanism: RSVP. RSVP's main
advantage is that it follows actual network
topology. SIP is at a distinct disadvantage since
all it knows about is the signaling path which
in normal circumstances has nothing to do with
the actual data path.

Maybe I'm misreading this whole paper, but it sure
looks like it to me. If my interpretation is
right, however, I'd like to know if the intention
is to signal the access routers providing the
L2/L3 bits using SIP instead of, say, COPS (or
DIAMETER). If so, I'd say that SIP truly has
arrived at becoming the new millenium's kitchen
sink if this is accepted.

	  Mike

Lewis Karl-QA3387 writes:
 > I have just reviewed the Mobility Related drafts and am wondering if
anyone
 > is aware of the current status of draft-itsumo-sip -mobility-req-01. In
 > particular, several issues were identified such as Mobile IP not being
 > sufficient for personal mobility and location services, completing
 > registration in less than a few seconds, reconfiguration in milliseconds,
 > providing location services, support of inter domain soft-hand and secure
 > signaling. Have these issues been addressed or actively being worked?
 > 
 > Karl
 > 
 > 
 > 
 > -----Original Message-----
 > From: Henning Schulzrinne [mailto:[email-masked]]
 > Sent: Monday, September 25, 2000 9:20 AM
 > To: [email-masked]
 > Subject: [SIP] Attempt at summarizing current SIP drafts
 > 
 > 
 > Given the proliferation of SIP-related drafts, I've created a summary of
 > efforts at http://www.cs.columbia.edu/~hgs/sip/drafts.html. This is
 > known to be incomplete, so I'd appreciate if you could send me any
 > additions or corrections. (Jonathan Rosenberg provided some of the text;
 > any mistakes or misrepresentations are mine.)
 > 
 > It is fairly clear that there are a large number of drafts that have not
 > changed materially for half a year or more. Maybe it's time to have a WG
 > last call or two or ten...
 > 
 > Henning
 > -- 
 > Henning Schulzrinne   http://www.cs.columbia.edu/~hgs
 > 
 > 
 > _______________________________________________
 > SIP mailing list
 > [email-masked]
 > http://lists.bell-labs.com/mailman/listinfo/sip
 > 
 > _______________________________________________
 > SIP mailing list
 > [email-masked]
 > http://lists.bell-labs.com/mailman/listinfo/sip
 > 

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: Michael Thomas <[email-masked]>
Date: Wed, 27 Sep 2000 12:32:53 -0700 (PDT)

I guess what I'm having a hard time with is the
starting point that assumes that SIP based
application mobility is Good Thing. While it's
clear that many applications *could* design in
mobility, what seems clear is that there are a
number of applications which won't be able to do
that for a variety of reasons. Assuming that those
applications are important too, then we're already
stuck with needing to solve for the general
problem.

Starting out with the assumption that Mobile IP
addresses the more general problem seems
attractive because a good solution with fast
handoff that addresses AAA and QoS would solve
most of the application layer problems in a
general way rather than just a SIP specific
way.

There also seems to be an implicit assumption in
the draft of linkage of SIP to a AAA function.
I'm going to guess that it is along the same line
of thinking of the DQoS gate controller idea. The
problem I have with that is that it is in the end
an optimization on the normal RSVP/COPS pull
model. However, things that don't fit into that
model still have the non-optimized way of doing
QoS authorization. That's probably not the fault
of this draft, but it does seem to make the entire
draft a cart-before-horse situation.

	Mike

---

From: Henry Sinnreich <[email-masked]>
Date: Wed, 27 Sep 2000 22:43:02 +0100

>what seems clear is that there are a
>that for a variety of reasons.

Voice, chat, IM, messaging, conferencing, games, etc., are
plenty of reasons to justify the SIP approach to mobility.

Henry

>From: [email-masked]
>[mailto:[email-masked]]On Behalf Of
>Michael Thomas
>Sent: Wednesday, September 27, 2000 8:33 PM
>To: Roy, Radhika R, ALCOO
>Cc: Michael Thomas; Lewis Karl-QA3387; 'Henning Schulzrinne';
>[email-masked]
>Subject: RE: [SIP] Attempt at summarizing current SIP
>drafts (SIP
>Mobility )
>
>
>
 >  > efforts at
http://www.cs.columbia.edu/~hgs/sip/drafts.html. This is

---

From: Michael Thomas <[email-masked]>
Date: Wed, 27 Sep 2000 16:00:55 -0700 (PDT)

> plenty of reasons to justify the SIP approach to mobility.

   But what if you could do all of the same things
   and not need to modify or involve SIP and have the
   additional gain that things like http worked as well?

		   Mike