Subject: Re: [SIP] transaction identification

From: Bertil Engelholm <[email-masked]>
Date: Tue, 05 Sep 2000 13:36:14 +0200

"Fairlie-Cuninghame, Robert" wrote:
> 
> Bertil,
> 
> There's a difference between removing marginally useless headers/features
> and changing the whole protocol syntax - thereby making the protocol no
> longer backwards compatible.

This backwards compatible argument seems to come up again and again.
Could someone please explain what defines when a change is regarded 
as "backward compatible" vs "non backward compatible" in the SIP
case ? Is it related only to UA's or also to proxy servers ?

When in time was it decided that no non backwards compatible 
changes are allowed any more ?

Does this mean we can't add a parameter in the requestURI to
fix the transaction id problem. If we add such a parameter it
means that all proxies have to change to use that parameter 
which I would regard as a non backward compatible change. 

> 
> There are too many SIP implementations already out there to make these
> changes now (even if as implementors we would like to make these
> simplifications).

Most SIP implementations became obsolete when Record-Route/Route 
was introduced not too long time ago. Are you saying that since 
then there has been MANY SIP implementations released ? 
If this is true I might understand the need for only backwards 
compatible changes better. At the same time I think it's a small
job to remove the use of compact form (if anyone is using it) the
use of comma separated lists and line folding.

> 
> I beleive the recent discussions about simplifying the SIP syntax were
> suggesting that implementations SHOULD generate messages in the canonical
> form but still MUST still be able to parse anything (for backwards compat) -
> as distinct from removing these annoying elements form the protocol
> altogether.
> 

Yes, my first suggestion was like that but when Henning welcomed 
possible simplifications in the protocol I took the chance to get
rid of more things. I didn't realize that he maybe meant that it's
OK to remove things ONLY if it is backwards compatible. 

Removing the VIA hiding is something I agree on at least when
there are no possibility to hide Record-Route and since hiding
the VIA cause problems for loop detection 

-- 
Bertil Engelholm
AXE Research and Development        voice : +46 8 727 3499
SIP Security                        Fax   : +46 8 647 8276
S-126 25 Stockholm Sweden           E-mail:
[email-masked]

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: Jonathan Rosenberg <[email-masked]>
Date: Tue, 05 Sep 2000 09:49:36 -0400

> case ? Is it related only to UA's or also to proxy servers ?

Both, of course. Backwards compatible means a change or fix is
"invisible" to existing SIP devices, whilst useful to ones compliant to
the bis draft.

> changes are allowed any more ?

This is IETF process for evolution of an RFC.

> which I would regard as a non backward compatible change.

If it breaks correct operation by existing proxies, yes, it cannot be
done.

> was introduced not too long time ago.

Huh? Not sure which specification you are referring to, but the one I
look at, rfc2543, has both Route and Record-Route.

> Are you saying that since

There are many implementations of rfc2543. Over 50 implementations came
to the last bakeoff.

> use of comma separated lists and line folding.

These are senseless things to remove. Handling short form is trivial.
Removing it will break backwards compatibility (requests with short form
will be rejected as errored). Things like Via hiding can be removed
since the Hide header will just be ignored, and the feature not
provided, just as if it were never in the spec in the first place.

-Jonathan R.
-- 
Jonathan D. Rosenberg                       72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.cs.columbia.edu/~jdrosen         PHONE: (732) 741-7244
http://www.dynamicsoft.com

---

From: Bertil Engelholm <[email-masked]>
Date: Wed, 06 Sep 2000 13:48:10 +0200

OK, I have now read through IETF documents regarding RFC's
and better understand the development of an RFC. I still
beleave SIP would be a much better protocol if certain
things was remove and/or changed. Since the SIP WG have
the motto : "Simplicity is key" I thought that everyone 
actually was interested in simplifying SIP. Maybe the motto 
today should be : "Backwards Compatibility is key" 8-).

May I suggest that you look over the text in the status 
chapter of the RFC and maybe there better explain what status
the RFC is really in. In that way you might avoid future 
discussions like the one I started.

/Bertil