Subject: RE: [SIP] IM Questions

From: Jonathan Rosenberg <[email-masked]>
Date: Mon, 18 Sep 2000 04:24:50 -0400

> -----Original Message-----
> From: [email-masked]
> [mailto:[email-masked]]On Behalf Of Bobby Sardana
> Sent: Tuesday, September 05, 2000 5:29 PM
> To: [email-masked]
> Subject: [SIP] IM Questions
> 
> 
> Greetings:
> 
> I have been reading the draft 
> [draft-rosenberg-impp-im-00.txt] and have
> the following questions:
> 
> a. In section 4.1 Message flow, the message F4 has two "Via" 
> headers. Is
> this an error since the proxy should have popped the topmost "Via"?

Yes, it is an error.

> b. The draft does not outline support for multiple users 
> (2+). How will
> the communication happen? What will be the message flow?

There are several models. One is the "reflector" approach; I can send an IM
to sip:[email-masked], and this would result in an IM being sent to
each of the members of that group. Much like a centralized conference server
in SIP. In fact, it works very well with that model.

The other approach is a fully distributed conference, where I would send an
IM to each of the other participants. Much like the fully distributed
multiparty conference for voice. 

> c. How are dynamic users added to a buddy list? Can a REGISTER message
> be generated to perform the dynamic addition?

Yes, that is one way. It can also be done administratively from a web page
or something.

-Jonathan R.

----
Jonathan D. Rosenberg                       72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.cs.columbia.edu/~jdrosen         PHONE: (973) 952-5000
http://www.dynamicsoft.com

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: Bobby Sardana <[email-masked]>
Date: Tue, 19 Sep 2000 12:54:25 -0700

Jonathan:

Thanks for the answers. However, I have some more questions regarding the
centralized server:

a. Can a centralized server INVITE buddies on its own? e.g., if a centralized
server is managing a buddy list -- 3 users and recognizes that the 3rd one just
became "on" and wants to INVITE it to the session. In this case how is the CSeq
value propagated?

The reason I ask this is because from the draft:

Each IM also carries a CSeq, which is a sequence number plus the name of the
method of the request. The CSeq uniquely identifies each IM in the session.

Consider the following scenario (3 users - A, B, & C)

a. A sends MESSAGE to a centralized server for propagation to B - CSeq 1
b. A and B are communicating with monotonically increasing CSeq numbers.
c. When C gets invited by the centralized server, if the above mentioned
criteria is good, what should be the CSeq value in INVITE and how is it
syncrhonized between A, B, C for the same conference.

Obviously, there are various hacks to do this but was wondering if there is a
built-in mechanism I may have overlooked.

Regards,

[email-masked]