Subject: [SIP] SIP syntax in 2543-bis-01

From: Gérard GONNET <[email-masked]>
Date: Tue, 12 Sep 2000 15:06:29 +0200

The <SIP-URL> syntax in the draft 2543bis-01, page 18, resulting from a modification of the former release, can produce some ambiguous interpretation.
This concern the <userinfo> element, described as :
<user-info = [user | telephone-subscriber] [":" password]>.
(was described in the former release as <user-info = user [":" password]>, notice that the <user> element is not optional).
From the C appendix, "Summary of Augmented BNF" page 116 of the reference draft, specifying "Square brakets enclose optional elements; "[foo bar]" is equivalent to "*1(foo bar)",we deduce that the <user-info> element is constituted with :
- a first optional element, whose content (when present) is a <user> or a <telephone-subscriber>.
- a second optional element, whose content (when present) is <":"> followed by a <password>.
This rule makes possible to reduce the content of a <user-info> to a <":" password> element only, thanks to the declaration of the <user> element as optional... (ok, the semantic seems strange, but we are "parsing" the syntax).
Using the SIP-URL description of the SIP-URL syntax :
<SIP-URL = "sip:"[userinfo "@"] hostport url-parameters [headers]>,
we can produce a SIP-URL element looking like this :
<sip::a_password@hostport url-parameters [headers]>,
which seems to be erroneous.
To avoid such situation, I would suggest to describe the <user-info> element with the following syntax :
<user-info = (user | telephone-subscriber) [":" password]>.
This syntax describes now the <user-info> element as formed with a mandatory <user> or <telephone-subscriber> child element, optionaly followed by a <":" password> element.
Introducing this rule into the SIP-URL syntax produces : the <user-info> element (optional), if present in the <SIP-URL>, must be constituted with at least a <user> or a <telephone-subscriber> child element, optionaly followed by a <":" password> element, followed with "@" fixed element, wich seems to be a non ambiguous syntax.

---

From: Jonathan Rosenberg <[email-masked]>
Date: Mon, 18 Sep 2000 03:05:53 -0400

-----Original Message-----
From: Gérard GONNET [mailto:[email-masked]]
Sent: Tuesday, September 12, 2000 9:06 AM
To: [email-masked]
Cc: [email-masked]; SEVESTRE Thibaut
Subject: [SIP] SIP syntax in 2543-bis-01

>The <SIP-URL> syntax in the draft 2543bis-01, page 18, resulting from a
modification of the >former release, can produce some ambiguous
interpretation.
>(was described in the former release as <user-info = user [":" password]>,
notice that the ><user> element is not optional).

Hmm. Not sure why that happened; I can see no good reason for just having a
password. Henning?

-Jonathan R.

Jonathan D. Rosenberg                       72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.cs.columbia.edu/~jdrosen         PHONE: (732) 741-7244
http://www.dynamicsoft.com 

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip