Subject: RE: [SIP] received param

From: Jonathan Rosenberg <[email-masked]>
Date: Fri, 29 Sep 2000 11:56:27 -0400

I agree that the proxy should not be checking the received parameter, since
it didn't insert it in the first place. In fact, I thought that the spec
said that the downstream proxy should actually remove the received parameter
before forwarding upstream. But, I couldn't find text stating that in
rfc2543 or the bis draft which said that.

I think its a good idea to strip out the received tag. Basically if a UA or
proxy sends a request with a via parameter X, what comes back in the
response should be exactly the same.

Anyone object to adding this to the spec (along with text clarifying not to
look at the received parameter if it is there).

-Jonathan R.

> -----Original Message-----
> From: Gethin Liddell [mailto:[email-masked]]
> Sent: Friday, September 29, 2000 4:57 AM
> To: Dvir Oren; SIP
> Subject: Re: [SIP] received param
> 
> 
> On Thu, 28 Sep 2000, Dvir Oren wrote:
> > I ran into a problem with my SIP implementation when a UAS 
> returned a
> > reply to a Proxy with a receiver-tagged Via.  The Proxy 
> then wanted to 
> > check whether this reply is for itself, or to be proxied.  It first
> > looked at the first Via to see if it's its own Via.  It found the
> > receiver-tagged Via, and tried to compare it with what it 
> knows about
> > itself.
> 
> I don't think that you should be making this comparison at all.
> 
> Section 2.1, although specifically talks about sip url, does say that
> when comparing parameters:
> 
> "If a com-ponent is omitted, it matches based on its default value.
> (For example, otherwise equivalent URLs without a port specification
> and with port 5060 match.) Components not found in both URLs being
> compared are ignored."
> 
> applying this ethos to headers, then as your via does not contain a
> received parameter, you should not be making this comparison.  Just
> compare on the sent-protocol, sent-by and any parameters you add (such
> as branch)
> 
> HTH
> 
> -- 
> Gethin Liddell
> Ubiquity Software Corporation
> 
> http://www.ubiquity.net
> mailto:[email-masked]
> 
> _______________________________________________
> SIP mailing list
> [email-masked]
> http://lists.bell-labs.com/mailman/listinfo/sip
> 

---
Jonathan D. Rosenberg                       72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.cs.columbia.edu/~jdrosen         PHONE: (973) 952-5000
http://www.dynamicsoft.com

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: Gethin Liddell <[email-masked]>
Date: Fri, 29 Sep 2000 17:27:29 +0100

> look at the received parameter if it is there).

no objection, but is this just gonna turn into another one of those "be
strict on what you send and liberal on what you receive" scenario's, 

i.e. should it not be a MUST to send back vias without modification but
a SHOULD in that clients are able to a handle modified vias as
described b4?

http://www.ubiquity.net