Subject: RE: [SIP] Session Timer Question

From: Jonathan Rosenberg <[email-masked]>
Date: Tue, 26 Sep 2000 22:01:58 -0400

> -----Original Message-----
> From: Christer Holmberg [mailto:[email-masked]]
> Sent: Tuesday, September 26, 2000 4:54 PM
> To: [email-masked]
> Subject: [SIP] Session Timer Question
> 
> 
> 
> Hi,
> 
> I have a question about the session timer.
> 
> Since the session timer can be used even if one party supports it,
> consider the following examples, where the UAS (but not the UAC)
> supports it.
> 
> A.
> 
> UAC	UAS
> 
> --------->   INVITE
> 
> <---------   200 OK
> 	     Session-Expires: X
> 
> 
> B.
> 
> UAC	UAS
> 
> --------->   INVITE
> 
> <---------   200 OK
> 
> 
> The question is: does the UAS need to insert the 
> Session-Expires header
> in the response? The UAC may even not be able to understand 
> it (even if
> it does, there is nothing it can do with it since it doesn't 
> support the
> session timer in the first place) and the UAS will do the refreshes in
> either case.

Yes, its needed for the benefit of proxies along the path who may be
interested in the information.

-Jonathan R.

---
Jonathan D. Rosenberg                       72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.cs.columbia.edu/~jdrosen         PHONE: (973) 952-5000
http://www.dynamicsoft.com

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: "Bodgey" <[email-masked]>
Date: Wed, 27 Sep 2000 10:31:35 +0530

> interested in the information.

When using the extension, we need use the "supported" header to consult
between the UAS and UAC before either UAS or UAC adds some extensions. So we
ought to define Option-tag to support the extension or a type of extension
that is clasified from the many extensions.

Bodgey