Subject: [SIP] Do Requests using record-route always go over UDP

From: [email-masked]
Date: Mon, 18 Sep 2000 12:35:00 -0500

I have a question regarding Record-Route behaviour.

The definition of Record-Route states that in the maddr field "transport
parameter" is not allowed.

Does this mean that all Requests using Record-Route to reach the
destination can only go over UDP(default) since there is no way to specify TCP.

Thanks,

Anoop

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: "Pathangi N Janardhanan" <[email-masked]>
Date: Tue, 19 Sep 2000 11:00:24 +0530

Hi Anoop,

> destination can only go over UDP(default) since there is no way to
specify TCP.

   A proxy should not mandate the use of TCP, through the use
of "transport parameter" in the maddr. It should be willing to accept
both TCP and UDP. It would be upto the UA to initiate the request
in either TCP or UDP which may be a configurable option on that
UA.

   The reason why the "transport addr" should not be specified is
given below from the draft

"Inclusion
 of, say, a TCP transport parameter may prevent a UA that
 supports only UDP but reached the proxy inserting the
 Record-Route via another proxy from reaching this proxy
"

Jana