Subject: RE: [SIP] Content Length Question

From: Peter Kjellerstedt <[email-masked]>
Date: Tue, 12 Sep 2000 13:43:59 +0200

> -----Original Message-----
> From: Bobby Sardana [mailto:[email-masked]]
> Sent: 12 September 2000 02:26
> To: IETF SIP
> Subject: [SIP] Content Length Question
> 
> Greetings:
> 
> I tried the FAQ but could not find answers to my questions:
> 
> a. Where is the grammar for:
>      Content-Length: ...     <-- note the three "." defined? 
> I tried the
> [draft-ietf-sip-rfc2543bis-02] but could not find the entry.
> 
> b. What is the exact meaning when 3 periods appear as 
> Content-Length? I tried
> checking the HTTP 1.1 spec as well but could not find the reference.
> 
> Information on the above is appreciated.
> 
> Regards,
> 
> [email-masked]

I suppose this is taken from one of the examples of SIP messages.
In that case it is not real SIP-syntax, but rather used to mark
that "here should be the length of the content, but we did not
calculate it for the example".

Hope this was the information you were looking for,

//Peter

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: Gethin Liddell <[email-masked]>
Date: Tue, 12 Sep 2000 13:11:53 +0100

> > [draft-ietf-sip-rfc2543bis-02] but could not find the entry.

did you try section 6.18: Content-Length ?

> > checking the HTTP 1.1 spec as well but could not find the reference.

just means that content length meaning is obvious and you should assume
the correct content-length is present in a real message.l  saves
henning from counting the number of characters in the payload just to
put in the call flows.

-- 
Gethin Liddell
Ubiquity Software Corporation

http://www.ubiquity.net
mailto:[email-masked]