Subject: RE: [SIP] Attempt at summarizing current SIP drafts

From: Lewis Karl-QA3387 <[email-masked]>
Date: Tue, 26 Sep 2000 16:37:48 -0500

I have just reviewed the Mobility Related drafts and am wondering if anyone
is aware of the current status of draft-itsumo-sip -mobility-req-01. In
particular, several issues were identified such as Mobile IP not being
sufficient for personal mobility and location services, completing
registration in less than a few seconds, reconfiguration in milliseconds,
providing location services, support of inter domain soft-hand and secure
signaling. Have these issues been addressed or actively being worked?

Karl

-----Original Message-----
From: Henning Schulzrinne [mailto:[email-masked]]
Sent: Monday, September 25, 2000 9:20 AM
To: [email-masked]
Subject: [SIP] Attempt at summarizing current SIP drafts

Given the proliferation of SIP-related drafts, I've created a summary of
efforts at http://www.cs.columbia.edu/~hgs/sip/drafts.html. This is
known to be incomplete, so I'd appreciate if you could send me any
additions or corrections. (Jonathan Rosenberg provided some of the text;
any mistakes or misrepresentations are mine.)

It is fairly clear that there are a large number of drafts that have not
changed materially for half a year or more. Maybe it's time to have a WG
last call or two or ten...

Henning
-- 
Henning Schulzrinne   http://www.cs.columbia.edu/~hgs

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: Faramak Vakil <[email-masked]>
Date: Wed, 27 Sep 2000 11:39:55 -0400

We are actively working on these issues
in the ITSUMO project. We submitted
an ID, "Host Mobility Management Protocol"
<draft-itsmo-hmmp.txt.00> to IETF in October
1999. It is expired now, though we plan to post
its updated version by early November.

Regards, Faramak

---

From: Henry Sinnreich <[email-masked]>
Date: Wed, 27 Sep 2000 18:28:54 +0100

Given Karl's note, I would add the suggestion to add a link to,
or just add all drafts from
http://www.softarmor.com/sipwg/drafts

Many valuable drafts were out of scope of the SIP WG:
- Mobility: Itsumo (Telcordia)
- Home Appliances (Telordia)
- Message Waiting Indicator (Cisco)
- SIP for Hearing Disabled
- SIP-QoS-OSP
- AAAarch-SIP-OSP
- SIP for selecting MPLS routes (... and Crowcroft)
Remember, SIP is not only for telephony, but for any session...

Related WGs
- SPIRITS: Bjorkner (IN services), Gurbani,
- INAP: Faynberg, Slutsman
- ETSI SIP: Sijben, more...

My apology if I have ommitted some.

Henry

>From: [email-masked]
>[mailto:[email-masked]]On Behalf Of
>Lewis Karl-QA3387
>Sent: Tuesday, September 26, 2000 4:38 PM
>To: 'Henning Schulzrinne'; [email-masked]
>Subject: RE: [SIP] Attempt at summarizing current SIP drafts
>
>
>efforts at
http://www.cs.columbia.edu/~hgs/sip/drafts.html. This is
known to be incomplete, so I'd appreciate if you could send me
any
additions or corrections. (Jonathan Rosenberg provided some of
the text;
any mistakes or misrepresentations are mine.)

It is fairly clear that there are a large number of drafts that
have not
changed materially for half a year or more. Maybe it's time to
have a WG
last call or two or ten...

Henning

---

From: Michael Thomas <[email-masked]>
Date: Wed, 27 Sep 2000 09:32:17 -0700 (PDT)

While I'm more than willing to believe that there
are mobility issues that SIP needs to deal with,
this paper seems to be positing SIP as the means
of initiating data sessions altogether. To my
mind, that's a rather bellheaded way of thinking
about how you do what amounts to L3 admission
control. In fact, the IETF already has an L3
admission control mechanism: RSVP. RSVP's main
advantage is that it follows actual network
topology. SIP is at a distinct disadvantage since
all it knows about is the signaling path which
in normal circumstances has nothing to do with
the actual data path.

Maybe I'm misreading this whole paper, but it sure
looks like it to me. If my interpretation is
right, however, I'd like to know if the intention
is to signal the access routers providing the
L2/L3 bits using SIP instead of, say, COPS (or
DIAMETER). If so, I'd say that SIP truly has
arrived at becoming the new millenium's kitchen
sink if this is accepted.

	  Mike

---

From: Faramak Vakil <[email-masked]>
Date: Wed, 27 Sep 2000 14:47:09 -0400

The document <draft-itsumo-sip-mobility-req-01>
describes the requirement for a mobility management
scheme that uses SIP to support terminal, personal
and service mobility. It does not suggest/propose to use SIP
for setting up data sessions or making resource reservation
across the network.

Regards, Faramak