Subject: [SIP] reg Proxy authorization and authentication

From: "Raja Sekhar" <[email-masked]>
Date: Sun, 24 Sep 2000 17:43:44 -0400

Hai
 Please any body calrify me  the problem I faced with  the authorization
header and authentication header
In my UAC code  I am adding the Proxy authoirization header  to   the
register request consists

But still I am getting the 407 proxy authentication required . I am using
the type DIGEST and relam and user name pawd of my service provider

1.Is it any sequence where the porxy authorization  header to be added   in
the register message . Is it any document availble for the order of the
header in the request message .
rajasekhar -voicecore

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: "Jonathan Rosenberg" <[email-masked]>
Date: Sun, 24 Sep 2000 22:43:06 -0400

> -----Original Message-----
> From: Raja Sekhar [mailto:[email-masked]]
> Sent: Sunday, September 24, 2000 5:44 PM
> To: [email-masked]
> Subject: [SIP] reg Proxy authorization and authentication
>
>
> Hai

Ordering of headers in requests is not important, unless requests are being
signed using PGP. Since thats not the case here, it doesn't matter.

I would recommend you check the call flows draft:
http://www.ietf.org/internet-drafts/draft-ietf-sip-call-flows-01.txt

which has examples for e2e authentication (401, not 407), but the message
formatting is pretty much the same.

-Jonathan R.
---
Jonathan D. Rosenberg                       72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.cs.columbia.edu/~jdrosen         PHONE: (973) 952-5000
http://www.dynamicsoft.com

---

From: "Raja Sekhar" <[email-masked]>
Date: Mon, 25 Sep 2000 09:41:56 -0400

Hello
But I am sending the Proxy autherization header in my register message . The
proxy authorization header consists of the authtype and credentials
1.But when I try to display the registrar message I am except user name ,I
am able to view the rest like type relam and nonce etc
2. How the proxy is going to resolve username and password
3. My register message  useing MD5 algorithm .
reegards
rajasekhar

-----Original Message-----
From: Jonathan Rosenberg [mailto:[email-masked]]
Sent: Sunday, September 24, 2000 10:43 PM
To: [email-masked]; [email-masked]
Subject: RE: [SIP] reg Proxy authorization and authentication

-Jonathan R.
---