Subject: RE: [SIP] SIP feature services

From: Jonathan Rosenberg <[email-masked]>
Date: Sun, 10 Sep 2000 02:07:46 -0400

This question only makes sense in the context of directly applying the
IN model for SIP applications. I think SIP and its operation is sufficiently
different that this really doesn't make sense.

In the SIP model, the AS is simply another SIP entity. This means that it
gets
the initial INVITE, along with any other signaling in the call (if it
record-routes).
Any "mid-call" event, such as a re-INVITE, gets to the AS because the proxy
will
forward the INVITE there are per normal SIP procedures.

Rajeev writes:
> How do you indicate the occurence of a mid-call trigger (such 
> as for call
> waiting) from a SIP proxy (which could be running in a 
> softswitch) to an
> application server (which contains logic on how to handle the 
> feature for
> this specific subscriber, and may be running on another 
> SCP-like node)? This
> is a transaction-type messaging between SIP proxy and 
> application server,
> which is not necessarily in the context of a SIP session 
> setup between the
> two.

-Jonathan R.

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: Hong Chen <[email-masked]>
Date: Mon, 18 Sep 2000 16:22:00 -0500

> the initial INVITE, along with any other signaling in the call (if it

Exact issue here, since the AS SIP address should be set in the SIP URI of
initial INVITE.
Questions raised here are:
who(UAC or SIP proxy) should set the AS SIP URI in INVITE request ? and
How to find the SIP address for an AS serving the feature?