Subject: [SIP] SIP message transport on TCP

From: Aseem Agarwal <[email-masked]>
Date: Fri, 15 Sep 2000 18:55:20 -0700

Is there any application level framing mechanism (like TPKT -rfc 1006
for H.225/245 in H.323 network) for SIP when used over TCP ?
If not, then each application will be required to collate the
data read in each TCP-recv till it gets the full message.

Any comments will be appreciated.

-aseem

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: Henning Schulzrinne <[email-masked]>
Date: Sat, 16 Sep 2000 08:37:47 -0400

The "framing" is described in the spec and is almost the same as that
used billions of times a day by HTTP servers.