Subject: RE: [SIP] Bug in 2543bis-02 re: Record-Route

From: Jonathan Rosenberg <[email-masked]>
Date: Tue, 19 Dec 2000 01:34:14 -0500

Its pending....

till then, let me be explicit on this one.

1. A UAC/UAS does NOT rebuild the route on each request. As Vijay pointed
out, the reconstruction is done on crash-restart, assuming the device is
trying to recover on a re-invite. 

2. proxies re-insert record-route into every request for robustness, to
handle the case above and also the case of "pre-loaded" route headers, where
the request starts out with a set of Route headers obtained out of band.

-Jonathan R.

---
Jonathan D. Rosenberg                       72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.cs.columbia.edu/~jdrosen         PHONE: (973) 952-5000
http://www.dynamicsoft.com

> -----Original Message-----
> From: Neil Deason [mailto:[email-masked]]
> Sent: Monday, December 18, 2000 5:22 AM
> To: Keith Robinson
> Cc: Billy Biggs; Jean-Francois Mule; [email-masked]
> Subject: Re: [SIP] Bug in 2543bis-02 re: Record-Route
> 
> 
> I wouldn't pay too much attention to the present Record-Route
> text. 
> This problem area was discussed in some detail at the recent
> bakeoff 
> + IETF. There should shortly be revised text from Jonathan R 
> which will be simpler, cleaner and work.
> 
> Cheers,
> Neil.
> -- 
> Ubiquity Software Corporation, UK        http://www.ubiquity.net
> 
> Keith Robinson wrote:
> > 
> > I believe that the way the text on the construction of the 
> Route headers is
> > worded will lead to
> > faulty behaviour as follows:
> > 
> > In 6.35.2 (construction of Route header) the text says
> > 
> > "A UA builds the Route header field for subsequent requests from the
> > Record-Route header fields
> > received in either a response or a request"
> > 
> > This implies that a UA will build a new Route every time a 
> Record-Route header
> > is present in
> > a request or a response, not just for the initial INVITE. 
> Therefore, coupled
> > with the prior text
> > about a proxy adding itself to every request is only SHOULD 
> not MUST, a proxy
> > which assumes that
> >  the Route will persist until the end of call leg and 
> doesn't add itself to
> > subsequent requests will be
> > excluded from the path if other proxies do add themselves 
> on subsequent requests
> > thereby causing
> > a UA to reconstruct the Route header, which would break the 
> rule that the path
> > is persistent until the
> > end of the call leg.
> > 
> > That said, I have read other memos on the list (can't 
> remember which, but they
> > are there) where the author
> > has implied that a proxy can take itself out of the path, 
> which in the above
> > scenario would be by excluding
> > itself on subsequent requests.
> > 
> > Perhaps there are two interpretations out there, one where 
> a proxy stays in for
> > good and one where a
> > proxy stays in until it excludes itself; whichever is 
> correct, the spec is
> > ambiguous as it seems to try and
> > support both at the same time. It can't, its one or the other.
> > 
> > Regards,
> > 
> > K. Robinson
> 
> _______________________________________________
> SIP mailing list
> [email-masked]
> http://lists.bell-labs.com/mailman/listinfo/sip
> 

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: "Keith Robinson" <[email-masked]>
Date: Wed, 20 Dec 2000 09:17:07 +0000

Requiring a proxy to add itself to each request for robustness in case the UA
crashes is fine but
it has to be MUST to be sure it stays in the path as it cant know when the UA is
about to crash-reboot.

Regards,

K. Robinson