Subject: RE: [SIP] Bug in 2543bis-02 re: Record-Route

From: "Emami-Nouri, Mohsen" <[email-masked]>
Date: Wed, 20 Dec 2000 12:30:09 -0800

Talking roubestness, proxy adding itself to each requests would only take
care of responses going the right route, but not any new request after an UA
crashed. For that the route ninformation needs to get persistant, so that
the UA also after a crash still has the route information, am I right?

-----Original Message-----
From: Keith Robinson [mailto:[email-masked]]
Sent: Wednesday, December 20, 2000 1:17 AM
To: Jonathan Rosenberg
Cc: 'Neil Deason'; Billy Biggs; Jean-Francois Mule;
[email-masked]
Subject: RE: [SIP] Bug in 2543bis-02 re: Record-Route

Requiring a proxy to add itself to each request for robustness in case the
UA
crashes is fine but
it has to be MUST to be sure it stays in the path as it cant know when the
UA is
about to crash-reboot.

Regards,

K. Robinson

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: Vijay Gurbani <[email-masked]>
Date: Wed, 20 Dec 2000 14:38:25 -0600

"Emami-Nouri, Mohsen" wrote:
> care of responses going the right route, but not any new request after an
> UA  crashed. 

I suspect not; the responses will follow the Via list, not the Route list.

> For that the route ninformation needs to get persistant, so that

Hence the need for every proxy to include a R-R so that a crashed UA can
resurrect the Route list from the R-R headers in the request it got after
rebooting.

- vijay
-- 
Vijay K. Gurbani  vkg@{lucent.com,research.bell-labs.com,acm.org}
Internet Software and eServices Group 
Lucent Technologies/Bell Labs Innovations 263 Shuman Blvd., Rm 1A-413
Naperville, Illinois 60566     Voice: +1 630 224 0216   Fax: +1 630 713 0184