Subject: RE: [SIP] 3pcc callflow question (Was:Changin local RTP port with out a good reason)

From: "Fairlie-Cuninghame, Robert" <[email-masked]>
Date: Mon, 18 Dec 2000 22:51:05 -0800

> An alternative flow has already been proposed which does not 
> suffer from the
> timeout problem, and which does not have this race condition:
> 

> > >  A                Controller            B
> > >  |  INV  SDP held    |                  | time t = 0
> > >  |<------------------|                  |
> > >  |                   |                  |
> > >  |  200 SDP A1       |                  |
> > >  |-----------------> |                  |
> > >  |                   |                  |
> > >  |       ACK         |                  |
> > >  |<------------------|                  |
> > >  |                   |                  |

Sorry to go back a bit but can I forget the reason why it was decided not to
start with:

A	Controller

INV no SDP 
<--------

200 SDP A1
-------->

ACK SDP held
<--------

This seems simpler as both A and B are behaving in the same manner (rather
than A having to realize that it must produce SDP A1 when it receives an
initial SDP held).

Was it because of crash-restart problems ?

Regards,

Robert.

> > >  |                   |  INV no SDP      |
> > >  |                   |----------------->|  (1)
> > >  |                   |                  |
> > >  |                   |  200 SDP B       |
> > >  |                   |<-----------------|
> > >  |      INV SDP B    |                  |
> > >  |<------------------|                  |
> > >  |                   |                  |
> > >  |  200 SDP A2       |                  |
> > >  |-----------------> |                  |
> > >  |                   |                  |
> > >  |                   |  ACK  SDP A2     |
> > >  |  ACK              |----------------->|
> > >  |<------------------|                  |
> > >  |                   |                  |
> > >  |                   |       RTP        |
> > >  |xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx |
> > >  |xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx |
> > >  |                   |                  |
> 
> 
> I'd like to start with this one as the basis for continuing
> discussion/concerns.
> 
> -Jonathan R.
> 
> 
> ---
> Jonathan D. Rosenberg                       72 Eagle Rock Ave.
> Chief Scientist                             First Floor
> dynamicsoft                                 East Hanover, NJ 07936
> [email-masked]                     FAX:   (973) 952-5050
> http://www.cs.columbia.edu/~jdrosen         PHONE: (973) 952-5000
> http://www.dynamicsoft.com
> 
> _______________________________________________
> SIP mailing list
> [email-masked]
> http://lists.bell-labs.com/mailman/listinfo/sip
> 

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: "Robert Sparks" <[email-masked]>
Date: Tue, 19 Dec 2000 10:57:30 -0600

Doesn't matter. Notice that in the original diagram, A1
isn't used in the negotiation with B. If A automatically
returns held sdp when it recieves held sdp, things don't
break.

Out of curiosity, does anyone have a UA deployed that won't
accept an initial INVITE to held media? If so, it argues for
using the delayed media approach you suggest.

RjS

> -----Original Message-----
> From: [email-masked]
> [mailto:[email-masked]]On Behalf Of Fairlie-Cuninghame,
> Robert
> Sent: Tuesday, December 19, 2000 12:51 AM
> To: [email-masked]
> Subject: RE: [SIP] 3pcc callflow question (Was:Changin local RTP port
> without a good reason)
>
>