Subject: Re: [SIP] Bug in 2543bis-02 re: Record-Route

From: "Keith Robinson" <[email-masked]>
Date: Mon, 18 Dec 2000 10:08:47 +0000

I believe that the way the text on the construction of the Route headers is
worded will lead to
faulty behaviour as follows:

In 6.35.2 (construction of Route header) the text says

"A UA builds the Route header field for subsequent requests from the
Record-Route header fields
received in either a response or a request"

This implies that a UA will build a new Route every time a Record-Route header
is present in
a request or a response, not just for the initial INVITE. Therefore, coupled
with the prior text
about a proxy adding itself to every request is only SHOULD not MUST, a proxy
which assumes that
 the Route will persist until the end of call leg and doesn't add itself to
subsequent requests will be
excluded from the path if other proxies do add themselves on subsequent requests
thereby causing
a UA to reconstruct the Route header, which would break the rule that the path
is persistent until the
end of the call leg.

That said, I have read other memos on the list (can't remember which, but they
are there) where the author
has implied that a proxy can take itself out of the path, which in the above
scenario would be by excluding
itself on subsequent requests.

Perhaps there are two interpretations out there, one where a proxy stays in for
good and one where a
proxy stays in until it excludes itself; whichever is correct, the spec is
ambiguous as it seems to try and
support both at the same time. It can't, its one or the other.

Regards,

K. Robinson

Billy Biggs <[email-masked]> on 15/12/2000 19:52:14

                                                              

 To:      Jean-Francois Mule <[email-masked]>             
                                                              
 cc:      Billy Biggs <[email-masked]>(bcc: Keith    
          Robinson/MAIN/MC1)                                  

 Subject: Re: [SIP] Bug in 2543bis-02 re: Record-Route        

Jean-Francois Mule ([email-masked]):

> Independently of the Record-Route discussions, the 2543bis-02 (dated
> 11-24-00) has a small issue:
>
> In the same section 6.35.1 of 2543bis-02, it is stated:
> "a request route, once established, persists until the end of the call
> leg, *regardless of whether the Record-Route header is present in
> subsequent requests.*"
> ...
> "Note that proxy servers have to add Record-Route headers to each
> request *as long as* they want to be "visited" by the next request for
> the call leg." The persistence of the record-route is confusing.  The
> suggestion is to just remove the note.

  The statement is correct: The Route persists until the end of the call
leg regardless.  Proxies may not ever leave the Route for a call-leg.
The only thing that can be updated is the Contact address at the far
end.

  That said, proxies must still add a Record-Route header, just to make
the protocol more explicit.

  Is there some other statement in the bis which makes this confusing?
Hopefully when this is re-written it will all become clearer.

--
Billy Biggs, 3Com               Email: [email-masked]
http://www.div8.net/billy/      Phone: [email-masked]

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: Neil Deason <[email-masked]>
Date: Mon, 18 Dec 2000 10:22:22 +0000

I wouldn't pay too much attention to the present Record-Route
text. 
This problem area was discussed in some detail at the recent
bakeoff 
+ IETF. There should shortly be revised text from Jonathan R 
which will be simpler, cleaner and work.

Cheers,
Neil.
-- 
Ubiquity Software Corporation, UK        http://www.ubiquity.net