Subject: [SIP] Consultation

From: james jack <[email-masked]>
Date: Tue, 5 Dec 2000 02:02:43 -0800 (PST)

Dear All:
  I have one SIP question to Consult.
  On RFC2543bis02 and
draft-ietf-sip-call-flows-01.txt,
If one send one following REGISTER request to
Registrar,what would happen? Support this REGISTER 
is the first REGISTER request for this user.
   REGISTER sip:there.com SIP/2.0
   Via: SIP/2.0/UDP there.com:5060
   From: LittleGuy <sip:[email-masked]>
   To: LittleGuy <sip:[email-masked]>
   Call-ID: [email-masked]
   CSeq: 1 REGISTER
   Contact: LittleGuy <sip:[email-masked]>
   Authorization:Digest username="UserB", realm="MCI  
WorldCom SIP",   
nonce="1cec4341ae6cbe5a359ea9c8e88df84f", opaque="",
    uri="sip:ss2.wcom.com",
response="71ba27c64bd01de719686aa4590d5824"
   Content-Length: 0

   For this REGISTER request, the Name-addr in Contact
header is the same as that of To header,Since To
header is the alias address, Contact header is the
practical address for one user. So if one INVITE
request send to the Server whose domain is the same
as that of Registrar, then if the Request_uri of
INVITE request is "[email-masked]", If the Server 
look up into the directory,the contact information is
no use to help find the next hop, at this time, what 
should the Proxy/Redirect server do?
   I think If the content of contact is the same 
as that of To header in REGISTER request, then this 
request is no use.
   Could anyone give me some advice and suggestion?
   Best Regards!
                              Yours: james   

__________________________________________________
Do You Yahoo!?
Yahoo! Shopping - Thousands of Stores. Millions of Products.
http://shopping.yahoo.com/

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: Vijay Gurbani <[email-masked]>
Date: Tue, 05 Dec 2000 07:52:42 -0600

james jack wrote:
> practical address for one user. 

Typically, Contact addresses contain a specific location ("user@host") as
opposed to a generic identifier ("user@domain") (see the Nov bis, Section
4.2.6, page 30).  It would appear to me that a well behaved UA, when it is 
registering itself in its own domain, will include a specific location in 
the REGISTER as opposed to a generic identifier.

> So if one INVITE request send to the Server whose domain is the same

Well, the proxy could try to route the request based on the Request URI.  It
may very well find (by querying DNS SRV records, say) that *it* is the next
hop server -- it can declare a loop at that point in time and send back the
appropriate 4xx response.

Another option is to have the registrar reject REGISTER requests from its
own domain if they do not include a specific location.

Regards,

- vijay
-- 
Vijay K. Gurbani  vkg@{lucent.com,research.bell-labs.com,acm.org}
Internet Software and eServices Group 
Lucent Technologies/Bell Labs Innovations 263 Shuman Blvd., Rm 1A-413
Naperville, Illinois 60566     Voice: +1 630 224 0216   Fax: +1 630 713 0184