Subject: RE: [SIP] Proxies modifying SDP

From: Baniel Uri-CUB001 <[email-masked]>
Date: Mon, 18 Dec 2000 19:05:17 -0600

Hmm...
Probably I was not clear and hence the confusion.
My intention was to be able to mimic the 'H323 gate keeper mode'
functionality, i.e. to have the end points think they talk to each other (in
the media streaming phase) but actually the media goes via a gate keeper. In
our SIP world this should be just a MG (Media Gateway).
The control may still go via a SIP proxy server, that is why I think
changing SDP fields (specifically the IP address for receiving media as well
as the RTP ports) may easily achieve this goal

Uri

-----Original Message-----
From: Steve Donovan [mailto:[email-masked]]
Sent: Sunday, December 17, 2000 9:12 PM
To: Baniel Uri-CUB001; 'Neil Deason'; [email-masked];
[email-masked]; [email-masked]
Subject: RE: [SIP] Proxies modifying SDP

Although I am having a hard time understanding why it would be necessary to
modify the SDP to cause the call to go through a specific gateway, as Neil
correctly points out, this is likely to be a function of a back-to-back UA.

Why is it not enough to have the proxy route the call to the gateway in
question by changing the request-URI to point to the gateway?

Steve

> -----Original Message-----
> From: [email-masked]
> [mailto:[email-masked]]On Behalf Of Baniel Uri-CUB001
> Sent: Friday, December 15, 2000 1:51 PM
> To: 'Neil Deason'; [email-masked]; [email-masked];
> [email-masked]
> Subject: RE: [SIP] Proxies modifying SDP
>
>
> I see it as the requested way of forcing the media stream to go
> via an 'IP switch' (like the H323 MCU).
> If a proxy server is not allowed or if it is not appropriate for
> it to touch the SDP element, then is there any other way to make
> sure the media stream goes via our MCU gateway. (There could be
> various of reasons why we would want to have such a gateway)
>
> What do u think?
>
> Uri
>
> -----Original Message-----
> From: Neil Deason [mailto:[email-masked]]
> Sent: Friday, December 15, 2000 12:30 PM
> To: [email-masked]; [email-masked]; [email-masked]
> Subject: RE: [SIP] Proxies modifying SDP
>
>
>
> >Bernie Hoeneisen wrote:
> > > I have question concerning the case, when SIP proxies modify SDP,
> > > which is AFAIK against SIP principles, isn't it?
> >I do not think so.
> >Why is that *against* SIP principles?  What principles?'
>
> The fundamental concept that payloads are opaque to SIP Proxy
> Servers. To do this sort of thing you probably want to use a
> back to back UA.
>
> Cheers,
> Neil.
> --
> Ubiquity Software, UK                    www.ubiquity.net
>
> > > In the concrete case, proxies would be able to remove certain codecs
> > > from the INVITE messages, depending on the current policy in the
> > > network. (The UAS gets a subset of the codecs, which were originally
> > > sent by the UAC.)
> > > What impact does such a proxy behavior have to SIP? I can think of
> > > problems with authentication and message integrity checking (UAC signs
> > > message with its private key).
> >It certainly depends on the security mechanism used.  For e.g., with the
> >simple basic md5, it does not cause any issue.
> >
> >Jean-Francois
>
> _________________________________________________________________________
> Get Your Private, Free E-mail from MSN Hotmail at http://www.hotmail.com.
>
>
> _______________________________________________
> SIP mailing list
> [email-masked]
> http://lists.bell-labs.com/mailman/listinfo/sip
>
> _______________________________________________
> SIP mailing list
> [email-masked]
> http://lists.bell-labs.com/mailman/listinfo/sip
>

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: "Steve Donovan" <[email-masked]>
Date: Mon, 18 Dec 2000 19:17:25 -0600

Baniel,

Thanks for the clarification.  Keep in mind that I am not an expert on
H.323, so I don't fully understand the H323 gate keeper mode you refer to.

This said, in order to implement what you refer to, you have a few options,
none of which directly  involves a proxy.

- The easiest way to handle this is to put a SIP user agent directly on the
media gateway and have that user agent directly determine the address of and
type of media to use for the call.

- If you want to have another device "control" the media flow, this is more
appropriately done using a Media Gateway Controller (MGC).  The MGC would be
a SIP end point, not a proxy.  It would communicate with the MG using one of
the control protocols (MGCP, MEGACO, ...).  With it being a SIP end-point,
it can do what ever it wants to the SDP, within the bounds of the rules
specified in the SIP specification.

There may be a proxy (or multiple proxies) between the caller and the
MGC/MG, but its job is to route the SIP request.  As stated earlier, the
message body of the request is opaque.

Hope this helps...

Steve

---
Steven R. Donovan
Architect                           dynamicsoft
mailto:[email-masked]     5100 Tennyson Parkway
sip:[email-masked]    Plano, Texas 75025
tel:+1-972-473-5469                 http://www.dynamicsoft.com

> Sent: Monday, December 18, 2000 7:05 PM
> To: 'Steve Donovan'; Baniel Uri-CUB001; 'Neil Deason';
> [email-masked]; [email-masked]; [email-masked]