Subject: RE: [SIP] 3pcc callflow question (Was:Changin local RTP port with out a good reason)

From: "Fairlie-Cuninghame, Robert" <[email-masked]>
Date: Tue, 19 Dec 2000 21:59:42 -0800

> 
> Doesn't matter. Notice that in the original diagram, A1
> isn't used in the negotiation with B. If A automatically
> returns held sdp when it recieves held sdp, things don't
> break.
> 
> Out of curiosity, does anyone have a UA deployed that won't
> accept an initial INVITE to held media? If so, it argues for
> using the delayed media approach you suggest.
> 
Hi Robert,

I imagine that some UA's may not be happy with an initial SDP (held) with no
vocoders, eg

v=0
o=...
c=IN IP4 0.0.0.0
m=audio 10000 RTP/AVP

[Otherwise the controller would have to know/guess the lowest capabilities
of UA A - which is unacceptable.]

Placing no SDP in the INVITE also has the advantage that the controller can
immediately take action if it detects that the 200 Ok from UA B (containing
SDP B) is incompatiable with SDP A1 (rather than the UA A re-INVITE failing
... which adds more chance of strange things happening due to incorrect UA
re-INVITE error handling).

Regards,

Robert.

> 
> > -----Original Message-----
> > From: [email-masked]
> > [mailto:[email-masked]]On Behalf Of 
> Fairlie-Cuninghame,
> > Robert
> > Sent: Tuesday, December 19, 2000 12:51 AM
> > To: [email-masked]
> > Subject: RE: [SIP] 3pcc callflow question (Was:Changin 
> local RTP port
> > without a good reason)
> >
> >
> > > An alternative flow has already been proposed which does not
> > > suffer from the
> > > timeout problem, and which does not have this race condition:
> > >
> >
> > > > >  A                Controller            B
> > > > >  |  INV  SDP held    |                  | time t = 0
> > > > >  |<------------------|                  |
> > > > >  |                   |                  |
> > > > >  |  200 SDP A1       |                  |
> > > > >  |-----------------> |                  |
> > > > >  |                   |                  |
> > > > >  |       ACK         |                  |
> > > > >  |<------------------|                  |
> > > > >  |                   |                  |
> >
> > Sorry to go back a bit but can I forget the reason why it was
> > decided not to
> > start with:
> >
> > A	Controller
> >
> > INV no SDP
> > <--------
> >
> > 200 SDP A1
> > -------->
> >
> > ACK SDP held
> > <--------
> >
> > This seems simpler as both A and B are behaving in the same 
> manner (rather
> > than A having to realize that it must produce SDP A1 when 
> it receives an
> > initial SDP held).
> >
> > Was it because of crash-restart problems ?
> >
> > Regards,
> >
> > Robert.
> >
> >
> > > > >  |                   |  INV no SDP      |
> > > > >  |                   |----------------->|  (1)
> > > > >  |                   |                  |
> > > > >  |                   |  200 SDP B       |
> > > > >  |                   |<-----------------|
> > > > >  |      INV SDP B    |                  |
> > > > >  |<------------------|                  |
> > > > >  |                   |                  |
> > > > >  |  200 SDP A2       |                  |
> > > > >  |-----------------> |                  |
> > > > >  |                   |                  |
> > > > >  |                   |  ACK  SDP A2     |
> > > > >  |  ACK              |----------------->|
> > > > >  |<------------------|                  |
> > > > >  |                   |                  |
> > > > >  |                   |       RTP        |
> > > > >  |xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx |
> > > > >  |xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx |
> > > > >  |                   |                  |
> > >
> > >
> > > I'd like to start with this one as the basis for continuing
> > > discussion/concerns.
> > >
> > > -Jonathan R.
> > >
> > >
> > > ---
> > > Jonathan D. Rosenberg                       72 Eagle Rock Ave.
> > > Chief Scientist                             First Floor
> > > dynamicsoft                                 East Hanover, NJ 07936
> > > [email-masked]                     FAX:   (973) 952-5050
> > > http://www.cs.columbia.edu/~jdrosen         PHONE: (973) 952-5000
> > > http://www.dynamicsoft.com
> > >
> > > _______________________________________________
> > > SIP mailing list
> > > [email-masked]
> > > http://lists.bell-labs.com/mailman/listinfo/sip
> > >
> >
> > _______________________________________________
> > SIP mailing list
> > [email-masked]
> > http://lists.bell-labs.com/mailman/listinfo/sip
> >
> 

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: Jonathan Rosenberg <[email-masked]>
Date: Fri, 22 Dec 2000 00:57:05 -0500

> From: Fairlie-Cuninghame, Robert [mailto:[email-masked]]
> Sent: Wednesday, December 20, 2000 1:00 AM
> To: 'Robert Sparks'; [email-masked]
> Subject: RE: [SIP] 3pcc callflow question (Was:Changin local RTP port
> with out a good reason)
> 
> 
> > 

This is not what "held SDP" looks like. The above SDP is actually invalid.
Quoting the BNF from rfc2327:

 media-field =         "m=" media space port ["/" integer]
                         space proto 1*(space fmt) CRLF

Thus, you must include at least one codec:

 v=0
 o=...
 c=IN IP4 0.0.0.0
 m=audio 10000 RTP/AVP 0

> of UA A - which is unacceptable.]

It doesn't matter. This held SDP is updated anyway with a re-invite later
on. The primary problem would only be if there were no codecs in the INVITE
that were supported by the recipient. Listing the the most common ones
(g.711, g.723.1, g.729) in the held SDP, as a result, should work fine, even
if they are not actually supported by A. 

However, it is simplified if the initial INVITE has no SDP.

-Jonathan R.
---

---

From: "Fairlie-Cuninghame, Robert" <[email-masked]>
Date: Wed, 27 Dec 2000 17:17:40 -0800

> However, it is simplified if the initial INVITE has no SDP.

What if the UA doesn't support audio m lines? Proposing an SDP with just
held audio will probably lead to call refusal.

I also imagine that things will get complicated when there are mutiple m
lines in the SDP (eg 2 audio + 1 video). What if the The 3pcc may even have
to rewrite each SDP unless the UA's are very good at heuristic/adhoc m line
matching.

Cheers,

Robert.