Subject: RE: [SIP] Record-Route and REGISTER

From: "Emami-Nouri, Mohsen" <[email-masked]>
Date: Wed, 20 Dec 2000 10:22:22 -0800

-----Original Message-----
From: Steve Donovan [mailto:[email-masked]]
Sent: Wednesday, December 20, 2000 7:12 AM
To: Simon Barber; Jonathan Rosenberg; 'Sean Olson'
Cc: 'David Shrader'; SIP List
Subject: RE: [SIP] Record-Route and REGISTER

> -----Original Message-----
> From: Simon Barber [mailto:[email-masked]]
> Sent: Tuesday, December 19, 2000 6:13 PM
> To: Jonathan Rosenberg; 'Sean Olson'; Steve Donovan
> Cc: 'David Shrader'; SIP List
> Subject: Re: [SIP] Record-Route and REGISTER
>
>
> From: "Jonathan Rosenberg" <[email-masked]>
> To: "'Sean Olson'" <[email-masked]>; "Steve Donovan"
> <[email-masked]>
> Cc: "Jonathan Rosenberg" <[email-masked]>; "'David Shrader'"
> <[email-masked]>; "SIP List" <[email-masked]>
> Sent: Tuesday, December 19, 2000 3:16 PM
> Subject: RE: [SIP] Record-Route and REGISTER
>
>
> > This issue is what I meant when I said:
> >
> > >What is the the scope of the Route? To which set of messages does
> > >it apply? When can the route be purged?
> >
> > The obvious generalization of the current Route mechanism is that a UA
> uses
> > the Routes for all requests with the same To/From/Call-ID. This
> would then
> > effect refreshes of REGISTER, and is also how we handle
> record-routing of
> > SUBSCRIBE/NOTIFY and MESSAGE as well.
> >
> > What would you use RR on REGISTER for? Not sure... any ideas?
>
>
> A firewall proxy for a large private network might want to keep state for
> the registration of a UA - and also load-balance. This brings up
> the further
> question of keeping the same proxy in the loop for future INVITE and other
> methods, as well as future REGISTERs.

But the can't the firewall proxy use the state that is already in the
registrar to which the REGISTER is being sent?

I can see that use of record-route would make a more efficient method for
routing REGISTERs to the same registrar (after the first is sent).  However,
there are other methods (for instance, routing based on the to field). 

I do not think this is a good idea no routing decision should be made based
on "to" header, can we make a exception for reigsration and do routing based
on "to" header?,  clearly no

such, is it worth it to create a special way of handling record-routes just
for REGISTER messages?  This seems to me to break the KISS principle.

more below...

> > > -----Original Message-----
> > > From: Sean Olson [mailto:[email-masked]]
> > > Sent: Tuesday, December 19, 2000 2:18 PM
> > > To: Steve Donovan
> > > Cc: Jonathan Rosenberg; 'David Shrader'; SIP List
> > > Subject: Re: [SIP] Record-Route and REGISTER
> > >
> > >
> > > What about subsequent re-registrations? It is conceivable that
> > > a stateful proxy might want to know about these re-registrations
> > > (perhaps for caching purposes). Of course, this doesn't help
> > > with the case where multiple UAs are registering for the same
> > > user.

Again, shouldn't that stateful proxy use the registrar/location server for
it's domain?  That's the only way to fix the multiple UA registering
problem.

> > >
> > > Sean
> > >
> > > Steve Donovan wrote:
> > > >
> > > > Why are we worried about record-routing REGISTER messages.
> > > Record-Routing
> > > > is used to ensure that all messages within a session go
> > > through interested
> > > > proxies.  This is obviously useful with INVITE and SUBSCRIBE.
> > > >
> > > > There is no session created by REGISTER.  As such, there
> > > are no other
> > > > messages that need to take the same route.
> > > >
> > > > Is the goal to ensure that subsequent REGISTER requests
> > > make it to the same
> > > > instance of a registrar within a domain?  If so, is the use
> > > of Record-Route
> > > > the correct solution?
> > > >
> > > > Steve
> > > >
> > > > > -----Original Message-----
> > > > > From: [email-masked]
> > > > > [mailto:[email-masked]]On Behalf Of
> > > Jonathan Rosenberg
> > > > > Sent: Tuesday, December 19, 2000 12:25 AM
> > > > > To: 'David Shrader'; SIP List
> > > > > Subject: RE: [SIP] Record-Route and REGISTER
> > > > >
> > > > >
> > > > >
> > > > >
> > > > >
> > > > >
> > > > > > -----Original Message-----
> > > > > > From: David Shrader [mailto:[email-masked]]
> > > > > > Sent: Sunday, December 17, 2000 3:40 PM
> > > > > > To: SIP List
> > > > > > Subject: [SIP] Record-Route and REGISTER
> > > > > >
> > > > > > When using the REGISTER method, however, the Contact header
> > > > > > is NOT used for
> > > > > > that purpose. The Contact header in the Response to a
> > > > > > REGISTER is simply a
> > > > > > list of registered contacts and does not in fact identify the
> > > > > > recipient of a
> > > > > > subsequent request.
> > > > >
> > > > > Correct. REGISTER is nearly a separate protocol, for all
> > > intents and
> > > > > purposes. As specified right now, record-routing for
> > > REGISTER is ambigous.
> > > > > In any case, record-routing for transactions outside of INVITE is
> > > > > not clear.
> > > > > What is the the scope of the Route? To which set of messages does
> > > > > it apply?
> > > > > When can the route be purged? These issues must be
> > > resolved as well, and
> > > > > they are much harder.
> > > > >
> > > > > The solution to your specific problem is for the UAC and
> > > UAC to use RR in
> > > > > REGISTER instead. So:
> > > > >
> > > > > 1. A UAC inserts a REcord-route into the REGISTER
> > > pointing to itself, just
> > > > > like the Contact would look in an INVITE
> > > > > 2. proxies can record-route
> > > > > 3. UAS (the registrar, in this case) also adds a RR, and reflects
> > > > > that back
> > > > > in 200 OK
> > > > > 4. Route is constructed normally except COntact is ignored
> > > > >
> > > > >
> > > > > Kind of a pain to have a special procedure for REGISTER,
> > > I know. In
> > > > > hindsight, I would have used something instead of Contact
> > > here, but at the
> > > > > time rfc2543 was being written, the usages were similar enough
> > > > > and the idea
> > > > > of record-routing REGISTER was not something we considered.
> > > > >
> > > > > -Jonathan R.
> > > > > ---
> > > > > Jonathan D. Rosenberg                       72 Eagle Rock Ave.
> > > > > Chief Scientist                             First Floor
> > > > > dynamicsoft                                 East Hanover, NJ 07936
> > > > > [email-masked]                     FAX:   (973) 952-5050
> > > > > http://www.cs.columbia.edu/~jdrosen         PHONE: (973) 952-5000
> > > > > http://www.dynamicsoft.com
> > > > >
> > > > > _______________________________________________
> > > > > SIP mailing list
> > > > > [email-masked]
> > > > > http://lists.bell-labs.com/mailman/listinfo/sip
> > > > >
> > > >
> > > > _______________________________________________
> > > > SIP mailing list
> > > > [email-masked]
> > > > http://lists.bell-labs.com/mailman/listinfo/sip
> > >
> > > _______________________________________________
> > > SIP mailing list
> > > [email-masked]
> > > http://lists.bell-labs.com/mailman/listinfo/sip
> > >
> >
> > _______________________________________________
> > SIP mailing list
> > [email-masked]
> > http://lists.bell-labs.com/mailman/listinfo/sip
> >
>
>

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: "Steve Donovan" <[email-masked]>
Date: Wed, 20 Dec 2000 14:09:45 -0600

> From: Emami-Nouri, Mohsen [mailto:[email-masked]]
> Sent: Wednesday, December 20, 2000 12:22 PM
> To: 'Steve Donovan'; Simon Barber; Jonathan Rosenberg; 'Sean Olson'

<snip>

> on "to" header?,  clearly no

In general I agree.  However, the example given for use of record-routing
registers was to assist in load balancing between multiple registrar's for
the same domain.  Given that the only information in the request-uri is the
domain name, the load balancing decision must be made on something else.
The most likely candidate is the To URL, given that this identifies the
party to which the registration applies.

This is not part of the baseline SIP defined routing behavior, as baseline
SIP does not deal with load balancing between registrars.  And I agree with
your point that this should not be part of the baseline SIP specification.

<snip>