Subject: RE: [SIP] Proxies modifying SDP

From: Baniel Uri-CUB001 <[email-masked]>
Date: Fri, 15 Dec 2000 13:50:44 -0600

I see it as the requested way of forcing the media stream to go via an 'IP switch' (like the H323 MCU).
If a proxy server is not allowed or if it is not appropriate for it to touch the SDP element, then is there any other way to make sure the media stream goes via our MCU gateway. (There could be various of reasons why we would want to have such a gateway)

What do u think?

Uri

-----Original Message-----
From: Neil Deason [mailto:[email-masked]]
Sent: Friday, December 15, 2000 12:30 PM
To: [email-masked]; [email-masked]; [email-masked]
Subject: RE: [SIP] Proxies modifying SDP

>Bernie Hoeneisen wrote:
> > I have question concerning the case, when SIP proxies modify SDP,
> > which is AFAIK against SIP principles, isn't it?
>I do not think so.
>Why is that *against* SIP principles?  What principles?'

The fundamental concept that payloads are opaque to SIP Proxy
Servers. To do this sort of thing you probably want to use a
back to back UA.

Cheers,
Neil.
--
Ubiquity Software, UK                    www.ubiquity.net

> > In the concrete case, proxies would be able to remove certain codecs
> > from the INVITE messages, depending on the current policy in the
> > network. (The UAS gets a subset of the codecs, which were originally
> > sent by the UAC.)
> > What impact does such a proxy behavior have to SIP? I can think of
> > problems with authentication and message integrity checking (UAC signs
> > message with its private key).
>It certainly depends on the security mechanism used.  For e.g., with the
>simple basic md5, it does not cause any issue.
>
>Jean-Francois

_________________________________________________________________________
Get Your Private, Free E-mail from MSN Hotmail at http://www.hotmail.com.

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: "Steve Donovan" <[email-masked]>
Date: Sun, 17 Dec 2000 21:11:56 -0600

Although I am having a hard time understanding why it would be necessary to
modify the SDP to cause the call to go through a specific gateway, as Neil
correctly points out, this is likely to be a function of a back-to-back UA.

Why is it not enough to have the proxy route the call to the gateway in
question by changing the request-URI to point to the gateway?

Steve

> From: [email-masked]
> [mailto:[email-masked]]On Behalf Of Baniel Uri-CUB001
> Sent: Friday, December 15, 2000 1:51 PM
> To: 'Neil Deason'; [email-masked]; [email-masked];
> [email-masked]
> If a proxy server is not allowed or if it is not appropriate for
> it to touch the SDP element, then is there any other way to make
> sure the media stream goes via our MCU gateway. (There could be
> various of reasons why we would want to have such a gateway)
>
> What do u think?
>
> Uri
>