Subject: [SIP] REFER open issues

From: Rohan Mahy <[email-masked]>
Date: Fri, 15 Dec 2000 10:08:50 -0800

Hi,

I'd like to summarize ALL the open issues that we have with REFER.  In the
interest of coming to consensus, I'd like to invite interested implementers
who have comments to meet in person before Minneapolis to close REFER open
issues.  If folks think this is a good idea, we would certainly post the
minutes and partial consensus back to the list for comments/changes.  As a
strawman, I will suggest sometime in the last week of January.  A few
plausible locations are: Dallas, New York, San Jose...  I volunteer to
organize this if necessary.

A short summary of the issues are below in no particular order:

1) Retransmission problem:
Robert Sparks already summarized this problem in his recent post.
(a) REFER completes early, use explicit SUBSCRIBE for more info
(b) REFER completes early and implicitly SUBSCRIBEs to more info
(c) REFER completes after 16 secs and provides URL for SUBSCRIBE
(d) send new REFER (new CSeq same call ID) after 32 seconds.

2) Cancellation:
If REFER returns a final response before a long INVITE transaction
completes, how do you cancel that INVITE?  
(a) send same REFER with ;method=CANCEL
(b) send REFERCANCEL method

3) Call-leg matching:
Should you include call-id's in Refer-to URLs?  If not, what do you use for
matching (Replaces or similar)?
(a) match call-ids
(b) use a Replaces header
(c) use the mesh-id to setup mesh, then say BYE
(d) use a new header

4) If we choose Replaces or the like, how do we express that we want to
*join* 2 legs via REFER?
(a) Join header
(b) Associate header
(c) new method
(d) something else

5) If Refer-To contains parameters (method, transport), or potentially
contradictory headers, what do we do with them?
(a) allow all of them if authorized
(b) allow a subset of methods/headers
(c) send an error mesage
(d) ignore the headers/parameters
(e) ignore the whole message

6) If we don't allow  ;method=BYE, how do we solve the problem described in
the Music on 
Hold flow?
(a) method=BYE
(b) ???

7) How do we ask devices to do stuff for us?  [probably defer this issue]
(a) REFER with parameters/headers
(b) PHONECTL
(c) some NEWMETHOD
(d) Mbus
(e) other

Any other REFER open issues I missed?

thanks,
-rohan

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: Rohan Mahy <[email-masked]>
Date: Fri, 15 Dec 2000 10:20:42 -0800

One minor addition below...

>(d) send new REFER (new CSeq same call ID) after 32 seconds.
(e) REFER completes early; use separate REFERDONE or similar message