Subject: [SIP] CPL and new XML options.

From: "Anuraj Ennai" <[email-masked]>
Date: Tue, 26 Dec 2000 15:14:40 +0530

Hi all,
I know this is not the place to raise issues about CPL.
But still, it seems appropriate to discuss it with a
wider audience.

It is evident that the intent of CPL is not just data
representation (pure XML as portable data), but also
processing of certain criteria. In the present CPL format,
the processing instructions and data represenation are
intertwined  together, limiting the application scope.
(Eg. matching of strings, conditional branches etc provided
in the XML doc itself.)

I believe it will be beneficial to separate both aspects.
Use the XML format for data and XSL/XSLT with
emerging XPATH/XPOINTER specs for filtering/
processing. This will make the representation and
processing independent providing more flexibility
to applications using CPL.

Any way, CPL is still evolving and this might be the way
to go. And in the end, am I making any sense?

Thanks & regards
Anuraj Ennai

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: "Rosen, Brian" <[email-masked]>
Date: Tue, 26 Dec 2000 09:54:07 -0500

You are correct, this is NOT the place to discuss CPL.

Please take this discussion to the iptel list.

Thanks

Brian

> -----Original Message-----
> From: Anuraj Ennai [mailto:[email-masked]]
> Sent: Tuesday, December 26, 2000 4:45 AM
> To: sip
> Subject: [SIP] CPL and new XML options.
> 
> 
> Hi all,