Subject: [SIP] RE: draft-hamer-sip-session-auth-00.txt

From: Henry Sinnreich <[email-masked]>
Date: Fri, 01 Dec 2000 16:12:54 -0600

There may not be enough time in the SIP WG, but SIP and session
authorization is now the subject of several draft and needs to be discussed
at least on the list.

For the IETF, Internet-wide compatibility is of higher priority, since
private IP networks and ISP networks have some latitude to customize their
internal network design, such a illustrated in the draft:
http://ietf.org/internet-drafts/draft-ietf-sip-manyfolks-resource-00.txt

This leads to top priority for the notions of:

1 - Interdomain, no matter how the domains are designed internally,
2 - Clearinghouses as trust brokers between domains.
    Clearinghouses are widely used at present for VoIP.

Getting now to the intradomain aspects, I would like to discuss the model in
<draft-hamer-sip-session-auth-00.txt>
Discussing the references, on page 9:
>there are a number of issues with this model:

> The same policy server makes decisions related to both service
> authorization and resource utilisation. This is only possible if
> the service provider and access provider are one and the same
> business entity and if the network is simple enough to warrant
> deployment of a single policy server.

The service provider and access provider DO NOT NEED to be the same, since
policy can be outsourced between business partners. See
http://ietf.org/internet-drafts/draft-gross-sipaq-00.txt
and
http://ietf.org/internet-drafts/draft-gross-cops-sip-00.txt

A second theme of the draft-hamer-sip-session-auth-00.txt is also:

> The end host is connected to a known point in the network that
> defines the edge router and policy server for that host. This is
> only possible in a network with fixed hosts and fixed routers
> where the administrative burden of defining these associations
> make this a feasible undertaking.

This is also arguable, since:

1 - SIP clients have to authenticate themselves to the SIP proxies
    that control service inside the domain, so they are known,
2 - SIP proxies, policy servers and edge routers are the crown
    jewels of the ISP, similar to the IN in telephony and well
    known and monitored network elements. Their security
    associations are not only administered by hand,
    but also with great care.

Also, why modifications to three protocols?
>-  Resource reservation protocol
>-  Policy management protocol
    (Which: COPS or DIAMETER?)
>-  Session management protocol
    (I suppose SDP is meant by this?)

The references above and the preceding work contains a large number of
scenarios and call flows, showing that existing protocols do the job without
any modifications. As for SIP, please see:
http://ietf.org/internet-drafts/draft-johnston-sip-osp-token-01.txt

Finally some nits regarding terminology:

I don't know what BEARER is in the IETF context. The ITU BEARER is very
different from IETF TRANSPORT and NETWORK and imply very different design
philosophies. Mixing these terms can lead to utter confusion.

SESSION MANAGER: SIP does only session setup, as its name implies. The IETF
Multimedia Conferencing Architecture <draft-ietf-mmusic-confarch-03> and
other MMUSIC work makes it clear that they don't believe in managing
sessions.
(There is always an exception that confirms the rule: SIP 3rd party call
control)

>Session management protocol? See the above.

>Bearer Control Domain.
Suggest we avoid loose definitions of domains. A domain is a domain is a
domain in the DNS sense.

Voila! Plenty of items to discuss. If there is no time in the SIP WG we may
have to try and meet at the bar.

Henry

Henry Sinnreich
WorldCom
400 International Parkway,
Dept. 1489, 2A313
Richardson, Texas, 75081

-----Original Message-----
From: Henry Sinnreich [mailto:[email-masked]]
Sent: Friday, December 01, 2000 10:32 AM
To: Stephen Thomas; Alan Johnston; Theodore Havinis; Steve Donovan at
DynamicSoft; Gerhard Gross; Diana Rawlins
Subject: RE: Conference call: draft-hamer-sip-session-auth-00.txt
Importance: High

I will be able to attend only for 30 minutes 3:00-3:300  CST due to a
conflict with another meeting.
Really sorry, but was not under my control.

>DATE:            12/1
>TIME:            3:00 CST - 5:00 CST
>BRIDGE:        V857-4113 / 4195
>TOLLFREE:    888-810-3146 / 4195

Henry

-----Original Message-----
From: Stephen Thomas [mailto:[email-masked]]
Sent: Tuesday, November 28, 2000 2:27 PM
To: Henry Sinnreich; Alan Johnston; Theodore Havinis; Steve Donovan at
DynamicSoft; Gerhard Gross; Diana Rawlins
Subject: Re: Conference call: draft-hamer-sip-session-auth-00.txt

I'll be there (virtually speaking).

Stephen

At 09:01 AM 2000-11-28 -0600, Henry Sinnreich wrote:
>Dear Friends,
>
>The draft <draft-hamer-sip-session-auth-00.txt> raises some issues with
>regard to our own work on SIP-QoS-OSP and APS. I have reserved a
>conference bridge for Friday afternoon to discuss the subject, in case you
>are interested.
>DATE:            12/1
>TIME:            3:00 CST - 5:00 CST
>BRIDGE:        V857-4113 / 4195
>TOLLFREE:    888-810-3146 / 4195
>
>Please confirm your attendance.
>
>Henry

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: Henry Sinnreich <[email-masked]>
Date: Fri, 01 Dec 2000 16:14:34 -0600

Henry

Henry Sinnreich
WorldCom