Subject: RE: [SIP] Record-Route and REGISTER

From: Jonathan Rosenberg <[email-masked]>
Date: Tue, 19 Dec 2000 01:25:24 -0500

> -----Original Message-----
> From: David Shrader [mailto:[email-masked]]
> Sent: Sunday, December 17, 2000 3:40 PM
> To: SIP List
> Subject: [SIP] Record-Route and REGISTER
> 
> When using the REGISTER method, however, the Contact header 
> is NOT used for
> that purpose. The Contact header in the Response to a 
> REGISTER is simply a
> list of registered contacts and does not in fact identify the 
> recipient of a
> subsequent request.

Correct. REGISTER is nearly a separate protocol, for all intents and
purposes. As specified right now, record-routing for REGISTER is ambigous.
In any case, record-routing for transactions outside of INVITE is not clear.
What is the the scope of the Route? To which set of messages does it apply?
When can the route be purged? These issues must be resolved as well, and
they are much harder.

The solution to your specific problem is for the UAC and UAC to use RR in
REGISTER instead. So:

1. A UAC inserts a REcord-route into the REGISTER pointing to itself, just
like the Contact would look in an INVITE
2. proxies can record-route
3. UAS (the registrar, in this case) also adds a RR, and reflects that back
in 200 OK
4. Route is constructed normally except COntact is ignored

Kind of a pain to have a special procedure for REGISTER, I know. In
hindsight, I would have used something instead of Contact here, but at the
time rfc2543 was being written, the usages were similar enough and the idea
of record-routing REGISTER was not something we considered.

-Jonathan R.
---
Jonathan D. Rosenberg                       72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.cs.columbia.edu/~jdrosen         PHONE: (973) 952-5000
http://www.dynamicsoft.com

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: "Ben Campbell" <[email-masked]>
Date: Tue, 19 Dec 2000 12:53:57 -0600

> of record-routing REGISTER was not something we considered.

I am unclear on what RR even means in the context of a register. If the UAC
receives a RR in the response to a register, what is it supposed to do with
it? There is no implied session for the route to be scoped to.

Ben.

---

From: "Steve Donovan" <[email-masked]>
Date: Tue, 19 Dec 2000 13:07:28 -0600

Why are we worried about record-routing REGISTER messages.  Record-Routing
is used to ensure that all messages within a session go through interested
proxies.  This is obviously useful with INVITE and SUBSCRIBE.

There is no session created by REGISTER.  As such, there are no other
messages that need to take the same route.

Is the goal to ensure that subsequent REGISTER requests make it to the same
instance of a registrar within a domain?  If so, is the use of Record-Route
the correct solution?

Steve

> From: [email-masked]
> [mailto:[email-masked]]On Behalf Of Jonathan Rosenberg
> Sent: Tuesday, December 19, 2000 12:25 AM
> To: 'David Shrader'; SIP List
> Subject: RE: [SIP] Record-Route and REGISTER
>
>
>
>
>
>

---

From: Sean Olson <[email-masked]>
Date: Tue, 19 Dec 2000 13:17:39 -0600

What about subsequent re-registrations? It is conceivable that
a stateful proxy might want to know about these re-registrations
(perhaps for caching purposes). Of course, this doesn't help
with the case where multiple UAs are registering for the same
user.

Sean