Subject: RE: [SIP] Proxies modifying SDP

From: Steve Gardell <[email-masked]>
Date: Tue, 19 Dec 2000 11:43:25 -0500

If memory serves, a "fully routed" H.323 gatekeepers routes the media
negotiation signalling, but does not route the actual RTP traffic. 

-----Original Message-----
From: Baniel Uri-CUB001 [mailto:[email-masked]]
Sent: Monday, December 18, 2000 8:05 PM
To: 'Steve Donovan'; Baniel Uri-CUB001; 'Neil Deason';
[email-masked]; [email-masked]; [email-masked]
Subject: RE: [SIP] Proxies modifying SDP

Hmm...
Probably I was not clear and hence the confusion.
My intention was to be able to mimic the 'H323 gate keeper mode'
functionality, i.e. to have the end points think they talk to each other (in
the media streaming phase) but actually the media goes via a gate keeper. In
our SIP world this should be just a MG (Media Gateway).
The control may still go via a SIP proxy server, that is why I think
changing SDP fields (specifically the IP address for receiving media as well
as the RTP ports) may easily achieve this goal

Uri

-----Original Message-----
From: Steve Donovan [mailto:[email-masked]]
Sent: Sunday, December 17, 2000 9:12 PM
To: Baniel Uri-CUB001; 'Neil Deason'; [email-masked];
[email-masked]; [email-masked]
Subject: RE: [SIP] Proxies modifying SDP

Although I am having a hard time understanding why it would be necessary to
modify the SDP to cause the call to go through a specific gateway, as Neil
correctly points out, this is likely to be a function of a back-to-back UA.

Why is it not enough to have the proxy route the call to the gateway in
question by changing the request-URI to point to the gateway?

Steve

> -----Original Message-----
> From: [email-masked]
> [mailto:[email-masked]]On Behalf Of Baniel Uri-CUB001
> Sent: Friday, December 15, 2000 1:51 PM
> To: 'Neil Deason'; [email-masked]; [email-masked];
> [email-masked]
> Subject: RE: [SIP] Proxies modifying SDP
>
>
> I see it as the requested way of forcing the media stream to go
> via an 'IP switch' (like the H323 MCU).
> If a proxy server is not allowed or if it is not appropriate for
> it to touch the SDP element, then is there any other way to make
> sure the media stream goes via our MCU gateway. (There could be
> various of reasons why we would want to have such a gateway)
>
> What do u think?
>
> Uri
>
> -----Original Message-----
> From: Neil Deason [mailto:[email-masked]]
> Sent: Friday, December 15, 2000 12:30 PM
> To: [email-masked]; [email-masked]; [email-masked]
> Subject: RE: [SIP] Proxies modifying SDP
>
>
>
> >Bernie Hoeneisen wrote:
> > > I have question concerning the case, when SIP proxies modify SDP,
> > > which is AFAIK against SIP principles, isn't it?
> >I do not think so.
> >Why is that *against* SIP principles?  What principles?'
>
> The fundamental concept that payloads are opaque to SIP Proxy
> Servers. To do this sort of thing you probably want to use a
> back to back UA.
>
> Cheers,
> Neil.
> --
> Ubiquity Software, UK                    www.ubiquity.net
>
> > > In the concrete case, proxies would be able to remove certain codecs
> > > from the INVITE messages, depending on the current policy in the
> > > network. (The UAS gets a subset of the codecs, which were originally
> > > sent by the UAC.)
> > > What impact does such a proxy behavior have to SIP? I can think of
> > > problems with authentication and message integrity checking (UAC signs
> > > message with its private key).
> >It certainly depends on the security mechanism used.  For e.g., with the
> >simple basic md5, it does not cause any issue.
> >
> >Jean-Francois
>
> _________________________________________________________________________
> Get Your Private, Free E-mail from MSN Hotmail at http://www.hotmail.com.
>
>
> _______________________________________________
> SIP mailing list
> [email-masked]
> http://lists.bell-labs.com/mailman/listinfo/sip
>
> _______________________________________________
> SIP mailing list
> [email-masked]
> http://lists.bell-labs.com/mailman/listinfo/sip
>

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: David Frascone <[email-masked]>
Date: Tue, 19 Dec 2000 10:56:04 -0600

This might be a useless response, since I can't find the example document that
I'm about to refer too . . but . . .  In the documents I read before San Diego,
I remember two pictures of a proxied senario.

In the first, the SIP requests were proxied, but the RTP was sent normally.
                      
In the second, the SIP requests were proxied, *and* the RTP was proxied.  In
this senario, didn't the SIP proxy have to modify the SDP to get it to work?

Please:  I know someone else read this document, or saw the slides I'm 
refering too . . . . Someone help refresh my poor tired memory :)

-Dave

---

From: Neil Deason <[email-masked]>
Date: Tue, 19 Dec 2000 17:20:25 +0000

> refering too . . . . Someone help refresh my poor tired memory :)

This sounds like the sort of ugliness forced upon us by 
firewalls. Maybe you're thinking of 
draft-rosenberg-sip-entfw-00.txt

hth,
Neil.
-- 
Ubiquity Software Corporation, UK        http://www.ubiquity.net

---

From: David Frascone <[email-masked]>
Date: Tue, 19 Dec 2000 11:32:48 -0600

That wasn't the one, but it also illustrates it.  Is there any way to do such
ugliness without modifying SDP?

I'm trying to leave a SDP parser out of my SIP proxy, but it looks like I might
need to include one :(