Subject: [SIP] Consultation

From: james jack <[email-masked]>
Date: Tue, 5 Dec 2000 01:49:48 -0800 (PST)

Dear All:
   How are you!
   I have one question to consult with, On page 66 of
RFC2543 bis02 , which says
"411 Length Required
The server refuses to accept the request without a
defined Content-Length. The client MAY repeat the
request if it adds a valid Content-Length header field
containing the length of the message-body in the
request message."
   But On page 45, which says"If a server receives
a UDP request without Content-Length,itMUST assume
that the request encompasses the remainder of
the packet."
   What's more, On table 4(page 36),which describes
the "Content-Length" must be appeared in request.
    Now I am confused with RFC2543bis02, If a server
receive an INVITE request without Content-Length over
UDP, what should happen? Will 411 response code send
out?
   Best regards!
                     Yours:James

__________________________________________________
Do You Yahoo!?
Yahoo! Shopping - Thousands of Stores. Millions of Products.
http://shopping.yahoo.com/

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: Vijay Gurbani <[email-masked]>
Date: Tue, 05 Dec 2000 07:35:55 -0600

James:

There was some discussion (and maybe a consensus) on this topic on the 
mailing list.  You may want to search the archives 
(http://www.bell-labs.com/mailing-lists/sip/) for the resolution.  Even
though I *think* I recall the resolution, I don't trust my memory enough to 
write down what it was. 

> UDP, what should happen? Will 411 response code send

- vijay
-- 
Vijay K. Gurbani  vkg@{lucent.com,research.bell-labs.com,acm.org}
Internet Software and eServices Group 
Lucent Technologies/Bell Labs Innovations 263 Shuman Blvd., Rm 1A-413
Naperville, Illinois 60566     Voice: +1 630 224 0216   Fax: +1 630 713 0184