Subject: Re: [SIP] Solving the REFER retransmit issue

From: William Marshall <[email-masked]>
Date: Wed, 20 Dec 2000 10:42:30 -0500 (EST)

My suggestion that REFER use the three-way handshake of INVITE
is clearly DOA, but there were a couple of items in the responses
that I would like to clarify.

> > From: Henning G. Schulzrinne [mailto:[email-masked]]
> > Sent: Saturday, December 16, 2000 5:27 PM
> > To: William Marshall
> > Cc: [email-masked]
> > Subject: Re: [SIP] Solving the REFER retransmit issue
> > 
> > 
> > While I have some sympathy for allowing the 3-way handshake for REFER,
> > I'm very concerned about the proxy backward compatibility issue. An
> > "old" proxy that thinks REFER is just another non-INVITE and a new UAS
> > that retransmits 200s until it gets an ACK will get not be happy
> > together. (A UAS that doesn't know REFER is likely to respond
> > immediately with a 400 and will likely just dump the ACK, so that
> > variation seems less of a concern.) Thus, we at least need a
> > Proxy-Require
> 

So what does a proxy do when it receives a 200-OK for a transaction
it believes is complete?

Consider the case where the UAC sends a request, times out and re-sends
the request.  Second message crosses the 200-OK in transit on the final
link to UAS.  So UAS re-transmits the 200-OK.  All the proxies in the
path now see this re-sent 200, and (I presume) should forward it along
the Via chain back to the UAC. 

Should the proxy remember the number of retransmissions
it saw for a request, and only pass that many responses.  I hope not.

So if a proxy should still forward the 200-OK based on the Vias,  I see no 
backward compatibility issue.

> > From: "James Undery" <[email-masked]>
> > To: [email-masked], [email-masked]
> > Subject: Re: [SIP] Solving the REFER retransmit issue
> > Date: Fri, 15 Dec 2000 01:14:43 -0000
> > 
> > You can and should send provisional responces to all requests that you can't 
> > process in a specific time (200ms IIRC).

Is this true even for non-INVITEs?  Doesn't a provisional response turn off
the retransmission of the request?  How is reliability of the 200-OK
response guaranteed>

It was my understanding that a proxy only sends a 100-Trying to an
INVITE, not to other requests.  All other requests do only end-end
reliability, not hop-hop.

Bill Marshall
[email-masked]

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: James Undery <[email-masked]>
Date: Wed, 20 Dec 2000 16:44:34 +0000 (GMT)

On Wed, 20 Dec 2000, William Marshall wrote:

> Is this true even for non-INVITEs?  

Section 7.1 and Section 10.1.2
 
> Doesn't a provisional response turn off
> the retransmission of the request?

No it switches from the T1 exponential backoff scheme to T2 retransmission

> How is reliability of the 200-OK
> response guaranteed>

In the normal way, although your next sentence explains this question.

> reliability, not hop-hop.

No to put it bluntly.

James Undery