Subject: [SIP] conflict in syntax

From: laks hmi <[email-masked]>
Date: Mon, 25 Dec 2000 20:28:07 -0800 (PST)

>i have clearly mentioned in first mail where exactly
the conflict is coming, once again i am explaining
below.
> Contact =  ( "Contact" | "m")":" ("*"
> | (1# (( name-addr | addr-spec ) *( ";"
> contact-params ))))

In the above syntax, (1# (( name-addr | addr-spec ) is
there in the beginning of the header after colon.
SIP_URL | URI is coming in addr-spec is the first
parameter can end with semicolon and token which
is there in the generic-param of the other-params
is conflicting with immediate *(";" contact-params )
where again semicolon and token will come.

In this both other-param in URL and *( ";"
contact-params ) can come zero or multiple times, so
we 
will not be knowing which parameter.

Regards
lakshmi

--- Christian Jansson <[email-masked]> wrote:
> Just a few lines below the Contact syntax there is a
> sentence that
> I think will solve your problem:
> 
> "Even if the "display-name"is empty, the "name-addr"
> form MUST be
> used if the "addr-spec" contains a comma, semicolon
> or question mark."
> 
> ---
> Christian Jansson
> 
> >The syntax is as foloows
> >Contact =  ( "Contact" | "m")":" ("*"
> >| (1# (( name-addr | addr-spec ) *( ";"
> >contact-params ))))
> 
> >i am telling abt (1# (( name-addr | addr-spec ),
> where
> >SIP-URL and URI is coming in address-spec and not
> in
> >the name-adress.
> 
> >Regards
> >lakshmi
> 
> 
> 
> --- Hisham Khartabil <[email-masked]>
> wrote:
> > name-addr = [display-name] "<" addr-spec ">"
> > 
> > 
> > > -----Original Message-----
> > > From: [email-masked]
> > > [mailto:[email-masked]]On Behalf
> Of
> > laks hmi
> > > Sent: Friday, 22 December 2000 11:50 AM
> > > To: Hisham Khartabil
> > > Cc: [email-masked]
> > > Subject: RE: [SIP] conflict in syntax
> > > 
> > > 
> > > what Mr.Hisham has told is correct but as i told
> > only
> > > in name-addr they have specified the "<" and
> ">".
> > > what abt the SIP-URL|URI in address-spec.
> > > 
> > > lakshmi
> > > 
> > >
> __________________________________________________
> > > Do You Yahoo!?
> > > Yahoo! Shopping - Thousands of Stores. Millions
> of
> > Products.
> > > http://shopping.yahoo.com/
> > > 
> > > _______________________________________________
> > > SIP mailing list
> > > [email-masked]
> > > http://lists.bell-labs.com/mailman/listinfo/sip
> > 
> > _______________________________________________
> > SIP mailing list
> > [email-masked]
> > http://lists.bell-labs.com/mailman/listinfo/sip
> 
> 
> __________________________________________________
> Do You Yahoo!?
> Yahoo! Shopping - Thousands of Stores. Millions of
> Products.
> http://shopping.yahoo.com/
> 
> _______________________________________________
> SIP mailing list
> [email-masked]
> http://lists.bell-labs.com/mailman/listinfo/sip
> 
> 
> _______________________________________________
> SIP mailing list
> [email-masked]
> http://lists.bell-labs.com/mailman/listinfo/sip

__________________________________________________
Do You Yahoo!?
Yahoo! Shopping - Thousands of Stores. Millions of Products.
http://shopping.yahoo.com/

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: Jonathan Rosenberg <[email-masked]>
Date: Fri, 29 Dec 2000 00:06:08 -0500

> From: laks hmi [mailto:[email-masked]]
> Sent: Monday, December 25, 2000 11:28 PM
> To: Christian Jansson; [email-masked]
> Subject: [SIP] conflict in syntax
> 
> 

THe answer given previously addresses your question. The name-addr form is
used when there are other-params, so that:

Contact: <sip:user@host;param1=val1>;param2=val2

param1 is a URL other-param, and param2 is a Contact header parameter. Any
parameter outside the angle brackets, or if there are no angle brackets, any
parameter at all, is a Contact header parameter.

-Jonathan R.

> > > > what abt the SIP-URL|URI in address-spec.
---
Jonathan D. Rosenberg                       72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.cs.columbia.edu/~jdrosen         PHONE: (973) 952-5000
http://www.dynamicsoft.com