Subject: RE: [SIP] Proxies modifying SDP

From: Baniel Uri-CUB001 <[email-masked]>
Date: Tue, 19 Dec 2000 11:42:01 -0600

Bernie

I do not think it is a bad idea at all. I think that when you run a commercial network, in which subscriber has to pay for capabilities/services etc, you have no choice but to have control over the media he/she is asking to use.
E.g. If one paid for using audio service only and all of the sudden asks for video stream as well, you may want to discard the video media from the SDP request

Hope that helps

Uri

-----Original Message-----
From: Bernie Hoeneisen [mailto:[email-masked]]
Sent: Tuesday, December 19, 2000 11:28 AM
To: [email-masked]
Cc: Steve Donovan; Baniel Uri-CUB001; Neil Deason; [email-masked];
[email-masked]; [email-masked]
Subject: RE: [SIP] Proxies modifying SDP

Hi again

On Mon, 18 Dec 2000 [email-masked] wrote:

> I suspect the original writer refers to some sort of media gateway 
> that is not  SIP enabled. Therefore one could not simply  proxy the 
> call to the gateway. 

My original question was a bit different one and it is not directly 
related to media gateways.
In the case I was describing, there are SIP proxies, which know about
policy in the network and would interact while the INVITE is
passing them. Such proxies would remove certain codecs from the SDP.
I have some doubts, that it is a good idea...

Thus, I am posting my original question again (see below, last line).

Hoping for more comments on this...

Cheers
 Bernie

PS: Here my original email:

On Fri, 15 Dec 2000, Bernie Hoeneisen wrote:

> I have question concerning the case, when SIP proxies modify SDP,
> which is AFAIK against SIP principles, isn't it?
>
> In the concrete case, proxies would be able to remove certain codecs
> from the INVITE messages, depending on the current policy in the
> network. (The UAS gets a subset of the codecs, which were originally
> sent by the UAC.)
>
> What impact does such a proxy behavior have to SIP? I can think of
> problems with authentication and message integrity checking (UAC signs
> message with its private key).
>
> Are there any other problems? Any comments are appreciated.

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: Bernie Hoeneisen <[email-masked]>
Date: Tue, 19 Dec 2000 19:55:00 +0200 (EET)

Uri,

I am not against the idea, that such things have to be controled.
The example actually concerns a commercial network with limited resources.

I am just worried about the possible negative impact to other SIP
functionality. I want to ensure: If we solve the mentioned problem by
proxies modifying SDP, that we do not cause new problems at some other
place.

I am trying to figure out, whether there is such negative impact, and
if yes, what problems it will cause.

cheers,
 Bernie

On Tue, 19 Dec 2000, Baniel Uri-CUB001 wrote:

> Bernie
> 
> I do not think it is a bad idea at all. I think that when you run a
> commercial network, in which subscriber has to pay for
> capabilities/services etc, you have no choice but to have control over
> the media he/she is asking to use. E.g. If one paid for using audio
> service only and all of the sudden asks for video stream as well, you
> may want to discard the video media from the SDP request
> 
> Hope that helps
> 
> Uri
>

---

From: "Gamze Seckin" <[email-masked]>
Date: Tue, 19 Dec 2000 10:40:26 -0700

Hi all,

I have couple of questions:

-  Is there an open source implementation for IMPP?
(If not, what would be a good start to deploy my own implementation?)

- What is the most accepted underlying protocol for IMPP? (I know there is
discussion around SIP, IMPX, but what is actually used mostly?)

thanks,

gamze

=================
Gamze Seckin, Ph.D.
Research Engineer, Luxxon Corporation
(650) 938 1919x2105
www.luxxon.com