Subject: Re: [SIP] Inteligent Codec Selection

From: William Marshall <[email-masked]>
Date: Wed, 20 Dec 2000 11:25:58 -0500 (EST)

[email-masked] wrote:
>
> I would like to set up a SIP solution that would negotiate to use G.711
> if there is sufficient bandwith between the two endpoints to do so, and would
> negotiate G.723.1 otherwise.
>
> Is there any way to do codec negotiation in such a manner?

Unfortunately there are limits to what can be said in the language
of SDP.  But within that, there are at least three possibilities.

1)  send an INVITE with only G.711, with qos required.  If it fails
with the 580-Precondition-Failure, try again with an INVITE with
only G.723.1, again with qos required.

2)  send an INVITE with two media streams, G.711 with qos optional,
and a second media stream for G.723.1 with qos required.  After getting 
the COMET, UAS can decide which media stream to use.  The UAC finds
this out when the media stream starts, since it indicated its willingness
to receive both simultaneously.  Alternatively, we could require
SDP in the 200-OK (in addition to the 183) which would inform the UAC, and
allow it to prepare for only one stream.

3) send an INVITE with two media streams, both with qos optional and
requesting a COMET from UAS.  When UAC receives the COMET, it decides
which codec to use; the COMET it sends to UAS contains the succss/failure
indication for each codec, which tells the UAS which to use.  

The convention in cases (2) and (3) is that the UAC/UAS would not use a 
codec for which the qos reservation failed, even if it appears in an m= 
line in the SDP.

Bill Marshall
[email-masked]

-----original message-----
From: Manoj Bhatia <[email-masked]>
To: Sunitha Kumar <[email-masked]>
Cc: [email-masked], [email-masked]
Subject: Re: [SIP] Inteligent Codec Selection
Date: Mon, 18 Dec 2000 10:21:36 -0500

Even if you use , manyfolks draft for SIP /QOS reservations and figure
out that you need to switch to G.723 from G.711 , you would still
need a re-INVITE/mid-call INVITE mechanism to trigger
the event.

Sunitha Kumar wrote:
> check out draft-manyfolks-sip-resource-01.txt.
> it talks about resource reservation.
>
>
>
>
> [email-masked] wrote:
>
>> I would like to set up a SIP solution that would negotiate to use
>> G.711
>> if there is sufficient bandwith between the two endpoints to do so,
>> and would
>> negotiate G.723.1 otherwise.
>>
>> Is there any way to do codec negotiation in such a manner?
>>
>> Torrey
>>
>> _______________________________________________
>> SIP mailing list
>> [email-masked]
>> http://lists.bell-labs.com/mailman/listinfo/sip
>
> --
> Sunitha Kumar
> http://www.cisco.com
>
>

--
Manoj Bhatia                           |        |         |
[email-masked]                       |       :|:       :|:
7025 Kit Creek Road, RTP, NC - 27709   |     :|||||:   :|||||:
Ph: 919-392-3873  Fax:919-392-6801     |  C i s c o S y s t e m s

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: Jonathan Rosenberg <[email-masked]>
Date: Fri, 22 Dec 2000 00:59:45 -0500

> -----Original Message-----
> From: William Marshall [mailto:[email-masked]]
> Sent: Wednesday, December 20, 2000 11:26 AM
> To: [email-masked]

I think this is not a safe assumption to make. The usage of two media
streams, offered as alternatives, is not what is defined by SDP. Multiple
media streams in SDP are parallel streams, not alternatives. You would need
something like Gonzalo's stream identifier draft.

-Jonathan R.
---
Jonathan D. Rosenberg                       72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.cs.columbia.edu/~jdrosen         PHONE: (973) 952-5000
http://www.dynamicsoft.com