Subject: RE: [SIP] Record-Route and REGISTER

From: Igor Slepchin <[email-masked]>
Date: Thu, 21 Dec 2000 15:17:24 -0500

I never suggested that all proxies always Record-Route. What I said is that
proxies should not necessarily base the decision about whether to record
route based only on the request type. E.g., there is nothing illegal with
inserting Record-Route into REGISTER or BYE. Otherwise, proxies won't be
able to R-R on new request types like SUBSCRIBE.

Of course, if a particular proxy _knows_ that it is only interested in
specific types of requests, it is perfectly fine for it to insert the R-R in
those messages only.

---
Igor Slepchin

> -----Original Message-----
> From: Billy Biggs [mailto:[email-masked]]
> Sent: Thursday, December 21, 2000 3:07 PM
> To: Igor Slepchin
> Cc: Jonathan Rosenberg; Sean Olson; Steve Donovan; David Shrader; SIP
> List
> Subject: Re: [SIP] Record-Route and REGISTER
> 
> 
> Igor Slepchin ([email-masked]):
> 
> > One thing I'd like to ensure is that proxies insert Record-Route in
> > all requests, no matter what the request method is (CANCEL 
> and ACK are
> > possible exceptions). It is then up to the endpoints to 
> decide whether
> > there is any use for that Record-Route. 
> > 
> > If we do that this way, the proxies won't need to know about cryptic
> > things like "Record-Route for INVITEs and SUBSCRIBEs but not for
> > REGISTER". Makes defining new methods much easier.
> 
>   Please, don't Record-Route unless you need to.
> 
>   If all proxies Record-Route'ed, we get:
> 
>   1) Huge messages
>   2) Increased failure probability
>   3) Increased delay
>   4) Intelligence in the network
>   5) ...
> 
>   A call-logger should only Record-Route for INVITE-initiated 
> call legs.
> Of course, a firewall proxy should Record-Route everything, 
> but that is
> a very special case.
> 
>   I've heard rumors that some proxies Record-Route 
> unconditionally (!!).
> 
> -- 
> Billy Biggs, 3Com               Email: [email-masked]
> http://www.div8.net/billy/      Phone: [email-masked]
> 

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: Billy Biggs <[email-masked]>
Date: Thu, 21 Dec 2000 14:55:03 -0600

Igor Slepchin ([email-masked]):

> I never suggested that all proxies always Record-Route. What I said is
> that proxies should not necessarily base the decision about whether to
> record route based only on the request type.

  I argue that the decision should be based on the request type and the
proxy's requirements.  Being conservative here is important to avoid all
the problems of having packets route through a (disinterested) third
party.

  Of course there is nothing illegal with adding the Record-Route to
everything (firewall proxy).  But this is the minority.  Proxies should
not Record-Route without good reason, and only for call-legs they are
specifically interested in.

  Also, remember that Record-Route is a call leg property, not a request
property, but whatever.