Subject: RE: [SIP] conflict in syntax

From: laks hmi <[email-masked]>
Date: Fri, 22 Dec 2000 02:07:37 -0800 (PST)

The syntax is as foloows
Contact =  ( ”Contact” | ”m”)”:” (”*”
| (1# (( name-addr | addr-spec ) *( ”;”
contact-params ))))

i am telling abt (1# (( name-addr | addr-spec ), where
SIP-URL and URI is coming in address-spec and not in
the name-adress.

Regards
lakshmi

--- Hisham Khartabil <[email-masked]>
wrote:
> name-addr = [display-name] "<" addr-spec ">"
> 
> 
> > -----Original Message-----
> > From: [email-masked]
> > [mailto:[email-masked]]On Behalf Of
> laks hmi
> > Sent: Friday, 22 December 2000 11:50 AM
> > To: Hisham Khartabil
> > Cc: [email-masked]
> > Subject: RE: [SIP] conflict in syntax
> > 
> > 
> > what Mr.Hisham has told is correct but as i told
> only
> > in name-addr they have specified the "<" and ">".
> > what abt the SIP-URL|URI in address-spec.
> > 
> > lakshmi
> > 
> > __________________________________________________
> > Do You Yahoo!?
> > Yahoo! Shopping - Thousands of Stores. Millions of
> Products.
> > http://shopping.yahoo.com/
> > 
> > _______________________________________________
> > SIP mailing list
> > [email-masked]
> > http://lists.bell-labs.com/mailman/listinfo/sip
> 
> _______________________________________________
> SIP mailing list
> [email-masked]
> http://lists.bell-labs.com/mailman/listinfo/sip

__________________________________________________
Do You Yahoo!?
Yahoo! Shopping - Thousands of Stores. Millions of Products.
http://shopping.yahoo.com/

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: "Christian Jansson" <[email-masked]>
Date: Fri, 22 Dec 2000 17:06:03 +0100

Just a few lines below the Contact syntax there is a sentence that
I think will solve your problem:

"Even if the "display-name"is empty, the "name-addr" form MUST be
used if the "addr-spec" contains a comma, semicolon or question mark."

---
Christian Jansson

>The syntax is as foloows
>Contact =  ( "Contact" | "m")":" ("*"
>| (1# (( name-addr | addr-spec ) *( ";"
>contact-params ))))