Subject: [SIP] What relationship between Call leg and CSeq header?

From: "Acer" <[email-masked]>
Date: Thu, 14 Dec 2000 09:39:30 +0800

Hi! Advanced:

      From the document: draft-ietf-sip-call-flow-01.txt section 3.1.1
wrote:

	User A   --------INVITE--------> User B  (step1)
	UserA   <-------100 Trying------ User B (step2)

	From step1 to step, I think that Call-ID should not change, but the
document wrote
               Call-ID from [email-masked] change to [email-masked]

	Is it correcnt?

      To make clear:

	What relationship is between call  leg and CSeq header?
	A "call" life is defined  when  client send the first INVITE to the final
response.
	(It would contain more than one transaction.)
	So, when the "call" create, it should use the same Call-ID except
re-INVITE happen.

	Is this correct?

        Who can help me to make clear those points?

	Thanks !

Acer Hsu
_1_0_0111_0010_11_000_10_0111_111_10_1_0_111_
       Hsu, Hung-Chi - Call me "Acer"...
              Mailto:[email-masked]
         Tel : 886-3-5914494 Fax : 886-3-5820310
         Internet Telecommunication Dept.
   K200 CCL/ITRI Bldg. 51, 195-11 Sec. 4, Chung Hsing Rd.,
   Chutung, Hsinchu, Taiwan 310, R.O.C.
_101_11000_1_0_101_00_1_010_001101_0101_111_11_

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: "Steve Donovan" <[email-masked]>
Date: Wed, 13 Dec 2000 23:34:36 -0600

> -----Original Message-----
> From: [email-masked]
> [mailto:[email-masked]]On Behalf Of Acer
> Sent: Wednesday, December 13, 2000 7:40 PM
> To: [email-masked]
> Subject: [SIP] What relationship between Call leg and CSeq header?
>
>
> Hi! Advanced:
>
>
>

No, this is not correct.  This is a good catch on your part.  The document
will need to be changed.

> 	So, when the "call" create, it should use the same Call-ID except

The call-id should remain the same for all transactions associated with that
call.  As such, it will remain the same between INVITEs and re-INVITEs (in
addition to INFO, BYE and any other transactions associated with the call).
The CSeq, however, will change for each transaction, including re-INVITEs.