Subject: Re: [SIP] Music on Hold in ietf-sip-service-examples-00

From: "Venkatesh Venkataramanan" <[email-masked]>
Date: Thu, 7 Dec 2000 16:06:19 +0530

I request a small clarification in this regard. Seems to me that this call
flow assumes that the far end UA being put on Hold necessarily has atleast
two call appearance buttons if this call flow has to succeed. Is this
understanding of mine correct? If so, using Refer to place calls on hold
wouldn't work for single line telephones that spoke SIP.
----- Original Message -----
From: "Billy Biggs" <[email-masked]>
To: "Alan Johnston" <[email-masked]>
Cc: "Robert Sparks" <[email-masked]>; "SIP List"
<[email-masked]>
Sent: Wednesday, November 29, 2000 10:39 PM
Subject: [SIP] Music on Hold in ietf-sip-service-examples-00

>   In sip-service-examples-00, you discuss performing music on hold using
> REFER.  A shortened call flow is below:
>
>   On hold:
>
>          User A        User B       Music Server
>           |              |              |
>           |   REFER Refer-To: sip:[email-masked]
>           |<-------------|              |
>           | INVITE/200 OK/ACK           |
>           |<--------------------------->|
>           |  200 OK      |              |
>           |------------->|              |
>           |              |              |
>
>   Off hold:
>
>           |              |              |
>           |   REFER Refer-To: [email-masked];method=BYE
>           |<-------------|              |
>           |  BYE/200 OK  |              |
>           |<--------------------------->|
>           |  200 OK      |              |
>           |------------->|              |
>           |              |              |
>
>   I have two problems with this method:
>
>   1. In our implementation, User A will hang up the call to User B after
>      the REFER completes successfully.  This is to protect ourselves
>      (User B will also send a BYE), however, I can imagine most
>      implementations will be similar.
>
>   2. As mentioned in my previous email on remote device control using
>      REFER, the URI [email-masked];method=BYE is insufficient to
>      indicate to the UA which call should be disconnected.  It's also
>      overloading REFER and obfuscating its meaning.
>
>   There are more appropriate ways to implement music on hold.  One is to
> have User B call up the music server itself and swap the SDP (3pcc).
> Another is to have User A call up the music on hold server when it
> receives on-hold SDP.
>
> --
> Billy Biggs, 3Com               Email: [email-masked]
> http://www.div8.net/billy/      Phone: [email-masked]
>
> _______________________________________________
> SIP mailing list
> [email-masked]
> http://lists.bell-labs.com/mailman/listinfo/sip
>
>

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: Rohan Mahy <[email-masked]>
Date: Thu, 07 Dec 2000 09:07:38 -0800

what's a line in SIP?  ;-)

seriously, you don't need *any* line buttons.  You need to be able to
associate zero or one active media flows and zero to <n> inactive media
flows with the same media terminating resource (speaker and microphone for
audio).  optionally a SIP UA that can support media selection and mixing
should be able to support <n> active media flows if they all use compatible
media and codecs.

thanks,
-rohan

---

From: "Venkatesh Venkataramanan" <[email-masked]>
Date: Fri, 8 Dec 2000 08:58:00 +0530

That's a very interesting concept ;-).... What is a "line" in a digital
phone ;-)? What you have essentially described is the functionality of a
multi line digital phone and "buttons" or "lines" are just a means provided
to the end user to easily identify a particular "media flow" so that he/she
can toggle between calls ;-), identify when all "lines" or "media sessions"
that can be supported by an UA has reached its limit and provide coverage on
busy treatment and so on! and what 'providing music on hold' or 'transfer'
means using this call flow with SIP is that you are using an 'additional
media session' or "line" which in turn reduces the number of incoming calls
which could otherwise be handled by the UA by 1 ;-)...
----- Original Message -----
From: "Rohan Mahy" <[email-masked]>
To: "Venkatesh Venkataramanan" <[email-masked]>; "Billy
Biggs" <[email-masked]>; "Alan Johnston" <[email-masked]>
Cc: "Robert Sparks" <[email-masked]>; "SIP List"
<[email-masked]>
Sent: Thursday, December 07, 2000 10:37 PM
Subject: Re: [SIP] Music on Hold in ietf-sip-service-examples-00