Subject: [SIP] Sip thru TCP

From: "Mayank Sharma" <[email-masked]>
Date: Thu, 7 Dec 2000 16:16:31 +0530

hi
	please excuse me if this question seems naive.
	When you (proxy server) are sending request's downstream through
TCP, you keep the connection alive untill the transaction is completed.
You keep listening on that connection all the while. So do we have to
spawn a dedicated thread to listen to that connection ? in this case
then the number of threads spawned will be enormous. Or we can go on
polling each connection but still the overhead persists. 
	Anyway out?

Mayank

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: Igor Slepchin <[email-masked]>
Date: Thu, 7 Dec 2000 15:04:24 -0500

See http://www.cs.columbia.edu/~hgs/sip/faq/cache/93.html

To answer your question more directly: that's up to you. I'd suggest that
you refer to some network programming book (Stevens' ones are an obvious
choice) before making a decision.

---
Igor Slepchin

> -----Original Message-----
> From: Mayank Sharma [mailto:[email-masked]]
> Sent: Thursday, December 07, 2000 5:47 AM
> To: [email-masked]
> Subject: [SIP] Sip thru TCP
> 
> 
> hi

Use select() (if you are coding in C, that is).