Subject: RE: [SIP] RECORD-ROUTE/ROUTE requirements

From: Jonathan Rosenberg <[email-masked]>
Date: Mon, 4 Dec 2000 01:27:46 -0500

> -----Original Message-----
> From: Fairlie-Cuninghame, Robert [mailto:[email-masked]]
> Sent: Sunday, December 03, 2000 10:31 PM
> To: 'Jonathan Rosenberg'; 'Jo Hornsby'; [email-masked]
> Subject: RE: [SIP] RECORD-ROUTE/ROUTE requirements
> 
> > This seems a very orthogonal issue. I don't really like it, 
> > because I don't
> > think it will be needed in practice, and it makes assumptions about
> > processing at previous hops. Specifically, it assumes that 
> > the non-existence
> > of the Contact header implies an older client, and it 
> assumes that the
> > To/From field won't successfully get a call routed properly. 
> > I can imagine a
> > SIP security proxy that removes all internal Via/Contact/RR 
> > headers, and
> > inserts a single RR header pointing to itself. The next hop 
> > proxy might then
> > insert a Contact header, making things very confusing.
> 
> 
> I would have thought that this is a good example FOR my 
> suggestion. Only the
> first and last proxy will have to remember how to route the 
> call (by storing
> state locally or adding an extra Record-Route). The two end 
> proxies will be
> unaffected by any of this bbehaviour 
> - they will be the only proxy using the information they add, 
> - they will only remember routing information if they 
> discover they will
> have not have route headers or Contacts later. 
> - the extra Record-Route is taken directly from and to) the 
> UA and _not_
> interpolated end-to-end. Ie, the first proxy builds an extra 
> Reocrd-Route
> directly from the initial From+source address that it sees, 
> the last proxy
> would build a Record-Route from the forward 
> request-URI+forward address that
> it used.

I just can't follow what you are saying.

My point is simple. You are making assumptions about the meaning of a
missing Contact. I gave an example where the Contact was missing for a good
reason. Insertion of it by another proxy may confuse the proxy that gets a
record-route back in a response that does not have the form it expected
(i.e., extra entry corresponding to the inserted Contact).
> > I also don't think it will be needed in practice, since 
> making Contact
> > mandatory was one of the first things we added to bis. I 
> > think that most UA
> > devices do insert Contact these days. In any case, I hate to 
> > litter a spec
> > with hacks designed to support features that are only 
> > potentially useful
> > during a transition period (which may already be over).
> > 
> Currently, I beleive we have only made the Contact mandatory 
> in the INVITE
> and OPTIONS 2xx response. In fact the Contact is disallowed in the
> 4xx,5xx,6xx response (except 485) [0], however I think it 
> would be a good
> idea to allow Record-Routes in any non-3xx final responses. 
> Eg 401. So we've
> got a couple of options: 

I don't see how your point addresses what I was saying.

My point was that this whole discussion is likely moot, since it is my
suspicion that Contact is inserted by most UAs already.

-Jonathan R.
---
Jonathan D. Rosenberg                       72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.cs.columbia.edu/~jdrosen         PHONE: (973) 952-5000
http://www.dynamicsoft.com

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: [email-masked]
Date: Mon, 4 Dec 2000 12:55:14 +0530

Hi,
    If a user agent A knows the IP addr of user agent B, he can directly
send the INVITE request to B bypassing SIP proxies. Now this requires the UA
B to be polling on some port to listen to such requests. Is there any
standard port for this like 5060 or should it be previously known be A via
e-mail or other means.

regards,
 Vijeth