Subject: [SIP] using lex and yacc for sip parser

From: lakshmi udaykumar <[email-masked]>
Date: 6 Dec 00 07:43:52 MST

Hi friends,

i am using lex and yacc for sip parser.
Is it necessary to divide everything like
alphabets, digits into individual characters,
since we may have to use sinlge characters and
in lex tokens always matches with the longest match
not the least.

According to syntax given in rfc2543, space is not
specified as they have given in the examples b/w
tokens. I want to know wether to follow only syntax
or to see examples to give space for better identification.

Hope i will get early reply.
Thanks
lakshmi

____________________________________________________________________
Get free email and a permanent address at http://www.netaddress.com/?N=1

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: "M. Ranganathan" <[email-masked]>
Date: Wed, 06 Dec 2000 10:19:39 -0500

Dont use lex  and yacc. Use antlr. lex and yacc were designed forprogramming languages with a consistent set of tokens.lakshmi udaykumar wrote:> Hi friends,>> i am using lex and yacc for sip parser.> Is it necessary to divide everything like> alphabets, digits into individual characters,> since we may have to use sinlge characters and> in lex tokens always matches with the longest match> not the least.>> According to syntax given in rfc2543, space is not> specified as they have given in the examples b/w> tokens. I want to know wether to follow only syntax> or to see examples to give space for better identification.>> Hope i will get early reply.> Thanks> lakshmi>> ____________________________________________________________________> Get free email and a permanent address at http://www.netaddress.com/?N=1>> _______________________________________________> SIP mailing list> [email-masked]> http://lists.bell-labs.com/mailman/listinfo/sip--M.RanganathanNIST Advanced Networking Technologies Group,100 Bureau Drive, Stop 8920, Gaithersburg, MD 20899.Tel: 301 975 3664 Fax: 301 590 0932