Subject: RE: [SIP] Proxies modifying SDP

From: [email-masked]
Date: Mon, 18 Dec 2000 14:18 -0000

I suspect the original writer refers to some sort of media gateway 
that is not  SIP enabled. Therefore one could not simply  proxy the 
call to the gateway. 

----Original Message-----
   >From:     	Steve Donovan <[email-masked]>
   >To:         	Baniel Uri-CUB001 <[email-masked]>; 'Neil 
Deason' <[email-masked]>; <[email-masked]>; 
<[email-masked]>; <[email-masked]>
   >Cc:         	
   >Subj:     	RE: [SIP] Proxies modifying SDP
   >Reply To:     	
   >Sent:    	Sunday, December 17, 2000 9:13 PM
   >
   >Although I am having a hard time understanding why it would be 
necessary to
   >modify the SDP to cause the call to go through a specific gateway, 
as Neil
   >correctly points out, this is likely to be a function of a 
back-to-back UA.
   >
   >Why is it not enough to have the proxy route the call to the 
gateway in
   >question by changing the request-URI to point to the gateway?
   >
   >Steve
   >
   >> -----Original Message-----
   >> From: [email-masked]
   >> [mailto:[email-masked]]On Behalf Of Baniel 
Uri-CUB001
   >> Sent: Friday, December 15, 2000 1:51 PM
   >> To: 'Neil Deason'; [email-masked]; [email-masked];
   >> [email-masked]
   >> Subject: RE: [SIP] Proxies modifying SDP
   >>
   >>
   >> I see it as the requested way of forcing the media stream to go
   >> via an 'IP switch' (like the H323 MCU).
   >> If a proxy server is not allowed or if it is not appropriate for
   >> it to touch the SDP element, then is there any other way to make
   >> sure the media stream goes via our MCU gateway. (There could be
   >> various of reasons why we would want to have such a gateway)
   >>
   >> What do u think?
   >>
   >> Uri
   >>
   >> -----Original Message-----
   >> From: Neil Deason [mailto:[email-masked]]
   >> Sent: Friday, December 15, 2000 12:30 PM
   >> To: [email-masked]; [email-masked]; 
[email-masked]
   >> Subject: RE: [SIP] Proxies modifying SDP
   >>
   >>
   >>
   >> >Bernie Hoeneisen wrote:
   >> > > I have question concerning the case, when SIP proxies modify 
SDP,
   >> > > which is AFAIK against SIP principles, isn't it?
   >> >I do not think so.
   >> >Why is that *against* SIP principles?  What principles?'
   >>
   >> The fundamental concept that payloads are opaque to SIP Proxy
   >> Servers. To do this sort of thing you probably want to use a
   >> back to back UA.
   >>
   >> Cheers,
   >> Neil.
   >> --
   >> Ubiquity Software, UK                    www.ubiquity.net
   >>
   >> > > In the concrete case, proxies would be able to remove 
certain codecs
   >> > > from the INVITE messages, depending on the current policy in 
the
   >> > > network. (The UAS gets a subset of the codecs, which were 
originally
   >> > > sent by the UAC.)
   >> > > What impact does such a proxy behavior have to SIP? I can 
think of
   >> > > problems with authentication and message integrity checking 
(UAC signs
   >> > > message with its private key).
   >> >It certainly depends on the security mechanism used.  For e.g., 
with the
   >> >simple basic md5, it does not cause any issue.
   >> >
   >> >Jean-Francois
   >>
   >> 
_______________________________________________________________________
__
   >> Get Your Private, Free E-mail from MSN Hotmail at 
http://www.hotmail.com.
   >>
   >>
   >> _______________________________________________
   >> SIP mailing list
   >> [email-masked]
   >> http://lists.bell-labs.com/mailman/listinfo/sip
   >>
   >> _______________________________________________
   >> SIP mailing list
   >> [email-masked]
   >> http://lists.bell-labs.com/mailman/listinfo/sip
   >>
   >
   >
   >_______________________________________________
   >SIP mailing list
   >[email-masked]
   >http://lists.bell-labs.com/mailman/listinfo/sip
   >

---

From: Bernie Hoeneisen <[email-masked]>
Date: Tue, 19 Dec 2000 19:27:57 +0200 (EET)

Hi again

> that is not  SIP enabled. Therefore one could not simply  proxy the 

My original question was a bit different one and it is not directly 
related to media gateways.
In the case I was describing, there are SIP proxies, which know about
policy in the network and would interact while the INVITE is
passing them. Such proxies would remove certain codecs from the SDP.
I have some doubts, that it is a good idea...

Thus, I am posting my original question again (see below, last line).

Hoping for more comments on this...

Cheers
 Bernie

PS: Here my original email:

On Fri, 15 Dec 2000, Bernie Hoeneisen wrote:

> I have question concerning the case, when SIP proxies modify SDP,
> In the concrete case, proxies would be able to remove certain codecs
> from the INVITE messages, depending on the current policy in the
> network. (The UAS gets a subset of the codecs, which were originally
> sent by the UAC.)
>
> What impact does such a proxy behavior have to SIP? I can think of
> problems with authentication and message integrity checking (UAC signs
> Are there any other problems? Any comments are appreciated.