Subject: RE: [SIP] Session progress

From: Jonathan Rosenberg <[email-masked]>
Date: Fri, 1 Dec 2000 14:59:12 -0500

> -----Original Message-----
> From: Baniel Uri-CUB001 [mailto:[email-masked]]
> Sent: Monday, November 27, 2000 2:42 PM
> To: [email-masked]'
> Subject: [SIP] Session progress
> 
> 
> Hi
> 
> 1) Bis 4.2.1 says:
> 
> "A UAC MUST be prepared to receive media data according to 
> the session description as soon as it sends an INVITE (or re-INVITE) "
> 
> 2) According the 183 draft that there must be first a two way 
> path established (or at least the UAC should get first the 
> UAS RTP information) before the UAC is able to get 
> Alerting/call treatment RTP packets.
> 
> I guess (2) overrides (1) (and is even included in 1 now)
> 
> My question is: Why is the need to have the two way path 
> established for being able to convey the RTP information from 
> the UAS to the UAC?

The reason the 183 draft discussed this approach, I believe, was to deal
with security. Since the 183 could be authenticated, and could also be used
for security preconditions, the INV/183 exchange was needed to ensure that I
was gettign media only from the party that sent me the 183. If I open up my
RTP ports upon sending the INVITE, and the INVITE is in the clear, anyone
can send me audio and I'll happily play it out.

This, however, deserves more attention and is worth discussing at IETF, as
Henning has pointed out. I've already put in on the list of issues.

-Jonathan R.

---
Jonathan D. Rosenberg                       72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.cs.columbia.edu/~jdrosen         PHONE: (973) 952-5000
http://www.dynamicsoft.com

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: "Mattias Hartikainen (EUS)" <[email-masked]>
Date: Fri, 1 Dec 2000 11:56:09 -0600

Hi,

It's my interpretation that the 183 draft takes a telephony
perspective.

It's not strictly necessary to have the two way path in order to
receive media (e.g. in-band information) from the callee. A one 
way path is enough for that. 

However, until you have established the two way path you 
effectively don't know whether you ever will be able to 
establish it, and from a telephony perspective that is not 
acceptable (I believe the draft elaborates on why). 

Cheers,
Mattias Hartikainen

-----Original Message-----
From: Baniel Uri-CUB001 [mailto:[email-masked]]
Sent: Friday, December 01, 2000 8:51 AM
To: [email-masked]'
Subject: RE: [SIP] Session progress

Hello there?

Looks like either my question below was too basic/stupid or you guys are
still thinking about the answer ?
I will appreciate any response

Thanks

Uri

-----Original Message-----
From: Baniel Uri-CUB001 [mailto:[email-masked]]
Sent: Monday, November 27, 2000 1:42 PM
To: [email-masked]'
Subject: [SIP] Session progress

Hi

1) Bis 4.2.1 says:

"A UAC MUST be prepared to receive media data according to the session
description as soon as it sends an INVITE (or re-INVITE) "

2) According the 183 draft that there must be first a two way path
established (or at least the UAC should get first the UAS RTP information)
before the UAC is able to get Alerting/call treatment RTP packets.

My question is: Why is the need to have the two way path established for
being able to convey the RTP information from the UAS to the UAC?

Thanks
Uri