Subject: [SIP] Reversing TO and FROM fields

From: Baniel Uri-CUB001 <[email-masked]>
Date: Tue, 19 Dec 2000 06:15:30 -0600

First, sorry 4 still being stuck with version 01 of the Bis...
Para 16.4 (Terminating a call) talks about callee being able to abourt a call by simply reversing the TO and FROM field..

What does that mean? Any simple example please

Thanks!

Uri

_______________________________________________
SIP mailing list
[email-masked]
http://lists.bell-labs.com/mailman/listinfo/sip

---

From: Vijay Gurbani <[email-masked]>
Date: Tue, 19 Dec 2000 09:23:58 -0600

Baniel Uri-CUB001 wrote:
> Para 16.4 (Terminating a call) talks about callee being able to abourt a 
> call by simply reversing the TO and FROM field..
> 

I think the intent of that paragraph is to state that if the callee (and
not the caller) wants to end the call, the To and From will be reversed.

Assume the following:

UAC                  UAS
INVITE ---->
To: A
From: B
               <------ 200 OK
                       To: A;tag=ffe1a
                       From: B
ACK --->
To: A;tag=ffe1a
From: B

If the UAC hangs up, the To and From URIs remain the same; if on the other
hand, the UAS (callee) hangs up, the To and From will be reversed; i.e.

UAC                  UAS
             <------ BYE
                     To: B
                     From: A;tag=ffe1a

Both the To and From retain the tags (see Section 11.4 in the 01 bis for
more info).

- vijay
-- 
Vijay K. Gurbani  vkg@{lucent.com,research.bell-labs.com,acm.org}
Internet Software and eServices Group 
Lucent Technologies/Bell Labs Innovations 263 Shuman Blvd., Rm 1A-413
Naperville, Illinois 60566     Voice: +1 630 224 0216   Fax: +1 630 713 0184