Subject: [Sip] Manyfolks and re-INVITE

From: Christer Holmberg <[email-masked]>
Date: Thu, 13 Sep 2001 16:00:54 +0300

Hi,

Another question related to the manyfolks draft.

If we want to send a mid-call re-INVITE, for example to change codecs, I
assume that we will have to do the same procedure as in the beginning of
the call, with the 18x-, PRACK-, and COMET messages.

Now, since there is nothing wrong by sending 1xx provisional responses
for a mid-call request, isn't the 18x responses defined for the call
setup procedure? Also, I've never seen any example of the use of
mid-call PRACKs, even if I guess it's not illegal from a protocol point
of view either.

Comments on this?

Regards,

Christer Holmberg
Ericsson Finland

---

From: William Marshall <[email-masked]>
Date: Thu, 13 Sep 2001 09:49:11 -0400 (EDT)

I'll add some text to section 11 (usage rules) making this
explicit.

Bill Marshall
[email-masked]

-----original message-----
Date: Thu, 13 Sep 2001 16:40:44 +0300
From: Christer Holmberg <[email-masked]>
To: William Marshall <[email-masked]>
Cc: [email-masked]
Subject: Re: [Sip] Manyfolks and re-INVITE

Hi,

> The sequence to change codecs mid-session would be identical to that
> to establish a new session.  The new media streams could require
> authorization, need resource reservations, etc, etc, etc.  The new
> media stream could even require "ringing" if the end user needs to
> do anything prior to the UAS accepting the codec change.  If any
> of this fails, the mid-session codec change fails.
> 
> Nothing in the protocol prevents 1xx provisional responses to a mid-session
> INVITE.  Nor does anything prevent a mid-session PRACK.

I know. I do think, however, that the re-INVITE scenario should be
described in the draft. And, even if 1xx messages ARE allowed, it am not
sure it is a very good idea to send 180 Ringing in the middle of the
call. I guess 183 is ok, and maybe we could even define a new 18x code
for this purpose, if needed. 

My point is that until now I guess most people have assumed that 18x and
PRACK are used only during the call setup, no matter what the standard
may allow.

Regards,

Christer (lmfchh)

> 
> Bill Marshall
> [email-masked]
> 
> -----original message-----
> Date: Thu, 13 Sep 2001 16:00:54 +0300
> From: Christer Holmberg <[email-masked]>
> Subject: [Sip] Manyfolks and re-INVITE
> 
> Hi,
> 

_______________________________________________
Sip mailing list  http://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip