Subject: [Sip] Question about the cc-transfer draft - usage of callId.

From: "Padhye, Chinmay" <[email-masked]>
Date: Mon, 17 Sep 2001 15:54:35 -0700

Hello,

            I have a question regarding the usage of call-id's during call
transfer. In example 7.2 the following steps are taken -

            a) A call is established between the transferor and the
transferee - clid 1.
            b) A call is established between the transferor and the
transfer-target - clid 2.
            c) A REFER message is sent to the transfer-target. - clid 2.
--->       d) The transfer-target issues an INVITE to the transferee with
clid 2.

            - Shouldnt the transfer-target use clid 3 when it tries to
establish a call with the transferee? 
            - Is this a mistake in the figure? If this allowed then a call
is established between two parties with the same call-id.

            A similar scenario is present in section 7.3.

Regards,

Chinmay

_______________________________________________
Sip mailing list  http://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Robert Sparks <[email-masked]>
Date: Tue, 18 Sep 2001 15:02:25 -0400

No real reason for the trigerred invite to have call-id of 2 in those
two figures anymore. I'll change it to call-id of 3.

RjS

> -----Original Message-----
> From: Padhye, Chinmay [mailto:[email-masked]]
> Sent: Monday, September 17, 2001 5:55 PM
> To: [email-masked]'
> Subject: [Sip] Question about the cc-transfer draft - usage of callId.
> 
> 
> Hello,
>

---

From: Jonathan Rosenberg <[email-masked]>
Date: Tue, 18 Sep 2001 23:41:17 -0400

> From: Robert Sparks [mailto:[email-masked]]
> Sent: Tuesday, September 18, 2001 3:02 PM
> To: 'Padhye, Chinmay'; [email-masked]'
> Subject: RE: [Sip] Question about the cc-transfer draft - usage of
> callId.
> 
> 

Just to be clear, its a stronger statement than that. That call-id can't be
2. Thats because call-ids for new calls are globally unqiue. 

-Jonathan R.

---
Jonathan D. Rosenberg, Ph.D.                72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.jdrosen.net                      PHONE: (973) 952-5000
http://www.dynamicsoft.com