Subject: RE: [Sip] SDP in REFER triggered INVITE

From: "Aaron Lo" <[email-masked]>
Date: Tue, 4 Sep 2001 17:38:51 -0700

Consider this scenario:

Say A, and B are in an audio call. If A wants to invite C into their
session and establish a conference call, A could use REFER to set up the
call, correct? If C can establish whatever session with A and B, C could
possibly choose to establish an IM session with the other two parties. 

Also consider this:

Say A and B are in an audio call. A is a sip phone that is incapable of
doing IM. Say B wants to transfer the call to C, C may establish an IM
session with A (which may fail). A and C would not be able to have a
meaningful session. 

For both cases, it is perfectly legitimate to for C to try to establish
an IM session. However, it is clearly not very meaningful or useful.

If A has the option to specify the type of session it wants C to
establish with the refer-to party, C could establish a meaningful
session. If C does not want to set up a session of the specified type,
it could still decline the REFER. 

An option to specify the media type in refer seems very attractive. 

-----Original Message-----
From: Brett Tate [mailto:[email-masked]] 
Sent: Wednesday, August 29, 2001 11:48 AM
To: Aaron Lo; [email-masked]
Subject: RE: [Sip] SDP in REFER triggered INVITE

> I have a question for REFER outside of 
> existing call-legs. 
> 
> Consider this:
> 
> A sends a REFER to B referring to C. 
> How does B know from the REFER what kind 
> of session to establish, i.e. audio/IM/etc,
> and what to include in the SDP body? 
 
The REFER doesn't indicate it.  B decides 
what sort of session it wishes to establish 
with C.  

A similar decision is made for 
INVITE without SDP situations.

_______________________________________________
Sip mailing list  http://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Brett Tate" <[email-masked]>
Date: Wed, 5 Sep 2001 11:41:47 -0400

> possibly choose to establish an IM session with the other two 

Correct.

C should pass an INVITE with SDP describing 
all media connections it is willing to 
participate.  If C is only willing to 
participate in an IM, it only passes the
IM media description in the SDP.

> session with A (which may fail). A and C would not be able to have a

It would fail if C only wishes to allow an IM 
session and A is only capable of performing 
a voice session.  The protocol allows the 
failure to be detected.  The call between A 
and B can remain.

Alternatively C can send OPTIONS to
determine what type of sessions A can support 
prior to sending the first INVITE to deal with 
"I prefer IM, but I'll do voice if required"
functionality.

> An option to specify the media type in refer seems very attractive. 

This option isn't needed unless the REFERer 
isn't willing to allow the REFERed and 
Refer-to parties negotiate the type of 
session.

This option would be nice from a 
billing perspective if the transferring 
party is going to be billed for the call 
between transferee and transfer-to.  
However this is a separate issue.

From a 3PCC perspective, I'd love to have 
this sort of control/communication.  
However I think that there were some people 
opposed to passing SDP/headers/parameters
within the REFER to communicate this sort 
of thing.

---

From: "Brett Tate" <[email-masked]>
Date: Thu, 6 Sep 2001 15:57:10 -0400

> > An option to specify the media type in refer seems very attractive. 

Potentially the "media=" aspects of
draft-ietf-sip-callerprefs could be used 
to communicate such information within the 
REFER to reduce the media negotiation 
between the referred and refer-to.