Subject: RE: [Sip] about H.323 and SIP

From: De Leo Walter <[email-masked]>
Date: Tue, 18 Sep 2001 15:15:16 -0300

Matt,
Applying your reasoning to the ISUP-SIP interface, you cannot understand why
is that interface being defined, and perhaps becoming an standar?
Do you think it should be left implementation specific?
I don't.
Regards.
Walter.

> -----Mensaje original-----
> De:	Matt Holdrege [SMTP:[email-masked]]
> Enviado el:	Jueves 13 de Septiembre de 2001 14:04
> Para:	Na Li; [email-masked]
> Asunto:	Re: [Sip] about H.323 and SIP
> 
> It's perfectly simple in concept that an MGC would speak H.323 on one 
> interface and SIP on another. In fact some MGC's or Softswitches do this 
> today. So if an MGC receives a call setup from an H.323 Gatekeeper which
> is 
> intended for a SIP network, it would simply send a call setup to the SIP 
> proxy that has reachability for the destination and upon receipt of an RTP
> 
> address would instruct the H.323 Gatekeeper or gateway to open up an RTP 
> connnection.
> 
> A similar action would take place if a call was destined for the PSTN and 
> the MGC needed use SIP-T to contact another MGC to setup the call at the 
> remote PSTN network. The far end MGC would speak MGCP or MEGACO/H.248 to 
> control the trunking gateway to the PSTN.
> 
> Since such protocol interworking occurs internal to a given platform/MGC, 
> there is no standard nor should there be. It is implementation specific as
> 
> there is no interworking with other elements.
> 
> 
> At 05:15 PM 9/12/2001, Na Li wrote:
> >Hello,
> >
> >I have several questions relating to H.323
> >
> >1) What's the fundamental difference between H.323 (including fast
> >setup) and SIP? I don't mean the text encoding or ANS.1 encoding.
> >2) Could Media gateway controller use H.323 for session creation, and
> >use Megaco to communicate with media gateway?
> >3) Is any standard there to map H.323 with SIP?
> >
> >Thanks, have a nice day
> >
> >Lina
> >
> >_______________________________________________
> >Sip mailing list  http://www1.ietf.org/mailman/listinfo/sip
> >This list is for NEW development of the core SIP Protocol
> >Use [email-masked] for questions on current sip
> >Use [email-masked] for new developments on the application of sip
> 
> 
> _______________________________________________
> Sip mailing list  http://www1.ietf.org/mailman/listinfo/sip
> This list is for NEW development of the core SIP Protocol
> Use [email-masked] for questions on current sip
> Use [email-masked] for new developments on the application of sip

_______________________________________________
Sip mailing list  http://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Matt Holdrege <[email-masked]>
Date: Fri, 21 Sep 2001 13:12:28 -0700

Interworking pure ISUP and pure SIP is implementation specific. To be 
clear, I'm referring to a call setup from an ISUP network to a Softswitch, 
and the Softswitch generating a SIP/SDP setup based on policy. The same 
goes for a call in the other direction.

However, transporting or preserving ISUP information using SIP requires a 
standard, thus we have SIP-T modes of encapsulation and mapping. This is 
the way to go if you do not want the Softswitch to generate the call details.

I hope I'm making myself clear as I'm kind of jet lagged right now.