Subject: [Sip] Query on Authorization header in bis draft

From: "Drage, Keith (Keith)" <[email-masked]>
Date: Mon, 17 Sep 2001 12:41:19 +0100

In table 4, the Authorization header carries rows that apply to it being a
request header and a response header.

In table 3 it is defined only as a request header, and in the authentication
procedures later in the document and in the references it only seems to
appear in requests. 

Is it truly only a request header and table 4 is wrong, or is there some
hidden secret somewhere.

Keith

Keith Drage
Lucent Technologies
Tel: +44 1793 776249
Email: [email-masked]

_______________________________________________
Sip mailing list  http://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Drage, Keith (Keith)" <[email-masked]>
Date: Tue, 18 Sep 2001 16:21:51 +0100

So, if this is the case, it cannot be a request header, as currently defined
in table 3 of the bis draft, but must be a general header. 

So,  which is right, and can I understand that from the current bis draft,
or does it require some modification.

Keith

Keith Drage
Lucent Technologies
Tel: +44 1793 776249
Email: [email-masked]

> ----------
> From: 	[email-masked][SMTP:[email-masked]]
> Sent: 	17 September 2001 12:47
> To: 	Drage, Keith (Keith)
> Cc: 	[email-masked]
> Subject: 	Re: [Sip] Query on Authorization header in bis draft
> 
> 
> 
> Hi Keith,
>      The "hidden secret" lies in section 18.2 which clarifies :
> 
> "...The Authorization header field is used in requests to authenticate
> the request originator end-to-end to proxies and the called user agent,
> and in responses to authenticate the called user agent or proxies
> returning
> their own failure codes."
> 
> 
> Regards,
> Subhash.
> 
> 
> 
> 
> 
> "Drage, Keith (Keith)" <[email-masked]> on 09/17/2001 05:11:19 PM
> 
> To:   [email-masked]
> cc:    (bcc: Subhash Ullal Nayak/HSSBLR)
> 
> Subject:  [Sip] Query on Authorization header in bis draft
> 
> 
> 
>

---

From: Jonathan Rosenberg <[email-masked]>
Date: Tue, 18 Sep 2001 23:22:31 -0400

> -----Original Message-----
> From: Drage, Keith (Keith) [mailto:[email-masked]]
> Sent: Tuesday, September 18, 2001 11:22 AM
> To: Drage, Keith (Keith); [email-masked]'
> Cc: [email-masked]
> Subject: RE: [Sip] Query on Authorization header in bis draft
> 
> 

No, it is not the case. Usage of authorization for authenticating responses
has been deprecated, and this has not been well pruned from the spec. It was
never well specified and rfc2617 anyway defines a different mechanism using
authorization info, which we will use instead.

-Jonathan R.
---
Jonathan D. Rosenberg, Ph.D.                72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.jdrosen.net                      PHONE: (973) 952-5000
http://www.dynamicsoft.com

---

From: "Drage, Keith (Keith)" <[email-masked]>
Date: Wed, 26 Sep 2001 10:41:36 +0100

So I expect to see removal of the "r" row for the Authorization header from
table 4 of the bis draft, and modification of section 18.2. (wherever they
appear in the new version of the spec).

Keith

Keith Drage
Lucent Technologies
Tel: +44 1793 776249
Email: [email-masked]

> ----------
> From: 	Jonathan Rosenberg[SMTP:[email-masked]]
> Sent: 	19 September 2001 4:22
> To: 	'Drage, Keith (Keith)'; [email-masked]'
> Cc: 	[email-masked]