Subject: [Sip] A few comments on draft-ietf-sip-callerprefs-04.txt

From: "Jo Hornsby" <[email-masked]>
Date: Tue, 4 Sep 2001 16:34:37 +0100

Hello.

In Section 5, is it very useful (helpful, even) to allow
Caller Prefs in a CANCEL request?  Seems it would only be
relevant in a case where a server saw a CANCEL and couldn't
match it to any existing Transaction, and that's about as
unlikely as an extremely unlikely thing in Unlikelyland.

In Section 5.5, under "queue-feature", I am not sure that
the text should say that "A pending call be terminated by
a SIP CANCEL or BYE request"; surely it should just be a
CANCEL?

Uber-Nit: Section 6.1: "They SHOULD reflect actual
characteristics of the URLs being registered."
                       ^^^^
should read "URIs"?

In Section 6.3, it doesn't seem too helpful to even give
the posibility of using Proxy-Require?  As is noted, it
is likely to cause the request to fail, and even if the
request doesn't fail, these are only preferences....

Nit: Section 6.4.2: In the paragraph beginning "If the
server proxies", I think it would be slightly clearer if
the text read "If the server elects to do a parallel
proxy", rather than "If the server elects to do a forking
proxy".

Finally, Section 9, I would have thought it would be
better to lean toward the positive case with the "too
many rules"; i.e., make the reject a MAY.  But maybe I'm
just too trusting/naiieve. &:)

 - Jo.
-- 
  Jo Hornsby; IT Professional         --       mailto:[email-masked]
 Ubiquity Software Corporation        --         http://www.ubiquity.net/

_______________________________________________
Sip mailing list  http://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Jonathan Rosenberg <[email-masked]>
Date: Fri, 7 Sep 2001 13:34:07 -0400

> -----Original Message-----
> From: Jo Hornsby [mailto:[email-masked]]
> Sent: Tuesday, September 04, 2001 11:35 AM
> To: [email-masked]
> Subject: [Sip] A few comments on draft-ietf-sip-callerprefs-04.txt
> 
> 
> Hello.
> 

Hmm. I hadn't thought about that. It is more likely than you think,
particularly in the case where its a stateless proxy that is implementing
this. Stateless proxies never have transaction state, so CANCEL is routed in
the same way the INVITE was routed. Maybe you can argue that stateless
proxies can't really implement caller prefs, and that may be true. I've come
to the conclusion that stateless proxies can only implement very static
routing logic, since otherwise if the routing logic changes mid-transaction,
your call is split into two directions, and you're stateless proxy has
accidentally forked, which can be very bad in some cases. 

Now, since caller prefs is mostly useful for routing based on registrations,
which can change, I would argue that a stateless proxy shouldn't implement
caller prefs, and would propose adding text to that regard.

The problem still remains of error cases, but this is definitely well into
unlikelyland, and doesn't seem important enough to worry about.

> a SIP CANCEL or BYE request"; surely it should just be a

Good catch. This is the danger of repeating main sip spec stuff in
extensions. I will strike this sentence entirely, and rather say, "a pending
call can be terminated as described in rfc2543". 

> characteristics of the URLs being registered."

Changed.

> request doesn't fail, these are only preferences....

The text does say that, and doesn't recommend it for that reason. 
Its really just stating what you can do anyway. I think its harmless,
and if anything, explicitly calling out that usage of Require is not
recommended
is probably a good thing.

> proxy", rather than "If the server elects to do a forking

Fixed.

> just too trusting/naiieve. &:)

Since I suspect 20 rules is way more than would ever be needed in any real
scenario, I think  SHOULD is fine here.

Thanks for your comments,
Jonathan R.

---
Jonathan D. Rosenberg, Ph.D.                72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.jdrosen.net                      PHONE: (973) 952-5000
http://www.dynamicsoft.com