Subject: [Sip] compression of SIP over TCP

From: [email-masked]
Date: Mon, 10 Sep 2001 19:19:43 +0300

Hi Jonathan,

A colleague of mine asked me this question related to SIP over
TCP: does UDPComp imply the compression of SIP over TCP is
not considered? I don't think the answer is yes but I'm
wondering too why your I-D is UDP oriented (it doesn't
need to be).

BR,
Zhigang

_______________________________________________
Sip mailing list  http://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Jonathan Rosenberg <[email-masked]>
Date: Wed, 19 Sep 2001 02:20:40 -0400

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: Monday, September 10, 2001 12:20 PM
> To: [email-masked]; [email-masked]
> Cc: [email-masked]
> Subject: compression of SIP over TCP
> 
> 
> Hi Jonathan,
> 

Correct, it doesn't need to be. There is no fundamental reason. UDP is the
harder problem, and thats what the draft tackles. Nothing prevents TCP from
working, I just didn't get to it in the first draft (and many other issues
too).

-Jonathan R.

---
Jonathan D. Rosenberg, Ph.D.                72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.jdrosen.net                      PHONE: (973) 952-5000
http://www.dynamicsoft.com

---

From: [email-masked]
Date: Thu, 20 Sep 2001 05:02:01 +0000

Does this mean that u feel that the problems with UDP 
have been solved in the draft?

Has anyone on the list build a large SIP server farm 
that supports UDP including fail-over if one of the SIP 
servers should fail?

thx  ..tom