Subject: RE: [Sip] Bis-04 inconsistency.

From: Jonathan Rosenberg <[email-masked]>
Date: Fri, 7 Sep 2001 14:43:41 -0400

> -----Original Message-----
> From: Jo Hornsby [mailto:[email-masked]]
> Sent: Wednesday, September 05, 2001 9:52 AM
> To: Fairlie-Cuninghame, Robert; [email-masked]
> Subject: RE: [Sip] Bis-04 inconsistency.
> 
> 
> > I don't believe the following paragraph in the ACK method 
> description
> > (Section 5.1.1) is correct:
> > 
> >    A proxy server receiving an ACK request after having 
> sent a 3xx, 4xx,
> >    5xx, or 6xx response must make a determination about 
> whether the ACK
> >    is for it, or for some user agent or proxy server 
> further downstream.
> >    This determination is made by examining the tag in the 
> To field. If
> >    the tag in the ACK To header field matches the tag in 
> the To header
> >    field of the response, and the From, CSeq and Call-ID 
> header fields
> >    in the response match those in the ACK, the ACK is meant for the
> >    proxy server. Otherwise, the ACK SHOULD be proxied 
> downstream as any
> >    other request. However, an ACK not destined for the 
> proxy SHOULD NOT
> >    be retransmitted.
> > 
> > ACK's for non-2xx responses are hop-by-hop and the UAC does 
> not copy the
> > tags from the non-2xx response into the ACK message, as described 
> > in Section
> > 15.4:
> > 
> >    A UAC copies the tag from the final response into the ACK, but
> >    it MUST NOT copy the tag into any subsequent requests unless the
> >    response was a 200-class response to an INVITE request.
> 
> Looks fine to me.  The "MUST NOT" applies to re-INVITEs,
> etc. (which don't exist unless there was a 2xx).

Looks fine to me too.

Note, however, that the scenario of a proxy getting an INVITE not for it
should never happen. ACK-200 should be Routed, and ACK for non-200 goes hBh
right to the server that generated the response.

-Jonathan R.
---
Jonathan D. Rosenberg, Ph.D.                72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.jdrosen.net                      PHONE: (973) 952-5000
http://www.dynamicsoft.com

_______________________________________________
Sip mailing list  http://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Fairlie-Cuninghame, Robert" <[email-masked]>
Date: Fri, 7 Sep 2001 11:54:22 -0700

> > etc. (which don't exist unless there was a 2xx).

Yeah that's what made me misread it - there are normally no "subsequent
requests" for ACK's to non-200 responses. I can only think that this was
trying to cover the 3xx response case when a new request is generated after
receiving the redirect.
 
> right to the server that generated the response.

Including stateless proxies? My understanding was they just forwarded
everything.

"Stateless Proxy: A logical entity that does not maintain state
             for a SIP transaction. A stateless proxy forwards every
             request it receives downstream and every response it
             receives upstream."

Robert.