Subject: [Sip] RE: [Sipping] Loose Routing Proposal

From: "Sean Olson (EUS)" <[email-masked]>
Date: Fri, 7 Sep 2001 10:08:38 -0500

I personally believe the issue of 
backwards compatibility at this point in
time is moot. The Route: header stuff has
changed dramatically since 2543. And I think
we are finding that it still is not quite 
right. What does backwards compatibility
mean if the old proxies are broken? 

We have three options:

1) Use a Proxy-Require:
2) Change to SIP/2.1 
3) Ignore backwards compatibility in this case

None of these are pretty, but (3) seems
the most straightforward way to continue.
Since 2543bis is going to be a recycled
Proposed Standard, is backwards compatibility
in this sense really important? 

flame away
/sean

>-----Original Message-----
>From: Jo Hornsby [mailto:[email-masked]]
>Sent: Friday, September 07, 2001 3:34 AM
>To: Dean Willis; [email-masked]
>Subject: RE: [Sipping] Loose Routing Proposal
>
>
>[Moved to SIP.  Hopefully this is the right thing todo.]
>
>> I believe Jonathan R looked at the Route: header and determined that
>> there does not appear to be a reasonable way to do this and preserve
>> backward compatibility -- rather than ignoring the "loose" flag,
>> older proxies would probably choke the route.
>
>I have to say that I'm still confused as to why we can't
>just say that Route is loose.  Neil has pointed out that
>the notion of DNS-incapable clients has already created
>a sortof precedent for this.  The only problem I've heard
>so far is that you lose the identity of the called party
>(because the Request-URI gets clobbered by some Route pop
>along the path); however, I fail to see why the proposal
>of adding the called party as the last Route entry will
>not work...?
>
>
> - Jo.
>
>
>
>_______________________________________________
>Sipping mailing list  http://www1.ietf.org/mailman/listinfo/sipping
>This list is for NEW development of the application of SIP
>Use [email-masked] for questions on current sip
>Use [email-masked] for new developments of core SIP
>

---

From: "Dean Willis" <[email-masked]>
Date: Fri, 7 Sep 2001 13:23:40 -0500

RE: [Sipping] Loose Routing ProposalOk, I think I see herein a proposal to change the fundamental route/record-route action in SIP.

1) Add type modifier syntax for loose and strict to Route and Record-Route

2) Switch to "pop on receive" rather than "pop on send".

3) Use hostnames instead of URLs to indicate route-nodes, or at least depecate the "user@" part. RL does retain some advantage from a DNS SRV perspective.

4) Stop rewriting the request URI when exercising a route. Do IP routers change the target address of a packet when forwarding the packet to a next hop router? nope.

I think this would actually be a very useful cleanup of what I see as a really confusing part of the specification.

Of course, the backward compatibility story here would be "not good".  Once could always increment the version number or declare it "not a problem".

--
dwillis
  ----- Original Message ----- 
  From: Sean Olson (EUS) 
  To: 'Jo Hornsby' ; Dean Willis ; [email-masked]' 
  Sent: Friday, September 07, 2001 10:08 AM
  Subject: [Sip] RE: [Sipping] Loose Routing Proposal

  We have three options: 

  1) Use a Proxy-Require: 
  2) Change to SIP/2.1 

  flame away 
  /sean