Subject: [Sip] Open Issue #130: CANCEL vs. BYE

From: Jonathan Rosenberg <[email-masked]>
Date: Wed, 19 Sep 2001 03:42:07 -0400

Rohan wrote:
> #130  "BYE vs. CANCEL"
>  >To hang up a call before a final response, does the UAC
>  >1) BYE, no tags
>  >2) CANCEL, then BYE if 2xx
>  >3) CANCEL + BYE no tags
>  >Related: can CANCEL have tags to be "directed"
>  >Related: can you send BYE for a 1xx "early leg"
>  >Proposal:
>  >CANCEL for all, then BYE on 2xx
>  >You can terminate a particular early leg with BYE w/ tags
>  >[CANCEL w/ tags is worse since: No bodies, Not e2e]

THis is the open issue that won't go away. There always seem to be threads
on it, with continuous dissenters.

Lets finish this. 

My proposal remains as above. If you want to hang up a call before a final
response, you send CANCEL. Any 2xx this may trigger are responded to with
BYE. Early call legs can be hung up with tagged BYE, which is better than
putting tags in CANCEL to hang up early call legs.

Please weigh in for this in either direction.

-JOnathan R.

---
Jonathan D. Rosenberg, Ph.D.                72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.jdrosen.net                      PHONE: (973) 952-5000
http://www.dynamicsoft.com

_______________________________________________
Sip mailing list  http://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Christer Holmberg <[email-masked]>
Date: Wed, 19 Sep 2001 12:28:20 +0300

Hi,

>Please weigh in for this in either direction.

I agree with the proposal.

However, I guess BYE (untagged) should still be allowed to hang up a
call before a final response, assuming that the untagged BYE will be
handled and routed like a CANCEL. Or?

So, BEFORE a final answer has been received:

CANCEL 		Hang up call
CANCEL + tag	NOT ALLOWED!
BYE     	Hang up call
BYE + tag	Terminate early call leg

And, AFTER a 200 final answer has been received (session established):

BYE		NOT ALLOWED???
BYE + tag	Hang up call

Regards,

Christer Holmberg
Ericsson Finland

---

From: "Bob Penfield" <[email-masked]>
Date: Wed, 19 Sep 2001 10:22:53 -0400

I agree with the proposal. CANCEL is the proper way to cancel a pending
request, and the CANCEL must match the request (no tags). Use BYE with tags
to terminate specific early call legs.

(-:bob

Robert F. Penfield
Chief Software Architect
Acme Packet, Inc.
130 New Boston Street
Woburn, MA 01801
[email-masked]

---

From: "Bob Penfield" <[email-masked]>
Date: Wed, 19 Sep 2001 10:28:54 -0400

----- Original Message -----
From: "Christer Holmberg" <[email-masked]>
To: "Jonathan Rosenberg" <[email-masked]>
Cc: <[email-masked]>
Sent: Wednesday, September 19, 2001 5:28 AM
Subject: Re: [Sip] Open Issue #130: CANCEL vs. BYE

> CANCEL + tag NOT ALLOWED!

UAS and proxy code may need to support BYE for backwards compatibility, but
we should discourage people from using a BYE as a CANCEL when acting as the
UAC.

---

From: "Jo Hornsby" <[email-masked]>
Date: Thu, 20 Sep 2001 17:36:18 +0100

> Please weigh in for this in either direction.

Sounds good to me.

 - Jo.

---

From: "Brett Tate" <[email-masked]>
Date: Thu, 20 Sep 2001 21:56:23 -0400

> Please weigh in for this in either direction.

The proposal sounds fine.  The text should 
strongly mention that a BYE with tags only 
terminates a particular early call-leg.  
It does necessarily ensure the cancellation 
of an INVITE.