Subject: RE: [Sip] Open Issue #72: CANCEL for multicast

From: Jonathan Rosenberg <[email-masked]>
Date: Tue, 25 Sep 2001 01:30:52 -0400

> -----Original Message-----
> From: Henry Chen [mailto:[email-masked]]
> Sent: Monday, September 24, 2001 5:56 PM
> To: Henning G. Schulzrinne
> Cc: Howard Hart; [email-masked]'
> Subject: Re: [Sip] Open Issue #72: CANCEL for multicast
> 
> 
> 
> 
> Totally agree. I would like to add one more general case for 
> the reason to
> leverage multicast by SIP:
> Whenever there is only one possible and relevant UAS who will 
> response the
> multicast request in the multicast group.
> The pattern is:
> 
> Multicast request to a multicast group and
> Only one possible UAS sends unicast response back.

How would the client know there is only one?
How would the server know its the only one?

Sounds like what you want is anycast, not multicast. Anycast is workable
with sip, since it really looks like unicast from a transport perspective.

-Jonathan R.

---
Jonathan D. Rosenberg, Ph.D.                72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.jdrosen.net                      PHONE: (973) 952-5000
http://www.dynamicsoft.com

_______________________________________________
Sip mailing list  http://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Henry Chen <[email-masked]>
Date: Tue, 25 Sep 2001 11:01:38 -0500

> How would the server know its the only one?

This is decided by the feature or application context or definition.
EX. Group pickup feature.
You want pickup a call in a pickup group, so you multicast SUBSCRIBER to the
group for the call-leg ring state.
For this case, the UAC is trying to pickup exactly one call in alert.
The UAS ringing is the only one in the pickup group who will response and
NOTIFY the UAC the ring call-leg state.
For the most of the time there is only one phone in the group ringing.
If there are more than one phones are ringing at the same time, the race
condition should be solved by some mechanism,
but the feature characteristic is only one phone.

> with sip, since it really looks like unicast from a transport perspective.

No, I did not mean anycast, it is multicast to a group of receivers.
I think we should open the door for SIP to leverage the Multicast, not only
just for media, but also for call signaling
for the purposes of scale and simplification of PROXY and AS.

Thanks,

Henry Chen