Subject: RE: [Sip] Open Issue #58: Rejected mid-call SDP in 2xx

From: Jonathan Rosenberg <[email-masked]>
Date: Fri, 7 Sep 2001 16:55:47 -0400

> -----Original Message-----
> From: Brett Tate [mailto:[email-masked]]
> Sent: Friday, September 07, 2001 4:10 PM
> To: 'Jonathan Rosenberg'
> Cc: [email-masked]
> Subject: RE: [Sip] Open Issue #58: Rejected mid-call SDP in 2xx
> 
> 
> Sounds fine with me.  However I guess that the 
> "MUST" will have implications for devices that 
> can't or don't distinguish between INVITE and 
> re-INVITE after having underwent a restart.

I had forgotten about this case. Good observation.

> I guess that these UA's would have to persist 
> parts of the SDP if they wish to allow a 
> re-INVITE without SDP to re-establish a call
> (which I don't recommend).

I agree that thats ugly.

I suppose that we could say that its a MUST to use the existing SDP if you
know it. A UA that sends a re-INVITE w/o SDP MUST be prepared for SDP that
may be different for the reason you describe. Hopefully its something
acceptable. If its not, BYE the call. I don't think we can reasonably do
better. We're already talking about the case where the UA has failed and
recovered.

Sound OK?

-Jonathan R.

---
Jonathan D. Rosenberg, Ph.D.                72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.jdrosen.net                      PHONE: (973) 952-5000
http://www.dynamicsoft.com

_______________________________________________
Sip mailing list  http://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Bert Culpepper" <[email-masked]>
Date: Fri, 7 Sep 2001 17:25:14 -0400

My comments below...

> From: [email-masked] [mailto:[email-masked]]On Behalf Of
> Jonathan Rosenberg
> Sent: Friday, September 07, 2001 4:56 PM
> To: [email-masked]'; Jonathan Rosenberg
> Cc: [email-masked]

Yes.  IMO, in the case a UA has failed and recovered it's reasonable to
expect problems in sessions that involve "complicated" media negotiation.
In more common cases, session re-establishment should work fine.

Regards,
Bert

---

From: "Brett Tate" <[email-masked]>
Date: Fri, 7 Sep 2001 18:05:33 -0400

> better. We're already talking about the case where the UA has 
 
Sounds fine if the above text also includes 
the portion from your original recommendation 
concerning the connection address and port 
potentially changing.  This would specifically 
be for those devices that respond to holds 
with holds.  I guess that it would also have
to accommodate for the new hold SDP format 
that is being discussed.

The "MUST" also prevents a 3PCC/B2BUA from 
using a re-INVITE without SDP to potentially 
get the UA to send an SDP with all media that 
it would like to use.  However I guess that 
this is acceptable since the 3PCC shouldn't be 
a necessary interface to establish these extra 
media streams for an established call.

---

From: Christer Holmberg <[email-masked]>
Date: Sun, 09 Sep 2001 19:54:47 +0300

Hi,

Doesn't the tag tell if it's an INVITE or a re-INVITE? 

I think we discussed this issue earlier, but I don't remember what was
the issue back then...

Regards,

Christer Holmberg
Ericsson Finland