Subject: [Sip] international chars in hostname part of SIP URL

From: "Ajay Chitturi" <[email-masked]>
Date: Fri, 7 Sep 2001 11:10:19 -0700

Hi,

The SIP URL syntax allows only alphanum and '-' for the hostname part of the SIP URL.
Is it by design to prevent the use of other characters in the domain name ?

Thanks
Ajay.

_______________________________________________
Sip mailing list  http://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Dean Willis" <[email-masked]>
Date: Fri, 7 Sep 2001 13:27:12 -0500

As I understand it, the restriction if for conformance with DNS,  which is
what translates those hostnames into IP addresses.  For example, the "_"
character (underscore) has historically been invalid in DNS. It's only
recently appeared as a valid restricted character for delimiting protocol
names in SRV records.

There's probably ongoing work on internationalizaing DNS, but it's not going
to be easy.

--
Dean

---

From: "Henning G. Schulzrinne" <[email-masked]>
Date: Fri, 07 Sep 2001 14:29:36 -0400

> Is it by design to prevent the use of other characters in the domain name ?

The current DNS and (standard-compliant) registrars only allow ASCII.
See RFC 1035 and the IDNS effort. Once this is resolved, it is likely
that domain names will be UTF-8 "externally" (they may be some strange
transformation deeper down), so implementations are well advised not to
be too picky about the characters in that URL.

See, for example, http://www.register.com/domain-rules.cgi
-- 
Henning Schulzrinne   http://www.cs.columbia.edu/~hgs