Subject: RE: [Sip] newbie question on SIP 180 vs. 183 messages

From: "Francois Audet" <[email-masked]>
Date: Thu, 20 Sep 2001 20:30:08 -0500

Same if you get a PROGRESS message, send a 183.

-----Original Message-----
From: Gonzalo Camarillo [mailto:[email-masked]]
Sent: Thursday, September 20, 2001 18:32
To: Eric King
Cc: [email-masked]
Subject: Re: [Sip] newbie question on SIP 180 vs. 183 messages

Hello,

If you know that the phone is ringing (an ALERT Q.931 message, for
instance) you send a 180 Ringing. If you receive a notification
indicating that the call is progressing, but you do not know for sure
whether the user is being alterted or not, you send a 183 Session
Progress message.

Regards,

Gonzalo

Eric King wrote:
> 
> I am hoping to get an understanding of what to expect in a SIP-to-ISDN
> interworking scenario.
> 
> Specifically, I'm in search of something that will indicate what 18x
> message should be generated upon:
> 
> a. the receipt of an ISDN ALERT message, and
> 
> b. the receipt of ISDN Progress/Call Proceeding message,
> 
> immediately after a SETUP message is forwarded to the PSTN as a result
> of an INVITE.
> 
> Unfortunately, I've only stumbled across text that speaks to SS7
> interworking.   What might be expected in an ISDN application?  Is there
> a reference that someone could point me to?
> 
> Thank you so much!
> 
> Eric
> 
> _______________________________________________
> Sip mailing list  http://www1.ietf.org/mailman/listinfo/sip
> This list is for NEW development of the core SIP Protocol
> Use [email-masked] for questions on current sip
> Use [email-masked] for new developments on the application of sip

-- 
Gonzalo Camarillo                    Phone :   +1 212 939 71 71
Columbia University                  Mobile:  +358 40 702 35 35
472 Computer Science Building        Fax   :  +358  9 299 30 52
1214 Amsterdam Ave., Mail Code 0401  http://www.hut.fi/~gonzalo
New York, NY 10027                   
USA                              [email-masked]

_______________________________________________
Sip mailing list  http://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Mark Watson" <[email-masked]>
Date: Fri, 21 Sep 2001 11:04:37 +0100

Eric,

Gonzalo's draft gives you SIP <> ISUP and ISUP <> ISDN is well defined in
ITU-T Recommendation Q.699. Add them together.

...Mark

-----Original Message-----
From: Eric King [mailto:[email-masked]]
Sent: 21 September 2001 02:18
To: Gonzalo Camarillo
Cc: sip
Subject: RE: [Sip] newbie question on SIP 180 vs. 183 messages

Hello Gonzalo,

Thank you!  Would you be able to point me to a(ny) SIP (or other) RFC
that details this?

Thanks,
Eric

> Sent: Thursday, September 20, 2001 6:32 PM
> To: Eric King
> Cc: [email-masked]