Subject: Open Issue #118: 481 then BYE, was: RE: [SIP] Killing hung media streams

From: Jonathan Rosenberg <[email-masked]>
Date: Wed, 19 Sep 2001 03:25:36 -0400

Folks,

Its been slightly over a week since I posted this. Folks may not realize
that this thread is a bis open issue, and I plan on aggressively making sure
these get handled. So, I've renamed the thread, and reposted. 

Rohan recently made some comments on this too:

> #118 "481 then BYE"  (OK not really a CANCEL issue, but similar)
>  >Bis-04 says that if you get a 481 to INVITE, consider the 
> call leg down
>  >Question: should you send BYE?
>  >Proposal: YES!
>  >Why?  Don't want to change fact that mid-call re-INVITE 
> failures don't
>  >terminate call.  One way to terminate calls
>  >[If media streams from A->B generate errors to A, or RTCP times out,
>  >re-INVITE to B.  If that generates 481, then BYE]
> 
> rohan> I concur with the proposal.

which is now four in favor. 

Those who spoke against this previously, you have been silent. SPEAK UP!

-Jonathan R.

---
Jonathan D. Rosenberg, Ph.D.                72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.jdrosen.net                      PHONE: (973) 952-5000
http://www.dynamicsoft.com

> -----Original Message-----
> From: Jonathan Rosenberg 
> Sent: Friday, September 07, 2001 2:54 AM
> To: 'Vijay Gurbani'; Jonathan Rosenberg
> Cc: [email-masked]
> Subject: RE: [SIP] Killing hung media streams
> 
> 
> 
> 
>  
> 
> > -----Original Message-----
> > From: Vijay Gurbani [mailto:[email-masked]]
> > Sent: Friday, August 31, 2001 11:01 AM
> > To: Jonathan Rosenberg
> > Cc: [email-masked]
> > Subject: Re: [SIP] Killing hung media streams
> > 
> > 
> > Jonathan Rosenberg wrote:
> > [...]
> > > Wow... my recollection is exactly the opposite. Possibly 
> > thats biased by 
> > > my own opinion on the correct solution, but I could have 
> > sworn that people
> > > concurred that we were going to stick with the rule that 
> > 4xx response to
> > > re-INVITE did not terminate a call.
> > 
> > Jonathan:
> > 
> > I recall having a similar discussion with you on the list in 
> > the context of 
> > the call reconstitution I-D.  The gist of the discussion is 
> > that the BYE is
> > is needed.  Going into the discussion I was unsure why this 
> > is so, but have
> > changed my mind since then.  
> > 
> > The reasons why BYE is preferred are listed in 
> > http://www1.ietf.org/mail-archive/working-groups/sip/current/m
> sg00559.html
> 
> 
> Well, I have three concrete yes's to my proposal to mandate 
> BYE (not including my own). A few people were unsure or 
> thought the consensus was otherwise. Please post your opinion 
> if you disagree. If there aren't sufficient dissenters in ONE 
> WEEK from today, I will declare this issue closed.
> 
> -Jonathan R.
> ---
> Jonathan D. Rosenberg, Ph.D.                72 Eagle Rock Ave.
> Chief Scientist                             First Floor
> dynamicsoft                                 East Hanover, NJ 07936
> [email-masked]                     FAX:   (973) 952-5050
> http://www.jdrosen.net                      PHONE: (973) 952-5000
> http://www.dynamicsoft.com
> 

_______________________________________________
Sip mailing list  http://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Brett Tate" <[email-masked]>
Date: Thu, 20 Sep 2001 14:33:48 -0400

> Those who spoke against this previously, you have been 

The proposal sounds fine.

---

From: Gonzalo Camarillo <[email-masked]>
Date: Sat, 22 Sep 2001 04:01:20 +0300

Hello,

I concur with the proposal as well. The UAC {\SHOULD} send a {\BYE} in
that situation. As far as it is not a {\MUST}, UACs that only understand
the class of the response (400) but not 481 specifically will be
compliant.

Regards,

Gonzalo

-- 
Gonzalo Camarillo                    Phone :   +1 212 939 71 71
Columbia University                  Mobile:  +358 40 702 35 35
472 Computer Science Building        Fax   :  +358  9 299 30 52
1214 Amsterdam Ave., Mail Code 0401  http://www.hut.fi/~gonzalo
New York, NY 10027                   
USA                              [email-masked]