Subject: [Sip] RE: [Sipping] Loose Routing Proposal

From: "Sean Olson (EUS)" <[email-masked]>
Date: Fri, 7 Sep 2001 09:54:34 -0500

[Moved to SIP mailing list]

There are several additional constraints
that make the 3GPP problem a little more
difficult.

1) The UA doesn't know what it's home
   proxy is. The home proxy is chosen
   dynamically for the UA by the home
   network based on the required 
   capabilities needed to fulfill the
   user's service profile.

2) This selection of the home proxy 
   is done at registration time to
   reduce call setup times for the INVITE.
   The selection is then stored in a home
   entity "database" called the HSS. 
   To reduce load on the HSS, it is desired
   that it is not queried for this selection
   information on every INVITE.

3) There are situations where the home network
   wishes to introduce an intermediary between
   the visited network and the user's home proxy
   for the purpose of hiding the user' home proxy
   identity. This means that the number of hops
   between the local outbound proxy and the user's
   home proxy may be 1 or 2. This implies at least
   a loose route.

Loose routing to the home network would
require that an entity in the home network
query the HSS to complete the routing of
the request.

Given the above constaints, a solution involving
a "strict" pre-loaded route was made. This pre-loaded
route is communicated in the Path: header that is
used in the REGISTER/200 OK.

I personally dislike the Path: header solution.
If a better solution can be found, I am all for it.
I just wanted to explain the background behind the
Path: header choice.

Regards,
Sean Olson
Ericsson Inc.

>-----Original Message-----
>From: Juha Heinanen [mailto:[email-masked]]
>Sent: Friday, September 07, 2001 8:49 AM
>To: Miguel A. Garcia
>Cc: Rosen, Brian; 'Cullen Jennings'; [email-masked]
>Subject: Re: [Sipping] Loose Routing Proposal
>
>
>Miguel A. Garcia writes:
>
> > The other problem that is not solved is how the local proxy might
> > get the knowledge of the route to apply for outbound calls in 
> > order to get to the home proxy. 
>
>i don't quit get what the problem is.  if the user wants to 
>use its home
>proxy, then the home proxy could be part of the ua's configuration and
>the ua could itself add the home proxy to the route.  if the ua doesn't
>care to use the proxy of the home operator, then the message would be
>routed normally without an explicit route.  finally, if the use doesn't
>care, but the local proxy cares, then the local proxy could find the
>home proxy, e.g, from the dns using srv records.
>
>-- juha
>
>_______________________________________________
>Sipping mailing list  http://www1.ietf.org/mailman/listinfo/sipping
>This list is for NEW development of the application of SIP
>Use [email-masked] for questions on current sip
>Use [email-masked] for new developments of core SIP
>

---

From: Juha Heinanen <[email-masked]>
Date: Fri, 7 Sep 2001 19:45:20 +0300

>    capabilities needed to fulfill the

why can't the proxy of mobileoperator.com proxy the message further to
the right proxy if the one returned from dns is not the correct one?

 >    information on every INVITE.

i don't buy the load argument.  there can be many load balanced hss'es
like there are many load balanced dns servers, web caches, etc.

 >    home proxy may be 1 or 2. This implies at least

again, the dns can in such a situation return the intermediary, which
forwards the message to the real proxy.  this is what we do all the
time today:  our pstn proxy is not even directly reachable from the
internet.

 > query the HSS to complete the routing of

so what?  again, i don't buy the load argument.  this is exactly what
our internet visible proxies do today.

 > I just wanted to explain the background behind the

good, then there is still a change unless the real reason is something
else.

-- juha

_______________________________________________
Sip mailing list  http://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip