Subject: RE: [Sip] Observations on use of REFER

From: "Tom-PT Taylor" <[email-masked]>
Date: Thu, 20 Sep 2001 17:14:21 -0400

If the Contact address is no longer valid, the Referror won't get the
NOTIFY, so it can't send back the 481.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Thursday, September 20, 2001 4:35 PM
To: Taylor, Tom-PT [NORSE:B881:EXCH]
Cc: [email-masked]'; sip; [email-masked]
Subject: Re: [Sip] Observations on use of REFER

> > 
> > Expiry of REFER-Created Subscription: 
> > 
> > Am I right in supposing that the only way the implicit subscription 
> > created by REFER expires is by explicit unsubscription?  Or is it 
> > possible to say that if a REFER is issued within the context of a 
> > call-leg, the subscription expires when the call-leg does? 
> 
> Does this really matter? 
> 
> [PTT] Yes, it does, because the Contact address supplied with the REFER
> may have a limited period of validity. 

And the below two paragraphs deal, I think, with what happens when that
period expires. Can you give me an example of what's broken by those
assumptions?

> 
> The Referror (playing the role of implicit subscriber) has some 
> period of time its willing to listen for notifies. With the implicit 
> subscription, it's not telling the far end how long this is. Any 
> notifies that arrive after that time, it 481s. If it decides to 
> shorten that time prematurely (because a bye was sent for example) 
> the net effect was if it had the shorter time in mind to begin with. 
> 
> The Referred party has no clue how long something cares about getting 
> notified. Its only recourse is to send interesting events (of which 
> there may be only one) until it receives a 481 to a NOTIFY. If its 
> unwilling to send any more events, it just stops. At some point the 
> referror is going to give up on listening. 
> 
...

---

From: Robert Sparks <[email-masked]>
Date: Thu, 20 Sep 2001 17:24:43 -0400

In which case, either the Contact address resolves to some other UA,
which will 481 the NOTIFY, or the NOTIFY transaction will timeout.
In either case, the subscription is removed from the notifier.
 
RjS

-----Original Message----- 
From: [email-masked] [ mailto:[email-masked]
<mailto:[email-masked]> ] 
Sent: Thursday, September 20, 2001 4:35 PM 
To: Taylor, Tom-PT [NORSE:B881:EXCH] 
Cc: [email-masked]'; sip; [email-masked] 
Subject: Re: [Sip] Observations on use of REFER 

...