Subject: RE: [Sip] Open Issue #182: Removal of Appendix A

From: Jonathan Rosenberg <[email-masked]>
Date: Thu, 6 Sep 2001 16:25:26 -0400

> -----Original Message-----
> From: Bob Penfield [mailto:[email-masked]]
> Sent: Thursday, September 06, 2001 7:44 AM
> To: Jonathan Rosenberg; [email-masked]
> Subject: Re: [Sip] Open Issue #182: Removal of Appendix A
> 
> 
> I'm OK with removing Appendix A. Are you still planning to make it a
> separate draft?
> 

Separate draft? No. It would cease to exist.

-Jonathan R.

---
Jonathan D. Rosenberg, Ph.D.                72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.jdrosen.net                      PHONE: (973) 952-5000
http://www.dynamicsoft.com

_______________________________________________
Sip mailing list  http://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Drage, Keith (Keith)" <[email-masked]>
Date: Mon, 10 Sep 2001 10:54:31 +0100

I thought it was Appendix B that was to go to a separate draft, have I
missed something somewhere?

Keith

Keith Drage
Lucent Technologies
Tel: +44 1793 776249
Email: [email-masked]

> ----------
> From: 	Bob Penfield[SMTP:[email-masked]]
> Sent: 	06 September 2001 12:44
> (-:bob
> Robert F. Penfield
> Chief Software Architect
> Acme Packet, Inc.
> 130 New Boston Street
> Woburn, MA 01801
> [email-masked]
> ----- Original Message -----
> From: "Jonathan Rosenberg" <[email-masked]>
> To: <[email-masked]>
> Sent: Wednesday, September 05, 2001 4:25 PM
> Subject: [Sip] Open Issue #182: Removal of Appendix A
> 
> 
> > Folks,
> >
> > Here is another open issue I would like quick resolution on.
> >
> > I am proposing to remove Appendix A completely from bis. The reason is
> that
> > the required/optional capabilities of the protocol are already specified
> > throughout the document through the usage of MUST/MAY/SHOULD and so on.
> > Having additional requirements here will only repeat what is already
> above,
> > possibly just summarizing it. This introduces the possibility of
> > inconsistent strengths, which is a problem right now. So, to make things
> > consistent and avoid confusion, we should ditch it.
> >
> > Anyone object?
> >
> > -Jonathan R.
> >
> > ---

---

From: "Drage, Keith (Keith)" <[email-masked]>
Date: Mon, 10 Sep 2001 10:54:31 +0100

I have no problem with removing it, but there seem to be some requirements
here that I am not convinced are in the existing main body, e.g. on a quick
look I was not able to find the equivalent of the first sentence of A.2 in
the main body.

Perhaps the removal process should be accompanied by a process of making
sure the requirements are also in the main body - assuming they are all
still relevent, I do not mind discussing proposals to delete specific
requirements.

Certainly ensuring that the requirements are integrated in the main text
rather than separately defined in annex A will ensure a more readable and
consistent document.

Keith

Keith Drage
Lucent Technologies
Tel: +44 1793 776249
Email: [email-masked]

> ----------
> From: 	Jonathan Rosenberg[SMTP:[email-masked]]
> Sent: 	05 September 2001 21:25
> To: 	[email-masked]'

---

From: Jonathan Rosenberg <[email-masked]>
Date: Wed, 19 Sep 2001 02:42:22 -0400

> From: Drage, Keith (Keith) [mailto:[email-masked]]
> Sent: Monday, September 10, 2001 5:55 AM
> To: [email-masked]'; Jonathan Rosenberg
> Subject: RE: [Sip] Open Issue #182: Removal of Appendix A
> 
> 

Funny you should mention it, since I think this one should be removed :) We
now have applications for sip, like IM and presence, where there may not be
any calls. There is really no reason for them to have to implement INVITE in
that case (their UA would simply 405 the INVITE).

> still relevent, I do not mind discussing proposals to delete specific

I think thats a good idea. I'll make sure its done as part of the rewrite.

---

---

From: "Drage, Keith (Keith)" <[email-masked]>
Date: Mon, 24 Sep 2001 14:17:45 +0100

See below
Keith Drage
Lucent Technologies
Tel: +44 1793 776249
Email: [email-masked]

> Sent: 	19 September 2001 7:42
> To: 	'Drage, Keith (Keith)'; [email-masked]'; Jonathan Rosenberg
No problem with removal of this particular requirement - merely quoting an
instance where at least a sanity check is required.

---

From: Jonathan Rosenberg <[email-masked]>
Date: Mon, 24 Sep 2001 14:08:51 -0400

> Sent: Monday, September 24, 2001 9:18 AM
> To: Drage, Keith (Keith); [email-masked]'; 'Jonathan Rosenberg'
> > Funny you should mention it, since I think this one should 
> be removed :)
> > We
> > now have applications for sip, like IM and presence, where 
> there may not
> > be
> > any calls. There is really no reason for them to have to 
> implement INVITE
> > in

Indeed. We have assigned someone to track every MUST/MAY/SHOULD for the
basic implementation to make sure that it is accounted for.

-Jonathan R.

---