Subject: [Sip] kosher to extend caller-prefs?

From: Rohan Mahy <[email-masked]>
Date: Wed, 05 Sep 2001 21:14:59 -0700

Hi,

Before the Last Call period is complete on caller preferences, I wanted to 
verify that we can extend caller prefs if needed. ??  I just posted a 
proposal for three new Contact attributes which I feel are needed for call 
control, and could be useful in Accept/Reject-Contact.

Please post any comments on my call-control attributes proposal to the 
sipping list.

thanks,
-rohan

_______________________________________________
Sip mailing list  http://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Jonathan Rosenberg <[email-masked]>
Date: Thu, 6 Sep 2001 00:46:52 -0400

> -----Original Message-----
> From: Rohan Mahy [mailto:[email-masked]]
> Sent: Thursday, September 06, 2001 12:15 AM
> To: [email-masked]
> Subject: [Sip] kosher to extend caller-prefs?
> 
> 
> Hi,
> 

The contact parameters can indeed be extended. The proxy algorithm is
independent of the semantics, and so proxies need not be aware of new
attributes. The UAC that requests a preference, and the UAS that indicates a
capability, have to sync up and use the same name/value pairs.

Request disposition cannot be extended, on purpose.

-Jonathan R.
---
Jonathan D. Rosenberg, Ph.D.                72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.jdrosen.net                      PHONE: (973) 952-5000
http://www.dynamicsoft.com