Subject: [Sip] about H.323 and Sip

From: "Na Li" <[email-masked]>
Date: Thu, 13 Sep 2001 10:26:37 -0500

Hi Lina, 

to your questions: 

1) The fundamental difference is in the model these two use - as you
probably know the SIP uses the Internet model - transaction oriented
(IETF) while H.323 uses "old-style" circtuit switched thinking (ITU-T). 

2) This is implementation specific. I can say that they are vendors
whose equipment can do exactly what you write (incl. the situation when
H.323 is replaced by SIP). 

3) There's no standard, but as far as I remember there is a draft
dealing with this: draft-agrawal-sip-h323-interworking-01.txt 

Kind regards 

--Peter 

"Na Li" <[email-masked]> 
Sent by: [email-masked] 
09/13/2001 02:15 AM 
        
        To:        <[email-masked]> 
        cc:         
        Subject:        [Sip] about H.323 and SIP

Hello,

I have several questions relating to H.323

1) What's the fundamental difference between H.323 (including fast
setup) and SIP? I don't mean the text encoding or ANS.1 encoding. 
2) Could Media gateway controller use H.323 for session creation, and
use Megaco to communicate with media gateway?
3) Is any standard there to map H.323 with SIP?

Thanks, have a nice day

Lina

_______________________________________________
Sip mailing list  http://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

_______________________________________________
Sip mailing list  http://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Matt Holdrege <[email-masked]>
Date: Thu, 13 Sep 2001 10:03:33 -0700

It's perfectly simple in concept that an MGC would speak H.323 on one 
interface and SIP on another. In fact some MGC's or Softswitches do this 
today. So if an MGC receives a call setup from an H.323 Gatekeeper which is 
intended for a SIP network, it would simply send a call setup to the SIP 
proxy that has reachability for the destination and upon receipt of an RTP 
address would instruct the H.323 Gatekeeper or gateway to open up an RTP 
connnection.

A similar action would take place if a call was destined for the PSTN and 
the MGC needed use SIP-T to contact another MGC to setup the call at the 
remote PSTN network. The far end MGC would speak MGCP or MEGACO/H.248 to 
control the trunking gateway to the PSTN.

Since such protocol interworking occurs internal to a given platform/MGC, 
there is no standard nor should there be. It is implementation specific as 
there is no interworking with other elements.

---

From: "Agboh, Charles" <[email-masked]>
Date: Fri, 14 Sep 2001 09:50:42 +0200

> -----Original Message-----
> From: Na Li [mailto:[email-masked]]
> Sent: Thursday, September 13, 2001 5:12 PM
> To: [email-masked]
> Subject: FW: [Sip] about H.323 and SIP
> 
> 
>  
>  
> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] 
> Sent: Thursday, September 13, 2001 3:51 AM
> To: Na Li
> Subject: Re: [Sip] about H.323 and SIP
>  
> 
> Hi Lina, 
> 
> to your questions: 
> 
I wonder if this sort of comment is really necessary.
> H.323 is replaced by SIP). 
In my opinion, the two protocols will coexists in the foreseeable future.
More than that, I cannot say.

---

From: [email-masked]
Date: Fri, 14 Sep 2001 11:10:39 +0200

Dear colleagues,

since I have started this discussion about the SIP vs. H.323, please let 
me very briefly explain my motivation.
Firstly, my intention was not to offend anybody here. I just wanted to 
express purely technical/protocol design background.
The truth really is, that H.323 has strong telephony/ISDN roots. However 
the truth also is that H.323 has still several advantages over SIP.
I don't want to extend my explanation on, which features I mean here, as 
this is the SIP mailing list (you can e-mail me on my address directly if 
needed).
Please, if anybody feels hit at the heart, I appologize, perhaps I should 
be more carefull with the wording.

Kind regards

D.I. Peter Gajdos

"Agboh, Charles" <[email-masked]>
Sent by: [email-masked]
09/14/2001 09:50 AM

        To:     "'Na Li'" <[email-masked]>, [email-masked]
        cc: 
        Subject:        RE: [Sip] about H.323 and SIP

---

From: De Leo Walter <[email-masked]>
Date: Fri, 21 Sep 2001 20:55:33 -0300

Yes, I think you are right. My only neurone is getting old.

Regards.

> -----Mensaje original-----
> De:	Matt Holdrege [SMTP:[email-masked]]
> Enviado el:	Viernes 21 de Septiembre de 2001 17:12
> Para:	De Leo Walter; [email-masked]'
> Asunto:	RE: [Sip] about H.323 and SIP
> 
> Interworking pure ISUP and pure SIP is implementation specific. To be 
> clear, I'm referring to a call setup from an ISUP network to a Softswitch,
> 
> and the Softswitch generating a SIP/SDP setup based on policy. The same 
> goes for a call in the other direction.
> 
> However, transporting or preserving ISUP information using SIP requires a 
> standard, thus we have SIP-T modes of encapsulation and mapping. This is 
> the way to go if you do not want the Softswitch to generate the call
> details.
> 
> I hope I'm making myself clear as I'm kind of jet lagged right now.
> 
> 
> At 11:15 AM 9/18/2001, De Leo Walter wrote:
> >Matt,
> >Applying your reasoning to the ISUP-SIP interface, you cannot understand
> why
> >is that interface being defined, and perhaps becoming an standar?
> >Do you think it should be left implementation specific?
> >I don't.
> >Regards.
> >Walter.
> >
> >
> > > -----Mensaje original-----
> > > De:   Matt Holdrege [SMTP:[email-masked]]
> > > Enviado el:   Jueves 13 de Septiembre de 2001 14:04
> > > Para: Na Li; [email-masked]
> > > Asunto:       Re: [Sip] about H.323 and SIP
> > >
> > > today. So if an MGC receives a call setup from an H.323 Gatekeeper
> which
> > > is