Subject: RE: [Sip] international chars in hostname part of SIP URL

From: "Ajay Chitturi" <[email-masked]>
Date: Fri, 7 Sep 2001 13:25:28 -0700

Also why does the user part of the URI allow only escaped characters and not full UTF8 minus {some reserved characters required for parsing) ? 
When UTF-8 domain names become a reality will a similar approach be followed for hostname part as well ?

Thanks
Ajay.

-----Original Message-----
From: Henning G. Schulzrinne [mailto:[email-masked]]
Sent: Friday, September 07, 2001 11:30 AM
To: Ajay Chitturi
Cc: [email-masked]
Subject: Re: [Sip] international chars in hostname part of SIP URL

Ajay Chitturi wrote:
> 
> Hi,
> 
> The SIP URL syntax allows only alphanum and '-' for the hostname part of the SIP URL.
> Is it by design to prevent the use of other characters in the domain name ?
> 

The current DNS and (standard-compliant) registrars only allow ASCII.
See RFC 1035 and the IDNS effort. Once this is resolved, it is likely
that domain names will be UTF-8 "externally" (they may be some strange
transformation deeper down), so implementations are well advised not to
be too picky about the characters in that URL.

See, for example, http://www.register.com/domain-rules.cgi
-- 
Henning Schulzrinne   http://www.cs.columbia.edu/~hgs

_______________________________________________
Sip mailing list  http://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Henning G. Schulzrinne" <[email-masked]>
Date: Fri, 07 Sep 2001 16:38:01 -0400

> When UTF-8 domain names become a reality will a similar approach be followed for hostname part as well ?

Domain names are the same thing as host names. I'm inquiring with
authorities on naming about other URL components.