Subject: FW: [Sip] about H.323 and SIP

From: "Na Li" <[email-masked]>
Date: Thu, 13 Sep 2001 10:11:57 -0500

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Thursday, September 13, 2001 3:51 AM
To: Na Li
Subject: Re: [Sip] about H.323 and SIP

Hi Lina, 

to your questions: 

1) The fundamental difference is in the model these two use - as you
probably know the SIP uses the Internet model - transaction oriented
(IETF) while H.323 uses "old-style" circtuit switched thinking (ITU-T). 

2) This is implementation specific. I can say that they are vendors
whose equipment can do exactly what you write (incl. the situation when
H.323 is replaced by SIP). 

3) There's no standard, but as far as I remember there is a draft
dealing with this: draft-agrawal-sip-h323-interworking-01.txt 

Kind regards 

--Peter 

"Na Li" <[email-masked]> 
Sent by: [email-masked] 
09/13/2001 02:15 AM 
        
        To:        <[email-masked]> 
        cc:         
        Subject:        [Sip] about H.323 and SIP

Hello,

I have several questions relating to H.323

1) What's the fundamental difference between H.323 (including fast
setup) and SIP? I don't mean the text encoding or ANS.1 encoding. 
2) Could Media gateway controller use H.323 for session creation, and
use Megaco to communicate with media gateway?
3) Is any standard there to map H.323 with SIP?

Thanks, have a nice day

Lina

_______________________________________________
Sip mailing list  http://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

_______________________________________________
Sip mailing list  http://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Paul Long" <[email-masked]>
Date: Thu, 13 Sep 2001 11:17:19 -0500

Peter,

H.323 does not use "old-style" circuit-switched thinking. This is SIP
propaganda.

Paul Long
ipDialog, Inc.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of Na Li
Sent: Thursday, September 13, 2001 10:12 AM
To: [email-masked]
Subject: FW: [Sip] about H.323 and SIP

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Thursday, September 13, 2001 3:51 AM
To: Na Li
Subject: Re: [Sip] about H.323 and SIP

Hi Lina,

to your questions:

Kind regards

--Peter

        To:        <[email-masked]>
        cc:

Hello,

Thanks, have a nice day

Lina

---

From: Henry Sinnreich <[email-masked]>
Date: Thu, 13 Sep 2001 15:41:19 -0500

> H.323 does not use "old-style" circuit-switched thinking. 
> This is SIP propaganda.

H.323 is part of the H.3xx suite and was developed to be compatible with
H.321, H.322, H324 - ISDN, ATM and POTS - all are circuit switched,
propaganda or not.

Its architecture has certainly started with ISDN multimedia.

Henry

Henry Sinnreich
WorldCom
400 International Parkway
Richardson, Texas 75081
USA 

> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of Paul Long
> Sent: Thursday, September 13, 2001 11:17 AM
> To: [email-masked]
> Subject: RE: [Sip] about H.323 and SIP
> 
> 
> Peter,
> 
> H.323 does not use "old-style" circuit-switched thinking. 
> This is SIP propaganda.
> 
> Paul Long
> ipDialog, Inc.
> 
> 1) The fundamental difference is in the model these two use - 
> as you probably know the SIP uses the Internet model - 
> transaction oriented
> 2) This is implementation specific. I can say that they are 
> vendors whose equipment can do exactly what you write (incl. 
> the situation when H.323 is replaced by SIP).
> 
> 3) There's no standard, but as far as I remember there is a 
> draft dealing with this: draft-agrawal-sip-h323-interworking-01.txt
> 
> Kind regards
> 
> --Peter
> 
> 
> 
> 
> 2) Could Media gateway controller use H.323 for session 
> creation, and use Megaco to communicate with media gateway?
> Use [email-masked] for questions on current 
> sip Use [email-masked] for new developments on the 
> application of sip
> 
> 
> 
> Use [email-masked] for questions on current 
> sip Use [email-masked] for new developments on the 
> application of sip
> 
> 
> Use [email-masked] for questions on current 
> sip Use [email-masked] for new developments on the 
> application of sip
>

---

From: "Paul Long" <[email-masked]>
Date: Thu, 13 Sep 2001 16:56:14 -0500

Henry,

Hey, what is this, guilt by association? :-) Yes, _they_ are circuit
switched, but H.323 and SIP are 100% packet switched, so I don't understand
what your point is here. Moreover, both H.323 and SIP are based on
technology from the same era--right about 1990--including the WWW, HTML,
ISDN, and H.320, so they are equally "old style."

BTW, I apologize for the "propaganda" remark. Those three cups of coffee
this morning kinda jazzed me up a bit. 8-}

Paul Long

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of Henry
Sinnreich
Sent: Thursday, September 13, 2001 3:41 PM
To: 'Paul Long'; [email-masked]
Subject: RE: [Sip] about H.323 and SIP

Henry

Henry Sinnreich
WorldCom

---

From: Henry Sinnreich <[email-masked]>
Date: Thu, 13 Sep 2001 20:52:47 -0500

The remark "old-style" circuit-switched thinking" is generic I believe,
since there is more to a protocol suite than just circuits or packets.
It is about what the thinking was behind the design.

It has to do with the standards process, architectural philosophy and
"details", such as ASN.1 versus text encoding, etc. Instead of repeating
old discussions, would suggest to go to several web sites that deal with
this subject, such as:

http://www.iptel.org/info/trends/sip.html

There are other web sites, probably also some of which take a more
favorable view of H.323.

I hope this answers the meaning :-)  of "thinking" in the above remark.

Henry

> Sent: Thursday, September 13, 2001 4:56 PM
> To: [email-masked]
> Hey, what is this, guilt by association? :-) Yes, _they_ are 
> circuit switched, but H.323 and SIP are 100% packet switched, 
> so I don't understand what your point is here. Moreover, both 
> H.323 and SIP are based on technology from the same 
> era--right about 1990--including the WWW, HTML, ISDN, and 
> H.320, so they are equally "old style."
> 
> BTW, I apologize for the "propaganda" remark. Those three 
> cups of coffee this morning kinda jazzed me up a bit. 8-}
> 
> Paul Long
> 
> From: [email-masked] [mailto:[email-masked]]On Behalf 
> Of Henry Sinnreich
> This is SIP 
> H.323 is part of the H.3xx suite and was developed to be 
> compatible with H.321, H.322, H324 - ISDN, ATM and POTS - all 
> are circuit switched, propaganda or not.
>