Subject: RE: [Sip] Open Issue #58: Rejected mid-call SDP in 2xx

From: Jonathan Rosenberg <[email-masked]>
Date: Fri, 7 Sep 2001 15:32:56 -0400

This note contained my proposed resolution to open issue #58 on rejected
mid-call SDP.

The proposal was to simply require a UA to return its current SDP in the
re-INVITE with no SDP (i.e., it MUST offer the SDP currently in use). Since
this SDP has already been agreed to, there is no need to ever reject it, so
the problem goes away. This is the simplest solution. 

Since no one objected to this proposal, I am now considering this issue
closed. THe SHOULD will be changed to a MUST.

-Jonathan R.

---
Jonathan D. Rosenberg, Ph.D.                72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.jdrosen.net                      PHONE: (973) 952-5000
http://www.dynamicsoft.com

> -----Original Message-----
> From: Jonathan Rosenberg 
> Sent: Tuesday, August 28, 2001 4:45 PM
> To: 'Bert Culpepper'; 'Kim Liu'; Jonathan Rosenberg
> Cc: [email-masked]
> Subject: RE: [Sip] Open Issue #58: Rejected mid-call SDP in 2xx
> 
> 
> 
> 
>  
> 
> > -----Original Message-----
> > From: Bert Culpepper [mailto:[email-masked]]
> > Sent: Thursday, August 23, 2001 3:11 PM
> > To: 'Kim Liu'; 'Jonathan Rosenberg'
> > Cc: [email-masked]
> > Subject: RE: [Sip] Open Issue #58: Rejected mid-call SDP in 2xx
> > 
> > 
> > How can it happen that B provides an offer that is not 
> acceptable to A
> > provided the UA complies with the first paragraph of B.4 in 
> > bis-04?  If
> > B does want to change, it should issue the re-INVITE. 
> 
> Well, the text does allow it to change. I suspect people 
> might change the IP address and port, just to allow 
> differentiation of media sent from the far side before and 
> after the re-invite. In principal, that should not warrant a 
> rejection.
> 
> It may very well be that the simplest solution to this 
> problem is simply to change this SHOULD to a MUST; i.e., in a 
> mid-call re-INVITE w/o SDP, the 2xx MUST contain the "same" 
> SDP as last provided to the peer, with the exception of being 
> able to change the IP address/port if so desired. 
> 
> I'm quite happy to do that, and would propose this as 
> probably the best and easiest solution. Objections?
> 
> (I'll admit, I don't know of a scenario off 
> > hand where
> > a UA would re-INVITE without SDP to see what the other side 
> > will respond
> > with.)
> 
> Its a classic third party call control scenario, and arises 
> quite frequently, actually, in order to connect the user to 
> different media sources during a call.
> 
> -Jonathan R.
> 
> ---
> Jonathan D. Rosenberg, Ph.D.                72 Eagle Rock Ave.
> Chief Scientist                             First Floor
> dynamicsoft                                 East Hanover, NJ 07936
> [email-masked]                     FAX:   (973) 952-5050
> http://www.jdrosen.net                      PHONE: (973) 952-5000
> http://www.dynamicsoft.com
> 
> 

_______________________________________________
Sip mailing list  http://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Brett Tate" <[email-masked]>
Date: Fri, 7 Sep 2001 16:09:47 -0400

Sounds fine with me.  However I guess that the 
"MUST" will have implications for devices that 
can't or don't distinguish between INVITE and 
re-INVITE after having underwent a restart.
I guess that these UA's would have to persist 
parts of the SDP if they wish to allow a 
re-INVITE without SDP to re-establish a call
(which I don't recommend).

> From: [email-masked] [mailto:[email-masked]]On Behalf Of
> Jonathan Rosenberg
> Sent: Friday, September 07, 2001 3:33 PM
> To: Jonathan Rosenberg; 'Bert Culpepper'; 'Kim Liu'
> Cc: [email-masked]'