Subject: RE: [Sip] Loose Routing draft

From: Robert Sparks <[email-masked]>
Date: Fri, 11 Jan 2002 09:54:20 -0500

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: Friday, January 11, 2002 7:54 AM
> To: [email-masked]; [email-masked]
> Subject: RE: [Sip] Loose Routing draft
> 
> 
> Hi Robert et al.!
> 
> Intersting I/D! It looks like, that we have a solution
> for the problem.
> 
> I have a couple of questions/comments:
> 
> I assume this new procedure can be applied for initial and
> subsequent requests. Is this assumention correct?

Yes it can. Note that different policies can be applied to initial
and subsequent requests (so you could loose-route the initial and
strict-route subsequents if that's what you wanted to do).

> 
> Is there a requirement, that loose routing is needed in
> subsequent requests?

There are people that want to be able to do this.

> 
> What would be the impact, if we allow a local policy
> (as described in your I/D) for the INITIAL request ONLY,
> and leave subsequent requests as before (i.e. strict
> source routing).
> Or in other words: Apply this local policy for
> pre-loaded route headers only.

We don't preclude that policy but I don't believe we should
require it.

> 
> Therefore we could introduce a new Route parameter, which 
> informs about, that the Routing can be loose, or has 
> to be strict.
> 
>  e.g. Route: [email-masked]; routing=loose
>  (or similar)

There's a problem with who knows when to include such an
indicator. If you are an endpoint, you don't know what
the service you are trying to use might need to do (unless
the service has told you through some mechanism like PATH,
in which case the service can manage its own policy)

> 
> New proxy implementations would route strict, if no
> such paramenter present and apply the local policy
> only of this parameter present.
> Older proxy implementations would simply ignore this
> new parameter.
> 
> I see the following advantages of my proposal:
> 
> - Changes to existing SIP are fewer
>   (only the new case of pre-loaded route headers
>   in initial request would be affected)
>   - more backwards compatibility
>   - Less new error cases (can apear only during session
>     first INVITE)
> 
> - Pre-loaded Route headers can be defined as
>   "loose" or as "strict"
> 
> 
> I am looking forward for comments on this proposal!
> 
> cheers, 
>  Bernie
> 
> 
> >-----Original Message-----
> >From: ext Robert Sparks [mailto:[email-masked]]
> >Sent: 11. January 2002 6:46
> >To: [email-masked]
> >Subject: [Sip] Loose Routing draft
> >
> >
> >I just submitted a draft refining the post I sent
> >out after IETF52 on the loose routing proposal.
> >
> >Until it appears in the archive, you can find it at
> >http://www.nostrum.com/~rjsparks/draft-sparks-sip-looseroute-00.txt
> >or
> >http://www.nostrum.com/~rjsparks/draft-sparks-sip-looseroute-00.html
> >
> >
> >RjS
> >
> >_______________________________________________
> >Sip mailing list  http://www1.ietf.org/mailman/listinfo/sip
> >This list is for NEW development of the core SIP Protocol
> >Use [email-masked] for questions on current sip
> >Use [email-masked] for new developments on the application of sip
> >
> 

_______________________________________________
Sip mailing list  http://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Christer Holmberg <[email-masked]>
Date: Thu, 17 Jan 2002 00:14:58 +0200

Hi,

>There are people that want to be able to do this.

I guess it shall be mentioned that it MUST be used for CANCEL (to the
INVITE request).

Does anything need to be said about ACK, or can it be treated like any
"subsequent request"?

Regards,

Christer Holmberg
Ericsson Finland

Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip