Subject: [Sip] RE: Bis-06 and Deprecating UDP

From: "Peterson, Jon" <[email-masked]>
Date: Mon, 28 Jan 2002 19:02:21 -0600

TCP doesn't have a MUST implement security scheme either - TLS is merely
strongly RECOMMENDED, you'll note.

I don't think the current text of bis amounts to the deprecation of UDP.

Jon Peterson
NeuStar, Inc.

> -----Original Message-----
> From: Michael Thomas [mailto:[email-masked]]
> Sent: Monday, January 28, 2002 4:23 PM
> To: Peterson, Jon
> Cc: 'Michael Thomas'; [email-masked]
> Subject: Bis-06 and Deprecating UDP
> 
> 
> Peterson, Jon writes:
>  > Today, SIP clients can use UDP without using IPSec, and 
> that won't change if
>  > we make IPSec mandatory to implement. Now that UDP and TCP are both
>  > mandatory in UAs, clients have a choice - either use UDP, 
> which has no
>  > recommended lower-layer security mechanism in the 
> specification, or use TCP,
>  > which you can secure with TLS. I don't see how this is 
> 'incomplete' just
>  > because a UA can choose to communicate in an insecure 
> fashion. If all proxy
>  > servers support TCP and TLS, then it sounds to me like a 
> client that
>  > supports TLS can always make a secure connection.
> 
>    It's incomplete because a perfectly valid transport
>    mode -- UDP -- doesn't have a perfectly valid MUST
>    IMPLEMENT security scheme. What you're saying is
>    "if you want security, use TLS". That is not
>    helpful for when you use UDP. 
> 
>    Frankly, I think this debate would be much better
>    served by talking about what the *real* 
>    implication is here: deprecating UDP. Are you
>    and the rest of the authors ready to do that?
>    Making UDP a poor relation to TCP has the same
>    effect. So we either keep it as a valid option
>    or deprecate it altogether. One or the other.
>    This current wishy-washiness is the worst of
>    all worlds.
> 
> 	Mike
> 

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Peterson, Jon" <[email-masked]>
Date: Wed, 30 Jan 2002 12:50:46 -0600

In the spec today, Digest is used for one-way authentication and replay
protection, which do indeed prevent a reasonable class of attacks. If I look
at the functions that I think I get out of TLS, they include:

- Allows a proxy server to authenticate itself to a user agent (with a
certificate). The Digest alternative, in which the server would authenticate
itself to a user with a shared secret, has always seemed a little kludgy to
me (and there are some fixes we'd need in the spec to get there), and
moreover it assumes a pre-existing trust relationship between user and
server which the PKI-based method does not. I think this is quite relevant
to the matter of what works for large deployments.
- Allows confidentiality between the user agent and the proxy server.
Obviously Digest isn't going to get us here. A few people in this thread
have asserted that confidentiality in the first hop isn't important
(basically arguing for walled-garden SIP networks), but there are a number
of attacks of which only arise if the attacker can inspect these messages. 
- Allows integrity between the user agent and the proxy server. Digest can
probably get us here, with some enhancements. Again, this would require some
work in the spec. That hop-by-hop integrity provided by TLS gis also a
little better understood that end-to-middle integrity Digest would provide
(which may require canonicalization of headers, and it might not be clear
which headers do and do not require integrity). Of course, Digest integrity
could also be used just for the first hop.

I think there needs to be some mechanism, at a reasonable normative
strength, that provides some of the services above in baseline SIP. I'd
rather not punt on those features.

Jon Peterson
NeuStar, Inc.

> From: Jonathan Rosenberg [mailto:[email-masked]]
> Sent: Tuesday, January 29, 2002 11:31 PM
> To: Michael Thomas
> Cc: Peterson, Jon; [email-masked]
> Subject: Re: [Sip] Bis-06 and Deprecating UDP
> 
> 
> 
> 
> Michael Thomas wrote:
> >
[snip] 
> Agreed, it is not. IMHO, we need a non-transport oriented solution as
> the baseline for UA to proxy security functions. I believe 
> that baseline
> is digest. While it certainly has many weaknesses that are well known,
> it is better than nothing, and has the benefit of being implementable
> and solving a reasonable class of attacks. TLS is better for smaller
> deployments, where the scale issues are not so bad that you 
> can pay for
> the persistent connections. IPSec is not likely to be any better in
> terms of scale, since both have the same state issues. Once you move
> away from persistent connections, TLS suffers heavily from expensive
> setups that you will effectively repeat for each call, increasing
> latency and overhead. IPSec is similar; I dislike its keying 
> mechanisms
> as well, but let us not dive into that, since its not really important
> for this point. So, since both TLS and IPSec have fatal flaws 
> for large
> deployments, digest is preferred as the only broadly workable solution
> there.
> 
> -Jonathan R.
> -- 
> Jonathan D. Rosenberg, Ph.D.            72 Eagle Rock Avenue
> Chief Scientist                         First Floor
> dynamicsoft                             East Hanover, NJ 07936
> [email-masked]                 FAX: (973) 952-5050
> http://www.jdrosen.net                  PH:  (973) 952-5000
> http://www.dynamicsoft.com
>