Subject: RE: [Sip] Attention - comment on Loose Routing draft

From: "Honeisen Bernhard (NET/Helsinki)" <[email-masked]>
Date: Tue, 15 Jan 2002 17:05:01 +0200

Hi RjS!

Some question:

Consider a situation, where a request is directed
to (B) and two service elements (X) and (Y) have
to be visited before.
(X) performs a service, which replaces the intended
destination URL, i.e. (B), whereas (Y) executes
some feature, which depends on the output of (X). 

When the request arrives at (X), the R-URI / Route
could look like:
- R-URI: <X>
- Route: <Y>,<B>
(The intended destination has been appended earlier
to Route as per section 5.2 in your I/D)

How can (X) now apply the destination URL relacing feature?
My first guess was, that (X) would modify the last entry
in the Route, i.e. (B).

Your first proposal in section 2 prohibits such behavior:
"[...] an element [...] MUST NOT modify or remove
subsequent Route header field values."

Is this restriction intended also for such cases or could
we relax it to allow modifying of the last entry in Route?
Would marking the last Route entry as the intended
destination (and allow modifying of such only) solve
this issue?

Greetings,
 Bernie

PS: Some Typos:

- section 5.5, F7-F12:
  s/Contact: sip:[email-masked]/Contact: sip:[email-masked]/

- section 5.5. F3/F4:
  - Shouldn't maddr in F4 contain a different IP-address
    than in F3?
  - Maybe add a FQDN <-> IP mapping table to ease
    the understanding of the examples.
   
- section 5.8:
  s/senting/sending/     

>-----Original Message-----
>From: ext Robert Sparks [mailto:[email-masked]]
>Sent: 14. January 2002 20:58
>To: [email-masked]'
>Subject: [Sip] Attention - comment on Loose Routing draft
>
>
>The draft below contains the resolution to a large
>set of open issues around processing of the Route header,
>preloaded routes, and the use of default outbound proxies.
>The plan is to modify bis to reflect these proposals.
>
>Please review it as soon as you can and comment if you
>see real problems. Silence will be taken as consent.
>
>RjS
>
>> -----Original Message-----
>> From: Robert Sparks [mailto:[email-masked]]
>> Sent: Thursday, January 10, 2002 10:46 PM
>> To: [email-masked]'
>> Subject: [Sip] Loose Routing draft
>> 
>> 
>> I just submitted a draft refining the post I sent
>> out after IETF52 on the loose routing proposal.
>> 
>> Until it appears in the archive, you can find it at
>> http://www.nostrum.com/~rjsparks/draft-sparks-sip-looseroute-00.txt
>> or
>> http://www.nostrum.com/~rjsparks/draft-sparks-sip-looseroute-00.html
>> 
>> 
>> RjS
>> 
>> _______________________________________________
>> Sip mailing list  http://www1.ietf.org/mailman/listinfo/sip
>> This list is for NEW development of the core SIP Protocol
>> Use [email-masked] for questions on current sip
>> Use [email-masked] for new developments on the application of sip
>> 
>
>_______________________________________________
>Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
>This list is for NEW development of the core SIP Protocol
>Use [email-masked] for questions on current sip
>Use [email-masked] for new developments on the application of sip
>

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Dean Willis" <[email-masked]>
Date: Thu, 17 Jan 2002 04:55:26 -0600

Hmm, RjS may disagree, but I think that the retargeting of the message at X
might override the service routing in the original request. Changing the
request URI means to me "don't send it to where it was being sent, send it
to this other place instead". Given this logic, service route points
downstream from X probably don't matter anymore.

--
Dean