Subject: [Sip] Regarding Encrytion of SIP messages

From: "Mukesh R Shah" <[email-masked]>
Date: Thu, 24 Jan 2002 13:03:08 +0530

hi ,

Is there any encryption technique used for SIP messages.
plz let me know about it (RFC/drafts/links).

Currently is there any who have implemented encryption on SIP messages ?

Regards,
Mukesh

---

From: Jonathan Rosenberg <[email-masked]>
Date: Thu, 24 Jan 2002 15:00:32 -0500

> Currently is there any who have implemented encryption on SIP messages ?

RFC2543 supported PGP, but this has been deprecated in bis.

Instead S/MIME will exist for the purposes of encryption. There will be
a good amount of detail on S/MIME in the forthcoming bis-06.

-Jonathan R.

-- 
Jonathan D. Rosenberg, Ph.D.            72 Eagle Rock Avenue
Chief Scientist                         First Floor
dynamicsoft                             East Hanover, NJ 07936
[email-masked]                 FAX: (973) 952-5050
http://www.jdrosen.net                  PH:  (973) 952-5000
http://www.dynamicsoft.com

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Michael Thomas <[email-masked]>
Date: Thu, 24 Jan 2002 13:29:28 -0800 (PST)

> a good amount of detail on S/MIME in the forthcoming bis-06.

   There hasn't been any list discussion of this.

   I for one don't support its inclusion.

	 Mike

---

From: Jonathan Rosenberg <[email-masked]>
Date: Thu, 24 Jan 2002 16:51:11 -0500

>    I for one don't support its inclusion.

Well, it has the benefit of being "for free". You can already do it
today, since SIP carries MIME anyway. All we are doing is making people
aware of that, and saying what is needed in order for it to work
properly.

What is your particular objection?

-Jonathan R.

---

From: Michael Thomas <[email-masked]>
Date: Thu, 24 Jan 2002 16:55:30 -0800 (PST)

> What is your particular objection?

Not having seen the actual draft, it's hard to
enumerate specific objections, but I'm mainly
concerned about the law of unintended
consequences. In particular, if SMIME make sense
for other kinds of protected delivery (say,
UAC/Proxy) later, does the bis-specified usage
make that difficult/impossible? I'm also concerned
about semantics and addressing and what happens
when you might be tempted to repeat SIP headers
inside and outside the MIME attachment.

Also: I frankly don't think the e2e crypto is all
that compelling at this point. Almost nobody
implemented the PGP stuff, and I doubt that a
change of format in the form of SMIME -- which has
probably less penetration in mail than PGP -- will
help that at all. It would be far more prudent to
say nothing and keep our options open. 

However, this may be an excellent thing to put
in an experimental RFC to see how it goes.

		   Mike