Subject: RE: [Sip] TLS section

From: "Peterson, Jon" <[email-masked]>
Date: Wed, 30 Jan 2002 13:51:27 -0600

One tiny note below.

Jon Peterson
NeuStar, Inc.

> -----Original Message-----
> From: Jonathan Rosenberg [mailto:[email-masked]]
> Sent: Tuesday, January 29, 2002 11:17 PM
> To: Peterson, Jon
> Cc: 'Michael Thomas'; Juha Heinanen; Rosen, Brian; 'Dean Willis';
> [email-masked]
> Subject: Re: [Sip] TLS section
> 
> 
[snip]
> 
> 
> Arguably, given that there are cases where IPSec is right and 
> where TLS
> is right, you should make both of them MUST to provide 
> interoperability.
> However, I think I would be visciously beaten by many folks for
> proposing that. 
>
[snip]
>
> The main issue will arise cross-domain. In those cases, I
> would probably select TLS over IPSec, primarily because I would expect
> the proxy application would need to know who it was talking with. 
> -Jonathan R.

While I'll come short of aggravated assault, I think the possibiliy of TLS
over IPSec is one of the reasons why we need to give some more thought to
interoperability of networks using these different security solutions. This
begs a lot of questions about how TLS would interact with transport mode as
opposed to tunnel mode IPSec. We'd probably want to avoid TLS over IPSec if
we can.

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Michael Thomas <[email-masked]>
Date: Wed, 30 Jan 2002 16:27:48 -0800 (PST)

> opposed to tunnel mode IPSec. We'd probably want to avoid TLS over IPSec if
  
   Why do "we" care about this? "We" aren't designing
   networks here. All "we" need to talk about is what
   MUST/SHOULD/MAY be implemented.

	   Mike