Subject: RE: [Sip] Open Issue #366: sip v. tel URL

From: "John Butz" <[email-masked]>
Date: Thu, 3 Jan 2002 09:29:33 -0500

Agreed.

Plus consistentcy on the use of a leading '+' for phone numbers listed
inside SIP URLs (as specified in E.123 and referred to in E.164)...

Last time i checked,  E.123 says a leading '+' should be used on
business cards and letterhead only.

Personally, I'd like to see the '+' dropped and the 'phone number' vs
'string of digits' decision be based on the domain of the UA.

I let guys argue the finer points

Best regards,
--John Butz
Vonage
T.  732-528-2616
F.  732-287-9119
E.  [email-masked] 

-----Original Message-----
From: Jonathan Rosenberg [mailto:[email-masked]]
Sent: Wednesday, January 02, 2002 1:04 AM
To: [email-masked]
Subject: [Sip] Open Issue #366: sip v. tel URL

THe spec is silent on what to do when a user enters just a telephone 
number at a
SIP UA. Does the UA generate a SIP URL using the default domain of the 
UA, or
does it generate a tel URL? Do we even need to say anything about this?
We
might, since otherwise, a UA that always uses tel won't interoperate
with a
proxy which doesn't support tel at all.

I would probably argue that when a user enters an unqualified name to be

called,
the UA generates a SIP URL, filling in the domain with its domain of
administration. This means that no matter what is entered, it is the 
domain of
the UA which is the one that needs to figure out how to interpret it. 
This makes
it work for things beyond phone numbers.

Either way, the spec should talk about this.

-Jonathan R.
-- 
Jonathan D. Rosenberg, Ph.D.            72 Eagle Rock Avenue
Chief Scientist                         First Floor
dynamicsoft                             East Hanover, NJ 07936
[email-masked]                 FAX: (973) 952-5050
http://www.jdrosen.net                  PH:  (973) 952-5000
http://www.dynamicsoft.com

_______________________________________________
Sip mailing list  http://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

_______________________________________________
Sip mailing list  http://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Info Van" <[email-masked]>
Date: Fri, 04 Jan 2002 10:39:48 -0500

hi,

i am not very experience about SIP or MobileIP so plz excuse me if I say something very naive here. but the heuristics you are talking about, won't they be very difficult (if not impossible) to formulate for SIP UA's using mobile IP where there is almost (or absolutely) no notion (information) of location related to the UA, so how does this database of appropriate PSAP help ?? rather if there is some extension by virtue of which a UA (optionally, to be 911 conformant) sends additional Location: information to the Registrar ?? I mean "real" GPS (or Geographic) location.

my 2 cents,
bdutta.
---

>> 
>>    My outbound proxy may never move, so this is
>>    not in any way generalizable. I understand that
>>    some people want to deploy proxies that way,
>>    but I strenuously object to this hack being the
>>    mechanism by which we localize 911.
>
>I wouldn't, either. However, I'm trying to find heuristics that are more
>likely to work in the short term. I've made proposals (and will spell
>them out in more detail soon) on how to make it possible for any entity
>to locate the appropriate PSAP. However, this requires a database that
>somebody needs to build and maintain. 

--
Click here for your very own create-a-date adventure from MatchMaker
Go to http://ecard.matchmaker.com/dating.html

---

From: "Abbie Barbir"<[email-masked]>
Date: Tue, 22 Jan 2002 14:44:27 -0500

see below

> From: Henning G. Schulzrinne [mailto:[email-masked]]
> Sent: Tuesday, January 22, 2002 11:10 AM
> To: Jonathan Rosenberg
> Cc: Dean Willis; Juha Heinanen; [email-masked]
> Subject: Re: [Sip] Open Issue #366: sip v. tel URL
> 
> 
> Jonathan Rosenberg wrote:
> > 
> 
> I suspect that some of this is probably better codified in a
> "implementation recommendations for SIP UA" document being written in
> the SIP Forum, rather than a protocol spec. I would see such
> recommendations as "here's something to think about - you can do
> something different, but be aware of the trade-offs".
> 
> > 
> > -Jonathan R.

agreed, it seems that this is the right thing to do

abbie