Subject: [Sip] Difference in sip bis04/bis05 BNF

From: Jasson Casey <[email-masked]>
Date: Wed, 2 Jan 2002 21:26:35 -0800 (PST)

I was going through the new BNF and I had a few
questions. 

The first is in sip bis05 line 9830:
TILDE    =  LWS " LWS ; tilde

Should the line read:
TILDE    =  LWS "~" LWS ; tilde

The second question is in sip bis05 line 9949:
headers =  "?" header *(" " header)

The corresponding line from bis04 (1107)
headers = "?" header *("&" header)

Why is the ampersand no longer present?

Finally, I had a question concerning (url|uri) within
the to/from headers. Specifically, I am seeking
clarification on the usage of to/from parameters (tag,
name=value, etc).

Originally, I had a concern about the difference
between a url|uri parameter and a to/from parameter.
In bis04 it seemed that the following "<" url|uri ">"
*(to/from-params) was used to know the difference.
Where in bis05 the use seems to be a bit different:

name-addr =  [ display-name ] LAQUOT addr-spec RAQUOT

So, "<" and ">" are only used for display-name
applications. If this is the new usage, then once
again how do I tell the difference between a (url|uri)
parameter and a (to|from) parameter. It seems that I
could encounter something like the following:

From:
sip:[email-masked]:1234;maddr=224.1.2.3;name=value;tag=1234

Is name=value a url|uri parameter or a from-param?

Any clarification would be helpful.

Thanks,

Jasson Casey
[email-masked]

__________________________________________________
Do You Yahoo!?
Send your FREE holiday greetings online!
http://greetings.yahoo.com

_______________________________________________
Sip mailing list  http://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Jonathan Rosenberg <[email-masked]>
Date: Thu, 03 Jan 2002 02:07:49 -0500

> TILDE    =  LWS "~" LWS ; tilde

Yes. This is a latex error of some sort. Thanks.

> Why is the ampersand no longer present?

Another latex error. Its correct in the PS/PDF.

> applications. 

What makes you say that? The usage is unchanged.

> If this is the new usage, then once

Nothing has changed. In the above case, maddr, name and tag would all be 
 From parameters. Please tell me what text implies that this has changed.

-Jonathan R.

-- 
Jonathan D. Rosenberg, Ph.D.            72 Eagle Rock Avenue
Chief Scientist                         First Floor
dynamicsoft                             East Hanover, NJ 07936
[email-masked]                 FAX: (973) 952-5050
http://www.jdrosen.net                  PH:  (973) 952-5000
http://www.dynamicsoft.com

---

From: Jasson Casey <[email-masked]>
Date: Thu, 3 Jan 2002 07:33:39 -0800 (PST)

Actually, it just took me a while to dig up the phrase
I was looking for.

sipbis04 lines 4177-4179:

Even if the "display-name" is empty, the "name-addr"
form MUST be used if the "addr-spec" contains a comma,
question mark, or semicolon.  

sipbis05 lines 8235-8238:

Even if the "display-name" is empty, the "name-addr"
form MUST be used if the "addr-spec" contains a comma,
question mark, or semicolon.

I was looking for a clarification in the ambiguity of
url-parameters and to/from parameters. As I read from
the above statements: whenever (url-parameters |
url-headers) are present name-addr will be used, which
will wrap the url in "<url>". I was looking for
something like this in the BNF.

Thanks,

Jasson Casey
[email-masked]

--- Jonathan Rosenberg <[email-masked]>

---

From: Jonathan Rosenberg <[email-masked]>
Date: Thu, 03 Jan 2002 14:39:45 -0500

> something like this in the BNF.

Its in the BNF, since the name-addr mandates the angle brackets.

-Jonathan R.