Subject: [Sip] Questions for Loose Route example

From: [email-masked]
Date: Tue, 22 Jan 2002 18:41:13 +0200

Hi Robert et al.

I am referring to the email sent by RjS on Tue 15.01.2002
concerning the appending the intended destination at the 
end of the Route set.

I still try to understand the loose route idea better.
Let's make another example:

A -> P1
=======

A want to send a request to B traversing
P1 and P2 before B;
i.e. A -> P1 -> P2 -> B 

R-URI: [email-masked]; maddr=p1.serviceop.com
...
Route: p2.tracing.com
...

P1 -> P2
========

P1 knows more about B and retargets the destination to 
[email-masked]. The "incoming" Route goes to maddr.

R-URI: [email-masked]; maddr=p2.tracing.com
...
(no Route)
...
Record-Route: [email-masked]; maddr=p1.serviceop.com
...

P2 -> B
=======
 
P2 strips maddr and routes to B.

R-URI: [email-masked]
...
(no Route)
...
Record-Route: [email-masked]; maddr=p2.tracing.com,
  [email-masked]; maddr=p1.serviceop.com
...

---

Is this a typical example of how such a retargeting service 
should be performed? Are there other examples on how this
could/should be done?
In particular, I am interested, on how P1 should handle
this situation.

I think we should have a clear understanding on how
this is done, before we can introduce this to the bis
draft. Even an inclusion in some example section
(or I/D) should be considered.

Please comment/improve this example.

cheers,
 Bernie

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Robert Sparks <[email-masked]>
Date: Wed, 23 Jan 2002 02:08:12 -0500

What you have below would is a reasonable scenario.

Note that in the initial request (what you show) the
maddr parameters in the request-URI are not necessary.
A can send the message to P1 with a R-URI of [email-masked].

In fact, while you are discovering the path to the destination,
using maddr as you have below can break if at some point a URI
with a non-default transport or port is introduced. (Say P1
found that the request should goto [email-masked]:6000). I'll be
posting more on this shortly.

In subsequent requests each element record-routing (and the last
hop using a Contact) can specify the appropriate transport/port
values for that hop, so maddrs appearing in those request URIs
isn't a problem.

RjS

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: Tuesday, January 22, 2002 10:41 AM
> To: [email-masked]
> Cc: [email-masked]
> Subject: [Sip] Questions for Loose Route example
> 
> 
> Hi Robert et al.
> 
Its not necessary for the maddr to be in this request-URI -
A can just send the request to P1. In fact, the maddr really
shouldn't be there for this case.