Subject: RE: [Sip] Default value for Timer C (was #282)

From: William Marshall <[email-masked]>
Date: Wed, 9 Jan 2002 08:05:00 -0500 (EST)

[email-masked] wrote:
> >> 3. If a uas needs an extension on timer C, it sends a 1xx. A proxy
> >> resets timer C on receipt of a 101-199. The UAS will need to
> >> send 1xx at
> >> least as frequently as once every 3m.
> 
> >Yes, and to be paranoidsafe a good few seconds short
> >of 3min, right?
> 
> For this to work reliably over UDP, the 1xx responses used to extend
> the timer should be sent reliably using 100-rel.

Since 100rel is optional and may not be supported by the UAC, the
UAS needs to implement two refresh algorithms....
  1) with Supported: 100rel, resend the 1xx reliably every 2.5min
  2) without Supported: 100rel, resend the 1xx every 1min (my rule-of-thumb
     for non-reliable keepalives is 1/3 of the timeout interval)
But, if the UAS knows a final response will come within 3min (like
a PSTN gateway, for instance) it need do none of this.

This has the benefit of keeping the complexity on the element that is
doing 1% of the cases, and nothing additional for the 99%.

Sounds like a good solution to me.

Bill Marshall
[email-masked]

_______________________________________________
Sip mailing list  http://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Brett Tate" <[email-masked]>
Date: Wed, 9 Jan 2002 13:37:14 -0500

> Since 100rel is optional and may not 
> be supported by the UAC, the UAS needs 
> to implement two refresh algorithms....
> But, if the UAS knows a final response 
> will come within 3min (like a PSTN gateway, 
> for instance) it need do none of this.

Sounds fine.  The UAS can ring infinitely 
if it desires.  The UAC/proxy can still 
use the Expires to restrict such activity.