Subject: [Sip] re: open issue #290: registrar increasing lifetime

From: Rohan Mahy <[email-masked]>
Date: Thu, 17 Jan 2002 18:04:49 -0800 (PST)

Jonathan sent this message...
Clarifying question inline..
--------------------------------------------------------------------------------

I would really like to resolve this one finally.

 From what I can tell, people seem to agree that,
generally speaking, the registrar shouldn't
increase it, and if the interval is too low,
it can reject it.

Brett's concern is backwards compatibility. However,
I think I have an easier answer for that.

I suspect there are zero existing UA's that ever include
an expires less than one hour. So, as long as we mandate
that a proxy support registrations of at least one
hour (i.e., it not reject registrations greater than one hour
because they are too short), we'll be backwards compatible in practice.

So, to summarize:

1. registrars can't increase the interval
2. registrars must not reject registrartions less than
one hour
3. registrars may reject registrations less that one
  hour, with some TBD response code

***Rohan*** I agree with 1 and 3, but 2 and 3 are contradictory.  ??

May I please hear a yea/nea from the people in this thread??

-Jonathan R.

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Jonathan Rosenberg <[email-masked]>
Date: Fri, 18 Jan 2002 01:07:13 -0500

Correction inline....

> Clarifying question inline..

Oops, I meant greater than or equal to one hour.

> ***Rohan*** I agree with 1 and 3, but 2 and 3 are contradictory.  ??

Yup, sorry bout that.

-Jonathan R.

-- 
Jonathan D. Rosenberg, Ph.D.            72 Eagle Rock Avenue
Chief Scientist                         First Floor
dynamicsoft                             East Hanover, NJ 07936
[email-masked]                 FAX: (973) 952-5050
http://www.jdrosen.net                  PH:  (973) 952-5000
http://www.dynamicsoft.com