Subject: RE: [Sip] [bis-05] Table 3 and the Supported header

From: "Drage, Keith (Keith)" <[email-masked]>
Date: Wed, 16 Jan 2002 14:32:51 -0000

See below

many thanks for the response

Keith

Keith Drage
Lucent Technologies
Tel: +44 1793 776249
Email: [email-masked]

> ----------
> From: 	Alan Johnston[SMTP:[email-masked]]
> Sent: 	15 January 2002 17:43
> To: 	'Drage, Keith (Keith)'; [email-masked]
> Subject: 	RE: [Sip] [bis-05] Table 3 and the Supported header
> 
> Keith,
> 
> The next version of bis will define that a blank in the "where" column
> means the header may be present in both requests and responses, which I
> believe is true for Supported.
> 
> I suppose that it should say "r" in the "proxy" column.  The noting of
> "r" in this column is a leftover from when 2543 had a defined mechanism
> for encrypting selected headers.  Since this mechanism is now gone,
> perhaps this label is not needed.  On the other hand, it doesn't hurt
> anything.
> 
I am looking for consistency, so either we should have it, or not have it.
Certainly if we believe that proxies can read all headers, we should remove
"r" as it will be a source of future confusion. Either that or we should
consistently use it.

Certainly the current bis-05 text:

       r: indicates that a proxy must be be able to read the header.
             Headers that need to be read cannot be encrypted.

does not correspond to your statements and needs to be amended.

> "g" for General header is no longer used and has been removed from
> Tables 2 and 3.
> 
I am looking for consistency, so I am happy with leaving the "where" column
blank so long as the "g" has been removed from elsewhere in the table. There
was at least one instance in bis-05

> Thanks,
> Alan Johnston
> sip:[email-masked]
> 
> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of Drage,
> Keith (Keith)
> Sent: Tuesday, January 15, 2002 8:26 AM
> To: [email-masked]
> Subject: [Sip] [bis-05] Table 3 and the Supported header
> 
> In Table 3 of the bis-05 draft, the Supported header is included. 
> 
> In this table the entry for "Where" is missing.
> 
> In addition, the entry for "proxy" is blank.
> 
> The timer draft contains procedures for proxies looking at the contents
> of
> the Supported header in a request, to see if the "timer" option-tag is
> included. I therefore assume that at least for requests, there should be
> an
> "r" in the proxy column.
> 
> If the "r" only applies for requests, then this header needs to be split
> into two rows, identified in the Where column by "R" and "r"
> respectively.
> If the behaviour is the same for both request and response, then the
> Where
> column should contain the value "g".
> 
> Incidently, while the value "g" is used in this table, it is not defined
> in
> the key at the start of the table.
> 
> Keith
> 
> 
> Keith Drage
> Lucent Technologies
> Tel: +44 1793 776249
> Email: [email-masked]
> 
> _______________________________________________
> Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
> This list is for NEW development of the core SIP Protocol
> Use [email-masked] for questions on current sip
> Use [email-masked] for new developments on the application of sip
> 

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Bob Penfield" <[email-masked]>
Date: Wed, 16 Jan 2002 11:13:36 -0500

I don't think it would be a good idea to remove "r" from the "where" column
in table 3. In spite of the fact that PGP encryption of headers has been
deprecated, there have been some proposals to put hashed values into headers
(e.g. Via recently). The base spec needs to clearly indicate those headers
that proxies must be able to read so they should not be mucked with by
endpoints or other intermediaries.

cheers,
(-:bob

----- Original Message -----
From: "Drage, Keith (Keith)" <[email-masked]>
To: "Drage, Keith (Keith)" <[email-masked]>; <[email-masked]>; "'Alan
Johnston'" <[email-masked]>
Sent: Wednesday, January 16, 2002 9:32 AM
Subject: RE: [Sip] [bis-05] Table 3 and the Supported header