Subject: AW: [Sip] Path to Working Group Item

From: [email-masked]
Date: Wed, 6 Mar 2002 13:42:46 +0200

Mayer Georg writes:

 Our aim was not to pollute any area of serious work and I am sorry if
 you got that impression - we are happy that SIP and SIPPING groups
 undertook and still undertake major efforts to enable also the specific
 3GPP requirements. The 3GPP IMS uses SIP in a specific way, as a
 private network uses SIP in a different way, etc..

enabling specific 3gpp ims requirements in ietf sip specifications is
fine as long as the requirements don't contradict with the sip protocol
architecture.  the path header proposal unfortunately does so and
therefore there is no way it can accepted.  you simply can't add the
path header to sip without a major rewrite of the existing sip
specifications (the rfc and the bis).

-- juha

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Mayer Georg <[email-masked]>
Date: Wed, 6 Mar 2002 12:26:33 +0100

Hello Juha et al,

> if i don't want to use any value added services from my home 
> proxy, but
> just want to make a cheaper call by just using the generic services of
> the network that i'm visiting (like ordering a pizza from a 
> shop next to
> my hotel), 3gpp should allow me to do it.  also, 3gpp should 
> allow me to
> make that call without registering with my home proxy, because i don't
> want myself to be reachable.  

Nothing is impossible - everything is permitted.

If you don't want to use the 3G value added services that's fine with 3G - you just set up your SIP call via pure UMTS Packet Switchted Domain (GPRS). Then you will find exactly the behaviour we all know and love from a pure IP-based solution. You do not even need to register here. 

The 3GPP IMS is only a part of the whole 3GPP architecture, it is based on the Packet Switched domain. If you want value added services you need to route through the IMS, i.e. to your home network - you have to register and then you can use SIP as shown in the 3G specs. As said above the Packet Switched domain can work independently of IMS and provides you IP access as you outlined it.

That's it - everyhting is permitted - nothing is impossible.

> if 3gpp doesn't allow me to do that, 3gpp architecture is 
> something very
> different from sip architecture and it doesn't make sense to pollute
> ietf sip protocol specifications with 3gpp requirements.

Our aim was not to pollute any area of serious work and I am sorry if you got that impression - we are happy that SIP and SIPPING groups undertook and still undertake major efforts to enable also the specific 3GPP requirements. The 3GPP IMS uses SIP in a specific way, as a private network uses SIP in a different way, etc.. As you joined this discussion I am sure you followed the process of IETF / 3GPP team-work during the last months - so you for sure have seen that 3GPP IMS is now a  completely IETF SIP based solution, adopting all brand-new changes from the SIP drafts. All that we need here is some addition that allows us to apply SIP for our specific service.

Keep on signalling
Georg
_______________________________________________________
Georg Mayer - Siemens AG
Information and Communication Mobile
ICM N PG SP ST N 1
Hofmannstr. 51, 81359 Munich, Germany
Fon: +49-89-722-33114
Fax: +49-89-722-62250
Mobile: +49-172-5371233
Email: [email-masked]

> -----Ursprüngliche Nachricht-----
> Von: [email-masked] [mailto:[email-masked]]
> Gesendet: Mittwoch, 6. März 2002 07:11
> An: Dean Willis
> Cc: Mark Watson; [email-masked]
> Betreff: Re: [Sip] Path to Working Group Item
> 
> 
> Dean Willis writes:
> 
>  > Because 3GPP provides value-added services in the home 
> proxy. If you don't
>  > traverse the home proxy on mobile-originated calls, you 
> don't get the
>  > value-added services.
> 
> if i don't want to use any value added services from my home 
> proxy, but
> just want to make a cheaper call by just using the generic services of
> the network that i'm visiting (like ordering a pizza from a 
> shop next to
> my hotel), 3gpp should allow me to do it.  also, 3gpp should 
> allow me to
> make that call without registering with my home proxy, because i don't
> want myself to be reachable.  
> 
> if 3gpp doesn't allow me to do that, 3gpp architecture is 
> something very
> different from sip architecture and it doesn't make sense to pollute
> ietf sip protocol specifications with 3gpp requirements.
> 
> -- juha
> 
> 
>

---

From: Henry Sinnreich <[email-masked]>
Date: Wed, 06 Mar 2002 15:18:17 -0600

To add to the fray I would like to take issue with the confusing term of
"Packet Switched".
Does "Packet Switched" mean Ethernet switching of some sorts, frame
relay, X.25, ATM switching, SNA, IPX or IP routing?
These "Packet Networks" are so much different, that the term becomes
more than useless - it is misleading IMHO.

If it is IP, call it IP.

Thanks, Henry

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of Mayer Georg
> Sent: Wednesday, March 06, 2002 5:27 AM
> To: [email-masked]'; Dean Willis
> Subject: AW: [Sip] Path to Working Group Item
> 
> 
> Hello Juha et al,
> 
> If you don't want to use the 3G value added services that's 
> fine with 3G - you just set up your SIP call via pure UMTS 
> Packet Switchted Domain (GPRS). Then you will find exactly 
> the behaviour we all know and love from a pure IP-based 
> solution. You do not even need to register here. 
> 
> The 3GPP IMS is only a part of the whole 3GPP architecture, 
> it is based on the Packet Switched domain. If you want value 
> added services you need to route through the IMS, i.e. to 
> your home network - you have to register and then you can use 
> SIP as shown in the 3G specs. As said above the Packet 
> Switched domain can work independently of IMS and provides 
> you IP access as you outlined it.
> 
> Our aim was not to pollute any area of serious work and I am 
> sorry if you got that impression - we are happy that SIP and 
> SIPPING groups undertook and still undertake major efforts to 
> enable also the specific 3GPP requirements. The 3GPP IMS uses 
> SIP in a specific way, as a private network uses SIP in a 
> different way, etc.. As you joined this discussion I am sure 
> you followed the process of IETF / 3GPP team-work during the 
> last months - so you for sure have seen that 3GPP IMS is now 
> a  completely IETF SIP based solution, adopting all brand-new 
> changes from the SIP drafts. All that we need here is some 
> addition that allows us to apply SIP for our specific service.
> 
> Keep on signalling
> Georg
> > Use [email-masked] for questions on 
> current sip Use 
> > [email-masked] for new developments on the application of sip
> > 
> 
> Use [email-masked] for questions on current 
> sip Use [email-masked] for new developments on the 
> application of sip
>