Subject: [Sip] header fields' sizes in SIP

From: [email-masked] (Vladica Stanisic)
Date: Mon, 25 Mar 2002 15:39:08 -0500

I am a student working on SIP designing a control memory.
Header fields' sizes in SIP are not defined since SIP is text based protocol.
Can anybody give me guidelines about sizes of mandatory header fields 

Allow
Call-ID
Contact
Content-Length
Content-Type
From
Proxy-Authenticate
Supported
To
Unsupported
Via
WWW-Authenticate

Thanks
-- 
Vladica Stanisic
Research Assistant
North Carolna State University
e-mail:[email-masked]

__________________________________________________________________
Your favorite stores, helpful shopping tools and great gift ideas. Experience the convenience of buying online with Shop@Netscape! http://shopnow.netscape.com/

Get your own FREE, personal Netscape Mail account today at http://webmail.netscape.com/

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Prabhas Sinha" <[email-masked]>
Date: Mon, 25 Mar 2002 17:13:14 -0500

I think this information is available in the RFC , I had read it long time
back but I'll put it here for you:
To:  (50 bytes for name/address-space) + (8 bytes for tag) = 58 bytes
From: (50 bytes for name/address-space) + (8 bytes for tag) = 58 bytes
Content Length: 12 bytes
Call-ID: 50 bytes
Content Encoding: 50 bytes
Content Type: 50 bytes
CSeq: 12 bytes
Via: 75 bytes

If there is some changes to it then somebody please correct me.
Moreover, please send your questions to
[email-masked] from now onwards.

Thanks,
Prabhas

----- Original Message -----
From: "Vladica Stanisic" <[email-masked]>
To: <[email-masked]>
Sent: Monday, March 25, 2002 3:39 PM
Subject: [Sip] header fields' sizes in SIP

> Your favorite stores, helpful shopping tools and great gift ideas.
Experience the convenience of buying online with Shop@Netscape!
http://shopnow.netscape.com/