Subject: [Sip] Why UAS can`t start a second offer before the session is complete??

From: "Peili Xu" <[email-masked]>
Date: Tue, 12 Mar 2002 11:49:43 +0800

Hi, All

    The current bis prevent UAS from offering a second SDO offer before the session is complte.
But in some situation this capability is suitable.
For example:

SIP UA1                MGC

------INVITE(SDP-O-1)------>    ;SDP1 offer a send/recv channel.

<-----180(SDP-A-1)----------    ;SDP2 answers a sendonly channel just for ringback
                              because MGC use an MRS to send ringback tone and perhaps don`t know                                 the MG`s RTP address.

<-----200(SDP-O-2)----------    ; when user pick up the phone MGC want to connect the                                                 bidirectional channle, so it offer`s a send/receive channel.

------ACK(SDP-A-2)--------->    ;UA1 answers a send/receive channel. 

Note: if the second offer is not allowed, we must rely on UA1 to start another offer. I think let MGC to start the offer is more reasonable.

Also, in such situation as the called party want to change local media info after the early media is established(such as PSTN forwording no answer and so on, the procedure is also needed.

---

From: Gonzalo Camarillo <[email-masked]>
Date: Tue, 12 Mar 2002 21:42:46 +0200

Hello,

the UAS can send another offer before the session gets established. But
this has to be sent in an UPDATE, not in the 200 OK.

Gonzalo

Peili Xu wrote:
>                               because MGC use an MRS to send ringback
> tone and perhaps don`t know                                 the MG`s
> RTP address.
> 
> <-----200(SDP-O-2)----------    ; when user pick up the phone MGC want
> to connect the
> bidirectional channle, so it offer`s a send/receive channel.
> 
> Note: if the second offer is not allowed, we must rely on UA1 to start
> another offer. I think let MGC to start the offer is more reasonable.
> 
> Also, in such situation as the called party want to change local media
> info after the early media is established(such as PSTN forwording no
> answer and so on, the procedure is also needed.
> 
> 
> 

-- 
Gonzalo Camarillo                    Phone :   +1 212 939 71 71
Columbia University                  Mobile:  +358 40 702 35 35
472 Computer Science Building        Fax   :  +358  9 299 30 52
1214 Amsterdam Ave., Mail Code 0401  http://www.hut.fi/~gonzalo
New York, NY 10027                   
USA                              [email-masked]

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Ranjit Avasarala" <[email-masked]>
Date: Tue, 12 Mar 2002 15:06:08 -0600

but I feel UPDATE should be sent only when UAS wants to modify some session
parameters.

Regards
Ranjit

-----Original Message-----
From: Gonzalo Camarillo [mailto:[email-masked]]
Sent: Tuesday, March 12, 2002 1:43 PM
To: Peili Xu
Cc: [email-masked]
Subject: Re: [Sip] Why UAS can`t start a second offer before the session
is complete??

Hello,

Gonzalo

---

From: Gonzalo Camarillo <[email-masked]>
Date: Tue, 12 Mar 2002 23:23:42 +0200

In the example given below the media stream will become sendrecv... In
this case your UPDATE will change the direction attribute of the stream.

Gonzalo