Subject: Home Extension Service was Re: [Sip] Multiple 200 OKs for an INVITE

From: [email-masked]
Date: Fri, 1 Mar 2002 08:33:11 -0500

From:  Tom Gray@MITEL on 03/01/2002 08:33 AM

The scenario pointed out with multiple 200 OKs is also pertinent for a home
extension service.  Have the call flows for this service been created, I find in
the service example draft a mention that they have not. It also raises questions
about who will supply and pay for a conference service to a home extension.
Callers would be hesitant to pay for a conference connection that was of benefit
only to the called party.

"Bob Penfield" <[email-masked]> on 02/28/2002 12:09:32 PM

To:   "Mark Taylor" <[email-masked]>, "SIP" <[email-masked]>
cc:    (bcc: Tom Gray/Kan/Mitel)

Subject:  Re: [Sip] Multiple 200 OKs for an INVITE

----- Original Message -----
From: "Mark Taylor" <[email-masked]>

>
> This may be a silly question but multiple INVITES are
> sent out which cause telephones to ring. Two of these
> telephones are answered by human beings at the same
> time and send a 200 OK. One of these telephones is
> connected to the voice path but the other experiences
> an immediate hang up.
>
> Isn't this extremely rude and will cause major
> emabarassment to the caller since his name and
> possibly picture have been dispayed on the receiving
> device. It could also be considered a form of criminal
> harrassment to call and imediately hang up on answer.

I think it is a rather common occurance that you pick up a phone and say
hello and noone is there because they decided the call was a mistake or got
tired of waiting for it to answer. It happens to me quite often,
particularly if I don't pick up for 3 or 4 rings.

I should also point out that proxies are required to CANCEL the other
branches when one of them answers. Therefore, the other unanswered phones
would likely stop ringing with a second or two.

You might consider it rude, but the reason that more than one phone rang is
because a user wanted all those phones to ring when he/she got called. The
theory being that the user would answer the phone he/she is next to and
there would be noone next to the other devices. However, some polite person
might decide they want to answer the user's unattended phone for them.

>
> It should be noted that for calls to human beings as
> oposed to machines that all end points that send a
> 200K must be conferenced into the connection.

This is not always possible, particularly on a small device with limited
resources.

cheers,
(-:bob

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Alan Johnston <[email-masked]>
Date: Fri, 01 Mar 2002 07:48:39 -0600

Tom,

You are correct - the home extension (sometimes called single line
extension) is not yet in the Service Examples I-D.  This is because not
all the tools needed to do so are SIP WG items - something that will
hopefully change shortly.

In the meantime, take a look at Section 7.2 of:

http://search.ietf.org/internet-drafts/draft-rosenberg-sip-call-package-
00.txt

For one possible approach.

Thanks,
Alan Johnston
WorldCom
sip:[email-masked]

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of [email-masked]
> Sent: Friday, March 01, 2002 7:33 AM
> To: Bob Penfield
> Cc: Mark Taylor; SIP
> Subject: Home Extension Service was Re: [Sip] Multiple 200 
> OKs for an INVITE
> 
> 
> 
> 
> The scenario pointed out with multiple 200 OKs is also 
> pertinent for a home extension service.  Have the call flows 
> for this service been created, I find in the service example 
> draft a mention that they have not. It also raises questions 
> about who will supply and pay for a conference service to a 
> home extension. Callers would be hesitant to pay for a 
> conference connection that was of benefit only to the called party.
> 
> 
> 
> 
> 
> telephones are 
> > answered by human beings at the same time and send a 200 OK. One of 
> > these telephones is connected to the voice path but the other 
> > experiences an immediate hang up.
> >
> I think it is a rather common occurance that you pick up a 
> phone and say hello and noone is there because they decided 
> the call was a mistake or got tired of waiting for it to 
> answer. It happens to me quite often, particularly if I don't 
> pick up for 3 or 4 rings.
> 
> I should also point out that proxies are required to CANCEL 
> the other branches when one of them answers. Therefore, the 
> other unanswered phones would likely stop ringing with a 
> second or two.
> 
> You might consider it rude, but the reason that more than one 
> phone rang is because a user wanted all those phones to ring 
> when he/she got called. The theory being that the user would 
> answer the phone he/she is next to and there would be noone 
> next to the other devices. However, some polite person might 
> decide they want to answer the user's unattended phone for them.
> 
> >
> This is not always possible, particularly on a small device 
> with limited resources.
> 
> cheers,
> (-:bob
> 
> 
> Use [email-masked] for questions on current 
> sip Use [email-masked] for new developments on the 
> application of sip
> 
> 
> 
> 
> 
> Use [email-masked] for questions on current 
> sip Use [email-masked] for new developments on the 
> application of sip
>