Subject: [Sip] Reason header question

From: "Christer Holmberg (LMF)" <[email-masked]>
Date: Thu, 21 Mar 2002 20:05:45 +0100

Hi,

To my understanding the following case is in the requirements for the Reason header, but my question is which code to use.

Assume that I send an INVITE, which gets forked. I may receive 18x responses from different servers, and I MAY start doing coced and/or resource negoatiation with some of them.

For some reason (may be because of the negoatiation above, or something else) I decide to send a tagged BYE to one or many servers, to terminate the call setup.

Now, one could argue that I should use code value 1 (Call Completed Elsewhere), but I don't really think that's always a good choise. I do NOT terminate the call because someone else established a session, but because of other issue. For example, I may have chosen to use a specific codec with every server, and one or more of the servers may not support that specific codec, so I terminate the setup...

Regards,

Christer Holmberg
Ericsson Finland

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Gonzalo Camarillo <[email-masked]>
Date: Fri, 22 Mar 2002 00:54:11 +0200

Hi Christer,

I am a little behind with my email. I have to answer a couple of other
previous emails related to the reason draft as well. My idea is to have
a little dicussion on the requirements. Depending on that discussion, we
will decide to get rid of the codes you are referring to, or, on the
other hand, decide which ones are essential and which are not.

Regards,

Gonzalo

-- 
Gonzalo Camarillo                    Phone :   +1 212 939 71 71
Columbia University                  Mobile:  +358 40 702 35 35
472 Computer Science Building        Fax   :  +358  9 299 30 52
1214 Amsterdam Ave., Mail Code 0401  http://www.hut.fi/~gonzalo
New York, NY 10027                   
USA                              [email-masked]