Subject: Re: [Sip] UPDATE Method & Glare

From: Jonathan Rosenberg <[email-masked]>
Date: Tue, 05 Mar 2002 13:20:33 -0500

Mark Watson wrote:
> 
> I agree - this needs to be described.

I've added text about it.

> 
> If I remember some earlier discussions correctly, then if you receive
> an UPDATE whilst waiting for a response to an UPDATE that you send
> yourself, the you should immediately reject the UPDATE, but with what
> failure response I do not know.

491. Its in 4.2 of bis-09.

> 
> Do we require a specific failure response for glare ? I guess you need
> to know that it is worth retrying after some random interval.

Yes, exactly.

> 
> Also, if you are waiting for a repsonse to an UPDATE you have sent,
> and you receive an UPDATE which is a retransmit of one you have
> previously responded to (presumably because your original response was
> lost), I believe you should just repeat your original response and
> continue waiting for the response to your UPDATE.

Of course. That is handled in the transaction layer, which will
retransmit the response.

> 
> Your UPDATE will probably be rejected, because the other guy thinks
> there is glare, but it is possible for both UPDATES to suceed if
> messages swap order in transit, but this is not a problem.

THere is no way for both to succeed.

> 
> Is this taken care of by the transaction layer in SIP or does it need
> to be explicitly described ?

Retransmits are discussed in the transaction layer only.

-Jonathan R.

-- 
Jonathan D. Rosenberg, Ph.D.            72 Eagle Rock Avenue
Chief Scientist                         First Floor
dynamicsoft                             East Hanover, NJ 07936
[email-masked]                 FAX: (973) 952-5050
http://www.jdrosen.net                  PH:  (973) 952-5000
http://www.dynamicsoft.com

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "George Foti (LMC)" <[email-masked]>
Date: Tue, 5 Mar 2002 13:31:14 -0500

Has UPDATE-02 been issued
/gf

> -----Original Message-----
> From: Jonathan Rosenberg [mailto:[email-masked]]
> Sent: Tuesday, March 05, 2002 1:21 PM
> To: Mark Watson
> Cc: George Foti (LMC); [email-masked]
> Subject: Re: [Sip] UPDATE Method & Glare
> 
> 
> 
> 
> Mark Watson wrote:
> >