Subject: Re: [Sip] URI and URL

From: Sean Olson <[email-masked]>
Date: Fri, 8 Mar 2002 09:50:55 -0800 (PST)

Every URL is a URI. See RFC2396, section 1.2:

    A URI can be further classified as a locator,
    a name, or both.  The term "Uniform Resource
    Locator" (URL) refers to the subset of URI
    that identify resources via a representation of
    their primary access mechanism (e.g., their
    network "location"), rather than identifying
    the resource by name or by some other attribute
    (s) of that resource. 

Your SIP URL is also a SIP URI. For the purposes
of SIP, the two terms are interchangeable. It is
arguable whether the tel: URI is also a tel: URL 
depending on how you view telephone numbers.

/sean

--- "Chen, Xin (Xin)" <[email-masked]> wrote:
> Hi,
> 
> I have a very basic question,
> 
> What is the difference between URI and URL?
> 
> For example, if sip:[email-masked] is my SIP URI,
> then what is my SIP
> URL?
> 
> In the SIPbis09, I see "SIP URI", "Request-URI" and
> "Tel URL", can I say
> "SIP URL", "Request-URL" and "Tel URI"?
> 
> Thanks
> 
> Xin Chen
> 
> Lucent Technologies
> Tel: +44 1793 883137
> Mobile: +44 7799 034668

=====
Sean Olson <[email-masked]>

__________________________________________________
Do You Yahoo!?
Try FREE Yahoo! Mail - the world's greatest free email!
http://mail.yahoo.com/

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Chen, Xin (Xin)" <[email-masked]>
Date: Fri, 8 Mar 2002 17:39:41 -0000

Hi,

For example, if sip:[email-masked] is my SIP URI, then what is my SIP
URL?

In the SIPbis09, I see "SIP URI", "Request-URI" and "Tel URL", can I say
"SIP URL", "Request-URL" and "Tel URI"?

Thanks

Xin Chen

Lucent Technologies
Tel: +44 1793 883137
Mobile: +44 7799 034668