Subject: RE: [Sip] Reason header simplification

From: Jean-Francois Mule <[email-masked]>
Date: Tue, 19 Mar 2002 21:34:18 -0700

Rohan wrote:
> Also I don't like to idea of sending ISUP (Q.850) or ISDN 
> (Q.931) response
> codes around inside a SIP network.
Actually, I like that option a lot since mapping is almost never a one to one exercize when translating cause codes or release reason codes between protocols. This is why some other protocols have also gone that route of "encapsulating" the q.850 codes inside release or release complete messages in order to have transparency.

> I'd rather use standard 
> ISUP-SIP or
> ISDN-SIP cause code translation, so that an ordinary SIP UA 
> can just use a set of well-defined SIP cause codes.
The requirement expressed here is something like "whenever possible, a SIP cause code should also be provided".  The reason header draft could clarify the rules of dealing with multiple reason header lines (we could have q.850 reason codes carried for end-to-end purposes or other H.323/SIP inter-working functions but still mandate a sip reason header line for the signaling hops along the sip chain).

Jean-Francois.

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Flemming Andreasen <[email-masked]>
Date: Wed, 20 Mar 2002 01:00:15 -0500

Jean-Francois Mule wrote:

> Actually, I like that option a lot since mapping is almost never a one to one exercize when translating cause codes or release reason codes between protocols.

True, but the idea with SIP is not to replicate ISUP or Q.931. I agree with Rohan here. Carrying "foreign" reason codes inside the SIP protocol itself is counter to the way we normally try to use SIP. The SIP-T framework is a good example of this and we should continue along those lines.

> This is why some other protocols have also gone that route of "encapsulating" the q.850 codes inside release or release complete messages in order to have transparency.
>
> > I'd rather use standard
> > ISUP-SIP or

If this information is only for non-SIP end-systems, then why does it have to be in a SIP header ?

-- Flemming

--
Flemming Andreasen
Cisco Systems