Subject: RE: [Sip] transport=tls

From: "Peterson, Jon" <[email-masked]>
Date: Thu, 14 Mar 2002 01:53:22 -0600

According to bis09, transport=tls has been deprecated. For the purposes of
backwards compatibility, the former transport=tls mechanism would be treated
roughly the same way as the SIPS URI scheme; the two important differences
are that transport=tls assumes TCP, and that a number of specific rules have
been mandated for handling the SIPS URI that presumably wouldn't hold for
transport=tls.

Either of the meanings that Dean alludes to below can be expressed by the
SIPS URI scheme in varying contexts. The use of SIPS in a Request-URI
mandates the latter meaning (use TLS for the whole signaling path), while
use in contexts such as a Record-Route, a Contact address of a registration,
or in a preferred NAPTR record can suggest to the use of TLS over particular
segments of a signaling path.

Jon Peterson
NeuStar, Inc.

> -----Original Message-----
> From: Dean Willis [mailto:[email-masked]]
> Sent: Wednesday, March 13, 2002 9:04 PM
> To: Sean Olson; [email-masked]
> Subject: Re: [Sip] transport=tls
> 
> 
> 
> As I understand it (and Jon P will shout if I'm wrong)
> 
> sip:[email-masked];transport=tls
> 
> means "send this towards [email-masked], using tls for the next hop"
> 
> and
> 
> sips:[email-masked]
> 
> means "send this to [email-masked], using tls for every hop until you
> get to domain.com"
> 
> --
> Dean
> 
> ----- Original Message -----
> From: "Sean Olson" <[email-masked]>
> To: <[email-masked]>
> Sent: Wednesday, March 13, 2002 7:41 PM
> Subject: [Sip] transport=tls
> 
> 
> > I'm assuming that
> >
> > sip:[email-masked];tranport=tls
> >
> > is not equivalent to
> >
> > sips:[email-masked]
> >
> > but that is not spelled out anywhere in the bis-09
> > draft. Or am I making a false assumption?
> >
> > /sean
> >
> > =====
> > Sean Olson <[email-masked]>
> >
> > __________________________________________________
> > Do You Yahoo!?
> > Try FREE Yahoo! Mail - the world's greatest free email!
> > http://mail.yahoo.com/
> >
> > _______________________________________________
> > Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
> > This list is for NEW development of the core SIP Protocol
> > Use [email-masked] for questions on current sip
> > Use [email-masked] for new developments on the application of sip
> >
> >
> 
> 
> _______________________________________________
> Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
> This list is for NEW development of the core SIP Protocol
> Use [email-masked] for questions on current sip
> Use [email-masked] for new developments on the application of sip
> 

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Michael Thomas <[email-masked]>
Date: Thu, 14 Mar 2002 07:23:32 -0800 (PST)

> segments of a signaling path.

   So let me get this straight: an INVITE with
   To: sips:...  should fail if somewhere along
   the path the next hop is protected, but just
   not with TLS? Somebody needs to remind why this
   is a Good Thing. 

	    Mike

---

From: Jari Arkko <[email-masked]>
Date: Thu, 14 Mar 2002 18:04:48 +0200

>    not with TLS? Somebody needs to remind why this

Yes... I've been meaning to bring this up too.
It would have been sufficient to require that
the proxies have direct knowledge of integrity,
confidentiality, and replay protection through
cryptographic means (e.g. IPsec API or use of TLS).

Jari

---

From: "mscansh" <[email-masked]>
Date: Fri, 15 Mar 2002 15:45:34 +0530

----- Original Message -----
From: "Michael Thomas" <[email-masked]>
To: "Peterson, Jon" <[email-masked]>
Cc: "'Dean Willis'" <[email-masked]>; "Sean Olson"
<[email-masked]>; <[email-masked]>
Sent: Thursday, March 14, 2002 8:53 PM
Subject: RE: [Sip] transport=tls

>    not with TLS? Somebody needs to remind why this

*********************************************************
Disclaimer

This message (including any attachments) contains 
confidential information intended for a specific 
individual and purpose, and is protected by law. 
If you are not the intended recipient, you should 
delete this message and are hereby notified that 
any disclosure, copying, or distribution of this
message, or the taking of any action based on it, 
is strictly prohibited.

*********************************************************

Visit us at http://www.mahindrabt.com