Subject: RE: [Sip] Path header vs. pre-loaded route in Contact

From: Rohan Mahy <[email-masked]>
Date: Wed, 6 Mar 2002 13:06:36 -0800

Hi George,

I think you misunderstood me.

---- Original message ----
>Date: Wed, 6 Mar 2002 14:05:00 -0500 
>From: "George Foti (LMC)" <[email-masked]>  
>Subject: RE: [Sip] Path header vs. pre-loaded route in 
Contact  
>To: "'Rohan Mahy'" <[email-masked]>, [email-masked]
>
>Comments inline
>> -----Original Message-----
>> From: Rohan Mahy [mailto:[email-masked]]
>> Sent: Wednesday, March 06, 2002 12:15 PM
>> To: [email-masked]
>> Subject: [Sip] Path header vs. pre-loaded route in Contact
>> 
>> 
>> Hi,
>> 
>> I think Juha is proposing something like this.  I haven't 
spent enough
>> time with loose-routing to figure it out on my own.  Does 
>> anyone have a
>> reason why this wouldn't work instead of using the Path 
header?
>> 
>> UA needs to find a proxy in the visited domain:
>> 
>> - DHCPv6 option for SIP servers
>>   or
>> - DHCPv6 option for domain name and then use DNS SRV or 
NAPTR
>> to find a suitable server (for example: nyc.visited.net)
>> 
>> Then the UA adopts this (visited) server as its outbound 
proxy, and
>> registers with the home network.  It adds a pre-loaded 
loose-route
>> (which points at the visited proxy) into its Contact.
>> 
>> REGISTER sip:home.net SIP/2.0
>> To: <sip:[email-masked]>
>> From: <sip:[email-masked]>
>> Contact: <sip:user@12:34:56:78:9a:bc:de?
Route=sip:nyc.visited.net;lr>
>> Route: sip:nyc.visited.net;lr           
^^^^^^^^^^^^^^^^^^^^^^^^^^^^
>> 
>> 
>> Alternatively the visited server could add the pre-loaded 
Route to the
>> contact.  (Since, it's really a B2BUA anyway  ;-)
>
>The only way that the visited server can know the route to 
pre-load is
>through response coming back to it from the registration 
process in the PATH
>header,  as the home proxy assigned  to the subscriber takes 
place only at
>registration, and that proxy name is returned in the 
response ( as described
>previously) 
>In conclusion the proposal cannot work

George, this is a Route header in the Contact which gets used 
for incoming calls only.  The visited proxy only needs to 
know its own address, or as Dean pointed out, any border 
proxies in the visited network that need to be in the path, 
but that wouldn't be reached if the home network was trying 
to use ordinary SIP loose-routing to get to nyc.visited.net

The visited network doesn't need to know anything about 
proxies in the home network for example because loose-routing 
would cause them to be reached based on local policy in the 
home network.

In the 3GPP case, it seems likely the P-CSCF would know the 
sip URI of any I-CSCF in the visited network, and could add 
this to the Contact header.  Like Dean said, this could run 
afoul of end-to-end message integrity, but that's not likely 
to affect the 3GPP case.

Can you think of anything else about this that would not work 
in the 3G case.

thanks,
-rohan

>
>
>> 
>> Since all the 3GPP entities support loose-routing, it 
seems at first
>> glance that this should work fine.  When the home proxy 
looks up the
>> Contact for [email-masked], it inserts a Route header and 
>> forwards the call
>> on as if the top-most Route URI was the request-URI.  You 
can still go
>> through as many border proxies as you want, before you 
arrive at the
>> visited network, which strips the Route header and 
forwards 
>> the request
>> onward.
>> 
>> thanks,
>> -rohan
>> 
>> 
>> 
>> _______________________________________________
>> Sip mailing list  
https://www1.ietf.org/mailman/listinfo/sip
>> This list is for NEW development of the core SIP Protocol
>> Use [email-masked] for questions on 
current sip
>> Use [email-masked] for new developments on the 
application of sip
>> 
>
>_______________________________________________
>Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
>This list is for NEW development of the core SIP Protocol
>Use [email-masked] for questions on 
current sip
>Use [email-masked] for new developments on the application 
of sip

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "George Foti (LMC)" <[email-masked]>
Date: Wed, 6 Mar 2002 17:41:25 -0500

Dean Willis wrote
> 
> This does use a couple more messages than REGISTER, so is by 
> some measure
> less efficient, but it can be shown to work adequately. 
> Whether one likes it
> or not, the REGISTER/PATH approach is reasonably efficient.

Absolutely so, and thats why it has been endorsed by 3GPP
/gf
> --
> Dean