Subject: RE: [Sip] Proxies Can Modify SDP?

From: "Zmolek, Andrew (Andrew)" <[email-masked]>
Date: Thu, 14 Mar 2002 12:08:04 -0700

We've been avoiding the terminology mess by calling this type of box an ALG (Application Layer Gateway), considering that B2BUA implies full regeneration rather than rewriting and B2BUA's by their nature don't deal with the media streams. 

--Andy Zmolek 
    Technology & Standards Engineer 
      CTO Standards 
        Avaya Inc. 

            [email-masked] 
              +1 720 444 4001 

-----Original Message-----
From: Paul Sijben [mailto:[email-masked]]
Sent: Tuesday, February 05, 2002 8:10 AM
To: Christer Holmberg
Cc: Tom-PT Taylor; [email-masked]'
Subject: Re: [Sip] Proxies Can Modify SDP?

The discussion on the TIPHON list was how such a box should be called. 
TIPHON has been using the term proxy for such a box for a while but it
seemed not appropriate usage since a proxy was intended as a routing
element ONLY.

So we shwitched to B2BUA. However that terms has been scrapped now from
the draft. 

Paul

Christer Holmberg wrote:
> 
> Hi,
> 
> A proxy controlling a media firewall, and/or doing some kind of "codec
> filtering", should be able to modify the SDP, right?
> 
> Regards,
> 
> Christer Holmberg
> Ericsson Finland
> 
> >I've been involved in a little bit of correspondence with TIPHON WG 3,
> >where there is some question whether proxies are allowed to modify
> >SDP.  I know this has shown up in E-mail, but it does not show up in
> >2543bis.  Could someone confirm this so I can forward the message to
> >TIPHON?
> >
> >Tom Taylor
> >[email-masked]
> >Ph. +1 613 736 0961 (ESN 396 1490)
> 
> _______________________________________________
> Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
> This list is for NEW development of the core SIP Protocol
> Use [email-masked] for questions on current sip
> Use [email-masked] for new developments on the application of sip

-- 
Paul Sijben                         Tel:+31 356874774 
Bell Labs - Advanced Technologies   Fax:+31 356875954
Lucent Technologies     (internal) http://voip.nl.lucent.com/~sijben 
Huizen, The Netherlands

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Chris Martin <[email-masked]>
Date: Thu, 14 Mar 2002 21:03:19 -0600

In a way wouldnt it be both a B2BUA (for the SIP) as well as an ALG (ALG
for the media)?