Subject: Re: [Sip] Question about Section 12.2 Requests within a Dialog

From: Ofir Arkin <[email-masked]>
Date: Fri, 01 Mar 2002 11:26:48 +0000

...Umm,

So if the Target-URI is changed in the middle of the dialog by a 
re-Invite it makes sense that the underlying Media Stream will be 
changed as well?

Why sending signaling to one place, and sending Media Streams to another 
place?

Ofir

Gonzalo Camarillo wrote:

> Hi,
> 
> That's right. The only thing that you can change in the target... well,
> if you consider the local and remote cseqs as pieces of state as well,
> they change in every request.
> 
> Gonzalo
> 
> Ofir Arkin wrote:
> 
>>So, there is no way to change other state information other than the
>>last hop (target URI)?
>>
>>Ofir
>>
>>Gonzalo Camarillo wrote:
>>
>>
>>>It will change the last hop (the target) for the route of the dialog.
>>>
>>>Gonzalo
>>>
>>>Ofir Arkin wrote:
>>>
>>>
>>>>What 'state' information does this change?
>>>>For example if I send a Re-INVITE within a dialog what 'state'
>>>>information will the Re-INVITE change?
>>>>
>>>>
>>>>
>>>>>>Second Question:
>>>>>>Why this might change the target URI?
>>>>>>I must admit that the target refresh thing got me really confused...
>>>>>>
>>>>>>
>>>>>>
>>>>>This mechanism allows an endpoint to change the URI it wants to be
>>>>>handed in future requests within this dialog. This can be used as a
>>>>>place to store state for future requests. The original proponents
>>>>>planned to use this as part of the mechanics to deal with mobility
>>>>>(address mobility in particular). I don't believe those ideas have
>>>>>been fleshed out.
>>>>>
>>>>>
>>>>
>>>>--
>>>>Ofir Arkin
>>>>Managing Security Architect
>>>>@stake, Limited.
>>>>http://www.atstake.com
>>>>email:
>>>>[email-masked]
>>>>Tel:
>>>>+44 (0) 207 495 7002
>>>>Fax:
>>>>+44 (0) 207 495 7062
>>>>Mobile: +44 (0) 779 630 8632
>>>>
>>>>-----------------------------
>>>>The information transmitted is intended only for the person or entity to
>>>>which it is addressed and may contain confidential and/or privileged
>>>>material.  Any review, re transmission, dissemination or other use of,
>>>>or taking of any action in reliance upon, this information by persons or
>>>>entities other than the intended recipient is prohibited.  If you
>>>>received this in error, please contact the sender and delete the
>>>>material from any computer.
>>>>
>>>>_______________________________________________
>>>>Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
>>>>This list is for NEW development of the core SIP Protocol
>>>>Use [email-masked] for questions on current sip
>>>>Use [email-masked] for new developments on the application of sip
>>>>
>>>>
>>--
>>Ofir Arkin
>>Managing Security Architect
>>@stake, Limited.
>>http://www.atstake.com
>>email:
>>[email-masked]
>>Tel:
>>+44 (0) 207 495 7002
>>Fax:
>>+44 (0) 207 495 7062
>>Mobile: +44 (0) 779 630 8632
>>
>>-----------------------------
>>The information transmitted is intended only for the person or entity to
>>which it is addressed and may contain confidential and/or privileged
>>material.  Any review, re transmission, dissemination or other use of,
>>or taking of any action in reliance upon, this information by persons or
>>entities other than the intended recipient is prohibited.  If you
>>received this in error, please contact the sender and delete the
>>material from any computer.
>>
> 

-- 
Ofir Arkin
Managing Security Architect
@stake, Limited.
http://www.atstake.com
email: 
[email-masked]
Tel: 
+44 (0) 207 495 7002
Fax: 
+44 (0) 207 495 7062
Mobile: +44 (0) 779 630 8632	

-----------------------------
The information transmitted is intended only for the person or entity to 
which it is addressed and may contain confidential and/or privileged 
material.  Any review, re transmission, dissemination or other use of, 
or taking of any action in reliance upon, this information by persons or 
entities other than the intended recipient is prohibited.  If you 
received this in error, please contact the sender and delete the 
material from any computer.

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: [email-masked]
Date: Fri, 1 Mar 2002 13:38:47 +0200

> -----Original Message-----
> From: ext Ofir Arkin [mailto:[email-masked]]
> Sent: Friday, March 01, 2002 1:27 PM
> To: Gonzalo Camarillo
> Cc: Robert Sparks; SIP
> Subject: Re: [Sip] Question about Section 12.2 Requests 
> within a Dialog
> 
> 
> ...Umm,
> 

Possible, but not necessary.

> Why sending signaling to one place, and sending Media Streams 

3PCC is one example.

Regards,
Hisham