Subject: [Sip] question on many-folks-draft05

From: "Salva Rey Calatayud" <[email-masked]>
Date: Fri, 15 Mar 2002 10:54:52 +0100

Hello,

	There is no example shown in the draft where the callee, 
receiving the first INVITE, sends an UPDATE to the caller. Is there 
any reason for this, isn't it allowed?

	For what I've read, the UPDATE are treated in the same fashion 
as the request that created the dialog (section 6.2 draft-ietf-sip-
update-00 ), in this case an INVITE, and we all know that the callee 
can send a re-INVITE to modify session parameters. Is it really 
bound to the request that created the dialog, or should it be bound 
to the last request received, and not terminated yet?

thanks,
Salva

**********************************
Salvador Rey Calatayud,  M.Sc.
Siemens AG                       Room 53521
[email-masked]           Munich, Perlach 
Phone number : +49-16095178051
**********************************

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: William Marshall <[email-masked]>
Date: Fri, 15 Mar 2002 09:16:24 -0500 (EST)

Sending an UPDATE with a new offer is allowed, according to
the rules given in the update-02 draft.  It would be
required by the manyfolks procedures if the caller included
a "a=conf" line in the SDP - then the rules in section 7
would require the UAS to send an offer "as soon as allowed
by the SIP offer/answer rules."

However, the initial answer to an offer contained in the INVITE
needs to be in a response related to the INVITE, e.g. a reliable
provisional one.  Use of UPDATE is not appropriate for the answer.

Bill Marshall
[email-masked]

-----original message-----
From: "Salva Rey Calatayud" <[email-masked]>
To: [email-masked]
Date: Fri, 15 Mar 2002 10:54:52 +0100
Subject: [Sip] question on many-folks-draft05

Hello,

thanks,
Salva