Subject: [Sip] Clarification relating to the Path header usage.

From: [email-masked]
Date: Tue, 5 Mar 2002 01:50:03 +0530

Hello Jonathan,

Recently you had posted to the mailing list suggesting
that the Path header fulfills 2 requirements: One (which
was under debate) regarding me knowing the path that
outgoing requests I originate should take. This was regarding
loose source-routing. The other one is mentioned below
from your text:

> Path fills two needs, and you have omitted the second
> one. The second one is so that INCOMING calls to me,
> can be routed from my home proxy through an intermediate
> proxy that needs to be visited. I think this is well
> within the scope of an extension to REGISTER, and I know
> of no other alternative to solve it. This is needed for
> any kind of visiting/roaming network where a local proxy
> needs to be visited for incoming calls.

My doubt is regarding this second usage. This works well
when the home proxy knows that there is one and only one
hop that is to be covered between the home proxy and me.
In case there are more than one hops to be traversed, does
each hop in the path need to remember the previous hop?

Consider the scenario:

UA1 --> P1 --> P2 --> registrar
                    |
                    |
                   home_proxy <-- UA2

registrar remembers Path as <sip:P2>, <sip:P1> for reaching
UA1. Now UA2 tries to reach UA1 via is home proxy. The query
with the registrar returns that both P2 and P1 should be
contacted (in that order).

So far so good. Now, how does "home_proxy" convey the information
that P2 should send the request to P1? It cannot add a Route
header. Should home_proxy add the Path header to the request
from UA2 and *somehow* make P1 understand this is the next hop?
If so, how? Details for this are missing in the draft....
Or am I missing something here?

Regards,
Siddharth.
--------------------
Siddharth Toshniwal @ Hughes Software Systems.
http://www.hssworld.com

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Dean Willis" <[email-masked]>
Date: Tue, 5 Mar 2002 11:07:51 -0600

> Or am I missing something here?

There can be as many nides recorded in the Path (or REGISTER Record-Route if
you want to call it that) as needed.

If I'm reading this right:

The thing you are calling "registrar" need s to also be  UA1's home proxy.

So it actually looks more like this

UA1---P1---P2---UA1HOME/REGISTRAR---UA2HOME---UA2

UA2 sends an INVITE through its home proxy, which uses whatever resolution
mechanism (such as DNS) needed to find UA1's home proxy and send the INVITE
there.

UA1's home proxy stored the Path or REGISTER Record-Route (or whatever we
call it) and attaches this as new loose-routing elements on the INVITE. This
results in transiting of P2 and P1 en route to UA1.

--
Dean