Subject: AW: [Sip] question on privacy 04

From: Ruppelt Christian <[email-masked]>
Date: Wed, 20 Mar 2002 17:34:14 +0100

The text in 7.1 Untrusted UAC Behavior
says: 
... and the UAC wants to control the privacy 
for any Remote-Party-ID ... by a downstream proxy.
Each of these RPID-privacy headers ...
to maintain privacy of the "addr-spec"

My question is: where does this "addr-spec" come from?
The proxy needs it to add a corresponding Remote-Party-ID.
Could this be outside the scope of the draft?

Christian       

-----Ursprüngliche Nachricht-----
Von: Flemming Andreasen [mailto:[email-masked]]
Gesendet: Mittwoch, 20. März 2002 16:27
An: Ruppelt Christian
Cc: [email-masked]
Betreff: Re: [Sip] question on privacy 04

It can send back a 407 and ask the UAC to authenticate itself. Note that this is
outside the scope of the privacy draft though.

-- Flemming

Ruppelt Christian wrote:

> How could the Proxy-o determine the identity of UA-o (see basic privacy example)?
> The From field (cryptographically random identifier, non identifying hostname)
> could not be used for this. The Remote-Party-ID header is not sent by UA-o.
>
> regards
> Christian
>
> _______________________________________________
> Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
> This list is for NEW development of the core SIP Protocol
> Use [email-masked] for questions on current sip
> Use [email-masked] for new developments on the application of sip

--
Flemming Andreasen
Cisco Systems

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Flemming Andreasen <[email-masked]>
Date: Mon, 25 Mar 2002 15:20:05 -0500

> My question is: where does this "addr-spec" come from?

Most likely, the proxy has access to a database that can map from the authenticated
identity to the actual addr-spec to use for the Remote-Party-Id.

> Could this be outside the scope of the draft?

Yes. The draft simply assumes that the identity has been determined and the proxy
inserts a corresponding addr-spec in the Remote-Party-Id.

-- Flemming

--
Flemming Andreasen
Cisco Systems