Subject: [Sip] Behaviour of a UAC on timeout

From: [email-masked]
Date: Tue, 12 Mar 2002 11:01:27 +0200

Section 12.2.1.2 says 

"The UAC will receive responses to the request from the transaction
layer. If the client transaction returns a timeout this is treated as a 408 (Request Timeout) response. 1999"

then it goes on to say 

"A UAC SHOULD also terminate a dialog if no response
at all is received for the request (the client transaction would inform the TU about the timeout.) 2008
For INVITE initiated dialogs, terminating the dialog consists of sending a BYE. 2009"

So, do we treat it as a 408 or terminate the dialog with a BYE? No where in the spec does it say that a if the UAC receives a 408 to an INVITE, it should terminate the dialog.

Regards,
Hisham Khartabil

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: [email-masked]
Date: Tue, 12 Mar 2002 11:07:41 +0200

I've answered my own question. This is for requests within a dialog.

Regards,
Hisham

> -----Original Message-----
> From: Khartabil Hisham (NMP/Helsinki) 
> Sent: Tuesday, March 12, 2002 11:01 AM
> To: [email-masked]
> Subject: [Sip] Behaviour of a UAC on timeout
> 
> 
> Section 12.2.1.2 says 
> 
> layer. If the client transaction returns a timeout this is 
> treated as a 408 (Request Timeout) response. 1999"
> 
> then it goes on to say 
> 
> at all is received for the request (the client transaction 
> would inform the TU about the timeout.) 2008
> So, do we treat it as a 408 or terminate the dialog with a 
> BYE? No where in the spec does it say that a if the UAC 
> receives a 408 to an INVITE, it should terminate the dialog.
> 
> Regards,
> Hisham Khartabil
>