Subject: [Sip] (no subject)

From: Aditi Budhraja <[email-masked]>
Date: Sat, 16 Mar 2002 01:44:14 -0800 (PST)

Hi
 I have a couple of questions related to service logic
creation and sip extension drafts
a) Are there provisions by which the existing SIP
stack can be extended to support the extension drafts
that IETF comes up with.In other words,are there APIs
by which new messages/headers/content types canbe
created in existing SIP entities without coming out
with a new version of the same.Pls illustrate with an
example
b) Service logic creation tools such as CPL etc can
provide service creation by looking into existing
messages etc.What happens when an extension comes up
that introduces a new message/header etc that might
have to be used to create a new service.Is there a
provision to handle this relationship between
scripting languages etc and new extensions to the
protocol.eg How do I create a new service using
instant messaging with CPL which I don't think
understands SUBSCRIBE/NOTIFY messages
c) Is there any draft for service creation in 3g
networks
Thanks
Aditi

__________________________________________________
Do You Yahoo!?
Yahoo! Sports - live college hoops coverage
http://sports.yahoo.com/

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Bobby Sardana <[email-masked]>
Date: Sat, 16 Mar 2002 10:59:34 -0800

Comments inline!

Aditi Budhraja wrote:
>...

Please check the following:

http://www.cs.columbia.edu/sip

There are many SIP stacks available and can be extended to
perform what you want.

>understands SUBSCRIBE/NOTIFY messages

An extensible SCE, that understands CPL, would be required 
to perform what you want. I am not aware of one in the SIP
world. 

Regards,

Bobby Sardana.
[email-masked]