Subject: Re: [Sip] SDP in unreliable 18x

From: "Salva Rey Calatayud" <[email-masked]>
Date: Mon, 18 Mar 2002 11:38:07 +0100

Hi,

	see at end (again)

On 15 Mar 2002, at 19:53, Gonzalo Camarillo wrote:

> Hi,
> 
> Salva Rey Calatayud wrote:
> > 
> > Hi,
> > 
> >         please see inline at end,
> > 
> > On 7 Mar 2002, at 22:01, Jonathan Rosenberg wrote:
> > 
> > >
> > >
> > > Christer Holmberg wrote:
> > > >
> > > > Hi Bob,
> > > >
> > > > > >Now, does this mean I'm not allowed to send an SDP 
in an UN-reliable
> > > > > >18x? And, if I do, is it then not regardes as an answer?
> > > > >
> > > > > You are allowed to send SDP in an unreliable 1xx. 
However, it MUST be
> > > > the
> > > > > same as the SDP you will send in a 2xx. The key 
sentence is "That same
> > > > exact
> > > > > answer MAY also be placed in any provisional 
responses sent prior to
> > > > the
> > > > > answer."
> > > >
> > > > True. But, in this case the UAC is not allowed to send a 
new offer (eg
> > > > using
> > > > UPDATE) before it has received the final response.
> > >
> > > Right. The idea was to try and add a semblance of 
compatibility with
> > > existing implementations. We want everything to be mapped 
to a set of
> > > non-overlapping O/A exchanges. So, the idea is that the 
SDP in an
> > > unrealiable 18x, and the SDP in a 2xx, are just the same 
answer. THus,
> > > we maintain the property of everything being a series of O/A 
exchanges,
> > > but allow a single answer to be present in multiple sip 
responses.
> > >
> > > However, it is NOT allowed, to send an offer in INVITE, an 
answer in a
> > > reliable 183, and then repeat the answer in the next reliable 
183. Thats
> > > because the answer has to be 
in the first reliable response 
sent back,
> > > which is the first 183. The SDP in the second 183 would be 
illegal,
> > > since it would be an offer, and those can't go in responses 
after the
> > > first SDP.
> > 
> >         I don't quite understand why these new offer on th
> > e reliable 183
> > would be illegal. Isn't it conveyed on a reliable delivered 
message. I
> > thought that was the only condition for O/A exchanges. or is it 
that
> > it's only allowed one O/A exchange per transaction?
> > 
> 
> It is illegal to avoid glare conditions, where you could not refuse 
the
> offer in the provisional response even though you would have sent 
an
> UPDATE.
> 
> The update draft outlines when you can send an offer and how.

 I never mentioned the UPDATE method being used here. could 
you answer my question why a second 183 rel conveying a second 
offer is illegal? feel free to give references to sections in drafts.

In a couple of my questions you always refer me to the update draft 
and suggested that I should read it. What does it make you think I 
haven't? If everything was so clear in the drafts we wouldn't be 
needing at all this mailing lists. I am afraid that drafts are far from 
error-free documents. So, be gentler and try to give an answer to 
questions instead of making references to documents all the time. 
And one second question on this email : 

	How many lines in the update draft mention that a UAS can 
issue an UPDATE?

thanks and regards,
Salva
**********************************
Salvador Rey Calatayud,  M.Sc.
Siemens AG                       Room 53521
[email-masked]           Munich, Perlach 
Phone number : +49-16095178051
**********************************

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Gonzalo Camarillo <[email-masked]>
Date: Mon, 18 Mar 2002 20:51:01 +0200

Hi,

> offer is illegal? feel free to give references to sections in drafts.

Because the UAC may be issuing an UPDATE at the same time as you are
sending this reliable response. You would have a glare condition in this
case, and since you cannot refuse a response saying "we have a glare
situation", the glare cannot be solver. You could say that the UPDATe
always win, but this does not seem like a good solution.

>         How many lines in the update draft mention that a UAS can

A UAS does not issue requests. UAS generate responses. If the "callee's
UA" generates an UPDATE, it is acting as a UAC.

Regards,

Gonzalo
-- 
Gonzalo Camarillo                    Phone :   +1 212 939 71 71
Columbia University                  Mobile:  +358 40 702 35 35
472 Computer Science Building        Fax   :  +358  9 299 30 52
1214 Amsterdam Ave., Mail Code 0401  http://www.hut.fi/~gonzalo
New York, NY 10027                   
USA                              [email-masked]