Subject: RE: [Sip] Some bis-09 findings

From: Alexandre Charest <[email-masked]>
Date: Wed, 6 Mar 2002 12:15:33 -0500

CANCEL request are hop-by-hop too and since each hop MUST wait until it
received a response before issuing the CANCEL there is no problem.

Alexandre C.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: March 6, 2002 12:10 PM
To: [email-masked]
Cc: [email-masked]
Subject: RE: [Sip] Some bis-09 findings

Christer,

> -----Original Message-----
> From: ext Christer Holmberg [mailto:[email-masked]]
> Sent: 06. March 2002 18:31
> To: Honeisen Bernhard (NET/Helsinki)
> Cc: [email-masked]
> Subject: Re: [Sip] Some bis-09 findings
> 
> 
> 
> Hi Bernhard,
> 
> > In the following some findings in the bis-09 draft
> > (all line numbers refer to pdf version):
> >
> > * lines 1464-1465: If no provisional response has been 
> received, the CANCEL request MUST
> >    NOT be sent;
> >
> >   I guess, this also applies even if a 100 Trying has been received.
> >   Should be clarified.
> 
> No. You ARE allowed to send a CANCEL if you have received a 
> 100 Trying.

Are you sure? In line 1471-72 there is an explanation, which 
indicates somehow differently.

        If it was allowed to send the CANCEL before receiving a
        response for the previous request, the server could receive
        the CANCEL before the original request.

As "100 Trying" are sent hop-to-hop, thus the UA could only have
received a 100 Trying from the first proxy, and 
the registrar server, which can be behind several proxies, might
not have received the original REGISTER request.

Or did I miss something?

cheers,
 Bernie 

> Regards,
> Christer Holmberg
> Ericsson Finland

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: [email-masked]
Date: Wed, 6 Mar 2002 19:10:11 +0200

Christer,

Or did I miss something?

cheers,
 Bernie