Subject: RE: [Sip] Path to Working Group Item

From: "George Foti (LMC)" <[email-masked]>
Date: Mon, 4 Mar 2002 07:36:31 -0500

inline

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: Monday, March 04, 2002 7:29 AM
> To: George Foti (LMC)
> Cc: Dean Willis; [email-masked]
> Subject: RE: [Sip] Path to Working Group Item
> 
> 
> George Foti (LMC) writes:
> 
>  > First, you are extending the meaning of record-route in core SIP. 
>  > Secondly,  it does not fully solve the problem of 3GPP, as 
> the registrar
>  > will need to include itself in the PATH, in the response 
> sent to the mobile
>  > for subsequent requests.
> 
> what i'm proposing is make record routing now to apply also to the
> register messages, which is much cleaner that inventing a new message
> for the same purpose.  by record routing a register message, 
> the network
> allows registering both the contact address and the route to it, which
> is consistent of the meaning of record route.
> 
> your other "requirement", i.e., that the mobile should get back the
> route to be used for subsequent requests, i have already before
> dismissed as bogus, because it is grossly against the sip protocol
> architecture. in sip, register messages do not establish a 
> dialogue and

It does not establish a dialogue. It establishes a PATH.
If you dont want to bother to understand the 3GPP architecture, stop making
*silly* comments about a requirement being bogus.
I suggest that you read more before making *irresponsible* statements
specially when you talk about saving bandwidth

> in sip anyone is able to make a call without first registering itself.
> 
> -- juha
> 

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: [email-masked]
Date: Mon, 4 Mar 2002 14:43:45 +0200

> specially when you talk about saving bandwidth

george,

calm down, this is just a game, not a personal affair.  no matter what
you call your thing, in sip there is no need to establish anything
before a ua can start sending invite and other non-register messages.
any "requirement" that doesn't accept that is bogus.

-- juha