Subject: [Sip] non-SIP-URI and tag

From: "Christer Holmberg (LMF)" <[email-masked]>
Date: Thu, 21 Mar 2002 19:39:15 +0100

Hi,

As we have discussed before, if a SIP-URI contains URI parameters the URI must be put between brackets. Otherwise the parameters will be regarded as header parameter (eg the tag parameter).

Now, since we are allowed to use other kinds of URIs in the To- and From headers (my client may not know the specific semantics of those), and the ABNF allows those URIs to contain the ";" characters (which are used to separate parameters in the SIP-URI), does this mean that ALL URIs must be put within brackets if they contain the ";" character - even if it doesn't have anything to do with URI parameters (I assume that is possible)?

Otherwise, when my parser finds a ";" character when parsing the non-SIP-URI, how does it now if the character is simply a character within some part of the URI, or if it separates URI parameters, or if it separates the URI from the rest of the header?

Regards,

Christer Holmberg
Ericsson Finland

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Christer Holmberg <[email-masked]>
Date: Tue, 26 Mar 2002 19:20:01 +0200

Any comments/clarifications on this?

Regards,

Christer Holmberg
Ericsson Finland

---

From: Sean Olson <[email-masked]>
Date: Tue, 26 Mar 2002 10:29:02 -0800 (PST)

Consistency is best. If the URI is not in
angle brackets, the semicolon should mark the
end of the URI and the start of the addr-spec 
parameters.

/sean

--- Christer Holmberg
<[email-masked]> wrote:
> > As we have discussed before, if a SIP-URI contains
> URI parameters the URI must be put between brackets.
> Otherwise the parameters will be regarded as header
> parameter (eg the tag parameter).
> >
> > Now, since we are allowed to use other kinds of
> URIs in the To- and From headers (my client may not
> know the specific semantics of those), and the ABNF
> allows those URIs to contain the ";" characters
> (which are used to separate parameters in the
> SIP-URI), does this mean that ALL URIs must be put
> within brackets if they contain the ";" character -
> even if it doesn't have anything to do with URI
> parameters (I assume that is possible)?
> >
> > Otherwise, when my parser finds a ";" character
> when parsing the non-SIP-URI, how does it now if the
> character is simply a character within some part of
> the URI, or if it separates URI parameters, or if it
> separates the URI from the rest of the header?
> >
> > Regards,
> >
> > Christer Holmberg
> > Ericsson Finland
> >
> > Sip mailing list 
> https://www1.ietf.org/mailman/listinfo/sip
> Sip mailing list 
> https://www1.ietf.org/mailman/listinfo/sip

=====
Sean Olson <[email-masked]>

__________________________________________________
Do You Yahoo!?
Yahoo! Movies - coverage of the 74th Academy Awards®
http://movies.yahoo.com/

---

From: Christer Holmberg <[email-masked]>
Date: Wed, 27 Mar 2002 07:36:05 +0200

Hi,

> Consistency is best. If the URI is not in angle brackets, the
> semicolon should mark the end of the URI and the start of the
> addr-spec parameters.

If we can agree on that, for ANY URI (no matter if the semicolon can be
used for other "non-parameter delimiter" purposes within the URI), I am
more than happy :)

Thanks!

Christer Holmberg
Ericsson Finland