Subject: RE: [Sip] Codecs selection & QoS reservation--Manyfolks

From: "Chen, Xin (Xin)" <[email-masked]>
Date: Thu, 21 Mar 2002 17:33:15 -0000

Hi Juan,

Unless we have a globle QoS mapping standards or both ends use same QoS
reservation protocol, I double both ends will get the same answer which
needs more QoS.

Xin Chen

Lucent Technologies
Tel: +44 1793 883137
Mobile: +44 7799 034668

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: 21 March 2002 17:25
To: Chen, Xin (Xin)
Cc: [email-masked]
Subject: Re: [Sip] Codecs selection & QoS reservation--Manyfolks

Hi,

Indeed, parties can use any of those negotiated codecs in the list without
session re-negotiation.
Therefore, should both end-points take into account the highest bandwidth
requirements for resource reservation ?

Best regards
Juan Carlos

"Chen, Xin (Xin)" <[email-masked]>@ietf.org on 21/03/2002 17:52:59

Sent by:  [email-masked]

To:   [email-masked]
cc:
Subject:  [Sip] Codecs selection & QoS reservation--Manyfolks

Hi,

There a case in my mind:

A offers one m= line with 5 codecs also with precondition either local or
e2e, B answers with 3 of the 5, and according to manyfolks, both A and B
starts to QoS reservation either local or e2e.

Since there are 3 codecs can be used for communication, is there a problem
that A and B reserve the QoS based on different codecs, let's assume that
the codec A used for QoS reservation requires higher QoS that B used, will
there be a problem for the session?

This is like the one-of-N codecs problem mentioned in unify draft.

Shall we mandate that A and B always use the first codec for QoS
reservation
since the first one is the prefered one?

Xin Chen

Lucent Technologies
Tel: +44 1793 883137
Mobile: +44 7799 034668

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Gonzalo Camarillo <[email-masked]>
Date: Mon, 25 Mar 2002 19:08:15 +0200

Hi,

As Juan Carlos pointed out, you always perform reservations for the
highest bandwidth codec (if bandwidth is the metric you use for QoS).

Regards,

Gonzalo

-- 
Gonzalo Camarillo                    Phone :   +1 212 939 71 71
Columbia University                  Mobile:  +358 40 702 35 35
472 Computer Science Building        Fax   :  +358  9 299 30 52
1214 Amsterdam Ave., Mail Code 0401  http://www.hut.fi/~gonzalo
New York, NY 10027                   
USA                              [email-masked]