Subject: Re: [Sip] Timeout condition in hold state

From: [email-masked]
Date: Mon, 25 Mar 2002 11:05:10 -0500

This appears to be more concerned with specific call processing issues and
policies than with SIP. It should be handled outside of SIP. A similar
concern could be raised about long duration calls. A stateful proxy will
reserve resources for all calls. If no activity is seen on a call for a
significant period of time, what should be done? Currently in the PSTN in
North America, calls are terminated in the network if they have been up for
48 hours to preserve resources. I do not see this being as SIP issue as
well although it will  need to be implemented on  SIP-enable systems.

"Nagaraj" <[email-masked]>@ietf.org on 03/25/2002 01:15:32 AM

Sent by:  [email-masked]

To:   <[email-masked]>, <[email-masked]>
cc:

Subject:  [Sip] Timeout condition in hold state

Hi all,

Is there any provision in SIP to take  care of the timeout in holding
condition ?

Consider a situation:

ua-A  establishes a SIP session with  ua-B.
After some time ua-B requests for a hold by using  INVITE method.
ua-A goes into "hold" state and waits for ua-B to  resume.

If now network goes down at ua-B, and he  disconnects without sending any
more SIP messages,
how ua-A will come to know  about it.

Is there a mechanism for determining  timeout value for ua-A, so that he
wont wait forever.

Regards,

-Nagaraj.

Nagaraj. Bhat.
Smart Yantra Technologies Pvt  Ltd
#57, 3rd Floor, HMT Layout
Behind R.T. Nagar Police Station
R.T.  Nagar
Bangalore - 560032
Phone: 91-80-3634917 / 91-80-3634918
Fax:  91-80-3631927

[email-masked]
[email-masked]
[email-masked]

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Victor Paulsamy" <[email-masked]>
Date: Mon, 25 Mar 2002 17:38:57 -0800

Nagaraj,

Take a look at
http://www.ietf.org/internet-drafts/draft-ietf-sip-session-timer-08.txt

Another handy tool would be RTCP packets. Hope this helps.

Regards,

--victor

Victor Paulsamy               E-mail: [email-masked]
Senior Software Engineer      Phone : 650.930.1339 (Direct)
Zapex Technologies, Inc.      Phone : 650.930.1300 (Main)
Mountain View, CA 94043       Fax   : 650.930.1399

> -----Original Message-----
> From: [email-masked]
> [mailto:[email-masked]]On Behalf Of
> [email-masked]
> Sent: Monday, March 25, 2002 8:05 AM
> To: Nagaraj
> Cc: [email-masked]; [email-masked]
> Subject: [Sip-implementors] Re: [Sip] Timeout condition in hold state
>
>
>
> Sip-implementors mailing list
> [email-masked]
> http://lists.cs.columbia.edu/mailman/listinfo/sip-implementors
>

---

From: "Nagaraj" <[email-masked]>
Date: Tue, 26 Mar 2002 10:20:57 +0530

Thnx for the solution.
Regards.
-Nagaraj.