Subject: [Sip] Quick requestion about REFER+Replaces: examples

From: Kim Liu <[email-masked]>
Date: Fri, 22 Mar 2002 14:17:52 -0500

In draft-ietf-sip-refer-02.txt and draft-bhatia-3pcc-refer-01.txt there 
are several examples presented with the Replaces header in a URL as:

Refer-To: 
sip:[email-masked]?Replaces:12345%40192.168.118.3;to-tag=12345;from-tag=5FFE-3994;

Just to double check my understanding of the URL header parsing, 
shouldn't all of those be more or less:

Refer-To: 
sip:[email-masked]?Replaces=12345%40192.168.118.3%3bto%2dtag%3d12345%3bfrom%2dtag%3d5FFE%2d3994;

Just trying to make sure I haven't missed exactly where the to-tag and 
from-tag belongs in this case.

-- 
Kim Liu  [email-masked]    :  Everyone is a darn fool for at
Senior Software Engineer    :  least five minutes a day;
Lucent Technologies         :  wisdom consists of not
Clearwater, FL, 33761       :  exceeding the limit

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Alan Johnston <[email-masked]>
Date: Fri, 22 Mar 2002 14:29:04 -0600

Hi Kim,

You are right.  The lack of escaping makes the examples in these drafts
more readable but perhaps less accurate per the syntax.

Take a look at the SIP Service Examples draft
(http://search.ietf.org/internet-drafts/draft-ietf-sipping-service-examp
les-00.txt) that show the escaping of the Replaces header in Refer-To
headers.

Thanks,
Alan Johnston
WorldCom
sip:[email-masked]

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of Kim Liu
> Sent: Friday, March 22, 2002 1:18 PM
> To: [email-masked]
> Subject: [Sip] Quick requestion about REFER+Replaces: examples
> 
> 
> Use [email-masked] for questions on current 
> sip Use [email-masked] for new developments on the 
> application of sip
>

---

From: Rohan Mahy <[email-masked]>
Date: Wed, 27 Mar 2002 11:04:17 -0800 (Pacific Standard Time)

Hi,

the "-" in to-tag and from-tag is unreserved and therefore doesn't need to
be escaped.  technically we could have allowed "@" in hnv-unreserved
without making implementation of new parsers terribly difficult, but that
is water under the bridge now.

thanks,
-rohan