Subject: [Sip] draft-antti-rfc2806bis-02.txt

From: [email-masked]
Date: Thu, 7 Mar 2002 10:14:20 +0530

Hi,

I have a doubt regarding the new syntax  proposed for telurl .
In the draft  the grammar says
telephone-uri      =  "tel:" subscriber
        subscriber         =  global-number / local-number
        global-number      =  "" 1*phonedigit [isdn-subaddress]
        *other
        local-number       =  1*(phonedigit / HEXDIGIT )
        [isdn-subaddress]
        context *other
        isdn-subaddress    =  ";isub=" 1*phonedigit
        context            =  ";context-tag=" 1*uric
        other              =  ";" oname "=" ovalue
        oname              =  1*uric
        ovalue             =  *uric
        phonedigit         =  DIGIT / visual-separator
        visual-separator   =  "-" / "." / "(" / ")"

If we see the syntax  for "other "

         other   =  ";" oname "=" ovalue
        oname              =  1*uric
        ovalue             =  *uric

Here what is the significance of keeping an  "=" as a must  after oname ,
since ovalue is zero or more.
Since it can be oname =   .

Instead of that why cant we  keep other as   other = oname   | oname
["="  1*uric].
If I am wrong please correct me.

regards
mahesh@hughes software systems

This message is proprietary to Hughes Software Systems Limited (HSS) and is
intended solely for the use of the individual to whom it is addressed.  It
may contain privileged or confidential information and should not be
circulated or used for any purpose other than for what it is intended.  If
you have received this message in error, please notify the originator
immediately.  If you are not the intended recipient, you are notified that
you are strictly prohibited from using, copying, altering, or disclosing
the contents of this message.  HSS accepts no responsibility for loss or
damage arising from the use of the information transmitted by this email
including damage from virus.

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Henning Schulzrinne <[email-masked]>
Date: Thu, 07 Mar 2002 09:14:02 -0500

Good point; it will be corrected in the next version. (The discussion of
the draft belongs in IPTEL, not the SIP WG, btw.)