Subject: Re: [Sip] question on many-folks-draft05

From: "Salva Rey Calatayud" <[email-masked]>
Date: Fri, 15 Mar 2002 15:56:46 +0100

see inline please,

On 15 Mar 2002, at 9:16, William Marshall wrote:

> Sending an UPDATE with a new offer is allowed, according to
> the rules given in the update-02 draft.  
how should this UPDATE be treated at the caller side (for this 
transaction taking the UAS role)? as a re-INVITE nested in an 
INVITE? is this allowed?

It would be
> required by the manyfolks procedures if the caller included
> a "a=conf" line in the SDP - then the rules in section 7
> would require the UAS to send an offer "as soon as allowed
> by the SIP offer/answer rules."
> 
> However, the initial answer to an offer contained in the INVITE
> needs to be in a response related to the INVITE, e.g. a reliable
> provisional one.  Use of UPDATE is not appropriate for the 
answer.
how can then the callee inform of the progression of the resource 
reservation? I am not sure if its allowed more than one offer/answer 
exchange per transaction. If it is, great, then we can send different 
offers updating the state from the callee to the caller on 183 rel and 
getting answers back in PRACK's, but if it's not allowed? note that 
a 200 OK shouldn't be issued by the callee until resource 
reservation has succeeded.

Salva Rey
[email-masked]

> 
> Bill Marshall
> [email-masked]
> 
> -----original message-----
> From: "Salva Rey Calatayud" <[email-masked]>
> To: [email-masked]
> Date: Fri, 15 Mar 2002 10:54:52 +0100
> Subject: [Sip] question on many-folks-draft05
> 
> Hello,
> 
> 	There is no example shown in the draft where the callee, 
> receiving the first INVITE, sends an UPDATE to the c
aller. Is 
there 
> any reason for this, isn't it allowed?
> 
> 	For what I've read, the UPDATE are treated in the same fashion 
> as the request that created the dialog (section 6.2 draft-ietf-sip-
> update-00 ), in this case an INVITE, and we all know that the 
callee 
> can send a re-INVITE to modify session parameters. Is it really 
> bound to the request that created the dialog, or should it be 
bound 
> to the last request received, and not terminated yet?
> 
> thanks,
> Salva
> 
> **********************************
> Salvador Rey Calatayud,  M.Sc.
> Siemens AG                       Room 53521
> [email-masked]           Munich, Perlach 
> Phone number : +49-16095178051
> **********************************
> 
> 
> _______________________________________________
> Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
> This list is for NEW development of the core SIP Protocol
> Use [email-masked] for questions on current 
sip
> Use [email-masked] for new developments on the application of 
sip

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Gonzalo Camarillo <[email-masked]>
Date: Fri, 15 Mar 2002 19:56:59 +0200

Hi,

> transaction taking the UAS role)? as a re-INVITE nested in an

Yes, it is allowed. Read the update draft.

> reservation has succeeded.

The callee sends his first offer in a 1xx rel response and then UPDAPTEs
are used. Read the update draft.

Anyway, in one of the examples it is said that the 200 OK response for
the INVITE carries an offer, when it should be said that an UPDATE
carries the offer. This has already been reported and I will fix it.

Regards,

Gonzalo

-- 
Gonzalo Camarillo                    Phone :   +1 212 939 71 71
Columbia University                  Mobile:  +358 40 702 35 35
472 Computer Science Building        Fax   :  +358  9 299 30 52
1214 Amsterdam Ave., Mail Code 0401  http://www.hut.fi/~gonzalo
New York, NY 10027                   
USA                              [email-masked]