Subject: [Sip] Some bis-09 findings

From: [email-masked]
Date: Wed, 6 Mar 2002 17:56:38 +0200

Hi!

In the following some findings in the bis-09 draft
(all line numbers refer to pdf version):

* lines 1464-1465: If no provisional response has been received, the CANCEL request MUST
   NOT be sent; 

  I guess, this also applies even if a 100 Trying has been received.
  Should be clarified.

*  lines 2573-2576, A proxy MUST NOT add additional targets to the target set if the
   Request-URI of the original request does not indicate a resource this
   proxy is responsible for.

   1) Does this mean, that in general the R-URI cannot be changed
       by a proxy, unless the R-URI points to this proxy?

   2) Does this mean,  that in general no new Route headers can be
       pushed to the Route-stack by a proxy, unless the R-URI points
       to this proxy?

   I think, the "MUST NOT" should be "SHOULD NOT" or
   a "IT IS NOT RECOMMENDED".
 
   Should be clarified.

* Furthermore I propose to add a definition for "target set" in section 6.

Regards,
 Bernie

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Christer Holmberg <[email-masked]>
Date: Wed, 06 Mar 2002 18:31:07 +0200

Hi Bernhard,

>   I guess, this also applies even if a 100 Trying has been received.

No. You ARE allowed to send a CANCEL if you have received a 100 Trying.

Regards,

Christer Holmberg
Ericsson Finland