Subject: RE: MESSAGE size limitations (Was: RE: [Sip] Message draft changes)

From: [email-masked]
Date: Wed, 22 May 2002 09:45:06 +0300

> Aki says:
> > I totally agree. However, I know of email lists / systems, 
> > which have local policy governing the sizes of attachments. I 
> > feel such optionality is currently missing from the MESSAGE 
> > draft. For example, the default content-indirection policy 
> > seems to be that the sender always performs it. How about if 
> > this was part of the recipient's service offering? Sort of 
> > like a safeguard for UAs behind the low-capacity links.
> 
> It's called a B2BUA or "in network UA" -- it accepts the SIP message,
> stores the content, and sends a new message (containing a pointer) on
> towards the user. Like other B2BUA-ish things, this capability is
> implicit in the current specification.

Yes, the capability is there, but since the sender itself is always responsible for enforcing the 1300 byte size limitation of the MESSAGE request, this effectively negates any need for such a UA in the network.

I was saying that it would be nice if the actual enforcement of the size limit could be relaxed, so that it could also be up to such a store-and-forward UA in the network. However, having said that I can't think of a simple way to make this happen.
 
Cheers,
Aki

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Ben Campbell <[email-masked]>
Date: Wed, 22 May 2002 08:26:12 -0500

>>Aki says:

[snip]

> I was saying that it would be nice if the actual enforcement of the size limit could be relaxed, so that it could also be up to such a store-and-forward UA in the network. However, having said that…

You would still have the congestion control issue to the b2bua. We are 
adding new wording to say that if you know you are congestion-safe all 
the way, you can exceed the limit. If that device is under your control 
in such a way that you can ensure congestion-safe transports all the way 
to the b2bua, then you would be covered.

Thanks!

Ben.

---

From: "Dean Willis" <[email-masked]>
Date: Wed, 22 May 2002 12:46:03 -0500

> Yes, the capability is there, but since the sender itself is
> always responsible for enforcing the 1300 byte size 
> limitation of the MESSAGE request, this effectively negates 
> any need for such a UA in the network.
> 
> I was saying that it would be nice if the actual enforcement
> of the size limit could be relaxed, so that it could also be 
> up to such a store-and-forward UA in the network. However, 
> having said that I can't think of a simple way to make this happen.

Ah. I think you're right. I'm not a fan of the 3261 wording on size
being blaneltly applied to message -- I think it far more reasonable to
make the forwarding deision on a per-sip-HOP basis, where the decision
maker has a reasonable understanding of the dynamics of the next hop,
and if we find a hop that has a smaller-than-message MTU and doesn't
support congestion control we reject and say "send smaller" . . .
There's much to be learned from Path-MTU discovery in TCP.

--
Dean