Subject: RE: [Sip] SIP WGLC of draft-ietf-sip-asserted-identity

From: "Elwell, John" <[email-masked]>
Date: Thu, 30 May 2002 13:31:13 +0100

Section 5, 3rd paragraph:
   "The proxy MAY add a P-Asserted-Identity header field with either a
   single SIP URI or a single SIPS URI.  Likewise, the proxy MAY add a
   P-Asserted-Identity header field with a single tel URL."

This seems to imply that a proxy can add a header even if there is already a
header of the type concerned. Presumably this should not be allowed.

--------------------------------------------------------------
John Elwell ([email-masked])
Siemens Communications Limited,
Technology Drive, Beeston,
Nottingham NG9 1LA, UK
Tel: +44 115 943 4989   Fax: +44 115 943 4969
--------------------------------------------------------------
	Internet communications are not secure and therefore Siemens
Communications Limited does not accept legal responsibility for the
contents of this message. Any views or opinions presented are solely
those of the author and do not necessarily represent those of Siemens
Communications Limited unless otherwise specifically stated.

> -----Original Message-----
> From: Dean Willis [mailto:[email-masked]]
> Sent: 28 May 2002 22:32
> To: 'sip'
> Cc: [email-masked]; [email-masked]; [email-masked]; 'Cullen
> Jennings'
> Subject: [Sip] SIP WGLC of draft-ietf-sip-asserted-identity
> 
> 
> 
> We need to do a quick working group last call on the 
> "Asserted Identity"
> draft.
> 
> Please submit comments to the list and draft editor IMMEDIATELY.
> 
> Draft available from:
> 
> http://www.softarmor.com/sipwg/drafts/draft-ietf-sip-asserted-
identity-0
0.html
http://www.softarmor.com/sipwg/drafts/draft-ietf-sip-asserted-identity-0
0.txt

And soon to be in the internet-drafts archive.

--
Dean

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Cullen Jennings" <[email-masked]>
Date: Thu, 30 May 2002 09:44:31 -0700

Yes, it should not be allowed. There can be at most one AI with a sip or
sips header and at most one AI with a tel. I agree the language is loose.
Any suggestion on what I should change this paragraph too?

What about:

   "The proxy MAY add a P-Asserted-Identity header field with either a
   single SIP URI or a single SIPS URI.  Likewise, the proxy MAY add a
   P-Asserted-Identity header field with a single tel URL. There can not be
   more that one of each of these so if there are existing
P-Asserted-Identity
   headers, they must be replaced."

I don't really like this either but it was the best I could do in 30
seconds - suggestions?

Thanks, Cullen

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of Elwell,
John
Sent: Thursday, May 30, 2002 5:31 AM
To: 'sip'
Subject: RE: [Sip] SIP WGLC of draft-ietf-sip-asserted-identity

identity-0
0.html

--
Dean

---

From: "Dean Willis" <[email-masked]>
Date: Thu, 30 May 2002 15:57:43 -0500

John Elwell pondered:
> This seems to imply that a proxy can add a header even if 
> there is already a header of the type concerned. Presumably 
> this should not be allowed.

Why?

There might be some issue with multiple tel URLs and gateway
interworking, but asserting multiple identities seems like a very
reasonable thing from a SIP perspective.

If you're a PGP user, you may well have multiple identities associated
with one PGO key. There are practical reasons for doing this, and it
doesn't seem to cause any problems.

Different proxies or authentication servers might "know you" by
different identities and be able to assert those identities on your
behalf. It might also be reasonable to have multiple assertions for the
same identity, like multiple signers in PGP.

Signed,

[email-masked]
[email-masked]
[email-masked]
[email-masked]

Ad nasueatum . . .