Subject: [Sip] Message draft changes

From: "Ben Campbell" <[email-masked]>
Date: Mon, 13 May 2002 14:16:26 -0500

Hi all,

I submitted draft-ietf-sip-message-04 last week. This version contains a few
AD requested changes, primarily in the area of congestion control.
Specifically:

1) Added an applicability statement clarifying the difference between the
pager and session models, and that this draft only defines the pager model.

2) Strengthened the congestion control section:

   * 1300 byte hard limit for physical payload size for pager model. This
applies to the actual payload only, not indirect content. Fragmenting
content across multiple requests is prohibited for pager model.

   * Overlapping MESSAGE requests outside of dialog but to same request-URI
are prohibited.
   * Overlapping MESSAGE requests inside a dialog are prohibited unless
every hop of the dialog uses a congestion-controlled transport, in which
case the strength is SHOULD NOT.

3) Trimmed the author list and added contributor section.

I do not believe we need to do another WGLC for these changes. Any new
feedback to 04 can be captured as part of the IETF last call.

The draft is available at:

http://www.ietf.org/internet-drafts/draft-ietf-sip-message-04.txt

Thanks!

Ben.

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: [email-masked]
Date: Wed, 22 May 2002 10:26:01 +0300

> -----Original Message-----
> From: ext Ben Campbell [mailto:[email-masked]]
> Sent: Tuesday, May 21, 2002 11:54 PM
> To: Dean Willis; 'Jonathan Rosenberg'
> Cc: Khartabil Hisham (NMP/Helsinki); Niemi Aki (NET/Espoo); 
> [email-masked]
> Subject: RE: [Sip] Message draft changes
> 

> 
> I assume the 1300 default was chosen for SIP in general 
> because of a belief
> that, if you have no knowledge of MTU size, that value is a 
> reasonable SWAG.
> I don't see how we can do any better for MESSAGE.

There is no need to mention anything about that in the MESSAGE draft. A reference to RFC3261 is enough for this issue.

Regards,
Hisham