Subject: [Sip] Re: Dialog-ID and Replaces reconciliation

From: "Miguel A. Garcia" <[email-masked]>
Date: Wed, 08 May 2002 10:55:51 +0300

Hi Eric:

The to-tag will be different only because Replaces will allow
a star "*". But if you consider that a star is a token, then
it is exacltly the same definition.

Rohan, any views on the proposed change to Replaces?

/Miguel

"Henrikson, Eric H (Eric)" wrote:
> 
> Miguel,
> 
> What you proposed looks fine.  I'm not certain about one thing though.  If
> the intent is to have the same definition for call-id, from-tag and to-tag,
> then there is still a difference with the proposed definitions of to-tag.
> Does this mean that only the Replaces header version of to-tag would apply
> if both headers are eventually adopted as standard headers?
> To put it another way, is it allowed to have multiple definitions of to-tag
> if both headers are adopted?
> 
> Eric
> 
> -----Original Message-----
> From: Miguel A. Garcia [mailto:[email-masked]]
> Sent: Monday, May 06, 2002 10:18 PM
> To: Henrikson, Eric H (Eric)
> Cc: [email-masked]; Rohan Mahy; Drage, Keith (Keith)
> Subject: Re: Dialog-ID and Replaces reconciliation
> 
> Eric, Rohan, Keith:
> 
> No rush. I think the important thing is to synchronize both headers.
> 
> My suggestion for both is to use the following syntax.
> 
>      P-Original-Dialog-ID = "P-Original-Dialog-ID" HCOLON dialog-value
>      dialog-value         = call-id COMMA to-tag COMMA from-tag
>                             [COMMA extension-param]
>      call-id              = "call-id" EQUAL callid
>      to-tag               = "to-tag" EQUAL token
>      from-tag             = "from-tag" EQUAL token
>      extension-param      = token [EQUAL (token | quoted-string)]
> 
> Example:
> 
> P-Original-Dialog-ID: call-id=03fdsslkdjfs, to-tag=23049, from-tag=04983
> 
> And for Replaces:
>       Replaces         = "Replaces" HCOLON replaces-values
>                           *(COMMA replaces-values)
> 
>       replaces-values  = call-id *( SEMI replaces-param )
>       call-id          = "call-id" EQUAL callid
>       replaces-param   = to-tag | from-tag | extension-param
>       to-tag           = "to-tag" EQUAL ( token | "*" )
>       from-tag         = "from-tag" EQUAL token
>       extension-param  = token [ EQUAL ( token | quoted-string ) ]
> 
> Example:
> 
> Replaces: call-id=03fdsslkdjfs, to-tag=23049, from-tag=04983
> 
> Is this acceptable???
> 
> /Miguel
> 
> "Henrikson, Eric H (Eric)" wrote:
> >
> > Miguel, Rohan,
> >
> > I took a look at the Replaces header and I see some similarities.
> However,
> > I don't think I'm going to have time today to rework the syntax and submit
> > all my 3GPP contributions.  So I think this will have to wait until later
> > this week.
> >
> > Eric
> >
> > -----Original Message-----
> > From: Miguel A. Garcia [mailto:[email-masked]]
> > Sent: Saturday, May 04, 2002 1:01 AM
> > To: [email-masked]; Rohan Mahy; Henrikson, Eric H (Eric); Drage, Keith
> > (Keith)
> > Subject: Dialog-ID and Replaces reconciliation
> >
> > Eric, Rohan:
> >
> > The SIP Replaces header and the P-Original-Dialog-ID header seem to
> > have some common parts. For instance, both define mechanisms to
> > transport the to-tag and the from-tag in the header value.
> >
> > I was wondering if it would be possible to re-use as much as possible
> > from the other.
> >
> > For instance, Replaces defines "to-tag" and "from-tag", whereas
> > P-Original-Dialog-ID defines "od-to-tag" and "od-from-tag". I think
> > it would be much better if P-Original-Dialog-ID defines "to-tag" and
> > "from-tag". The "original-dialog" meaning is implicitely carried
> > in the header name and syntax.
> >
> > This would allow easier definition of the SIP dictionary used in
> > compression, because we don't need different entries in the
> > dictionary. It would also allow to reuse as much as possible the
> > software code in an implementation.
> >
> > On the other hand, Replaces seems to lack a "call-id=" string.
> > P-Original-Dialog-ID has it, and it is certainly needed. Is there
> > a way to synchronize these two??
> >
> > I hope you can take my comments onboard.
> >
> > /Miguel
> >
> > --
> > Miguel-Angel Garcia                     Oy LM Ericsson AB
> >                                         Jorvas, Finland
> > mailto:[email-masked]     Phone:  +358 9 299 3553
> > mailto:[email-masked]        Mobile: +358 40 5140002
> 
> --
> Miguel-Angel Garcia                     Oy LM Ericsson AB
>                                         Jorvas, Finland
> mailto:[email-masked]     Phone:  +358 9 299 3553
> mailto:[email-masked]        Mobile: +358 40 5140002

-- 
Miguel-Angel Garcia                     Oy LM Ericsson AB
                                        Jorvas, Finland
mailto:[email-masked]     Phone:  +358 9 299 3553
mailto:[email-masked]        Mobile: +358 40 5140002

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Henrikson, Eric H (Eric)" <[email-masked]>
Date: Tue, 7 May 2002 12:07:52 -0500

Miguel,

Eric

-----Original Message-----
From: Miguel A. Garcia [mailto:[email-masked]]
Sent: Monday, May 06, 2002 10:18 PM
To: Henrikson, Eric H (Eric)
Cc: [email-masked]; Rohan Mahy; Drage, Keith (Keith)
Subject: Re: Dialog-ID and Replaces reconciliation

Eric, Rohan, Keith:

Example:

And for Replaces:

Example:

Is this acceptable???

/Miguel

However,