Subject: RE: [Sip] Asserted-Identity: How to 'hint'?

From: "Peterson, Jon" <[email-masked]>
Date: Sun, 19 May 2002 12:10:55 -0500

My argument was not that the proposed hint won't work - just that it isn't
necessary to solve the problem at hand. It might not be the case that the
problems with the hint stop at the philosophical point you mention below.
What I asked in my last mail was not whether or not we needed a hint, but
rather whether or not we should table that question until we resolve the
other questions at hand. I just don't want to spend the cycles arguing about
the hint given our very aggressive timetable - frankly, I think that
reaching consensus on this hint matter might push back our dates a bit.
Let's investigate this hint stuff in June, but for now just figure out how a
Trust Domain can manage an asserted identity in a message.

Jon Peterson
NeuStar, Inc.

> -----Original Message-----
> From: Rohan Mahy [mailto:[email-masked]]
> Sent: Sunday, May 19, 2002 8:29 AM
> To: Peterson, Jon
> Cc: [email-masked]
> Subject: Re: [Sip] Asserted-Identity: How to 'hint'?
> 
> 
> Hi,
> 
> The requirement for a hint is well understood, limited in
> scope, and well motivated in the draft.  Nobody has identified
> any technical reason why the hint won't work.   Your argument
> that allowing a hint weakens the strength of the language on
> ignoring Asserted-Identity from untrusted parties is purely
> philosophical in nature.  I don't buy your argument.
> 
> thanks,
> -rohan
> 
> 
> ---- Original message ----
> >Date: Fri, 17 May 2002 16:02:11 -0500
> >From: "Peterson, Jon" <[email-masked]>  
> >Subject: [Sip] Asserted-Identity: How to 'hint'?  
> >To: "[email-masked]'" <[email-masked]>
> >
> >
> >In the course of the discussion between Mark Watson, Cullen
> Jennings and
> >myself about the short-term identity work, we have returned a
> few times to
> >the question of the infamous hint. This hint is, of course, a
> way that a
> >user agent (one that is not a member of the Trust Domain in
> the short-term
> >network asserted identity space) can provide a 'hint' to the
> intermediary
> >that will generate an Asserted-Identity indicating which
> identity among
> >several possibilities should be asserted.
> >
> >The need for this arises particularly from the 3G space, in
> which the
> >authentication process takes place independently of SIP and
> does not carry
> >this sort of personal identity information. It also assumes
> that the
> >operators of the intermediary in question are aware of
> several legitimate
> >identities which the user can elect to assert.
> >
> >It has been proposed on the mailing list and elsewhere that the
> >Asserted-Identity header should be re-used by user agents
> outside the Trust
> >Domain to provide such a hint. I see a number of reasons for
> and against
> >using the Asserted-Identity for this purpose. For example,
> today, there is a
> >requirement that asserted-identities which are transmitted
> from untrusted
> >sources should not be used in any way - this would seem to
> weaken that
> >requirement. There is also possibly some behavior that still
> needs to be
> >specified (like how an intermediary would reject or otherwise
> handle a
> >request with an inappropriate hint) that might be impactful
> to our choice.
> >
> >For the time being, however, I would like to suggest that
> providing the hint
> >is outside the scope of the current deliverables (the
> asserted-identity
> >requirements and mechanism drafts), which need to be
> complete, as we
> >discussed in the interim meeting, by the end of this month. I
> believe that a
> >separate draft should propose the use of Asserted-Identity or
> any other
> >header for this hint (in whatever timeframe is appropriate
> for 3G's
> >requirements), but that we should not speak to this matter in
> the current
> >asserted-identity deliverables. There is, as I see it, no
> dependency on
> >defining this hint before we dictate how intermediaries will
> assert
> >identities.
> >
> >Any comments on this plan?
> >
> >Jon Peterson
> >NeuStar, Inc.
> >
> >_______________________________________________
> >Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
> >This list is for NEW development of the core SIP Protocol
> >Use [email-masked] for questions on current sip
> >Use [email-masked] for new developments on the application
> of sip
> 

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: [email-masked]
Date: Sun, 19 May 2002 20:58:49 +0300

Peterson, Jon writes:

 > necessary to solve the problem at hand. 

i don't know what problem you have in hand, but i definitely need the
hint to solve the problem that i (and anyone who gateways sip calls to
pstn) has in hand: i need a hint header, when i can't use the uri in the
from header as the hint, i.e., when the from is anonymous.

if the intention of the sip working group is only to solve 3gpp problems
and ignore the generic problems, then we either need another working
group or the 3gpp folks have to solve their problems somewhere else.
the area directors might be able to give a hint what we should do.

-- juha

---

From: "Cullen Jennings" <[email-masked]>
Date: Sun, 19 May 2002 18:27:29 -0700

I'm not really sure what you see as the problem at hand - I'm just guessing,
but ... If the Gateway was part of the Trust Domain, I think you can solve
the problem you want without the hint. If the GW is not part of the Trust
Domain then I don't see even how the hint will really help if all the
elements act as required.

Cullen

> From: [email-masked] [mailto:[email-masked]]On Behalf Of
> [email-masked]
> Sent: Sunday, May 19, 2002 10:59 AM
> To: Peterson, Jon
> Cc: 'Rohan Mahy'; [email-masked]
> Subject: RE: [Sip] Asserted-Identity: How to 'hint'?
>
>
> Peterson, Jon writes:
>

---

From: [email-masked]
Date: Mon, 20 May 2002 07:19:36 +0300

Cullen Jennings writes:

 > the problem you want without the hint.

no, i can't because the user almost always has multiple sip identities
and thus, in the anonymous case, needs to hint the trust domain which
identity he/she wants to use for the call.

-- juha