Subject: RE: [Sip] WGLC for draft-ietf-sip-privacy-general

From: "Peterson, Jon" <[email-masked]>
Date: Thu, 30 May 2002 15:43:30 -0500

On the first issue, yes, the examples in sip-asserted-identity go against
this SHOULD in sip-privacy-general, with some good reasons. Perhaps those
reasons could stand to be motivated a bit in the identity draft - but I
don't think this is the wrong behavior, anyway.

On the second issue, the draft says if 'none' is present the privacy service
MUST NOT perform any privacy function. The draft also says (section 4.2):
"An intermediary MUST NOT modify the Privacy header in any way if the 'none'
priv-value is already specified." So I think it should be clear that Privacy
headers containing 'none' will not be removed.

Jon Peterson
NeuStar, Inc.

> -----Original Message-----
> From: Elwell, John [mailto:[email-masked]]
> Sent: Thursday, May 30, 2002 5:26 AM
> To: 'sip'
> Subject: RE: [Sip] WGLC for draft-ietf-sip-privacy-general
> 
> 
>    "When a privacy service performs one of the functions corresponding to
>    a privacy level listed in the Privacy header, it SHOULD remove the
>    corresponding priv-value from the Privacy header - otherwise, any
>    other privacy service involved with routing this message might
>    unnecessarily apply the same function, which in many cases would be
>    undesirable."
> 
> This seems to be in contradiction with 
> draft-ietf-sip-asserted-identity,
> which show "Privacy: id" being maintained with the forwarded INVITE.
> 
>    "When the last priv-value (not counting 'critical') has
>    been removed from the Privacy header, the entire Privacy header MUST
>    be removed from a message."
> 
> Is this wise in the case of "None"?
> 
> --------------------------------------------------------------
> John Elwell ([email-masked])
> Siemens Communications Limited,
> Technology Drive, Beeston,
> Nottingham NG9 1LA, UK
> Tel: +44 115 943 4989   Fax: +44 115 943 4969
> --------------------------------------------------------------
> 	Internet communications are not secure and therefore Siemens
> Communications Limited does not accept legal responsibility for the
> contents of this message. Any views or opinions presented are solely
> those of the author and do not necessarily represent those of Siemens
> Communications Limited unless otherwise specifically stated.
> 
> 
> 
> 
> > -----Original Message-----
> > From: Dean Willis [mailto:[email-masked]]
> > Sent: 28 May 2002 22:32
> > To: 'sip'
> > Cc: [email-masked]; [email-masked]; [email-masked]; Jon
> > Peterson ([email-masked])
> > Subject: [Sip] WGLC for draft-ietf-sip-privacy-general
> > 
> > 
> > 
> > We need to do a quick review of the general privacy draft 
> > developed out
> > of our discussion in Las Vegas.
> > 
> > Please send any issues to the list and the editor IMMEDIATELY.
> > 
> > The draft is available from:
> > 
> > http://www.softarmor.com/sipwg/drafts/draft-ietf-sip-privacy-g
> > eneral-00.
> > html
> > http://www.softarmor.com/sipwg/drafts/draft-ietf-sip-privacy-g
> eneral-00.
> txt
> And soon to be available from internet-drafts if not already . . .
> 
> 
> --
> Dean
> 
> 
> _______________________________________________
> Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
> This list is for NEW development of the core SIP Protocol
> Use [email-masked] for questions on current sip
> Use [email-masked] for new developments on the application of sip
> 
> _______________________________________________
> Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
> This list is for NEW development of the core SIP Protocol
> Use [email-masked] for questions on current sip
> Use [email-masked] for new developments on the application of sip
> 

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Jonathan Rosenberg <[email-masked]>
Date: Fri, 31 May 2002 16:18:51 -0400

> headers containing 'none' will not be removed.

I think you should explicitly note this exception. In my experience, the
more explicit you are in specs, the better.

-Jonathan R.

-- 
Jonathan D. Rosenberg, Ph.D.            72 Eagle Rock Avenue
Chief Scientist                         First Floor
dynamicsoft                             East Hanover, NJ 07936
[email-masked]                 FAX: (973) 952-5050
http://www.jdrosen.net                  PH:  (973) 952-5000
http://www.dynamicsoft.com