Subject: Re: [Sip] Last Call: The Refer Method to Proposed Standard

From: [email-masked]
Date: Wed, 22 May 2002 12:41:04 +0200

- Section 6.1, 2nd paragraph, contains a rather strange sentence

  "For example, if the URI is a SIP URI indicating an INVITE 
   should be generated ..."

  I guess that it should be:

  "For example, if the URI is a SIP URI indicating an INVITE 
   an INVITE should be generated ..."

- The use of colons after header names is not always consistent.
  E.g. in 6.3.1's first bullet item "Call-ID".

- Section 7.1, first paragraph, states:

  "The details of this flow indicate this ..."

  I guess it should state:

  "The details of this flow indicate that this ..."

  Furthermore, the example that follows is not in line with the
  text. The text states that there is no To: tag, but there is
  one in the example.

- Section 8.1 talks about INVITE URIs. I am not sure whether this
  type of URI (although I think I understand what is meant) is 
  defined anywhere.

Regards,

Frank

----- Original Message -----
From: "The IESG" <[email-masked]>
To: <IETF-Announce:>
Cc: <[email-masked]>
Sent: Monday, May 20, 2002 12:59 PM
Subject: [Sip] Last Call: The Refer Method to Proposed Standard

>
> The IESG has received a request from the Session Initiation Protocol
> Working Group to consider publication of the following Internet-Drafts
> as Proposed Standards:
>
>  o The Refer Method
> <draft-ietf-sip-refer-04.txt>
>  o The Session Inititation Protocol (SIP)
> <draft-ietf-sip-replaces-02.txt>
>  o The Reason Header Field for the Session Initiation Protocol
> <draft-ietf-sip-reason-01.txt>
>  o Internet Media Types message/sipfrag
> <draft-sparks-sip-mimetypes-03.txt>
>  o SIP Extension for Registering Non-Adjacent Contacts
> <draft-willis-sip-path-06.txt>
>
>
> The IESG will also consider publication of Best Current Practices for
> Third Party Call Control in the Session Initiation Protocol
> <draft-ietf-sipping-3pcc-00.txt> as a BCP.
>
>
> The IESG plans to make a decision in the next few weeks, and solicits
> final comments on this action.  Please send any comments to the
> [email-masked] or [email-masked] mailing lists by June 3, 2002.
>
> Files can be obtained via
http://www.ietf.org/internet-drafts/draft-ietf-sip-refer-04.txt
> http://www.ietf.org/internet-drafts/draft-ietf-sip-replaces-02.txt
> http://www.ietf.org/internet-drafts/draft-ietf-sip-reason-01.txt
> http://www.ietf.org/internet-drafts/draft-sparks-sip-mimetypes-03.txt
> http://www.ietf.org/internet-drafts/draft-willis-sip-path-06.txt
> http://www.ietf.org/internet-drafts/draft-ietf-sipping-3pcc-00.txt
>
>
> _______________________________________________
> Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
> This list is for NEW development of the core SIP Protocol
> Use [email-masked] for questions on current sip
> Use [email-masked] for new developments on the application of sip
>

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Robert Sparks <[email-masked]>
Date: 22 May 2002 16:23:24 -0500

>    an INVITE should be generated ..." 
No, try
 "For example, if the URI is a SIP URI that indicates an INVITE
  should be generated".

See below
>   E.g. in 6.3.1's first bullet item "Call-ID". 
will fix
>   "The details of this flow indicate that this ..." 
correct. will add "that"

>   text. The text states that there is no To: tag, but there is 
It states there is no To: tag in the REFER request (and there isn't).
I think you are seeing the To: tags in the subsequent messages?

>   type of URI (although I think I understand what is meant) is 
draft-rfc2543bis-09 captures this in its discussion of SIP URIs.

An SIP INVITE URI is one which either has no ;method= URI parameter
(defaulting to INVITE) or explicitly states ;method=INVITE.
Alternatives might look like
sip:[email-masked];method=SUBSCRIBE

RjS