Subject: RE: [Sip] Asserted-Identity: How to 'hint'?

From: "Zmolek, Andrew (Andrew)" <[email-masked]>
Date: Sat, 18 May 2002 15:49:19 -0600

Juha wrote:

> first, i don't like at all the idea that ietf sip working group
> discussions are dictated and constrained by 3gpp schedules.  we must
> have time to really solve the problems and not just hide them 
> under the carpet because of 3gpp.

I agree with Juha's concern here, but at the same time I have to admit that past history in the IETF around this class of problems is not encouraging, so the plausible alternatives seem worse. Regardless of how bullish one might be over 3GPP itself, it has been an effective forcing function for work that would otherwise be bogged down for years in the politics of obstructionism that have taken over so many other well-intentioned working groups around us. 

Thanks to the seemingly tireless efforts of a few members of the SIP community, we have been able to make tremendous progress in the past year (by addressing concerns head-on--not avoiding and postponing them), and if Jon is ready to take this on I'm inclined to throw more support on the side of getting this done than worry unduly about producing something less than perfect. The IETF is already quite effective at drowning most of its young in an ocean of worry and concern--it would really be quite a feat indeed to produce a runt *and* somehow sneak it by those in the IETF pledged to fight evil in all its many forms.

--Andy

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Rohan Mahy <[email-masked]>
Date: Sun, 19 May 2002 08:29:05 -0700

Hi,

The requirement for a hint is well understood, limited in
scope, and well motivated in the draft.  Nobody has identified
any technical reason why the hint won't work.   Your argument
that allowing a hint weakens the strength of the language on
ignoring Asserted-Identity from untrusted parties is purely
philosophical in nature.  I don't buy your argument.

thanks,
-rohan

---- Original message ----
>Date: Fri, 17 May 2002 16:02:11 -0500
>From: "Peterson, Jon" <[email-masked]>  
>Subject: [Sip] Asserted-Identity: How to 'hint'?  
>To: "[email-masked]'" <[email-masked]>
>
>
>In the course of the discussion between Mark Watson, Cullen
Jennings and
>myself about the short-term identity work, we have returned a
few times to
>the question of the infamous hint. This hint is, of course, a
way that a
>user agent (one that is not a member of the Trust Domain in
the short-term
>network asserted identity space) can provide a 'hint' to the
intermediary
>that will generate an Asserted-Identity indicating which
identity among
>several possibilities should be asserted.
>
>The need for this arises particularly from the 3G space, in
which the
>authentication process takes place independently of SIP and
does not carry
>this sort of personal identity information. It also assumes
that the
>operators of the intermediary in question are aware of
several legitimate
>identities which the user can elect to assert.
>
>It has been proposed on the mailing list and elsewhere that the
>Asserted-Identity header should be re-used by user agents
outside the Trust
>Domain to provide such a hint. I see a number of reasons for
and against
>using the Asserted-Identity for this purpose. For example,
today, there is a
>requirement that asserted-identities which are transmitted
from untrusted
>sources should not be used in any way - this would seem to
weaken that
>requirement. There is also possibly some behavior that still
needs to be
>specified (like how an intermediary would reject or otherwise
handle a
>request with an inappropriate hint) that might be impactful
to our choice.
>
>For the time being, however, I would like to suggest that
providing the hint
>is outside the scope of the current deliverables (the
asserted-identity
>requirements and mechanism drafts), which need to be
complete, as we
>discussed in the interim meeting, by the end of this month. I
believe that a
>separate draft should propose the use of Asserted-Identity or
any other
>header for this hint (in whatever timeframe is appropriate
for 3G's
>requirements), but that we should not speak to this matter in
the current
>asserted-identity deliverables. There is, as I see it, no
dependency on
>defining this hint before we dictate how intermediaries will
assert
>identities.
>
>Any comments on this plan?
>
>Jon Peterson
>NeuStar, Inc.
>

---

From: "Mark Watson"<[email-masked]>
Date: Mon, 20 May 2002 12:08:25 +0100

The 'hint' was one of the three requirements that 3GPP communicated to us in
April.

It is a separate requirement from the Network Asserted Identity itself, and
so is not addressed in the requirements draft, although I have been careful
to point this out, and to point out that it is a requirement nontheless, on
several occasions.

I believe we need the 'hint' in the same timeframe as the rest of the short
term work.

Whether it is the same header/draft or a different header/draft is another
question on which I will only say that we'd better make up our minds pretty
quick.

...Mark

> -----Original Message-----
> From: Peterson, Jon [mailto:[email-masked]]
> Sent: 19 May 2002 18:11
> To: 'Rohan Mahy'
> Cc: [email-masked]
> Subject: RE: [Sip] Asserted-Identity: How to 'hint'?
> 
> 
> 
> My argument was not that the proposed hint won't work - just 
> that it isn't
> necessary to solve the problem at hand. It might not be the 
> case that the
> problems with the hint stop at the philosophical point you 
> mention below.
> What I asked in my last mail was not whether or not we needed 
> a hint, but
> rather whether or not we should table that question until we 
> resolve the
> other questions at hand. I just don't want to spend the 
> cycles arguing about
> the hint given our very aggressive timetable - frankly, I think that
> reaching consensus on this hint matter might push back our 
> dates a bit.
> Let's investigate this hint stuff in June, but for now just 
> figure out how a
> Trust Domain can manage an asserted identity in a message.
> 
> Jon Peterson
> NeuStar, Inc.
> 
> > -----Original Message-----
> > From: Rohan Mahy [mailto:[email-masked]]
> > Sent: Sunday, May 19, 2002 8:29 AM
> > To: Peterson, Jon
> > Cc: [email-masked]
> > Subject: Re: [Sip] Asserted-Identity: How to 'hint'?
> > 
> > 
> > Hi,
> >

---

From: Andrew Allen <[email-masked]>
Date: Wed, 22 May 2002 10:51:19 -0400

I agree with Dave. Lets put the hint in the asserted-identity. Lets not have
two redundant headers that need to be transferred over the Radio interface
unnecessarily.

Andrew

> From: David R. Oran [mailto:[email-masked]]
> Sent: Wednesday, May 22, 2002 9:45 AM
> To: 'Mark Watson'; 'Peterson, Jon'; 'Rohan Mahy'; [email-masked]
> I suggest we allow the hint to be placed in the 
> asserted-identity rather
> than in another header. A boundary proxy has to deal with a UA putting
> in the header no matter what, if only to reject the request with an
> error.
> 
> Once we have a full solution the issue of hints should go 
> away as a side
> effect of having the "authorization server" functionality that Jon
> proposes. Better IMHO to have one obsolescent header to deal 
> with rather
> than two, as well as avoiding the concomitant verbiage describing the
> combinatoric cases involving two headers.
> 
> Dave.
> 
> > From: [email-masked] [mailto:[email-masked]] On 
> > Behalf Of Mark Watson
> > Sent: Wednesday, May 22, 2002 9:59 AM
> > To: 'Peterson, Jon'; 'Rohan Mahy'; [email-masked]
> > Importance: High
> > All,
> > Can we have a *decision* asap as to whether the 'hint' uses 
> > Asserted-Identity, or another header in another draft.
> > 
> > I do not mind which. If the latter I will publish an I-D 
> > describing it as soon as we have a decision, assuming it is 
> > this week, since I'm away next week.
> > 
> > If we do nothing, then I guess 3GPP will make up its own mind 
> > how to do this, without supervision or advice from IETF, 
> > which I think would  be a bad thing.
> > 
> > Regards...Mark
> > 
> > 
> > From: Watson, Mark [MDN05:EP10:EXCH] 
> > Sent: 20 May 2002 12:08
> > To: 'Peterson, Jon'; 'Rohan Mahy'
> > Cc: [email-masked]
> > The 'hint' was one of the three requirements that 3GPP 
> > communicated to us in April. 
> > It is a separate requirement from the Network Asserted 
> > Identity itself, and so is not addressed in the requirements 
> > draft, although I have been careful to point this out, and to 
> > point out that it is a requirement nontheless, on several 
> > occasions. I believe we need the 'hint' in the same timeframe 
> > as the rest of the short term work. 
> > Whether it is the same header/draft or a different 
> > header/draft is another question on which I will only say 
> > that we'd better make up our minds pretty quick. ...Mark 
> > 
> >