Subject: RE: [Sip] SIP WGLC of draft-ietf-sip-asserted-identity

From: "Elwell, John" <[email-masked]>
Date: Fri, 31 May 2002 09:14:46 +0100

I had assumed that any header that was to be removed would already have been
removed at this point. However, looking at the rest of the text again, this
is not clear. So how about:

"The proxy MAY add a P-Asserted-Identity header field with either a single
SIP URI or a single SIPS URI, provided there is not already a SIP URI or
SIPS URI present or replacing a SIP URI or SIPS URI from an untrusted
source.  Likewise, the proxy MAY add a P-Asserted-Identity header field with
a single tel URL, provided there is not already a tel URL present or
replacing a tel URL from an untrusted source."

John

--------------------------------------------------------------
John Elwell ([email-masked])
Siemens Communications Limited,
Technology Drive, Beeston,
Nottingham NG9 1LA, UK
Tel: +44 115 943 4989   Fax: +44 115 943 4969
--------------------------------------------------------------
	Internet communications are not secure and therefore Siemens
Communications Limited does not accept legal responsibility for the
contents of this message. Any views or opinions presented are solely
those of the author and do not necessarily represent those of Siemens
Communications Limited unless otherwise specifically stated.

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: 31 May 2002 08:59
> To: Elwell, John
> Cc: 'Cullen Jennings'; [email-masked]
> Subject: RE: [Sip] SIP WGLC of draft-ietf-sip-asserted-identity
> 
> 
> Elwell, John writes:
> 
>  > "The proxy MAY add a P-Asserted-Identity header field with 
> either a single
>  > SIP URI or a single SIPS URI, provided there is not 
> already a SIP URI or
>  > SIPS URI present.  Likewise, the proxy MAY add a 
> P-Asserted-Identity header
>  > field with a single tel URL, provided there is not already 
> a tel URL
>  > present."
> 
> what about modifying an existing nai header? is that is not 
> allowed then
> the above text is fine with me, since it also forces the 
> proxy to reject
> the request if the user has inserted the nai and the network doesn't
> like its contents.
> 
> -- juha
> 

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Jonathan Rosenberg <[email-masked]>
Date: Fri, 31 May 2002 16:29:38 -0400

> replacing a tel URL from an untrusted source."

THis is still awkward. Might I suggest:

If there is no P-Asserted-Identity header field present, a proxy MAY add
one containing at most one SIP or SIP URIs, and at most one tel URL. If
there is a P-Asserted-Identity header present, and it contains a SIP or
SIP URI from an untrusted source, the proxy MAY replace that SIP or SIPS
URI with a single SIP or SIP URI. If there is a P-Asserted-Identity
header present, and it contains a tel URL from an untrusted source, the
proxy MAY replace that tel URL with a single tel URL.

-Jonathan R.

-- 
Jonathan D. Rosenberg, Ph.D.            72 Eagle Rock Avenue
Chief Scientist                         First Floor
dynamicsoft                             East Hanover, NJ 07936
[email-masked]                 FAX: (973) 952-5050
http://www.jdrosen.net                  PH:  (973) 952-5000
http://www.dynamicsoft.com