Subject: RE: [Sip] Message draft changes

From: "Ben Campbell" <[email-masked]>
Date: Tue, 14 May 2002 09:40:25 -0500

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: Tuesday, May 14, 2002 4:54 AM
> To: [email-masked]
> Cc: [email-masked]
> Subject: RE: [Sip] Message draft changes
>
>
> Hi Ben,
>
> > I submitted draft-ietf-sip-message-04 last week. This version
> > contains a few
> > AD requested changes, primarily in the area of congestion control.
> > Specifically:
> >
> > 1) Added an applicability statement clarifying the difference
> > between the
> > pager and session models, and that this draft only defines
> > the pager model.
> >
> > 2) Strengthened the congestion control section:
> >
> >    * 1300 byte hard limit for physical payload size for pager
> > model. This
> > applies to the actual payload only, not indirect content. Fragmenting
> > content across multiple requests is prohibited for pager model.
>
> I don't agree with this at all. This sort of hard limit really
> hampers the whole IM application. The session mode and paging
> mode IM are very different in nature. Session IM is clearly
> conversational, whereas paging mode IM much more of a
> "shoot-and-forget" type messaging. Now if the selection between
> the two is not based on user preference and needs but on payload
> size, I don't think this serves the IM users very well.
>
> Also, 1300 bytes seems awfully little, if I want to send
> message/cpim with S/MIME protection.
>

I understand your concern. The problem is, the IESG is very concerned about
the potential for congestion caused by MESSAGE. We initially stated that, if
your payload was over 1300 bytes, you must use a congestion-controlled
transport. The SIP spec itself says that now, I think. The problem is,
outside of a dialog, there is no way to ensure that no hop will traverse
UDP. So to allow larger payloads, we would have to solve that problem first.
We did not want to make MESSAGE dependent on a solution for that problem.

There is work underway to define a mechanism for indirect content. I think
we will have to use that for any sort of large content.

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: [email-masked]
Date: Tue, 14 May 2002 12:54:02 +0300

Hi Ben,

> content across multiple requests is prohibited for pager model.

I don't agree with this at all. This sort of hard limit really hampers the whole IM application. The session mode and paging mode IM are very different in nature. Session IM is clearly conversational, whereas paging mode IM much more of a "shoot-and-forget" type messaging. Now if the selection between the two is not based on user preference and needs but on payload size, I don't think this serves the IM users very well. 

Also, 1300 bytes seems awfully little, if I want to send message/cpim with S/MIME protection.
 
Cheers,
Aki