Subject: [Sip] Sending SOAP over SIP

From: [email-masked]
Date: Mon, 13 May 2002 18:24:12 +0200

hi all,

	Thanks in advance. 

	To send SOAP over HTTP, the tag 'SOAPAction' is sent in the HTTP headers when sending SOAP requests to identify the intent of the request. This header can be used by the Firewalls and Proxies to filter the SOAP Message. In HTTP this field is defined as mandatory, so the client MUST include this field in the HTTP header when sending a SOAP message. SOAP can be sent over HTTP as a ContentType=text/xml, and over SIP with the same content type. 
	In SIP, to allow the appropiate filtering by proxies there should be defined a SOAPAction field as mandatory in the client request. Do you think if there is something defined regarding this ? 

	Another option to let the proxies identify that a SOAP message is inside the SIP message would be to define a ContentType=text/soap+xml, but I think that this is not defined currently in IANA.
	
	Note that I am trying to avoid the use of a proprietary format, but I am pointing a general format of sending SOAP over SIP. And also, I am referring to individual sessionless calls, including the SOAP code in a single SIP call, not using a SIP call to establish a session (INVITE) and afterwards send a message using HTTP. 

Br,
	Ignacio

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Gonzalo Camarillo <[email-masked]>
Date: Tue, 14 May 2002 13:17:04 +0300

Hi,

inline:

>         In SIP, to allow the appropiate filtering by proxies there should be defined a SOAPAction field as mandatory in the client request. Do you think if there is something defined regarding this…

I do not think anybody has defined such a header field.

>         Another option to let the proxies identify that a SOAP message is inside the SIP message would be to define a ContentType=text/soap+xml, but I think that this is not defined currently in IA…

I do not think this has been registered either.

>         Note that I am trying to avoid the use of a proprietary format, but I am pointing a general format of sending SOAP over SIP. And also, I am referring to individual sessionless calls, includ…

could you please elaborate on what you mean by "sessionless calls"?

I do not understand the last paragraph, but it seems that you want to
use SIP only as a transport, without using any of the existing SIP
semantics defined in existing methods. Is that right?

Best regards,

Gonzalo
-- 
Gonzalo Camarillo         Phone :  +358  9 299 33 71
Oy L M Ericsson Ab        Mobile:  +358 40 702 35 35
Telecom R&D               Fax   :  +358  9 299 30 52
FIN-02420 Jorvas          Email :  [email-masked]
Finland                   http://www.hut.fi/~gonzalo