Subject: MESSAGE size limitations (Was: RE: [Sip] Message draft changes)

From: [email-masked]
Date: Thu, 16 May 2002 09:42:04 +0300

Hi,

Comments inline.

> > > I submitted draft-ietf-sip-message-04 last week. This version
> > > contains a few
> > > AD requested changes, primarily in the area of congestion control.
> > > Specifically:
> > >
> > > 1) Added an applicability statement clarifying the difference
> > > between the
> > > pager and session models, and that this draft only defines
> > > the pager model.
> > >
> > > 2) Strengthened the congestion control section:
> > >
> > >    * 1300 byte hard limit for physical payload size for pager
> > > model. This
> > > applies to the actual payload only, not indirect content. 
> Fragmenting
> > > content across multiple requests is prohibited for pager model.
> >
> > I don't agree with this at all. This sort of hard limit really
> > hampers the whole IM application. The session mode and paging
> > mode IM are very different in nature. Session IM is clearly
> > conversational, whereas paging mode IM much more of a
> > "shoot-and-forget" type messaging. Now if the selection between
> > the two is not based on user preference and needs but on payload
> > size, I don't think this serves the IM users very well.
> >
> > Also, 1300 bytes seems awfully little, if I want to send
> > message/cpim with S/MIME protection.
> >
> 
> I understand your concern. The problem is, the IESG is very 
> concerned about
> the potential for congestion caused by MESSAGE. We initially 
> stated that, if
> your payload was over 1300 bytes, you must use a congestion-controlled
> transport. The SIP spec itself says that now, I think. The problem is,
> outside of a dialog, there is no way to ensure that no hop 
> will traverse
> UDP. So to allow larger payloads, we would have to solve that 
> problem first.
> We did not want to make MESSAGE dependent on a solution for 
> that problem.

Since it is totally possible to send the MESSAGE directly to the recipient (R-URI points to the interface address directly, not the AOR), doesn't the sender in this case have definite knowledge, that the hop will use TCP? The MUST strength forces the UA to *always* follow the fixed 1300 limit. 

I'm sure there are also other cases, where UDP hops will definitely not exist. I'm wondering if the congestion control could do away with some SHOULD based construct on the size limitation? The MUST really limits the features of IM, in my opinion.

> There is work underway to define a mechanism for indirect 
> content. I think
> we will have to use that for any sort of large content.

I'm aware of that work. The problem is that it is still in a concept level only. Even though it looks like a trivially solvable problem, discussions on the requirements in the interim meeting suggested that there are some tricky issues to it, too. I'm not buying this argument until there's at least a WG item for a solution.

Cheers,
Aki

> 
> 
> _______________________________________________
> Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
> This list is for NEW development of the core SIP Protocol
> Use [email-masked] for questions on current sip
> Use [email-masked] for new developments on the application of sip
> 

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Ben Campbell" <[email-masked]>
Date: Thu, 16 May 2002 08:47:58 -0500

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: Thursday, May 16, 2002 1:42 AM
> To: [email-masked]; [email-masked]
> Subject: MESSAGE size limitations (Was: RE: [Sip] Message draft changes)
>
[snip]

> Since it is totally possible to send the MESSAGE directly to the
> recipient (R-URI points to the interface address directly, not
> the AOR), doesn't the sender in this case have definite
> knowledge, that the hop will use TCP? The MUST strength forces
> the UA to *always* follow the fixed 1300 limit.
>
> I'm sure there are also other cases, where UDP hops will
> definitely not exist. I'm wondering if the congestion control
> could do away with some SHOULD based construct on the size
> limitation? The MUST really limits the features of IM, in my opinion.

We had it as a SHOULD before, and were asked to change it. It might be
possible to change it to say you MUST NOT exceed 1300 bytes unless you have
affirmative knowledge that no hop along the way will use UDP. But that
limits you to some pretty trivial uses in the pager model.

> I'm aware of that work. The problem is that it is still in a
> concept level only. Even though it looks like a trivially
> solvable problem, discussions on the requirements in the interim
> meeting suggested that there are some tricky issues to it, too.
> I'm not buying this argument until there's at least a WG item for
> a solution.

I agree it is not trivial, but it is doable. I think we are in process of
getting a wg item for this in SIMPLE. We _do_ have a wg item for message
sessions in SIMPLE, which would be another possible solution.