Subject: [Sip] request/response over different transport

From: "vishal" <[email-masked]>
Date: Wed, 1 May 2002 11:46:55 +0530

Hi ,
      It should be possible to receive request sent over UDP and send response over TCP because in some cases when UDP message size is greater than MTU size ,then message sending will not succeed .
        Reverse of this should not be allowed i.e receive over TCP and send response over UDP .

Possible scenario can be  endpoint received  query for cappability set over UDP but response message is  bigger than MTU size ...

regards, vishal

---

From: Bobby Sardana <[email-masked]>
Date: Tue, 30 Apr 2002 23:58:17 -0700

The scenario you have described requires the UAS to decide whether to
transport via TCP or UDP, depending on the request and the response. If
the response size is less than path MTU then I am not sure why can't we
use UDP for response.

regards,

Bobby Sardana.
[email-masked]

vishal wrote:

> Hi ,      It should be possible to receive request sent over UDP and
> send response over TCP because in some cases when UDP message size is
> greater than MTU size ,then message sending will not succeed .
> Reverse of this should not be allowed i.e receive over TCP and send
> response over UDP . Possible scenario can be  endpoint received  query
> for cappability set over UDP but response message is  bigger than MTU
> size ...
>   regards, vishal

---

From: "vishal" <[email-masked]>
Date: Wed, 1 May 2002 13:04:14 +0530

Hi Bobby,
      you are correct if message size is less than MTU size then response must be over UDP .....

some other problems are :

 when proxy forwards INVITE requests .It adds "Via:" field into it along with appropriate parametres ....if message is forwarded by many proxies then this message may become greater than MTU size in particular network ....how this  case should be handled ? 
    should next proxy establish TCP connection and then forward it OR reject this message?

If proxy forwards this  message using TCP and UAS receives INVITE over TCP then UAS  response will be sent over TCP  and UAC should be prepared to receive response over TCP or UDP  for its previous INVITE over UDP request.

regards, vishal

Vishal ,
Knowledge Systems Pvt Ltd  ,INDIA
470, East End Main Road  
9th Block Jayanagar 
Bangalore
      
  ----- Original Message ----- 
  From: Bobby Sardana 
  To: vishal 
  Cc: [email-masked] 
  Sent: Wednesday, May 01, 2002 12:28 PM
  Subject: Re: [Sip] request/response over different transport

  The scenario you have described requires the UAS to decide whether to transport via TCP or UDP, depending on the request and the response. If the response size is less than path MTU then I am not sure why can't we use UDP for response. 
  regards, 

  Bobby Sardana. 
  [email-masked] 

  vishal wrote: 

    Hi ,      It should be possible to receive request sent over UDP and send response over TCP because in some cases when UDP message size is greater than MTU size ,then message sending will not succeed .        Reverse of this should not be allowed i.e receive over TCP and send response over UDP . Possible scenario can be  endpoint received  query for cappability set over UDP but response message is  bigger than MTU size ... 
      regards, vishal

---

From: Jonathan Rosenberg <[email-masked]>
Date: Wed, 01 May 2002 19:50:21 -0400

We thought about this problem a great deal for bis. The conclusion was
that sending the response over a different transport was too complex and
broke too many sip assumptions that exist throughout the spec.

Instead, the spec mandates the use of TCP when you are within a few
hundred bytes of the MTU. The few hundred byte headroom exists to handle
the majority of the cases Record-Route will cause an increase in the
response size. This doesn't guarantee that you won't get a response that
exceeds the MTU, but it reduces its probability.

more below.

vishal wrote:
>  when proxy forwards INVITE requests .It adds "Via:" field into it along
> with appropriate parametres ....if message is forwarded by many proxies
> then this message may become greater than MTU size in particular network
> ....how this  case should be handled ?

Establish a TCP connection. This is discussed in Section 18 of bis.

> 
> If proxy forwards this message using TCP and UAS receives INVITE over
> TCP then UAS response will be sent over TCP  and UAC should be prepared
> to receive response over TCP or UDP  for its previous INVITE over UDP
> request.

UDP. There is a proxy that straddles UDP/TCP. It will receive the
resposne over TCP, and forward it towards the UAC over UDP.

-Jonathan R.

-- 
Jonathan D. Rosenberg, Ph.D.            72 Eagle Rock Avenue
Chief Scientist                         First Floor
dynamicsoft                             East Hanover, NJ 07936
[email-masked]                 FAX: (973) 952-5050
http://www.jdrosen.net                  PH:  (973) 952-5000
http://www.dynamicsoft.com

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip