Subject: [Sip] SIP WGLC of draft-ietf-sip-asserted-identity

From: "Dean Willis" <[email-masked]>
Date: Tue, 28 May 2002 16:32:06 -0500

We need to do a quick working group last call on the "Asserted Identity"
draft.

Please submit comments to the list and draft editor IMMEDIATELY.

Draft available from:

http://www.softarmor.com/sipwg/drafts/draft-ietf-sip-asserted-identity-0
0.html
http://www.softarmor.com/sipwg/drafts/draft-ietf-sip-asserted-identity-0
0.txt

And soon to be in the internet-drafts archive.

--
Dean

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Peterson, Jon" <[email-masked]>
Date: Thu, 30 May 2002 17:14:05 -0500

I agree that asserting multiple identities is interesting. In the course of
the short-term work, we made a simple scope decision that multiple
identities (aside from one SIP[S] URI and one tel URL) is a long-term
problem. Obviously, it is pretty easy with the long-term approach to sign
multiple identity values in a single body, provide multiple bodies, and so
on.

Jon Peterson
NeuStar, Inc.

> -----Original Message-----
> From: Dean Willis [mailto:[email-masked]]
> Sent: Thursday, May 30, 2002 1:58 PM
> To: 'Elwell, John'; 'sip'
> Subject: RE: [Sip] SIP WGLC of draft-ietf-sip-asserted-identity
> 
> 
> 
> John Elwell pondered:
> > Section 5, 3rd paragraph:
> >    "The proxy MAY add a P-Asserted-Identity header field 
> with either a
> >    single SIP URI or a single SIPS URI.  Likewise, the 
> proxy MAY add a
> >    P-Asserted-Identity header field with a single tel URL."
> > 
> > This seems to imply that a proxy can add a header even if 
> > there is already a header of the type concerned. Presumably 
> > this should not be allowed.
> 
> Why?
> 
> There might be some issue with multiple tel URLs and gateway
> interworking, but asserting multiple identities seems like a very
> reasonable thing from a SIP perspective.
> 
> If you're a PGP user, you may well have multiple identities associated
> with one PGO key. There are practical reasons for doing this, and it
> doesn't seem to cause any problems.
> 
> Different proxies or authentication servers might "know you" by
> different identities and be able to assert those identities on your
> behalf. It might also be reasonable to have multiple 
> assertions for the
> same identity, like multiple signers in PGP.
> 
> Signed,
> 
> [email-masked]
> [email-masked]
> [email-masked]
> [email-masked]
> 
> Ad nasueatum . . .
> 
>

---

From: "Elwell, John" <[email-masked]>
Date: Fri, 31 May 2002 08:41:21 +0100

Dean,

My motivation for saying it should not be allowed was that it seemed to be
implied elsewhere in the document - I wanted clarification. However,
multiple identities of the same type might give a problem for gateways, as
you pointed out. I guess a gateway would just have to pick one, e.g., the
first.

Regards,

John

--------------------------------------------------------------
John Elwell ([email-masked])
Siemens Communications Limited,
Technology Drive, Beeston,
Nottingham NG9 1LA, UK
Tel: +44 115 943 4989   Fax: +44 115 943 4969
--------------------------------------------------------------
	Internet communications are not secure and therefore Siemens
Communications Limited does not accept legal responsibility for the
contents of this message. Any views or opinions presented are solely
those of the author and do not necessarily represent those of Siemens
Communications Limited unless otherwise specifically stated.

> Sent: 30 May 2002 21:58