Subject: Re: [Sip] Silence Suppression in SDP for VoIP

From: [email-masked]
Date: Wed, 5 Feb 2003 14:34:02 +0530

Hi folks,

The same issue was discussed on the MMUSIC and AVT
lists earlier last year. Thought it would be good
to pick up from where we left that time since there
were opinions that time too that these parameters
(ecan and silenceSupp) be moved to VoIP in general
rather than keeping them to VoATM. The following are
URL references to the same:

[Original mail - Subject: Silence suppression attribute]
http://www1.ietf.org/mail-archive/working-groups/mmusic/current/msg00408.ht
ml

[Thread indices]
http://www1.ietf.org/mail-archive/working-groups/mmusic/current/thrd29.html
http://www1.ietf.org/mail-archive/working-groups/avt/current/mail42.html

[Need for signalling silence suppression]
http://www1.ietf.org/mail-archive/working-groups/mmusic/current/msg00425.ht
ml

Even then, necessity for signalling silence suppression
was debated, but the list seemed to be agreeing on
the need for a media level parameter describing echo
cancellation at the end of this thread. What is the
opinion on that now?

Cheers,
Siddharth.

--------------------------------------------------------
Siddharth Toshniwal
Hughes Software Systems
Prestige Opal                    http://www.hssworld.com
146, Infantry Road          Ph (O): +91-80-2286390 (7094)
Bangalore-560001, India           Mobile: +91-9845154068
--------------------------------------------------------

Jonathan Rosenberg <[email-masked]> on 02/05/2003 05:02:25 AM

To:   Steve Silverman <[email-masked]>
cc:   Alex Agranov <[email-masked]>, "'David R. Oran'"
      <[email-masked]>, [email-masked] (bcc: Siddharth J Toshniwal/HSSBLR)

Subject:  Re: [Sip] Silence Suppression in SDP for VoIP

In some cases, the codec itself contains specific silence packets, and
so their usage would be negotiated using the codec specific parameters.
You can also use the specific payload format for comfort noise, and so
support of that is negotiated using the SDP codec negotiation
methodology in offer/answer. However, when silence suppression is done
generally, by sending nothing, no signaling support is needed since all
RTP receivers need to be prepared to receive nothing and treat it as
silence. That is why there are both RTP timestamps and sequence numbers.

In the case of fax, I still do not see the issue. The sending side would
know that it is sending g.711 encoded fax, and therefore never detect
silence.

-Jonathan R.

Steve Silverman wrote:
> I would have thought that if one side is using silence suppression, the
> other side needs to understand this.
> If true, how is the use of this communicated?
>
> Steve Silverman
>
>     -----Original Message-----
>     *From:* [email-masked] [mailto:[email-masked]]*On Behalf Of
>     *Alex Agranov
>     *Sent:* Tuesday, February 04, 2003 12:30 PM
>     *To:* 'David R. Oran'; [email-masked]'
>     *Subject:* RE: [Sip] Silence Suppression in SDP for VoIP
>
>     Hi,
>
>     I see your point.
>     But if this is right, then why does H323 protocol support silence
>     suppression and echo
>     cancellation parameters?
>
>     On the other hand, in case of fax fallback to G711 coder (if T38 is
>     not supported), there is a
>     need to specify to remote device that "echo cancelation is ON, and
>     silence suppression is OFF".
>     AFAIK fax will not be properly passed if silence suppression is not
>     turned off.
>     And this, I beleive, is the reason why
>     draft-ietf-sipping-realtimefax-00.txt makes use of
>     "ecan" and "silenceSupp" SDP attributes.
>
>     Also there is a following sentence in H323-SIP interworking draft :
>             "A fmtp SDP attribute for silence suppression SHOULD be
>     defined if
>             silence suppression is on."
>     Is it not valid any more?
>
>     Best regards,
>                  Alex Agranov
>
>      > -----Original Message-----
>      > From: David R. Oran [mailto:[email-masked]]
>      > Sent: Tuesday, February 04, 2003 5:53 PM
>      > To: Alex Agranov; [email-masked]'
>      > Subject: Re: [Sip] Silence Suppression in SDP for VoIP
>      >
>      >
>      > There are no such parameters in SDP nor SIP because both of these
>     are
>      > algorithm options for one end of a media stream. The source
>      > of the stream
>      > does these by itself and therefore they have no end-to-end
>      > significance. As
>      > a consequence there is no need for the receiver to know
>      > anything about Vad
>      > or ecan parameters of the transmitter, or vice versa.
>      >
>      > The reason these exist in MGCP and Megaco is because those are
>     device
>      > control protocols intended for comand and control of an endpoint,
as
>      > opposed to peer signaling protocols like SIP.
>      >
>      > --On Tuesday, February 04, 2003 12:24 PM +0200 Alex Agranov
>      > <[email-masked]> wrote:
>      >
>      > >
>      > > Hi,
>      > >
>      > > I tried to ask this question in sip-implementors maillist but
>     nobody
>      > > could answer it there...
>      > >
>      > > What is the proper way to indicate Silence Suppression and Echo
>      > > Cancelation coder parameters in SDP? In MGCP these parameters
are
>      > > passed in LCO element, but for SIP Offer/Answer model these
>      > parameters
>      > > should be passed in SDP. Right?
>      > >
>      > > There is RFC3108 that defines "ecan" and "silenceSupp"
>      > attributes, but it
>      > > applies to VoATM. Is it applicable to VoIP too?
>      > >
>      > > Some late drafts, e.g.
>      > draft-ietf-sipping-realtimefax-00.txt, seem to
>      > > assume  RFC3108 attributes are valid for VoIP. Is this correct?
>      > >
>      > > Best regards,
>      > >                 Alex Agranov
>      > > ---
>      > > Senior Software Engineer
>      > > COMGATES Ltd.
>      > > 15 Hagalim Avenue
>      > > Herzliya, 46725
>      > > Israel
>      > > Tel. +972.9.950.0404,  Ext: 228
>      > > Fax. +972.9.950.0385
>      > > Mobile. +972.54.928435
>      >
>      > ------------------------
>      > David R. Oran
>      > Cisco Systems
>      > 7 Ladyslipper Lane
>      > Acton, MA 01720
>      > Office: +1 978 264 2048
>      > VoIP: +1 408 571 4576
>      > Email: [email-masked]
>      >
>

--
Jonathan D. Rosenberg, Ph.D.                72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.jdrosen.net                      PHONE: (973) 952-5000
http://www.dynamicsoft.com

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Alex Agranov <[email-masked]>
Date: Wed, 5 Feb 2003 17:17:02 +0200

Hi,

Talking about G711 fax fallback - I agree that for the direct call between 2
SIP UA's silence 
suppression may be detected by each SIP UA when it recognizes the fax tone.

However let's look at the following scenario:

(SIP UA) ----SIP---- (PSTN GW) ----SS7---- (PSTN GW) ----SIP---- (SIP UA)

There is a need to pass information about silence mode between PSTN GW's,
so that they make proper connections in the corresponding MGW's.

For the regular SS7 call this information is included in SS7 message. But if
we 
have regular SIP UA's (not SIP-T GW's), there is no indication of silence
suppression mode 
in the SIP message. Hence there will be no indication of silence mode in SS7
message too.

Best regards,
                Alex Agranov
---
Senior Software Engineer
COMGATES Ltd.
15 Hagalim Avenue
Herzliya, 46725
Israel

> From: Jonathan Rosenberg [mailto:[email-masked]]
> Sent: Wednesday, February 05, 2003 1:32 AM
> To: Steve Silverman
> Cc: Alex Agranov; 'David R. Oran'; [email-masked]
> >      > control protocols intended for comand and control of 
> an endpoint, as
> >      > > Cancelation coder parameters in SDP? In MGCP these 
> parameters are

---

From: Alex Agranov <[email-masked]>
Date: Thu, 13 Feb 2003 11:17:02 +0200

Sorry if I missed smth, but what was decided on silence suppression
negotiation? 

Don't you think that the following case (described in one of my previous
mails):

makes such negotiation meaningful?

Best regards,
                Alex Agranov
---
Chief Software Architect
COMGATES Ltd.
15 Hagalim Avenue
Herzliya, 46725
Israel