Subject: [Sip] Proxy inserting Record-Route

From: [email-masked]
Date: Mon, 10 Feb 2003 17:31:19 +0200

RFC3261 says:

"If this proxy wishes to remain on the path of future requests
         in a dialog created by this request (assuming the request
         creates a dialog), it MUST insert a Record-Route header field
         value into the copy before any existing Record-Route header
         field values, even if a Route header field is already present."

It fails to mention where the proxy should adds that record-route header. On top or bottom of the existing record-route headers. I deduce that it should add it on top since a UAS must copy record-route headers to a response reserving the order. Also a UAC creating a route-set uses these record-route headers taking them in reverse order.

Did I miss it in the spec?

Regards,
Hisham
_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Jonathan Rosenberg <[email-masked]>
Date: Wed, 12 Feb 2003 00:49:42 -0500

inline.

[email-masked] wrote:
 > RFC3261 says:
 >
 > "If this proxy wishes to remain on the path of future requests in a
 > dialog created by this request (assuming the request creates a
 > dialog), it MUST insert a Record-Route header field value into the
 > copy before any existing Record-Route header field values, even if a
 > Route header field is already present."
 >
 > It fails to mention where the proxy should adds that record-route
 > header.

Of course it does. It says "before". Seems clear enough to me.

-Jonathan R.

-- 
Jonathan D. Rosenberg, Ph.D.                72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.jdrosen.net                      PHONE: (973) 952-5000
http://www.dynamicsoft.com