Subject: [Sip] Silence Suppression in SDP for VoIP

From: Alex Agranov <[email-masked]>
Date: Tue, 4 Feb 2003 12:24:10 +0200

Hi, 

I tried to ask this question in sip-implementors maillist but nobody
could answer it there...

What is the proper way to indicate Silence Suppression and Echo 
Cancelation coder parameters in SDP? In MGCP these parameters are 
passed in LCO element, but for SIP Offer/Answer model these parameters 
should be passed in SDP. Right? 

There is RFC3108 that defines "ecan" and "silenceSupp" attributes, but it
applies to VoATM. Is it applicable to VoIP too?

Some late drafts, e.g. draft-ietf-sipping-realtimefax-00.txt, seem to assume
RFC3108 attributes are valid for VoIP. Is this correct?

Best regards,
                Alex Agranov
---
Senior Software Engineer
COMGATES Ltd.
15 Hagalim Avenue
Herzliya, 46725
Israel
Tel. +972.9.950.0404,  Ext: 228
Fax. +972.9.950.0385
Mobile. +972.54.928435

---

From: "David R. Oran" <[email-masked]>
Date: Tue, 04 Feb 2003 10:52:33 -0500

There are no such parameters in SDP nor SIP because both of these are 
algorithm options for one end of a media stream. The source of the stream 
does these by itself and therefore they have no end-to-end significance. As 
a consequence there is no need for the receiver to know anything about Vad 
or ecan parameters of the transmitter, or vice versa.

The reason these exist in MGCP and Megaco is because those are device 
control protocols intended for comand and control of an endpoint, as 
opposed to peer signaling protocols like SIP.

--On Tuesday, February 04, 2003 12:24 PM +0200 Alex Agranov 
<[email-masked]> wrote:

> Some late drafts, e.g. draft-ietf-sipping-realtimefax-00.txt, seem to
> assume  RFC3108 attributes are valid for VoIP. Is this correct?
>
> Best regards,
>                 Alex Agranov
> ---
> Senior Software Engineer
> COMGATES Ltd.
> 15 Hagalim Avenue
> Herzliya, 46725
> Israel

------------------------
David R. Oran
Cisco Systems
7 Ladyslipper Lane
Acton, MA 01720
Office: +1 978 264 2048
VoIP: +1 408 571 4576
Email: [email-masked]
_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip