Subject: [Sip] Over sessions and dialogs

From: "Manuel Moreno" <[email-masked]>
Date: Thu, 13 Feb 2003 11:59:16 +0100

Hi everybody

We have one SIP session with "n" dialogs...

With BYE (and the specific tags) is posible to close one particular dialog
in the SIP session ...

Is possible to close all dialogs and the session with one BYE withot tags??

Thank you

Manuel

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Nataraju A.B." <[email-masked]>
Date: Thu, 13 Feb 2003 16:50:03 +0530

----- Original Message ----- 
From: Manuel Moreno 
To: [email-masked] 
Sent: Thursday, February 13, 2003 4-29
Subject: [Sip] Over sessions and dialogs

Hi everybody

ABN: Logically sepaking this is not required..... 
If I am missing something, please let me know..

ABN: a 3261 compliant stack must be able to close all teh dialogs within that particular session.

Thank you

Manuel

Regards,
-------------------------------------------
Nataraju A.B.
Huawei Technologies India Pvt. Ltd.,
Tel : +91-80-5217152 / 4 Xtn 142
-------------------------------------------
"Each problem that I solved became a rule which served afterwards to solve other problems." 
- Rene Descartes (1596-1650), "Discours de la Methode"

---

From: Prasanna Venkatesh <[email-masked]>
Date: Thu, 13 Feb 2003 21:00:13 +0530

Hi,
	As per RFC-3261 it is not allowed to send a BYE unless and until you have a
To tag i.e. a BYE is only allowed in the "early" state in a client.
	And in RFC-2543-bis02, no overlapping of transactions are allowed.
Hence your scenario can never araise.

One more clarification on your question, there cannot be more than one
dialog unless and until there is a To tag.

Cheers,
Prasanna

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of Manuel
Moreno
Sent: Thursday, February 13, 2003 4:29 PM
To: [email-masked]
Subject: [Sip] Over sessions and dialogs

Hi everybody

Thank you

Manuel