Subject: RE: [Sip] Silence Suppression in SDP for VoIP

From: Alex Agranov <[email-masked]>
Date: Tue, 4 Feb 2003 19:29:40 +0200

Hi,

I see your point. 
But if this is right, then why does H323 protocol support silence
suppression and echo 
cancellation parameters? 

On the other hand, in case of fax fallback to G711 coder (if T38 is not
supported), there is a 
need to specify to remote device that "echo cancelation is ON, and silence
suppression is OFF". 
AFAIK fax will not be properly passed if silence suppression is not turned
off.
And this, I beleive, is the reason why draft-ietf-sipping-realtimefax-00.txt
makes use of
"ecan" and "silenceSupp" SDP attributes.

Also there is a following sentence in H323-SIP interworking draft :
	"A fmtp SDP attribute for silence suppression SHOULD be defined if 
	silence suppression is on."
Is it not valid any more?

Best regards,
             Alex Agranov

> -----Original Message-----
> From: David R. Oran [mailto:[email-masked]]
> Sent: Tuesday, February 04, 2003 5:53 PM
> To: Alex Agranov; [email-masked]'
> Subject: Re: [Sip] Silence Suppression in SDP for VoIP
> 
> 
> There are no such parameters in SDP nor SIP because both of these are 
> algorithm options for one end of a media stream. The source 
> of the stream 
> does these by itself and therefore they have no end-to-end 
> significance. As 
> a consequence there is no need for the receiver to know 
> anything about Vad 
> or ecan parameters of the transmitter, or vice versa.
> 
> The reason these exist in MGCP and Megaco is because those are device 
> control protocols intended for comand and control of an endpoint, as 
> opposed to peer signaling protocols like SIP.
> 
> --On Tuesday, February 04, 2003 12:24 PM +0200 Alex Agranov 
> <[email-masked]> wrote:
> 
> >
> > Hi,
> >
> > I tried to ask this question in sip-implementors maillist but nobody
> > could answer it there...
> >
> > What is the proper way to indicate Silence Suppression and Echo
> > Cancelation coder parameters in SDP? In MGCP these parameters are
> > passed in LCO element, but for SIP Offer/Answer model these 
> parameters
> > should be passed in SDP. Right?
> >
> > There is RFC3108 that defines "ecan" and "silenceSupp" 
> attributes, but it
> > applies to VoATM. Is it applicable to VoIP too?
> >
> > Some late drafts, e.g. 
> draft-ietf-sipping-realtimefax-00.txt, seem to
> > assume  RFC3108 attributes are valid for VoIP. Is this correct?
> >
> > Best regards,
> >                 Alex Agranov
> > ---
> > Senior Software Engineer
> > COMGATES Ltd.
> > 15 Hagalim Avenue
> > Herzliya, 46725
> > Israel
> > Tel. +972.9.950.0404,  Ext: 228
> > Fax. +972.9.950.0385
> > Mobile. +972.54.928435
> 
> ------------------------
> David R. Oran
> Cisco Systems
> 7 Ladyslipper Lane
> Acton, MA 01720
> Office: +1 978 264 2048
> VoIP: +1 408 571 4576
> Email: [email-masked]
>

---

From: "Steve Silverman" <[email-masked]>
Date: Tue, 4 Feb 2003 13:01:28 -0500

RE: [Sip] Silence Suppression in SDP for VoIPI would have thought that if
one side is using silence suppression, the other side needs to understand
this.
If true, how is the use of this communicated?

Steve Silverman
  -----Original Message-----
  From: [email-masked] [mailto:[email-masked]]On Behalf Of Alex
Agranov
  Sent: Tuesday, February 04, 2003 12:30 PM
  To: 'David R. Oran'; [email-masked]'
  Subject: RE: [Sip] Silence Suppression in SDP for VoIP

  Hi,

  I see your point.

  On the other hand, in case of fax fallback to G711 coder (if T38 is not
supported), there is a
  need to specify to remote device that "echo cancelation is ON, and silence
suppression is OFF".
  AFAIK fax will not be properly passed if silence suppression is not turned
off.
  And this, I beleive, is the reason why
draft-ietf-sipping-realtimefax-00.txt makes use of
  "ecan" and "silenceSupp" SDP attributes.

  Best regards,
               Alex Agranov

---

From: Jonathan Rosenberg <[email-masked]>
Date: Tue, 04 Feb 2003 18:32:25 -0500

In some cases, the codec itself contains specific silence packets, and 
so their usage would be negotiated using the codec specific parameters. 
You can also use the specific payload format for comfort noise, and so 
support of that is negotiated using the SDP codec negotiation 
methodology in offer/answer. However, when silence suppression is done 
generally, by sending nothing, no signaling support is needed since all 
RTP receivers need to be prepared to receive nothing and treat it as 
silence. That is why there are both RTP timestamps and sequence numbers.

In the case of fax, I still do not see the issue. The sending side would 
know that it is sending g.711 encoded fax, and therefore never detect 
silence.

-Jonathan R.

Steve Silverman wrote:
> I would have thought that if one side is using silence suppression, the 
> other side needs to understand this.
>     *From:* [email-masked] [mailto:[email-masked]]*On Behalf Of
>     *Alex Agranov
>     *Sent:* Tuesday, February 04, 2003 12:30 PM
>     *To:* 'David R. Oran'; [email-masked]'
>     *Subject:* RE: [Sip] Silence Suppression in SDP for VoIP
> 
>     Hi,
> 
>     I see your point.
>     On the other hand, in case of fax fallback to G711 coder (if T38 is
>     not supported), there is a
>     need to specify to remote device that "echo cancelation is ON, and
>     silence suppression is OFF".
>     AFAIK fax will not be properly passed if silence suppression is not
>     turned off.

-- 
Jonathan D. Rosenberg, Ph.D.                72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.jdrosen.net                      PHONE: (973) 952-5000
http://www.dynamicsoft.com

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Qiru Zhou <[email-masked]>
Date: Tue, 04 Feb 2003 16:55:39 -0500

In the following cases, there are needs to to understand the far end device
attributes:

1. A device connect to a non human device, such as a speech recognition
   receiver.
   In this case, the non human device may not work since it may less
   tolerant than human. The current automatic detection algorithms may
   not be reliable enough to cover all situations.

2. The channel is used to pass non voice signals (such as fax) and in-band
   control signals.
   In this case, the non human device may not work due to the adaptation
   algorithm signal distortion.

3. A device connect to a gateway with network (far end) echo canceller/noise
   suppresser.
   In this case, the communication still work but may have degraded
   performance due to the incorrect estimation of the echo canceller/noise
   suppresser parameters.

It will be desirable to exchange device attribute information such as
echo canceller/noise suppresser at the session setup time than guess them
remotely. It looks natural to me to use SDP "ecan" and "silenceSupp" defined
in RFC 3108 in VoIP and converged networks.

-- Qiru Zhou

Subject: 
       RE: [Sip] Silence Suppression in SDP for VoIP
   Date: 
       Tue, 4 Feb 2003 13:01:28 -0500
  From: 
       "Steve Silverman" <[email-masked]>
    To: 
       "Alex Agranov" <[email-masked]>, "'David R. Oran'" <[email-masked]>, <[email-masked]>

I would have thought that if one side is using silence suppression, the other side
needs to understand this.  If true, how is the use of this communicated?  
 
Steve Silverman

     -----Original Message-----
     From: [email-masked] [mailto:[email-masked]]On Behalf Of Alex Agranov
     Sent: Tuesday, February 04, 2003 12:30 PM
     To: 'David R. Oran'; [email-masked]'
     Subject: RE: [Sip] Silence Suppression in SDP for VoIP

     Hi, 

     I see your point. 
     But if this is right, then why does H323 protocol support silence suppression and echo 
     cancellation parameters? 

     On the other hand, in case of fax fallback to G711 coder (if T38 is not supported), there is a 
     need to specify to remote device that "echo cancelation is ON, and silence suppression is OFF". 
     AFAIK fax will not be properly passed if silence suppression is not turned off. 
     And this, I beleive, is the reason why draft-ietf-sipping-realtimefax-00.txt makes use of 
     "ecan" and "silenceSupp" SDP attributes. 

     Best regards, 
                  Alex Agranov 

     > > Tel. +972.9.950.0404,  Ext: 228 
==============================================================================
Qiru Zhou                                 (http://www.bell-labs.com/org/1133/)
Converged Network and Service Research  Bell Laboratories, Lucent Technologies
600 Mountain Avenue, 2D428, Murray Hill, NJ 07974, USA 
tel +1 908 582 4562  | fax +1 908 582 7308  |     [email-masked]
==============================================================================
_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip