Subject: RE: [Sip] Impossible to use real persistent connection with sip

From: "Christian Jansson" <[email-masked]>
Date: Wed, 12 Feb 2003 17:51:28 +0100

Vijay K. Gurbani wrote:

<snip>

> Section 18 of rfc3261 correctly instructs implementors to 
> close connections after a certain time (64*T1).  

No, it does not. Section 18 does not say when to close sockets, but
rather that you should not close the socket to soon. So if you feel like
it, you could leave the connection open forever.

> It also 
> recognizes that two proxies in a peering relationship will 
> actually have two connections open towards each other (which 
> can be avoided).  And it also rightly defines "persistence" 
> to mean a transaction duration. rfc3261 must ensure that the 
> transactional integrity of SIP is preserved, and it does.

It says that it is good to keep the connection open during a
transaction, but it does not say that connections should be closed when
the transaction is terminated.

> 
> All that is being done now is an attempt to investigate an 
> extension that will enable "persistence" to mean some 
> duration longer than a transaction's lifetime.  Exactly how 
> long, how to negotiate it (or
> not) is what comes next.

Not needed. Close the socket when you have to, and probably it will be
more effective to keep it open for a while in case you need it again (as
Cullen Jennings wrote).

Christian Jansson
Hotsip
 
> 
> Cheers.
> 
> - vijay
> -- 
> Vijay K. Gurbani  vkg@{lucent.com,research.bell-labs.com,acm.org}
> Wireless Networks Group/Internet Software and Services
> Lucent Technologies/Bell Labs Innovations, 2000 Lucent Lane, Rm 6G-440
> Naperville, Illinois 60566     Voice: +1 630 224 0216
> 
> _______________________________________________
> Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
> This list is for NEW development of the core SIP Protocol
> Use [email-masked] for questions on current 
> sip Use [email-masked] for new developments on the 
> application of sip
> 
_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Vijay K. Gurbani" <[email-masked]>
Date: Wed, 12 Feb 2003 11:44:34 -0600

Christian Jansson wrote:
> No, it does not. Section 18 does not say when to close sockets, 

That's your interpretation.  When I read the following sentence from
section 18:

    "It is RECOMMENDED that connections be kept open for some
    implementation-defined duration..."

It implies to me that after the duration has passed, the entity is
free to close the socket.

> but

I am afraid I don't read it that way; i.e. leave the connection open
forever.

> more effective to keep it open for a while in case you need it again (as

Exactly how long is the question.  For some peering arrangements between
service providers and for UACs always using a default outbound proxy,
does it make sense to leave TCP/TLS sockets open for a longer time than
a transaction.  That is the crux of the problem.

Cullen Jennings writes:
> Hmm - I did not read 3261 quite that way.
> 
> I thought it was more along the lines of what you want to get too where 
> it is up to the proxy and UA to make intelligent decision about when to 
> close a connection. I think it would be good to provide some information 
> level advice about schemes UA and Proxies might want to use to do a good 
> job of this.

Right; or schemes between proxies.

> If this required more information to be passed between them to do a
> good job of it that would be interesting but without seeing the 
> scheme it is hard to see that they need any more information than 
> they have today.

Fair enough.  Folks on the CC list (except [email-masked] :-)) are working
on an I-D and it'll be available as soon as they are done.

Thanks,

- vijay

---

From: Sean Olson <[email-masked]>
Date: Wed, 12 Feb 2003 17:49:53 -0800 (PST)

I'm looking forward to reading the draft.
I think this is a common problem that deserves
greater scrutiny. I don't think there is any 
lack of potential solutions. I would like to see
some clean (informational) recommendations on
how this should be done. In addition to connection
persistence, I think connection re-use is an
interesting problem that could potentially be 
solved with a common design. This is similar
to recommendations on how best to use SCTP
in a SIP environment.

Regards,
Sean Olson
Microsoft

--- "Vijay K. Gurbani" <[email-masked]> wrote:
> Vijay K. Gurbani 
> vkg@{lucent.com,research.bell-labs.com,acm.org}
> Sip mailing list 
> https://www1.ietf.org/mailman/listinfo/sip

__________________________________________________
Do you Yahoo!?
Yahoo! Shopping - Send Flowers for Valentine's Day
http://shopping.yahoo.com
_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip