Subject: [Sip] Never can a proxy modify SIP message body?

From: "Chen Zaifeng,BISC R&D SA(BJ)" <[email-masked]>
Date: Mon, 16 Jun 2003 09:18:30 +0800

Dear All:
I found two statements in rfc3261 which seem to conflict each other:
1. In page 23, in the definition of "Proxy, Proxy Server", it says that "A proxy interprets, and, if necessary, rewrites 
    specific parts of a request message before forwarding it."
2. In page 100, under the title of "1. Copy request", it says that "The proxy MUST NOT add to, modify, or remove the 
    message body."

On the other hand, there are scenarios that need a proxy to modify a SIP message body, e.g. for SIP<-->PSTN/ISDN
calls, it is dangerous to delivery ISUP MIME content encapsulated in SIP message body to SIP user client, or receive
such ISUP content from SIP user client (in such cases the ISUP content might be mostly for malicious usage) and
forward it to somewhere like SIP-PSTN gateways, then a proxy might have to screen/remove ISUP MIME content
encapsulated in SIP message body.

Any of your ideas or clarifications to my puzzles are highly appreciated. Thanks!

Sincerely yours, 
Chen Zaifeng
--------------------------------------------------------------------------
Beijing International Switching System Corporation Ltd.
TD/DEW
No. 14 Jiu Xian Qiao Road
Beijing 100016, P. R. China
Tel:  +86-10-8457 1921
Fax: +86-10-6436 7732
E-mail: <mailto:[email-masked]>

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Tom Taylor <[email-masked]>
Date: Mon, 16 Jun 2003 14:59:05 -0400

There are two possibilities here: the SIP UA can legitimately send encapsulated ISUP 
to the network, but that ISUP has to be checked for valid and legitimate content, or 
the SIP UA has no right to send encapsulated ISUP.  In the first case, you need a UA 
to do the checking.  This can be a B2BUA or a SIP-to-ISUP gateway, with the former 
being the more likely solution.

If the SIP UA has no right to send encapsulated ISUP, a proxy can reject the message 
on the basis of the Content-Type header field.