Subject: [Sip] Question on rfc3263 - locating sip servers

From: Udi Weintrob <[email-masked]>
Date: Thu, 5 Jun 2003 10:01:53 +0300

Hi,
I have a question regarding RFC3263.

from the RFC (4):
Because the ACK request for 2xx responses to INVITE constitutes a
different transaction, there is no requirement that it be delivered
to the same server that received the original request (indeed, if
that server did not record-route, it will not get the ACK).

Does that mean that for ACK on 2xx responses, I need to re-query the DNS
server (assuming a non IP uri)?
Do I need to query the DNS even if the URI of the ACK is the same as the URI
of the initial INVITE request?

thanks,
Udi J. Tirosh.

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Nataraju A.B." <[email-masked]>
Date: Thu, 05 Jun 2003 13:15:49 +0530

The basic requirement for ACK for 2xx of INVOTE is to make sure the UAS that 2xx been received by UAC. 

Also ACK may not pass through the same route which the INVITE passed through to UAS.

UAC while sending the ACK request will use the route header in the 2xx(INVITE) response and the Req-URI will be set with teh contact address in teh 2xx response.

more comments inline..

Regards,
-Nataraju A.B.
May you live as long as you wish and love as long as you live. 
--Robert A. Heinlein Time Enough for Love.

----- Original Message ----- 
  From: Udi Weintrob 
  To: [email-masked] 
  Sent: Thursday, June 05, 2003 12:31 PM
  Subject: [Sip] Question on rfc3263 - locating sip servers

  Hi,

  from the RFC (4):

  [Nataraju A.B.]
  U may need to query the DNS server if u have not cached the domain name and FQDN mapping.

  [Nataraju A.B.]
  In the first place There is no point in sending ACK to some one else also. 

  thanks,
  Udi J. Tirosh.

---

From: "Bang Du" <[email-masked]>
Date: Thu, 5 Jun 2003 12:02:01 -0700

Hi Udi,
In either case, you need to do the dns query.

Regards,
Bang

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of Udi
Weintrob
Sent: Thursday, June 05, 2003 12:02 AM
To: [email-masked]
Subject: [Sip] Question on rfc3263 - locating sip servers

Hi,

from the RFC (4):

thanks,
Udi J. Tirosh.

---

From: Amit Bhadoria <[email-masked]>
Date: Thu, 5 Jun 2003 13:28:07 -0700 (PDT)

udi,

its not a MUST to do a DNS querry for subsequent messages, you could cache
the results from last successfull querry and use it. however, in case of
failover, or to handle some non-trivial case, you may have to do DNS
querry again -- and thats exactly what these guidelines are for, to give a
standard/open procedure.

as a side note, the Record-route inserted by each intermediate hop gives a
little hint on how it wants to be resolved for subsequent messages. for
example, it may choose to insert its domain only, in which case you may
have to do NAPTR/SRV querries.

regards,
-amit.
--
Amit Bhadoria
Software Engineer
http://www.cisco.com