Subject: [Sip] Sip and flash function

From: "Alejandro Islas" <[email-masked]>
Date: Mon, 2 Jun 2003 12:59:13 -0500

Hi all, I´m new to SIP so I was wondering is there some official document (draft or RFC) towards the behaviour of a SIP UA after receiving a FLASH from the end user??? In other words, how do SIP interacts with digitally services such as "transfer call" that needs a FLASH+number undestanding???
 Alejandro Islas
 Kb/TEL 
MEXICO

---

From: "Drage, Keith (Keith)" <[email-masked]>
Date: Thu, 5 Jun 2003 15:50:35 +0100

FLASH + number is stimulus signalling, i.e. the sending terminal does not understand the service that is being requested. This type of signalling is inappropriate to SIP entities (although potentially could in some limited circumstances be passed transparently through the SIP system to some remote entity, e.g. a voice mail server).

You need some entity in the way (before SIP is reached) that interprets that FLASH + number as the call transfer service, or whatever and implements the rest of call transfer in a stimulus fashion back to the non-SIP user, and implements call transfer towards the SIP entities. This is exactly the same function as is performed in the PSTN between the user access and SS7.

As this entity is not in SIP, it is out of scope of the SIP/SIPPING groups.

You will find example descriptions of a number of services provided by SIP in SIPPING group drafts e.g.

http://www.ietf.org/internet-drafts/draft-ietf-sipping-cc-transfer-01.txt
http://www.ietf.org/internet-drafts/draft-ietf-sipping-service-examples-04.txt 
http://www.ietf.org/internet-drafts/draft-ietf-sipping-basic-call-flows-02.txt
http://www.ietf.org/internet-drafts/draft-ietf-sipping-pstn-call-flows-02.txt
http://www.ietf.org/internet-drafts/draft-ietf-mmusic-offer-answer-examples-00.txt

Some of these are obviously more relevent to you than others.

regards

Keith

Keith Drage
Lucent Technologies
Tel: +44 1793 776249
Email: [email-masked] 
-----Original Message-----
From: Alejandro Islas [mailto:[email-masked]]
Sent: 02 June 2003 18:59
To: [email-masked]
Subject: [Sip] Sip and flash function

Hi all, I´m new to SIP so I was wondering is there some official document (draft or RFC) towards the behaviour of a SIP UA after receiving a FLASH from the end user??? In other words, how do SIP interacts with digitally services such as "transfer call" that needs a FLASH+number undestanding???
 Alejandro Islas
 Kb/TEL 
MEXICO
_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip