Subject: [Sip] Complex status info transfer in SIP presence service

From: "Chen Zaifeng,BISC R&D SA(BJ)" <[email-masked]>
Date: Mon, 16 Jun 2003 09:40:32 +0800

Dear All:
I have questions about SIP based presence service:

1.  If a Registar is used to be a source of original presence info, how to transfer complex or multiple status
     info (not only Online and Offline), e.g. Busy, Idle, No Disturb, from Presentity to Registar? Can these
     status info be contained in an extension parameter of Contact header of Register message?
2. How about the solution that no Registar is used and Presentity push presence info directly to Presence 
    Server by sending of NOTIFY message?

Any of your ideas or answers will be highly appreciated! Thanks!

Sincerely yours, 
Chen Zaifeng
--------------------------------------------------------------------------
Beijing International Switching System Corporation Ltd.
TD/DEW
No. 14 Jiu Xian Qiao Road
Beijing 100016, P. R. China
Tel:  +86-10-8457 1921
Fax: +86-10-6436 7732
E-mail: <mailto:[email-masked]>

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Henry Sinnreich <[email-masked]>
Date: Mon, 16 Jun 2003 10:22:10 -0500

Please see the I-D <draft-schulzrinne-simple-rpids-01.txt> at the
ietf.org archive.

Henry

Henry Sinnreich
MCI
400 International Parkway
Richardson, Texas 75081
USA

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of Chen Zaifeng,BISC R&D SA(BJ)
> Sent: Sunday, June 15, 2003 8:41 PM
> To: [email-masked]'
> Subject: [Sip] Complex status info transfer in SIP presence service
> 
> 
> Dear All:
> 1.  If a Registar is used to be a source of original presence 
> info, how to transfer complex or multiple status
>      info (not only Online and Offline), e.g. Busy, Idle, No 
> Disturb, from Presentity to Registar? Can these
>      status info be contained in an extension parameter of 
> Contact header of Register message? 2. How about the solution 
> that no Registar is used and Presentity push presence info 
> directly to Presence 
> Use [email-masked] for questions on current 
> sip Use [email-masked] for new developments on the 
> application of sip
>