Subject: Re: [Sip] WGLC for auth-id body

From: Robert Sparks <[email-masked]>
Date: 09 Jun 2003 14:40:33 -0500

I've reviewed this document (with revision of referredby
particularly in mind) and have the following minor comments:

- It would help section 4 to more explicitly note that it
  is discussing using AIBs to do something beyond(besides?)
  providing integrity protection/authentication for the 
  request it appears in.  It would also help to capture that
  the presence of these other things don't preclude the section
  2 use of an AIB. Perhaps this text at end of the first paragraph
  of section 4:

     Such information might be carried in one or more supplemental
     AIBs. The presence of these supplemental AIBs does not preclude
     the use of AIB as specified in this document to protect the
     message in which they appear.

- Instead of a special case of INVITE (see the heading of section 4), I
  think this simply a different use of an AIB. This document constrains
  the use of AIBs for providing integrity protection of messages and
  authenticating their sender regardless of method type. Section 4 is
  trying to note that other AIBs might appear that do something 
  different. Perhaps this section could be titled "Potential additional
  uses of AIBs"?

- Section 10 (Security Considerations): The first sentence needs to
  be scoped to the section 2 use of AIBs, not all uses of AIBs with
  message/sipfrag in them.

- Spelling Nits:
   * Second sentence, last paragraph Page 4: 
       s/SHOULD be added it to/SHOULD be added to/
   * Second sentence, last paragraph, section 4, Page 6:
       s/harder to correlated an AIB/harder to correlate an AIB/

Other than that, I believe this document is ready to go.

RjS

On Tue, 2003-05-13 at 19:39, Rohan Mahy wrote:
> Hello Everyone,
> 
> I would like to begin Working Group Last Call on
> 
> http://www.ietf.org/internet-drafts/draft-ietf-sip-authid-body-01.txt
> 
> WGLC will end on Friday, June 13, 2003.
> 
> thanks,
> -rohan
> 
> _______________________________________________
> Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
> This list is for NEW development of the core SIP Protocol
> Use [email-masked] for questions on current sip
> Use [email-masked] for new developments on the application of sip

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Peterson, Jon" <[email-masked]>
Date: Fri, 13 Jun 2003 03:03:16 -0400

Thanks for these comments. A few notes below.

Jon Peterson
NeuStar, Inc.

[snip]
>      message in which they appear.

Yes, I do think it is important to capture the idea that there may be
multiple AIBs in a SIP message that identify different parties. The text
given above looks good to me.

>   different. Perhaps this section could be titled "Potential additional

Well, although REFER-instigated INVITEs might not be a special case as such,
most would probably say that 3PCC is a special case. But still, we need a
section title that accommodates both, so I think that's fair; a better title
for this section is probably in order. I think we need something with the
sense "Use of AIBs to express the identity of someone other than the sender
of the INVITE". I'll try to figure out a way to compress that to
header-size.

>   be scoped to the section 2 use of AIBs, not all uses of AIBs with

Okay, fine.

>        s/harder to correlated an AIB/harder to correlate an AIB/

Thanks, I'll take care of all of those.

---

From: "Mary Barnes" <[email-masked]>
Date: Fri, 13 Jun 2003 11:09:38 -0500

There's one more nit that I noticed that doesn't appear to be mentioned by
Robert. 

In the second paragraph of section 4, the 2nd clause of the last sentence
needs rewording.  I think it should read:
   " ..., the From header
   of the INVITE would indicate the referee, whereas a separate header
   would indicate the referrer."

Regards,
Mary.

-----Original Message-----
From: Peterson, Jon [mailto:[email-masked]]
Sent: Friday, June 13, 2003 2:03 AM
To: 'Robert Sparks'; Rohan Mahy
Cc: [email-masked]; 'Dean Willis'; [email-masked]
Subject: RE: [Sip] WGLC for auth-id body

Jon Peterson
NeuStar, Inc.

[snip]

Okay, fine.

---

From: "Peterson, Jon" <[email-masked]>
Date: Fri, 13 Jun 2003 13:03:45 -0400

Noted - yes, your text is superior. It'll be fixed. Thanks!

Jon Peterson
NeuStar, Inc.

> From: Mary Barnes [mailto:[email-masked]]
> Sent: Friday, June 13, 2003 9:10 AM
> To: 'Peterson, Jon'; 'Robert Sparks'; Rohan Mahy