Subject: [Sip] Is there any standard SIP/SDP for communicating echo cancellation ?

From: "Hashmi, Mohamed Hadi" <[email-masked]>
Date: Wed, 23 Jul 2003 10:04:48 -0600

For transmitting FAX or Modem call over VoIP  ( RTP- preferably G.711) in PSTN-SIP-PSTN call it is required that echo cancellation be turned off at both end Gateways. There are specific standards for FAX (T.38) and MoIP (V.150.1) to deal with these issues, but not every vendor has implemented those standards in their Media Gateways. 

In such a situation  G.711 with echo cancellation turned off at both end will help transmitting such calls like FAX or  MoIP. Gateway control protocols such as MGCP,  Megaco,  IPDC  etc do have specific tags to handle this case. But don't know how this information can be communicated between two Gateway Controllers using SIP.  Is anybody aware of any standard SDP  for such a functionality?  Although an SDP can be custom designed for this purpose but this wouldn't help interoperation between two different vendors. 

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Rohan Mahy <[email-masked]>
Date: Thu, 24 Jul 2003 00:31:20 +0200

Hi,

It would probably help if you took a look at 
draft-ietf-sipping-realtimefax-01.txt and its references.  If you still 
have questions, please post your question to the MMUSIC WG mailing list.

many thanks,
-rohan
co-chair SIP and SIPPING

On Wednesday, July 23, 2003, at 06:04 PM, Hashmi, Mohamed Hadi wrote:

> For transmitting FAX or Modem call over VoIP  ( RTP- preferably G.711) 
> in PSTN-SIP-PSTN call it is required that echo cancellation be turned 
> off at both end Gateways. There are specific standards for FAX (T.38) 
> and MoIP (V.150.1) to deal with these issues, but not every vendor has 
> implemented those standards in their Media Gateways.
>
> In such a situation  G.711 with echo cancellation turned off at both 
> end will help transmitting such calls like FAX or  MoIP. Gateway 
> control protocols such as MGCP,  Megaco,  IPDC  etc do have specific 
> tags to handle this case. But don't know how this information can be 
> communicated between two Gateway Controllers using SIP.  Is anybody 
> aware of any standard SDP  for such a functionality?  Although an SDP 
> can be custom designed for this purpose but this wouldn't help 
> interoperation between two different vendors.
>