Subject: RE: [Sip] SIP SUBSCRIBE question

From: Idnani Ajaykumar-AIDNANI1 <[email-masked]>
Date: Wed, 13 Aug 2003 13:53:39 -0500

May be there is something here that I am missing, so I would appreciate if you could help me understand. Why should the UA not be there? The UA has just restarted, it is still using the same Address-of-Record and the same Contact address. So I would assume the Notify will land on the UA. Is the UA supposed to ignore a NOTIFY that is not connected to any active dialog on the UA? Or is it supposed to respond back with an error response, if so what should be the error response, and what should be the behavior of the Notifier when it receives the error response.

Thanks and Regards
- Ajay

-----Original Message-----
From: Jonathan Rosenberg [mailto:[email-masked]] 
Sent: Wednesday, August 13, 2003 1:41 PM
To: Idnani Ajaykumar-AIDNANI1
Cc: [email-masked]; [email-masked]
Subject: Re: [Sip] SIP SUBSCRIBE question

No, the subscription is removed once there is a notification. The 
NOTIFY will fail since the UA is no longer there, and thus the 
subscription removed.

-Jonathan R.

Idnani Ajaykumar-AIDNANI1 wrote:

> I think the assumption here is that the timeout is relatively small. However if we were to set the SUBSCRIBE such that the subscription never expires - something like 2^32 - 1 - then the old subscription cannot be removed automatically. The UA would need to explicitly remove the subscription as Brett stated.
> 
> Regards
> - Ajay
> 
> -----Original Message-----
> From: Jonathan Rosenberg [mailto:[email-masked]] 
> Sent: Wednesday, August 13, 2003 12:53 PM
> To: [email-masked]
> Cc: [email-masked]
> Subject: Re: [Sip] SIP SUBSCRIBE question
> 
> 
> 
> Brett Tate wrote:
> 
> 
>>>>>From a protocol perspective, it has no relation to
>>>>the prior subscription.  They are separate subscriptions.
>>>>>From an event perspective, the notifier could decide 
>>>>to audit, terminate, or continue the prior subscription.
>>>
>>>There is no reason for it to change the existing 
>>>subscription in any way. Doing so, just because of 
>>>the arrival of the new subscription, is likely to 
>>>lead to interop problems, some of which you point 
>>>out below. The two subscriptions are totally separate, 
>>>period.
>>
>>
>>Unfortunately situations occur where a notifier will 
>>only allow a limited number of subscriptions from user 
>>for a user for the same event.  Rejecting the new 
>>subscribe without also auditing the old subscription 
>>is likely going to lead to a loss of that service 
>>until an old subscription is removed (expires or 481).
>>
>>For example, a phone subscribes to message-summary.
>>The phone restarts and loses its old message-summary
>>subscription.  It sends a new subscription for
>>message-summary.  If the notifier does not intend
>>to allow an infinite number of message-summary
>>subscriptions from the same user for the same user,
>>the subscribes would start being reject once a threshold
>>is reached. 
> 
> 
> There is really no need for this. The next NOTIFY to the old 
> subscription will time out and therefore be removed automatically.
> 
> -Jonathan R.

-- 
Jonathan D. Rosenberg, Ph.D.                600 Lanidex Plaza
Chief Technology Officer                    Parsippany, NJ 07054-2711
dynamicsoft
[email-masked]                     FAX:   (973) 952-5050
http://www.jdrosen.net                      PHONE: (973) 952-5000
http://www.dynamicsoft.com

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Mingcheng Zhu" <[email-masked]>
Date: Wed, 13 Aug 2003 12:15:13 -0700

Hi,

I think the to tag, from tag and callID will have no match at the UA side
and this will trigger the deletion of subscription at Notifier side.

Regards,

Mingcheng

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of Idnani
Ajaykumar-AIDNANI1
Sent: Wednesday, August 13, 2003 11:54 AM
To: 'Jonathan Rosenberg'; Idnani Ajaykumar-AIDNANI1
Cc: [email-masked]; [email-masked]
Subject: RE: [Sip] SIP SUBSCRIBE question

May be there is something here that I am missing, so I would appreciate if
you could help me understand. Why should the UA not be there? The UA has
just restarted, it is still using the same Address-of-Record and the same
Contact address. So I would assume the Notify will land on the UA. Is the UA
supposed to ignore a NOTIFY that is not connected to any active dialog on
the UA? Or is it supposed to respond back with an error response, if so what
should be the error response, and what should be the behavior of the
Notifier when it receives the error response.

Thanks and Regards
- Ajay

-----Original Message-----
From: Jonathan Rosenberg [mailto:[email-masked]]
Sent: Wednesday, August 13, 2003 1:41 PM
To: Idnani Ajaykumar-AIDNANI1
Cc: [email-masked]; [email-masked]
Subject: Re: [Sip] SIP SUBSCRIBE question

-Jonathan R.

Idnani Ajaykumar-AIDNANI1 wrote:

> I think the assumption here is that the timeout is relatively small.
However if we were to set the SUBSCRIBE such that the subscription never
expires - something like 2^32 - 1 - then the old subscription cannot be
removed automatically. The UA would need to explicitly remove the
subscription as Brett stated.

---

From: Jonathan Rosenberg <[email-masked]>
Date: Wed, 13 Aug 2003 15:21:48 -0400

Idnani Ajaykumar-AIDNANI1 wrote:

> May be there is something here that I am missing, so I would
> appreciate if you could help me understand. Why should the UA not
> be there? The UA has just restarted, it is still using the same
> Address-of-Record and the same Contact address. So I would assume
> the Notify will land on the UA. Is the UA supposed to ignore a
> NOTIFY that is not connected to any active dialog on the UA?

No, but the dialog identifiers don't match an existing subscription. 
So, the UAS generates a 481, and this causes the server to terminate 
the subscription.

-Jonathan R.