Subject: [Sip] SIP SUBSCRIBE question

From: Idnani Ajaykumar-AIDNANI1 <[email-masked]>
Date: Fri, 8 Aug 2003 15:17:48 -0500

Hi, 
 
What is the expected behavior of Notifier if it receives a SUBSCRIBE message from a UAC in the following scenario
 
- The SUBSCRIBE is sent with a new Call-ID when there is already an existing dialog associated with the same UAC and for the same Event Package 
 
Should the Notifier overwrite the new subscription with the existing subscription (update the expire interval) or not?
 
Best Regards
- Ajay

---

From: "Brett Tate" <[email-masked]>
Date: Mon, 11 Aug 2003 10:41:50 -0400

> What is the expected behavior of Notifier if it 
> receives a SUBSCRIBE message from a UAC in the 
> following scenario
> 
> - The SUBSCRIBE is sent with a new Call-ID when 
> there is already an existing dialog associated 
> with the same UAC and for the same Event Package 
>
> Should the Notifier overwrite the new subscription 
> with the existing subscription (update the expire 
> interval) or not?

From a protocol perspective, it has no relation to
the prior subscription.  They are separate subscriptions.
From an event perspective, the notifier could decide 
to audit, terminate, or continue the prior subscription.

If it audits the prior subscription, it would send 
a notify with the current state information and 
time remaining before expiration.  The subscriber 
should return a 481 if the subscription/dialog no 
longer exists.

If the notifier terminates the prior subscription, a 
notify should be sent.  This might lead to another new 
subscribe if the subscriber really wanted two subscription.
Such activity might lead to a continual new subscription
process if the subscriber wants two subscriptions and the
notifier does not allow it.

If it continues the prior subscription, the notifier
would continue to send notifies when needed.  The
subscriber will return a 481 if they are not wanted.
If nothing triggers the notify and the subscriber does
not refresh the subscription, it will expire naturally.

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Jonathan Rosenberg <[email-masked]>
Date: Wed, 13 Aug 2003 11:20:25 -0400

> to audit, terminate, or continue the prior subscription.

There is no reason for it to change the existing subscription in any 
way. Doing so, just because of the arrival of the new subscription, is 
likely to lead to interop problems, some of which you point out below. 
The two subscriptions are totally separate, period.

-Jonathan R.

-- 
Jonathan D. Rosenberg, Ph.D.                600 Lanidex Plaza
Chief Technology Officer                    Parsippany, NJ 07054-2711
dynamicsoft
[email-masked]                     FAX:   (973) 952-5050
http://www.jdrosen.net                      PHONE: (973) 952-5000
http://www.dynamicsoft.com

---

From: "Brett Tate" <[email-masked]>
Date: Wed, 13 Aug 2003 12:37:41 -0400

> There is no reason for it to change the existing 
> subscription in any way. Doing so, just because of 
> the arrival of the new subscription, is likely to 
> lead to interop problems, some of which you point 
> out below. The two subscriptions are totally separate, 
> period.

Unfortunately situations occur where a notifier will 
only allow a limited number of subscriptions from user 
for a user for the same event.  Rejecting the new 
subscribe without also auditing the old subscription 
is likely going to lead to a loss of that service 
until an old subscription is removed (expires or 481).

For example, a phone subscribes to message-summary.
The phone restarts and loses its old message-summary
subscription.  It sends a new subscription for
message-summary.  If the notifier does not intend
to allow an infinite number of message-summary
subscriptions from the same user for the same user,
the subscribes would start being reject once a threshold
is reached.  This would lead to a loss of message-summary 
service until a related subscription expires or triggers
an update and until the phone retries a new message-summary 
subscription again.

---

From: Jonathan Rosenberg <[email-masked]>
Date: Wed, 13 Aug 2003 13:53:15 -0400

Brett Tate wrote:

> is reached. 

There is really no need for this. The next NOTIFY to the old 
subscription will time out and therefore be removed automatically.

-Jonathan R.