Subject: RE: AW: [Sip] SIPIT Interop problem with ;user=phone

From: "Rosen, Brian" <[email-masked]>
Date: Wed, 27 Aug 2003 14:59:02 -0400

You are thinking about big trunk gateways.
I'm talking about smaller ones.
TRIP is extreme overkill for a 4 or 8 line gateway.
TRIP is unnecessary if all the gateways in a system are
routable by some simple ruleset.

Registration by the gateway is a Good Thing.
The user part of the AOR is not all that usefull, although
we actually do use it, but it lets the signalling system
know that the gateway is up and running, and how to contact it.

Brian

> -----Original Message-----
> From: Dean Willis [mailto:[email-masked]]
> Sent: Wednesday, August 27, 2003 1:33 PM
> To: Rosen, Brian
> Cc: 'Cullen Jennings'; [email-masked]
> Subject: RE: AW: [Sip] SIPIT Interop problem with ;user=phone
> 
> 
> Brian said:
> > You are the weird one because you have both a phone
> > and a gateway with the same AOR, unless you are relying
> > on the gateway not registering as the phone number it
> > has on its port.  We've seen a gateway that did that.
> 
> I'm sorry somebody sent you a defective gateway. I hope you 
> were able to
> get it fixed.
> 
> Gateways, at least multiline gateways, should NEVER EVER register.
> That's deeply evil! They get calls from PSTN, turn them into SIP
> INVITES, and send them out (ostensibly, to the default 
> proxy). They get
> SIP INVITES from their IP side, turn the user part into a 
> phone number,
> and signal it out to PSTN. Very simple business. Having gateways
> "register" leads to insanity like trying to send a regisration request
> for every phone number in the NANP, or in a given area code, or the
> like. That's whay we have TRIP, with its prefix-ranges and weights.
> 
> A telephone number is not an address of record. It's the 
> user-part of an
> address of record and must be evaluated in the context of 
> some domain to
> be meaningful. By convention, we assume that a telephone 
> number having a
> leading + is evaluated in the E.164 domain context. It doesn't really
> have to be (not a MUST), but it's a useful convention. 
> Anything else, we
> have to "guess at" the context, unless the context is specifically
> stated in the right-hand-side production of a SIP(S) URI.
> 
> The user=phone parameter was meant as a hint to help guess the
> evaluation context. The original argumentation for it was that
> user=phone would help disambiguate a case where there were cearly two
> different AORs with the same "user part" in a given domain -- a case
> that I don't believe we've found to exist. In some environments it is
> clearly not meaningful. In other environments, it MIGHT be. 
> 
> The question: Is the utility of the parameter in those environments
> sufficient to justify the complexity that it apparently creates?
> 
> --
> Dean
> 
> 

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Cullen Jennings <[email-masked]>
Date: Wed, 27 Aug 2003 14:41:15 -0700

I'm firmly off topic here but ...

I think that TRIP could be very interesting for small GWs too. At one point
in time Free World Dialup had a huge number of single port GWs. The trick
was knowing which ones were currently busy - they went from 0% to 100%
pretty quick and often a very large percentage of them were in use. TRIP was
excellent for providing the resource availability information so that you
could find a GW that was not in use without probing a bunch of GWs. It also,
for this case, moved the administration of what phone numbers this GW could
cheaply call to the right place. Clearly in some other cases you want that
sort administrative entry centralized.

Anyways, I think the discussion of using SIP for registration of PSTN GWs
was done to death in IPTEL.

Cullen