Subject: RE: AW: [Sip] SIPIT Interop problem with ;user=phone

From: Dean Willis <[email-masked]>
Date: Wed, 27 Aug 2003 12:43:17 -0500

brian suggested about user=phone:
> I think it should be used to denote that the user part is a dial string.

Assume a gateway gets a SIP INVITE that does NOT have a user=phone
parameter, but the host-part of the request-URI matches the
area-of-responsibility for that gateway (for example, it's hostname).

Should it:

1) Respond with a 404 (or related code), because it's a GATEWAY and it
MUST receive a dial-string as the user-part of a SIP(S) request-URI.

2) Try to convert the user part) into a phone number anyhow.

If case 1, I submit that we just added a lot of complexity to other
people's forwarding tables, and I don't think we got anything out of the
effort.

If case 2, I submit that the user=phone parameter achieved nothing and
might as well be deprecated.

--
Dean

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Rosen, Brian" <[email-masked]>
Date: Wed, 27 Aug 2003 13:24:28 -0400

So the response should be?

I think the basic idea on the table is to define what it does mean.
It may not be possible to cover all the current uses.
It may be possible to guide evolution of its use.

We've seen a couple reasons why flushing it is probably not the
right thing to do.

I'm willing to write something that specifies what it does,
if there is anything close to consensus on what that might be.

Right now, I'd say:
It should NOT be a duplicate of what a tel URI does, even though
that's what some systems do now.

It should NOT be used when you happen to have a numeric username.

It might be used to indicate that it is a translated tel uri.
I wonder if it wouldn't it be better to have another way to denote 
this condition.

Brian

> -----Original Message-----
> From: Cullen Jennings [mailto:[email-masked]]
> Sent: Wednesday, August 27, 2003 12:21 PM
> To: Dean Willis; Brian Rosen
> Cc: [email-masked]
> Subject: Re: AW: [Sip] SIPIT Interop problem with ;user=phone
> 
> 
> 
> The more this conversation goes on, the more it looks like 
> people are using
> this flag in an implementation specific way and it currently has no
> specified meaning.
> 
> On 8/27/03 8:25, "Dean Willis" <[email-masked]> wrote:
> 
> > On Tue, 2003-08-26 at 07:34, Rosen, Brian wrote:
> >> We might be weird, but lack of user=phone indicates to our proxy
> >> that we should look up the user part in our registered user list.
> >> Including user=phone means we pass the user string to our
> > 
> > You're weird ;-). We look up the user part first, becasue 
> guess what --
> > SOME gateways slap a user=phone on the end of any call 
> coming from PSTN,
> > and I really want to be able to divert that to a SIP UA that isn't a
> > PSTN phone but registers with a user-part that looks like a phone
> > number.
> > 
> > How would your system be able to handle that? Insert 
> routing table logic
> > in your phone number processing that diverts the call back to a non
> > user=phone format and reprocesses it?
> > 
> > My believf: The only responsible thing to do with a 
> user=phone is ignore
> > it.
> > 
> > --
> > Dean
> > 
> > 
>