Subject: AW: AW: Warning about dial plan assumptions (was RE: AW: [Sip] SIPIT Inte rop problem with ;user=phone)

From: "Stastny Richard" <[email-masked]>
Date: Sun, 24 Aug 2003 15:10:00 +0200

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_______________________________________________Sip mailing list  https://www1.ietf.org/mailman/listinfo/sipThis list is for NEW development of the core SIP ProtocolUse [email-masked] for questions on current sipUse [email-masked] for new developments on the application of sip

---

From: "Stastny Richard" <[email-masked]>
Date: Sun, 24 Aug 2003 17:24:12 +0200

IF it would be just the translation from a local dial plan to
a global identifier (= E.164 number) then this is just a simple
script you could either run at the server (UAS) or at the client (UAC).
 
This would require that all servers are able to handle E.164, which
I would prefer anyway. On the other hand, if I look at the current
implementations most of them are not configured in this way. Since
the script in the client should be generic, considering roaming and
the possibility to attach to more then one server (eg like the Cisco
phones) it should translate also the "own" local number to E.164.
 
It would be easy for servers to retranslate this to local numbers,
PROVIDED A E.164 NUMBER for the ITAD EXISTS. Since
this is NOT the case in most implementations the generic approach
would not work (we are working on this one too ;-)
BTW, in this case the client could also query ENUM
directly and submit the sip: URI directly, saving the server this effort.
 
I am also currently working on a paper on numbering and dialing plans
for VoIP, maybe we could join or efforts ;-)
 
best regards
Richard

	-----Ursprüngliche Nachricht----- 
	Von: Henning Schulzrinne [mailto:[email-masked]] 
	Gesendet: So 24.08.2003 16:51 
	An: Conroy, Lawrence (SMTP) 
	Cc: Adam Roach; [email-masked]; Stastny Richard 
	Betreff: Re: Warning about dial plan assumptions (was RE: AW: [Sip] SIPIT Inte rop problem with ;user=phone)

	In an earlier iteration of this discussion in the IPTEL WG, there was
	some consensus that the appropriate way is to download a dialplan into
	the end system, which then does the translation from dialed digits to a
	global identifier. That way, it doesn't matter where the SIP or tel URI
	ends up and removes the where-was-this-number-dialed guessing by the
	outbound proxy. This should be part of the general configuration
	mechanism. I had volunteered to write up a spec for that, but I'm
	waiting for the general shape of the configuration data format to settle.
	
	Conroy, Lawrence (SMTP) wrote:

	> *I* would love such a specification, because it's what my
	> cellphone does. You wouldn't because you are in the NANP.
	>
	> Thus any spec mustn't be "over the wire" - it MUST be at
	> most an end system issue. It's dangerous for a Proxy to
	> interpret, as the expectations of the end user may differ.
	>
	> I'd be confused and miffed if I dialled 0117 and my proxy
	> and PSTN gateway gave me a Russian number rather than the
	> Bristol number I expected. So, no doubt, would the callee :).
	>
	> all the best,
	>   Lawrence

����X��X��m����5��_��?�������+-�w��ȩN��+-����u�ޖ�fz{h~�^r��H�Ϯ�hr�T��"�)��鞞�+���[�n&�v�讫��ب��'r��z{l��,zȩ�)���_������ׯzZ)������橦X�jب���

---

From: "Roy, Radhika R, ALABS" <[email-masked]>
Date: Sun, 24 Aug 2003 13:58:47 -0400

Inline [RRR]

-----Original Message-----
From: Stastny Richard [mailto:[email-masked]]
Sent: Sunday, August 24, 2003 11:24 AM
To: Henning Schulzrinne; Conroy, Lawrence (SMTP)
Cc: Adam Roach; [email-masked]
Subject: AW: Warning about dial plan assumptions (was RE: AW: [Sip]
SIPIT Inte rop problem with ;user=phone)

....

[RRR] I think that this the right approach (I have also been thinking along this line).
 
....
 
best regards
Richard

J*fj)b�	b��m��?�0�'�~���f��f��X��)ߣ�"�8b�X��+��DYׯzZ)�����ay�+y">�-��%RǬ����W�z{h��,r�n���y۟���z�b�{(�˫����*T��"����'�~��~��{^��h�g���'����bq�b�z�*

---

From: "Rosen, Brian" <[email-masked]>
Date: Mon, 25 Aug 2003 10:04:47 -0400

This breaks nearly every existing phone.  Is that your intention?

user=phone, at the moment, means "this is a dial string".  
It used to be that you could do the same in a tel uri, but we
"fixed" that.  Until we have overwhelming deployment of end devices
that translate dial strings to tel uris (PLEASE do not say
E.164s or global identifier, they are not all global numbers after 
translation), we need to leave user=phone as the way to send a dial 
string.

Brian

> From: Henning Schulzrinne [mailto:[email-masked]]
> Sent: Sunday, August 24, 2003 10:52 AM
> To: Conroy, Lawrence (SMTP)
> Cc: Adam Roach; [email-masked]; Richard
> Subject: Re: Warning about dial plan assumptions (was RE: AW: [Sip]
> _______________________________________________
> Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
> This list is for NEW development of the core SIP Protocol
> Use [email-masked] for questions on current sip
> Use [email-masked] for new developments on the application of sip
> 

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Rohan Mahy <[email-masked]>
Date: Wed, 27 Aug 2003 16:56:12 -0700

On Monday, August 25, 2003, at 07:37 AM, Rosen, Brian wrote:

> I think it can mean anything the proxy that knows how to translate a
> dial string to a "full" routable URI allows it to mean.
> So, the answer is no. it doesn't have to parse as telephone-subscriber.
> It has to parse as userinfo.

I disagree vociferously.  The only reason not to generate a string 
which can be parsed as a telephone-subscriber is sheer laziness.  There 
is NO REASON why you cannot interpret a dial string as an ordinary 
(user=ip) SIP URI.  If your proxy can't do this, then either get a new 
proxy that can or configure your UAs to be less lazy and write a proper 
telephone-subscriber (either an e164 or a localnumber with 
phone-context) into the userpart and set user=phone.

thanks,
-rohan

>> From: Christer Holmberg (SE/LMF)
>> [mailto:[email-masked]]
>> Sent: Monday, August 25, 2003 10:18 AM
>> To: 'Rosen, Brian'; 'Henning Schulzrinne'; Conroy, Lawrence (SMTP)
>> Subject: RE: Warning about dial plan assumptions (was RE: AW: [Sip]
>> Hi,
>> Assuming that user=phone means "this is a dial string", does
>> it also means that the syntax has to be according to the
>> telephone-subscriber ABNF? Ie, do we use "+" instead of "00",
>> can we use visual separators without nodes treating them as
>> actual parts of the actual user identifier, etc etc etc? OR,
>> shall we define a separate syntax for "dial-string" in a
>> SIP-URI? I think THAT is the question that started this
>> discussion at the SIPit.
>>
>> Regards,
>>
>> Christer Holmberg
>> Ericsson Finland
>>
>>> From: Rosen, Brian [mailto:[email-masked]]
>>> Sent: 25. elokuuta 2003 17:05
>>> To: 'Henning Schulzrinne'; Conroy, Lawrence (SMTP)
>>> Subject: RE: Warning about dial plan assumptions (was RE: AW: [Sip]