Subject: [Sip] proxy stateless

From: v l <[email-masked]>
Date: Wed, 13 Aug 2003 12:50:54 -0700 (PDT)

I have a question regarding stateless proxy
processing.

If a UA sends an ill defined INVITE (say with
Max-forwards = 0) to a stateless proxy. The 
proxy sends a 483 Too Many Hops response back
to the UA.

Now the UA sends a good ACK for this to the stateless
proxy with the Request URI which is the same as
the INVITE.

How does the stateless proxy know that this ACK is
meant for the previous INVITE and should not be
forwarded ahead?

__________________________________
Do you Yahoo!?
Yahoo! SiteBuilder - Free, easy-to-use web site design software
http://sitebuilder.yahoo.com

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Tom Taylor <[email-masked]>
Date: Thu, 14 Aug 2003 11:14:16 -0400

If this happens, I don't see that the stateless proxy has to recognize anything.  It 
just forwards the ACK and lets the UAS deal with the protocol violation.