Subject: RE: AW: [Sip] SIPIT Interop problem with ;user=phone

From: [email-masked]
Date: Thu, 28 Aug 2003 11:43:53 +0300

No one has been able to convince me why not to use a tel URI for dial strings and sip URI for pure sip users.

When a proxy receives a sip request with a sip request-uri containing a domain it is responsible for, it looks up it s registration table and rejects the request with 404 if not found.

When a proxy receives a sip request with a tel request-uri without a phone-context, it forwards the request to its default GW.

When a proxy receives a sip request with a tel request-uri with a phone-context, it forwards the request to the proxy/GW indicated by the phone-context.

Why does a proxy need to translate a tel URI to a sip URI before forwarding a request?

I believe tel:12345;phone-context:example.com and sip:[email-masked] can be the same or different users. Why do we have to restrict them to be the same user?

Also, why do we need to represent tel:12345;phone-context:example.com as sip:[email-masked];user=phone ? what is the gain in this?

Regards,
Hisham

> -----Original Message-----
> From: ext Dean Willis [mailto:[email-masked]]
> Sent: Thursday, August 28, 2003 1:01 AM
> To: Rosen, Brian
> Cc: 'Cullen Jennings'; [email-masked]
> Subject: RE: AW: [Sip] SIPIT Interop problem with ;user=phone
> 
> 
> Brian said:
> 
> > sip:[email-masked];user=phone means that the call
> > will be passed to the Pittsburgh PBX gateway calling 
> extension 4826.  
> > You could get to the same phone by dialing 
> > sip:[email-masked];user=phone, but that may route a different 
> > way (for example, it could be routed to a local gateway, to the 
> > local PBX, and then over a tie line between the local PBX and the 
> > Pittsburgh PBX).
> 
> My goodness, that is different. While it is a very reasonable "user
> part", I would not have considered "pitpbx4826" a dial string, and my
> first hunch would be that it's simply invalid when combined with
> user=phone. (it probably isn't which means we DO have a spec clarity
> problem). I would have been much more likely to encode this as
> sip:[email-masked], which means to me "whatever 4826 means to
> pitpbx.marconi.com", which is what I think you wanted to express.
> 
> It might be reasonable for proxy "marconi.com" to route (this is
> expressible in TRIP) all digit sequences starting with 300 to
> pitpbx.marconi.com, and potentially even strip off the 
> matched digits so
> there's no uncertainty at pitpbx. Going this way lets you 
> make a dynamic
> route-optimization decision at the proxy as to whether it 
> would be more
> efficient to route via PSTN. In any case, it lets one use
> [email-masked], again with no user=phone.
> 
> I think you've gone down a very different design path that requires a
> heck of a lot more work in setting up gateways and intelligence for
> string-manipulation in those gateways than might have been required by
> other design paths. It'll work, sort of, with the right equipment, but
> seems overly complex.
> 
> Maybe it's time to write a book about how to build
> usable/useful/maintainable SIP networks for the enterprise?
> 
> Remember: failures induced by convoluted implementations do not
> necessarily entail a design flaw in the components used in that
> implementation. Or, as I like to say, baroque is probably broken.
> 
> 
> --
> Dean
> 
> 
> _______________________________________________
> Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
> This list is for NEW development of the core SIP Protocol
> Use [email-masked] for questions on current sip
> Use [email-masked] for new developments on the application of sip
> 

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Dean Willis <[email-masked]>
Date: Thu, 28 Aug 2003 13:03:38 -0500

On Thu, 2003-08-28 at 03:43, [email-masked] wrote:
> No one has been able to convince me why not to use a tel URI 
> for dial strings and sip URI for pure sip users.
> 
> When a proxy receives a sip request with a sip request-uri containing 
> a domain it is responsible for, it looks up it s registration table 
> and rejects the request with 404 if not found.

What if the call originator didn't KNOW that the request was going to
end up on a gateway? Can the proxy send the request to a gateway anyhow?

Proxies can reasonably do a LOT more than just registration based
routing. The proxy in my office, for example, executes a user-supplied
CPL script, which allows the specification of actions to take (like
forwarding the call to my mobile phone) if there is no registration.

> When a proxy receives a sip request with a tel request-uri without a phone-context, it forwards the request to its default GW.

or applies whatever other routing rules it would apply, for example
prefix matching in TRIP.

> When a proxy receives a sip request with a tel request-uri with a phone-context, it forwards the request to the proxy/GW indicated by the phone-context.

Phone-context is NOT currently a globally routable thing. It provides,
at best, a locally-meaningful hint about how one might proceed.

Citing an example inf RFC 2806:

     tel:0w003585551234567;phone-context=+3585551234

   This URL places a voice call to the given number. The number format
   is intended for local use: the first zero opens an outside line, the
   "w" character waits for a second dial tone, and the number already
   has the international access code appended to it ("00"). This kind of
   phone number MUST NOT be used in an environment where all users of
   this URL might not be able to successfully dial out by using this
   number directly. However, this might be appropriate for pages in a
   company intranet. The <area-specifier> which is present hints that
   the number is usable only in an environment where the local entity's
   phone number starts with the given string (perhaps singling out a
   company-wide block of telephone numbers).

> Why does a proxy need to translate a tel URI to a sip URI before forwarding a request?

Because its routing table might tell it that the gateway to handle that
tel URI is remote, and the other SIP proxies between here and there
might have different, even conflicting, routing policies for TEL URIs.

> Also, why do we need to represent tel:12345;phone-context:example.com as sip:[email-masked];user=phone ? what is the gain in this?

Because @example.com is probably globally routable (at least, we have
well-documented resolution procedures), and phone-context:example.com is
probably not globally routable (we do NOT have well-documented
resolution procedures).

--
Dean