Subject: [Sip] The seventh INVITE transmission - isn't it a waste

From: Sarit Galanos <[email-masked]>
Date: Thu, 28 Aug 2003 13:32:35 +0300

Hi,
This question was posted to the sip-implementers mailing list and no one
could come up with 
a logical explanation so here it is again:

For UDP the client transaction retransmits INVITE requests at an interval
that starts at T1 seconds and doubles after every retransmission.
This should continue until timer B expires - 64*T1 msec.

The result is that the seventh transmission takes place after 63*T1
milliseconds:

0 Invite sent 
1st retrans T1(tme interval) (T1) time since first transmission after this
expiry 
2nd retrans 2_T1 (T1 + 2_T1) ==>> 3T1 
3rd retrans 4_T1 (T1 + 2_T1 + 4_T1) ==>> 7T1 
4th retrans 8_T1 (T1 + 2_T1 + 4_T1 + 8_T1) ==>> 15T1 
5th retrans 16_T1 (T1 + 2_T1 + 4_T1 + 8_T1 +16_T1) ==>> 31T1 
6th retrans 32_T1 (T1 + 2_T1 + 4_T1 + 8_T1 +16_T1 + 32_T1) ==>> 63T1 

Since T1 defaults to 500 msec, the transaction will terminate 500 msec after
the last transmission.

My question is:
Isn't it a waste to retransmit the request 500 msec before the transaction
terminates?

Regards,
Sarit.

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Adam Roach <[email-masked]>
Date: Thu, 28 Aug 2003 13:00:53 -0500

Sarit Galanos [mailto:[email-masked]] writes:

> Isn't it a waste to retransmit the request 500 msec before
> the transaction terminates?

No. Check 3261; 500 ms is an estimate for the round trip
time for a message. In theory, it is exactly long enough
for a response to come back.

/a