Subject: RE: [Sip] SIPIT Interop problem with ;user=phone

From: Adam Roach <[email-masked]>
Date: Fri, 22 Aug 2003 13:04:53 -0500

I agree with Dean and Gordon. The semantics of "user=phone"
have always eluded me. Unless we invest considerable effort
in defining the precise meaning of this parameter, it would
appear that it is doing more harm than good.

/a

> -----Original Message-----
> From: Gordon Ledgard [mailto:[email-masked]]
> Sent: Friday, August 22, 2003 12:56
> To: 'Dean Willis'; 'Robert Sparks'; [email-masked]
> Subject: RE: [Sip] SIPIT Interop problem with ;user=phone
> 
> 
> 
> I'm rather inclined to agree with Dean. 
> 
> I think the parameter amounts to a cheap trick for the sake of
> fixing what amounts to an archaic database problem... Is the 
> user in some
> IP network domain, or does this call need to be forwarded to some
> phone network gateway? And as he points out, it does so poorly.
> 
> Gordon
> 
> 
> 
> 
> -----Original Message-----
> From: Dean Willis [mailto:[email-masked]]
> Sent: Friday, August 22, 2003 12:45 PM
> To: 'Robert Sparks'; [email-masked]
> Subject: RE: [Sip] SIPIT Interop problem with ;user=phone
> 
> 
> 
> > A companion question is should a UA arbitrarily hang 
> > ;user=phone off a digit string it collects from its user, or 
> > should it 
> > transform that string into a telephone-subscriber formatted number?
> > 
> > Both questions have clear answers if we explicitly add that
> > if ;user=phone is present in a URI then the userinfo part
> > MUST be formatted as a telephone-subscriber. Would anyone 
> > object to adding this requirement?
> 
> The problem is that the syntax of telephone-subscriber 
> doesn't actually
> allow conveying all sorts of stuff that one might actually 
> want to use a
> digit strings in private dialing networks that actually talk 
> to phones.
> 
> My suggestion is to deprecate user=phone entirely. It's a 
> silly hack that,
> as far as I can tell, just complicates implementations and 
> URI comparison
> with little actual value in return.
> 
> --
> Dean
> 
> 
> _______________________________________________
> Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
> This list is for NEW development of the core SIP Protocol
> Use [email-masked] for questions on current sip
> Use [email-masked] for new developments on the application of sip
> 
> _______________________________________________
> Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
> This list is for NEW development of the core SIP Protocol
> Use [email-masked] for questions on current sip
> Use [email-masked] for new developments on the application of sip
> 

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Juha Heinanen <[email-masked]>
Date: Sat, 23 Aug 2003 20:40:17 +0300

> appear that it is doing more harm than good.

i too am in favor of deprecating user=phone.

-- juha