Subject: Warning about dial plan assumptions (was RE: AW: [Sip] SIPIT Inte rop problem with ;user=phone)

From: Adam Roach <[email-masked]>
Date: Sat, 23 Aug 2003 21:44:25 -0500

Conroy, Lawrence (SMTP) [mailto:[email-masked]] writes:

> Personally, I'd dearly love a specification stating
> that '00' as the first characters of a destination
> string should be converted into a '+' as that's what
> my body memory assumes, but that's NOT a protocol
> issue,  IMHO. It's only a matter of interpretation
> within an end system.

Be careful what you assume. I would be a bit confused
and miffed if I dialed "00" on my SIP phone and had it
converted to "tel:+".

Why, you may ask, would I dial "00"? Because I want
to reach my long distance operator, of course. That's
what it means in the US (and possibly all of the NANP).
By contrast, the NANP prefix for making international
calls is "011".

This should serve as a powerful cautionary tale against
making any assumptions about the dialing plan that
might be expected by your users.

/a

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Conroy, Lawrence (SMTP)" <[email-masked]>
Date: Sun, 24 Aug 2003 12:45:01 +0100

>and miffed if I dialed "00" on my SIP phone and had it

Hi Adam, folks,
   Thanks, that's exactly what I meant.

*I* would love such a specification, because it's what my
cellphone does. You wouldn't because you are in the NANP.

Thus any spec mustn't be "over the wire" - it MUST be at
most an end system issue. It's dangerous for a Proxy to
interpret, as the expectations of the end user may differ.

I'd be confused and miffed if I dialled 0117 and my proxy
and PSTN gateway gave me a Russian number rather than the
Bristol number I expected. So, no doubt, would the callee :).

all the best,
   Lawrence
-- 
-----------------------------------------------------------------------
Roke Manor Research    : This information is provided "as is" and is not
<mailto:[email-masked]>: intended to create any contractual or legal
<tel:+441794833666>    : relationship.

---

From: Henning Schulzrinne <[email-masked]>
Date: Sun, 24 Aug 2003 10:51:31 -0400

In an earlier iteration of this discussion in the IPTEL WG, there was 
some consensus that the appropriate way is to download a dialplan into 
the end system, which then does the translation from dialed digits to a 
global identifier. That way, it doesn't matter where the SIP or tel URI 
ends up and removes the where-was-this-number-dialed guessing by the 
outbound proxy. This should be part of the general configuration 
mechanism. I had volunteered to write up a spec for that, but I'm 
waiting for the general shape of the configuration data format to settle.